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1 Introduction

1.

Introduction

1.1

Add-on Module RF-TIMBER CSA

The Canadian Standard CAN/CSA O86-09 Engineering Design in Wood [1] provides the most
comprehensive set of wood design requirements for Canadian conditions, and is referenced
by building codes across the country. This Standard employs the limit states design method.
With the RFEM add-on module RF-TIMBER CSA from the company DLUBAL all users obtain a
powerful tool for the design of timber structures modeled with member elements according
to this Standard.
RF-TIMBER CSA performs all cross-section resistance designs, stability analyses, and deformation analyses provided by the standard. The stability analysis is carried out according to
the equivalent member method or the second-order analysis. When the equivalent member
method is applied, the program considers stability factors based on effective buckling lengths
and effective lengths for lateral buckling. Second order analyses require the definition of imperfections in RFEM. The design is performed with unit stability factors for compression with
buckling.
In timber construction, the serviceability limit state is an important design. In this connection,
you can assign load cases, load combinations, and result combinations individually to various
design situations. The limit deformations are preset according to the Standard, and can be adjusted, if necessary. In addition to this, it is possible to specify reference lengths and precambers that will be considered accordingly in the design.
If necessary, you can optimize standardized or parametric cross-sections and export them to
RFEM. Separate design cases allow for a separate design of large systems or analysis of variants.
RF-TIMBER CSA is one of the add-on modules integrated in the RFEM environment. Thus, the
design-relevant input data is preset when you open the module. Subsequent to the design,
you can use the graphical RFEM user interface to evaluate the results. Last but not least, you
can document the checks from the analysis of internal forces to the design in the global
printout report.
We hope you will enjoy working with RF-TIMBER CSA.
Your DLUBAL Team
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1.2

RF-TIMBER CSA - Team

The following people were involved in the development of RF-TIMBER CSA:

Program coordination
Georg Dlubal
Myroslava Petronyuk

Younes El Frem

Programming
Tomáš Drtina
Darya Shatalova

Jiří Patrák

Cross-section and material database
Jan Rybín
Petr Oulehle

Jiří Kubíček
Peter Roth

Program design, dialog figures, and icons
Georg Dlubal
Robert Kolouch

Jan Miléř

Program supervision
Jiří Hanzálek
Gerhard Rehm

Ondřej Švorc
Bastian Kuhn

Localization, manual
Fabio Borriello
Dmitry Bystrov
Rafael Duarte
Lara Freyer
Ladislav Kábrt
Nilton Lopes

José Martínez
Myroslava Petronyuk
Jagoda Podgórna
Chelsea Prokop
Marcela Svitáková
Robert Vogl

Technical support and quality management
Cosme Asseya
Markus Baumgärtel
Sonja von Bloh
Frank Faulstich
René Flori
Walter Fröhlich

1.3

Bastian Kuhn
Ulrich Lex
Andreas Niemeier
Gerhard Rehm
Walter Rustler
Frank Sonntag

Using the Manual

Topics like installation, graphical user interface, results evaluation, and printout are described
in detail in the manual of the main program RFEM. The present manual focuses on typical features of the RF-TIMBER CSA add-on module.
The descriptions in this manual follow the sequence and structure of the module's input and
results windows. In the text, the described buttons are given in square brackets, for example
[View mode]. At the same time, they are pictured on the left. Expressions appearing in dialog
boxes, windows, and menus are set in italics to clarify the explanations.
At the end of the manual, you find the index. However, if you still cannot find what you are
looking for, please check the DLUBAL blogs at https://www.dlubal.de/blog/en where you can
search the articles by specific terms.
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1.4

Open the Add-on Module RF-TIMBER CSA

RFEM provides the following options to start the add-on module RF-TIMBER CSA.

Menu
To start the program in the RFEM menu bar, click
Add-on Modules → Design - Timber → RF-TIMBER CSA.

Figure 1.1: Menu: Add-on Modules → Design - Timber → RF-TIMBER CSA

Navigator
As an alternative, you can start the add-on module in the Data navigator by clicking
Add-on Modules → RF-TIMBER CSA.

Figure 1.2: Data navigator: Add-on Modules → RF-TIMBER CSA

6
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Panel
If results from RF-TIMBER CSA are already available in the RFEM model, you can also open the
design module in the panel:
Set the relevant RF-TIMBER CSA design case in the load case list of the RFEM toolbar. Then click
the [Show results] button to graphically display the design criterion on the members.
When the results display is activated, the panel is available, too. Now you can click the button
[RF-TIMBER CSA] in the panel to open the module.

Figure 1.3: Panel button [RF-TIMBER CSA]
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2.

Input Data

When you have started the add-on module, a new window opens. In this window a Navigator
is displayed on the left, managing the available windows that can be currently selected. The
drop-down list above the navigator contains the design cases (see Chapter 7.1, page 57).
The design relevant data is defined in several input windows. When you start RF-TIMBER CSA
for the first time, the following parameters are imported automatically:
• Members and sets of members
• Load cases, load combinations, and result combinations
• Materials
• Cross-sections
• Effective lengths
• Internal forces (in background, if calculated)
To select a window, click the corresponding entry in the navigator. To set the previous or next
input window, use the buttons shown on the left. You can also use the function keys to select
the next [F2] or previous [F3].
To save the results, click [OK]. Thus, you exit RF-TIMBER CSA and return to the main program.
To exit the module without saving the new data, click [Cancel].

2.1

General Data

In the 1.1 General Data window, you select the members, sets of members, and actions that
you want to design. The tabs are managing the load cases, load combinations, and result
combinations for the different designs.

Figure 2.1: Window 1.1 General Data

8
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Design of

Figure 2.2: Design of members and sets of members

The design can be carried out for Members as well as for Sets of Members. If you want to design
only selected objects, clear the All check box: Then you can access the text boxes to enter the
numbers of the relevant members or sets of members. The list of the numbers preset in the
field can be cleared by clicking the [Delete] button. Alternatively, you can select the objects
graphically in the RFEM work window after clicking [].
When you design a set of members, the program determines the extreme values of the analyses of all members contained in the set of members and takes into account the boundary
conditions of connected members for the stability analysis. The results are shown in the results
windows 2.3 Designs by Set of Members, 3.2 Governing Internal Forces by Set of Members, and 4.2
Parts List by Set of Members.
Click [New] to create a new set of members. The dialog box that you already know from RFEM
appears where you can specify the parameters of set of members.
If beams are divided by nodes, it is necessary to verify them as a set of members.

Comment

Figure 2.3: User-defined comment

In this text box, you can enter user-defined notes.

2.1.1

Ultimate Limit State

Figure 2.4: Window 1.1 General Data, tab Ultimate Limit State

Existing Load Cases / Combinations
This column lists all load cases, load combinations, and result combinations created in RFEM.
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To transfer selected entries to the Selected for Design list on the right, click []. Alternatively,
you can double-click the items. To transfer the complete list to the right, click [].
To transfer multiple entries at once, select them while pressing the [Ctrl] key, as common for
Windows applications.
Load cases highlighted in red, like LC 5 in Figure 2.4, cannot be designed. This happens when
the load cases are defined without any load data or the load cases contain only imperfections.
When you transfer the load cases, a corresponding warning appears.
At the end of the list, several filter options are available. They will help you assign the entries
sorted by load case, load combination, or action category. The buttons have the following
functions:
Selects all load cases in the list
Inverts the selection of load cases
Table 2.1: Buttons in the tab Ultimate Limit State

Selected for Design
The column on the right lists the load cases, load combinations, and result combinations selected for design. To remove selected entries from the list, click [] or double-click the entries.
To transfer the entire list to the left, click [].
The design of an enveloping max/min result combination is performed faster than the design
of all contained load cases and load combinations.
However, the analysis of a result combination has also disadvantages: First, the influence of the
contained actions is difficult to discern. Second, for the determination of the size factor for
bending (KZbg) for glued-laminated timber, the envelope of the moment distributions is analyzed. From that, the most unfavorable distribution (max or min) is applied. However, this distribution only rarely reflects the moment distribution in the individual load combinations.
Thus, in the case of RC design, more unfavorable values of the factor KZbg are to be expected,
leading to higher ratios.
Result combinations should be selected for design only for dynamic combinations. For "usual"
combinations, load combinations are recommended.

10
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2.1.2

Serviceability Limit State

Figure 2.5: Window 1.1 General Data, tab Serviceability Limit State

Existing Load Cases and Combinations
This section lists all load cases, load combinations, and result combinations created in RFEM.

Selected for Design
Load cases, load combinations, and result combinations can be added or removed (see Chapter 2.1.1).
It is possible to assign different limit values for deflection to the individual load cases, load
combinations, and result combinations. The following design situations are available for
selection:
•

Live

•

Permanent

•

Total

You can change the design situation by using the drop-down list that you can open by clicking
[] at the end of the box (see Figure 2.5).
The limit values of the deformations are specified in the Standard dialog box (see Figure 2.8,
page 14) which you can call up by clicking the [Standard] button.
In the 1.12 Serviceability Data window, the reference lengths decisive for the deformation
check are managed (see Chapter 2.12, page 61).
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2.1.3

Standard

All preset parameters which are applied to the design are specified in the Standard dialog box.
To check and, if necessary, adjust these parameters, you can use the [Standard] button in all
input windows in order to open the Standard dialog box. It consists of four tabs.

General Factors

Figure 2.6: Dialog box Standard, tab General Factors

In the dialog box sections, you can check or, if necessary, modify the Resistance Factors, the
Load Duration Factors or the System Factors.
The buttons in the Standard dialog box are reserved for the following functions:
Button

Function
Resets the program's default settings
Imports user-defined standard settings
Saves the current settings as default
Deletes a user-defined Standard

Table 2.2: Buttons in the Standard dialog box

12
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Service and Treatment Factors
In the second tab of the Standard dialog box, you find Service Condition Factors and the Treatment Factors. These can be also modified, if necessary.

Figure 2.7: Dialog box Standard, tab Service and Treatment Factors
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Deflection Limits
In the third tab, you can define the Limit Values of Deflection for the SLS design, depending
on the design situation.

Figure 2.8: Dialog box Standard, tab Deflection Limits

Used Standards
The last tab informs you about the Standards according to which the design is performed.

Figure 2.9: Dialog box Standard, tab Used Standards
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2.2

Materials

The window consists of two parts. In the upper part, all materials created in RFEM are listed. In
the Material Properties section, the properties of the current material, that is, the table row currently selected in the upper section, are displayed.

Figure 2.10: Window 1.2 Materials

Materials that will not be used in the design are dimmed. Materials that are not allowed are
highlighted in red. Modified materials are displayed in blue.
The material properties required for the determination of internal forces are described in
Chapter 4.3 of the RFEM manual (Main Properties). The material properties required for design
are stored in the global material library. These values are preset (Additional Properties).
To adjust the units and decimal places of material properties and stresses, select in the module's menu Settings → Units and Decimal Places (see Chapter 7.3, page 61).

Material Description
The materials defined in RFEM are already preset, but it is always possible to modify them: To
do this, click the material in column A. Then click [] or press function key [F7] to open the material list.

Figure 2.11: List of materials

According to the design concept of CAN/CSA-O86-09:2009-05 [1], the list includes only materials of the Canadian Standard.
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When you have imported a material, the design relevant Material Properties are updated.
If you change the material description manually and the entry is stored in the material library,
RF-TIMBER CSA will import the material properties, too.
Principally, it is not possible to edit the material properties in the RF-TIMBER CSA module.

Material Library
Numerous materials are already available in the library. To open the corresponding dialog box,
select
Edit → Material Library
or click the button shown on the left.

Figure 2.12: Dialog box Material Library

In the Filter section, CAN/CSA is preset as Standard. Select the material quality that you want to
use for the design in the Material to Select list. You can check the corresponding properties in
the dialog section below.
Click [OK] or press [↵] to transfer the selected material to window 1.2 of the module RF-TIMBER
CSA.
Chapter 4.3 of the RFEM manual describes in detail how materials can be filtered, added, or
rearranged.
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Material Properties
The lower section of window 1.2 contains the specified strength values for bending fb, tension
parallel ft, tension perpendicular f tp, shear fv, compression parallel fc, compression perpendicular fcp, as well as modulus of elasticity for design of compression members E05.
The specified bending and shear strength values and modulus of elasticity for glued-laminated
timber (material of [1] Table 6.3 special application) are extended for cases of bending perpendicular and parallel to the wide faces of laminations and bending to fby and fbz. If the narrow
faces of laminations are normal to the direction of load, the bending resistance and stiffness
for glulam are based on No. 2 grade lumber properties. When structural laminated timber material stressed primarily in bending is selected, the value fby is doubled for the case of positive
fby,pos and negative fby,neg bending. In addition, the value fcp is doubled for compression fcp,c and
tension fcp,t face of cross-section.
For beams of [1] Table 5.3.1C with special application materials loaded to the wide face, the
specified strengths for bending and the specified modulus of elasticity are automatically multiplied by the relevant wide face factor. Please note that this multiplication is used only in the
add-on module. The internal forces are not recalculated in RFEM.
The design values of the material strengths are to be determined with the modification factors.
Those factors can be modified in the Standard Settings dialog box (see Figure 2.6 and Figure 2.7,
pages 12 and 13).
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2.3

Cross-Sections

This window manages the cross-sections used for design. In addition, the window allows you
to specify optimization parameters.

Figure 2.13: Window 1.3 Cross-Sections

Cross-Section Description
The cross-sections defined in RFEM are preset together with the assigned material numbers.
The design is possible for the parametric timber rectangular and circular cross-section and for
standardized timber rectangular cross-section according to the Canadian Standard CAN/CSA
O86-09.
To modify a cross-section, click the entry in column B selecting this field. Click [Cross-section
Library] or [...] in the field or press function key [F7] to open the cross-section table of the current input field (see the following two figures).
In those dialog boxes, you can select a different cross-section or a different cross-section table.
To select a different cross-section category, click [Back to cross-section library] to access the
general cross-section library.
Chapter 4.13 of the RFEM manual describes how cross-sections can be selected from the library.

18
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Figure 2.14: Parametric timber cross-sections of the library

Figure 2.15: Standardized timber cross-sections of the library

The new cross-section description can be entered in the text box directly. If the database contains an entry, RF-TIMBER CSA imports these cross-section parameters, too.
A modified cross-section will be highlighted in blue.
If cross-sections specified in RF-TIMBER CSA are different from the ones used in RFEM, both
cross-sections are displayed in the graphic in the right part of the window. The designs will be
performed with the internal forces from RFEM for the cross-section selected in RF-TIMBER CSA.
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Max. Design Ratio
This table column is displayed only after the calculation. It is a decision support for the optimization. By means of the displayed design ratio and colored relation scales, you can see which
cross-sections are little utilized and thus oversized, or overloaded and thus undersized.

Optimize
You can optimize all rectangular and circular cross-sections: For the RFEM internal forces, the
program searches the cross-section that comes as close as possible to a user-defined maximum
utilization ratio. You can define the maximum ratio in the Other tab of the Details dialog box,
(see Figure 3.4, page 37).
If you want to optimize a cross-section, open the drop-down list in column D or E. Recommendations for optimizing cross-sections can be found in Chapter 7.2 on page 58.

Remark
This column shows remarks in the form of footers that are described in detail below the crosssection list.

Info About Cross-Section
In the Info About Cross-Section dialog box, you can check the cross-section properties and
stress points.

Figure 2.16: Dialog box Info About Cross-Section

The right part of the dialog box shows the currently selected cross-section.

20

Program RF-TIMBER CSA © 2014 Dlubal Software GmbH

2 Input Data

The buttons below the graphic have the following functions:
Button

Function
Displays or hides the stress points
Displays or hides the numbers of stress points
Shows the details of the stress points (see Figure 2.17)
Displays or hides the dimensions of the cross-section
Displays or hides the principal axes of the cross-section
Resets the full view of the cross-section graphic
Prints the cross-section values and cross-section graphic

Table 2.3: Buttons of cross-section graphic

Click [Details] to call up specific information on the stress points (distances to center of gravity,
statical moments of area, etc.).

Figure 2.17: Dialog box Stress Points

Member with tapered cross-section
For tapered members with different cross-sections at both member ends, the module displays
the two cross-sections numbers in separate table rows, in accordance with the definition in
RFEM.
RF-TIMBER CSA is also able to design glued-laminated tapered members if the same crosssection type is defined for the start and the end cross-section. Additional specifications are
required in Window 1.10 (see Chapter 2.10, page 31).
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2.4

Load Duration

In window 1.4, you define the load duration to consider factors reflecting the different load duration for all chosen load cases, load combinations, result combination, and dynamic combinations.

Figure 2.18: Window 1.4 Load Duration

Loading
All actions selected in the 1.1 General Data window are listed here. For combinations, included
load cases are listed, too.

Description
The load case descriptions make the classification easier.

Load Type
This table column shows the load cases' types of action as defined while creating them in RFEM.
They are the basis for the presetting in the subsequent table column.

Load Duration
Loads and their superpositions must be assigned to classes of load duration. The classification
of actions is specified in [1] Table 2.3.2, for example.
For load cases and variable result combinations, the load duration can be changed by using
the list shown on the left: Click the cell in column C, thus selecting the field. The [] button becomes available. For load combinations and Or result combinations, RF-TIMBER CSA performs
the classification automatically taking into account the shortest load duration action of included load cases. When the bottom-side button is switched to User-defined settings, load combinations and Or result combinations are user-changeable as well.
The class of the load duration is required for the determination of the load duration factor, KD.

22
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Factor KD
The impact of the load duration on the material strengths is taken into account by means of
the load duration factor (see [1] Table 4.3.2.2).
The default values of the factors KD can be checked and, if necessary, adjusted in the Standard
dialog box (see Figure 2.6, page 12).

Loading Distribution
This column will be added when a radial stress design is to be carried out for tapered or curved
members. Those settings can be made in Window 1.10 or 1.11 (see Chapters 2.10 and 2.11).
For the design of tension perpendicular to grain, the distribution of the loading has to be assigned so that the size factor, KZtp, can be determined (see [1] Table 6.5.6.6.1).

2.5 Service Conditions and Treatment - Members
The determination of moisture and wood treatment makes it possible to assign the service
condition factors, KS, and the treatment factors, KT, to each member. The moisture service conditions can be specified individually for sawn lumber or glued-laminated timber according to
[1] Table 5.4.2 and Table 6.4.2, the treatment factor according to [1] Table 5.4.3 and Chapter
6.4.4.

Figure 2.19: Window 1.5 Service Conditions and Treatment - Members

By default, RF-TIMBER CSA assigns Dry service conditions and None or Preservative (not incised)
treatment. If you want to define different moisture conditions or treatment to the selected
members, use the [] button.
The default values of the factors KS and KT can be checked and, if necessary, adjusted in the
Standard dialog box (see Figure 2.7, page 13).
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Below the Settings table, you find the Set input for members No. check box. If it is selected, the
settings entered afterward will be applied to the selected or even to All members. Members
can be selected by entering the member number or by selecting them graphically with the []
button. This option is useful when you want to assign identical conditions to several members.
Please note that settings that have been already defined cannot be changed subsequently by
using this function.
The other buttons below the table have the following functions:
Button

Function
Exports table into MS Excel or OpenOffice.org Calc
Directs to the row of member graphically selected in RFEM work window
Switches into RFEM work window

Table 2.4: Buttons in the window Service Conditions and Treatment - Members

2.6

Service Conditions and Treatment Set of Members

This window is only available if one or more sets of members have been selected in window
1.1 General Data.

Figure 2.20: Window 1.6 Service Conditions and Treatment - Sets of Members

The concept of this window is similar to the one in the previous window 1.5 Service Conditions
and Treatment - Members window. In this window, you can assign the moisture service conditions and the treatment of the wood to each set of members.
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2.7

Effective Lengths - Members

The appearance of the window depends on whether the stability analysis is carried out according to the equivalent member method or according to second-order analysis. You can specify
that method in the Stability tab of the Details dialog box (see Figure 3.2, page 35). The following description refers to the equivalent member default method. For that, the parameters of
buckling and lateral-torsional buckling must be defined.
If the stability analysis is deactivated in the Stability tab of the Details dialog box, window 1.7 is
not shown.
The window consists of two parts. The table in the upper part provides summarized information
about the factors for the lengths of buckling and lateral-torsional buckling as well as the equivalent member lengths of the members to be designed. The effective lengths defined in RFEM are
preset. In the Settings section, you can see further information about the member whose row is
selected in the upper section.
Click [] to select a member graphically and to show its row.
Changes can be made in the table as well as in the Settings tree.

Figure 2.21: Window 1.7 Effective Lengths - Members for equivalent member method

The effective lengths can be entered manually in the table and in the Settings tree, or defined
graphically in the work window after clicking [...]. This button is enabled when you click in the
text box (see figure above).
The Settings tree manages the following parameters:
•

Cross-section

•

Length (actual length of the member)

•

Buckling Possible (corresponds to column A)

•

Buckling About Axis y Possible (corresponds to columns B to D)

•

Buckling About Axis z Possible (corresponds to columns E to G)

•

Lateral-Torsional Buckling Possible (corresponds to columns H to J)

Program RF-TIMBER CSA © 2014 Dlubal Software GmbH

25

2 Input Data

In this table, you can specify for the currently selected member whether to carry out a buckling
or a lateral-torsional buckling analysis. In addition to this, you can adjust the Effective Length
Factor for the respective lengths. When a coefficient is modified, the equivalent member
length is adjusted automatically, and vice versa.
You can also define the buckling length of a member in a dialog box. To open it, click the
button shown on the left. It is located on the right below the upper table of the window.

Figure 2.22: Dialog box Select Effective Length Factor

For each direction, you can select one of the buckling modes (recommended and theoretical
values of buckling length factors as specified in [1] Table A.5.5.6.1) or enter a User-defined effective length coefficient K.
If an eigenvalue analysis was carried out in the add-on module RF-STABILITY, you can also select a Buckling mode to determine the factor.

Buckling Possible
A stability analysis for flexural buckling and lateral-torsional buckling requires the ability of
members to resist compressive forces. Therefore, members for which such resistance is not
possible because of the member type (for example tension members, elastic foundations, rigid
couplings) are excluded from design in the first place. The corresponding rows appear dimmed
and a note is displayed in the Comment column.
The Buckling Possible check boxes in table column A and in the Settings tree enable you to classify specific members as compression members or, alternatively, to exclude them from the design according to [1].
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Buckling About Axis y or Axis z
With the check boxes in the Possible table columns, you decide whether a member is susceptible to buckling about the y-axis and/or z-axis. Those axes represent the local member axes,
with axis y being the "major" and axis z the "minor" member axis. The buckling length factors
Ke,y and Ke,z for buckling about the major or the minor axis can be selected freely.
You can check the position of the member axes in the cross-section graphic in window 1.3
Cross-Sections (see Figure 2.13, page 18). To access the RFEM work window, click [View mode].
In the work window, you can display the local member axes by using the member's context
menu or the Display navigator.

Figure 2.23: Selecting the member axis systems in the Display navigator of RFEM

If buckling is possible about one or even both member axes, you can enter the effective length
factors as well as the effective lengths in the columns C and D respectively as F and G. The same
is possible in the Settings table.
To specify the buckling lengths in the work window graphically, click [...]. This button becomes
available when you click in a Le text box (see Figure 2.21).
When you define the effective length factor Ke, the program determines the effective length Le
by multiplying the member length L by this buckling length coefficient. The text boxes for Ke
and Le are interactive.

Lateral-Torsional Buckling
Table column H controls for which members a lateral-torsional buckling analysis is to be carried
out.

Define Le
The member lengths are preset in column I as equivalent member lengths relevant for lateraltorsional buckling. When you set the option manually in the list box, you can specify the length
for lateral-torsional buckling Le in column J. You can also define it graphically after clicking […]
as the distance of the lateral supports. Thus, you can adjust the boundary conditions of a structural component if it consists of several members between the supports.
When the option acc. to Table 6.5.6.4.3 is selected, you can determine the lateral-torsional buckling length in accordance with [1] Table 6.5.6.4.3. A new dialog box is opened in which you can
select the effective length according to the loading conditions (see figure below).
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Figure 2.24: Dialog box Effective Length for Bending Members acc. to Table 6.5.6.4.3

Below the Settings table, you find the Set inputs for members No. check box. If selected, the settings entered afterward will be applied to the selected or to All members. Members can be selected by typing the member number or by selecting them graphically using the [] button.
This option is useful when you want to assign the same boundary conditions to several members. Please note that already defined settings cannot be changed subsequently with this
function.

Comment
In the last table column, you can enter you own comments for each member to describe, for
example, the selected equivalent member lengths.
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2.8

Effective Lengths - Sets of Members

This window is only available if one or more sets of members have been selected in window
1.1 General Data. Additionally, the stability check must have been activated in the dialog box
Details, tab Stability (see Figure 3.2, page 35).

Figure 2.25: Window 1.8 Effective Lengths - Sets of Members

The concept of this window is similar to the one in the previous window 1.7 Effective Lengths Members. In this window, you can enter the effective lengths for buckling as well as for lateraltorsional buckling as described in Chapter 2.7. They determine the boundary conditions of the
entire set of members which is to be treated as an equivalent member.
Please note that curved sets of members are excluded from the stability analysis.
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2.9

Additional Design Parameters

This window allows you to allocate the system factor, KH, for each member. This factor depends
on the interaction between members in the model and on the material. By clicking the [] button in column B, the Case according to [1] Chapter 5.4.4 can be selected.
By default, the program assigns None/No system factor. The factor can be checked and, if necessary, adjusted in the Standard dialog box (see Figure 2.6, page 12).

Figure 2.26: Window 1.9 Additional Design Parameters

The Set input for members No. check box below the table enables you to assign the settings to
selected or All members (see Chapter 2.5 and Chapter 2.7).
The Material Description (also below the table) informs you which material is used for the current member. The buttons to the right of this text box are described in Table 2.4 on page 24.
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2.10 Tapered Members
This window is only available when you have selected at least one member with different
cross-sections at both member ends for the design in Window 1.1 General Data. This window
manages criteria such as the angle of taper of variable cross-sections, for example.
The design of tapered members is only possible for rectangular cross-sections whose material
is glued-laminated timber according to [1] Table 6.3.

Figure 2.27: Window 1.10 Tapered Members

Cross-Section
The first two columns list the sections that are defined at the Member Start and Member End.

Length L
In this column, you can check the length of each tapered member.

Angle of Taper α
RF-TIMBER CSA determines the inclination of the taper on the basis of geometric conditions.
That angle is displayed for your information.
The maximum angle of taper can be defined in the Details dialog box, tab Other (see Figure 3.4,
page 37).

Radial Stress Design with Apex
If this check box has been ticked, RF-TIMBER CSA performs the design for the maximum tension
stresses perpendicular to the grain in the ridge cross-section according to [1] Clause 6.5.6.6.2.
If this design is activated, it will be necessary to check the Loading Distribution in Window 1.4
Load Duration (see Chapter 2.4, page 22). The distribution of the loading has an effect on the
size factor for tension perpendicular to grain, KZtp.
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2.11 Curved Members
This window is available when at least one member with a curved shape has been selected for
design in Window 1.1 General Data. Curved members can be defined, for example, by using the
line types "arc" or "circle", i.e. lines with constant radius of curvature along the entire length.
The design of curved members is only possible for rectangular cross-sections whose material
is glued-laminated timber according to [1] Table 6.3.

Figure 2.28: Window 1.11 Curved Members

Lamination Thickness
In those two columns, you can specify the type and the thickness t of the lamellas. The various
Standard and Non-standard lamination thicknesses are listed in [1] Table A.6.5.5.

Minimum Inner Radius of Curvature
The program checks the inner radius of curvature. The design is only allowed for members
whose inner radius, Ri, meets the limit criterion as described in [1] Table A.6.5.5. For that, the
Type of End can be selected in the list box.
The Limit Criterion is displayed in column E. This value depends on the lamination thickness
and the end type of the member.

Radial Stress Design
Optionally RF-TIMBER CSA performs a check of the tension stresses perpendicular to the grain
in each location of the member where the bending moment tends to decrease the curvature
(increase the radius) of the member.
If this design is activated, it will be necessary to check the Loading Distribution in Window 1.4
Load Duration (see Chapter 2.4, page 22). The distribution of the loading has an effect on the
size factor for tension perpendicular to grain, KZtp.
The enclosed angle, β, can be determined only for members that are located on an undivided
curved line, i.e. a line without additional nodes. Thus, the radial stress design is not possible for
sets of members either.
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2.12 Serviceability Data
This input window controls several settings for the serviceability limit state design. It is only
available if you have set the relevant entries in the Serviceability Limit State tab of window 1.1
General Data (see Chapter 2.1.2, page 11).

Figure 2.29: Window 1.12 Serviceability Data

In column A, you decide whether you want to apply the deformation to single members, lists
of members, or sets of members.
In table column B, you enter the numbers of the members or sets of members that you want to
design. You can also click [...] to select them graphically in the RFEM work window. Then, the
Reference Length appears in column D automatically. This column presets the lengths of the
members, sets of members, or member lists. If required, you can adjust these values after selecting the Manually check box in column C.
Column E controls the governing Direction for the deformation analysis. You can select the directions of the local member axes x and y and the resultant direction R.
In columns F and G, you can allow for some Precamber wc,y and wc,z.
The Beam Type is important to correctly determine the limit deformations. Column H controls
whether there is a beam or a cantilever and which end is not supported.
The settings in the Serviceability tab of the Details dialog box decide whether the deformations
are related to the undeformed initial model or to the shifted ends of members or sets of members (see Figure 3.3, page 36).
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3.

Calculation

3.1

Detail Settings

Before you start the [Calculation], it is recommended to check the design details. You can open
the corresponding dialog box in all windows of the add-on module by clicking [Details].
The Details dialog box contains the following tabs:
•
•
•
•

3.1.1

Resistance
Stability
Serviceability
Other

Resistance

Figure 3.1: Dialog box Details, tab Resistance

Consideration of Connections
Often zones near member connections show weakening of the cross-section. It is possible to
take into account this effect by a Reduction of limit tension stresses.
The numbers of the relevant nodes can be entered manually or selected graphically by clicking
the [] button.
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The Connection length defines the zone on the member where reduced stresses are considered.
In the text box below, enter the allowable stress ratio for Inside connections in percent. If required, you can also change the maximum ratio for Outside connections of the connection zone.

Positive or Negative Bending About y-Axis
Structural glued laminated timber members stressed in bending have different reference
bending design values for positive bending (bottom of beam is stressed in tension) and negative bending (top of beam is stressed in tension), see [4] Table 5A and Table 5C.
For RF-TIMBER CSA to apply the correct bending design value, you have to specify whether the
bottom side of members is located in the direction of the local z-axis or opposite.

Limit Value for Special Cases
Torsion design is not specified in CAN/CSA O86-09. It is possible to ignore shear stresses due to
torsion if a user-defined ratio of the torsional shear resistance is not exceeded (default: 5 %).
If the limit is exceeded, a note appears in the result window. This limit setting is not part of the
Standard [1]. Changing the limit is the responsibility of the user.
It is also possible to completely Ignore torsion.

3.1.2

Stability

Figure 3.2: Dialog box Details, tab Stability

The Check stability check box controls whether to run, in addition the cross-section design, a
stability analysis. If you clear the check box, the input windows 1.7 and 1.8 will not be shown.
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The equivalent member method uses the internal forces determined in RFEM. In this method,
make sure that the Geometrically linear static analysis has been set (the default setting is
the 2nd order analysis). When you perform the stability analysis according to the equivalent
member method, the effective lengths of the members and sets of members subject to compression or compression and bending must be specified in windows 1.7 and 1.8.
Equivalent member method:
Specifying method of analysis in RFEM

If the bearing capacity of the model is significantly affected by its deformations, we recommend selecting a calculation according to the second order theory. This approach additionally
requires the definition of imperfections in RFEM and their consideration for the load combinations. The flexural buckling analysis is carried out during the calculation of the load combinations in RFEM.
The lateral-torsional buckling design must also be carried out for second order calculations.
Thus, the lateral-torsional buckling lengths of members or sets of members are to be specified
in Windows 1.7 or 1.8 Effective Lengths manually. In this way, we can make sure that the lateraltorsional buckling analysis is performed with the appropriate factors (for example 1.0).

3.1.3

Serviceability

Figure 3.3: Dialog box Details, tab Serviceability

The option fields control whether the maximum deformations are related to the shifted ends
of members or sets of members (connection line between start and end nodes of the deformed system) or to the undeformed initial system. As a rule, the deformations are to be
checked relative to the displacements in the entire structural system.

36

Program RF-TIMBER CSA © 2014 Dlubal Software GmbH

3 Calculation

3.1.4

Other

Figure 3.4: Dialog box Details, tab Other

Cross-Section Optimization
The optimization is targeted on the maximum design ratio of 100 %. If necessary, you can
specify a different limit value in this text box.

Check of Member Slenderness Ratio
In the two text boxes, you can specify the limit values of the member slendernesses. You can
define the ratios separately for members with bending, CB, and for members with compression, CC.
The limit values are compared to the real member slendernesses in window 3.3. This window
is available after the calculation (see Chapter 4.8, page 46) if the corresponding check box is selected in the Display Result Tables dialog box section.

Maximum Angle of Taper
The taper angle α is described in [1] Figure 6.5.6.6.3. According [1] Table 6.5.6.6.3, the maximum
value of that angle is 30°. The Used limitation can be set to a smaller angle, if necessary.

Display Result Tables
In this dialog section, you can select the results windows including parts lists that you want to
display in the output windows. The windows are described in Chapter 4 Results.
Window 3.3 Member Slendernesses is inactive by default.

Program RF-TIMBER CSA © 2014 Dlubal Software GmbH

37

3 Calculation

3.2

Start Calculation

To start the calculation, click the [Calculation] button which is available in all input windows of
the RF-TIMBER CSA add-on module.
RF-TIMBER CSA searches for the results of the load cases, load and result combinations that are
to be designed. If they cannot be found, the program starts the RFEM calculation to determine
the design relevant internal forces.
You can also start the calculation in the user interface of RFEM: In the dialog box To Calculate
(menu Calculate → To Calculate), design cases of the add-on modules are listed like load cases
and load combinations.

Figure 3.5: Dialog box To Calculate

If the RF-TIMBER CSA cases are missing in the Not Calculated section, select All or Add-on Modules in the drop-down list below the section.
To transfer the selected RF-TIMBER CSA cases to the list on the right, use the [] button. Click
[OK] to start the calculation.
To calculate a design case directly, use the list in the toolbar. Select the RF-TIMBER CSA design
case in the toolbar list, and then click [Show Results].

Figure 3.6: Direct calculation of a RF-TIMBER CSA design case in RFEM

Subsequently, you can observe the design process in a separate dialog box.
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4.

Results

Window 2.1 Design by Load Case is displayed immediately after the calculation.

Figure 4.1: Results window with designs and intermediate values

The designs are shown in the results windows 2.1 through 2.5, sorted by different criteria.
Windows 3.1 and 3.2 list the governing internal forces. Window 3.3 informs you about the
member slendernesses. The last two results windows 4.1 and 4.2 show the parts lists sorted by
member and set of members.
Every window can be selected by clicking the corresponding entry in the navigator. To set the
previous or next input window, use the buttons shown on the left. You can also use the function keys to select the next [F2] or previous [F3] window.
To save the results, click [OK]. You exit RF-TIMBER CSA and return to the main program.
Chapter 4 Results describes the different results windows one by one. Evaluating and checking
results is described in Chapter 5 Evaluation of Results starting on page 49.
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4.1

Design by Load Case

The upper part of the window provides a summary, sorted by load cases, load combinations,
and result combinations of the governing designs. Furthermore, the list is divided in Ultimate
Limit State Design and Serviceability Limit State Design results.
The lower part gives detailed information on the cross-section properties, analyzed internal
forces, and design parameters for the load case selected above.

Figure 4.2: Window 2.1 Design by Load Case

Description
This column shows the descriptions of the load cases, load and result combinations used for
the design.

Member No.
This column shows the number of the member that bears the maximum design ratio of every
designed loading.

Location x
The column shows the x-location at which the maximum design ratio of each member occurs.
For the table output, the program uses the following member locations x:
•
•
•
•

Start and end node
Division points according to possibly defined member division (see RFEM table 1.16)
Member division according to specification for member results (RFEM dialog box
Calculation parameters, tab Global Calculation Parameters)
Extreme values of internal forces

Design
Columns D and E show the design conditions according to CAN/CSA O86-09.
The lengths of the colored bars represent the respective utilizations.
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Design According to Formula
This column lists the equations of the Standard by which the designs have been performed.

Load Duration
In column G, the load duration classes as defined in window 1.4 are listed (see Chapter 2.4,
page 22).

4.2

Design by Cross-Section

Figure 4.3: Window 2.2 Design by Cross-Section

This window lists the maximum ratios of all members and actions selected for design, sorted
by cross-sections. The results are sorted by cross-section design, stability design, and serviceability limit state design.
For tapered members, both cross-section descriptions are displayed in the table row next to
the cross-section number.
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4.3

Design by Set of Members

Figure 4.4: Window 2.3 Design by Set of Members

This results window is displayed if you have selected at least one set of members for the design. The window lists the maximum ratios sorted by set of members.
The Member No. column shows the number of the one member within the set of members that
bears the maximum ratio for the individual design criteria.
The output by sets of members clearly presents the design for an entire structural group (for
example a chord).
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4.4

Design by Member

Figure 4.5: Window 2.4 Design by Member

This results window presents the maximum ratios for the individual designs sorted by member
number. The columns are described in detail in Chapter 4.1 on page 40.

4.5

Design by x-Location

Figure 4.6: Window 2.5 Design by x-Location
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This results window lists the maxima for each member at all x-locations resulting from the division points in RFEM:
•

Start and end node

•
•

Division points according to possibly defined member division (see RFEM table 1.16)
Member division according to specification for member results (RFEM dialog box
Calculation Parameters, tab Global Calculation Parameters)

•

Extreme values of internal forces

4.6

Governing Internal Forces by Member

Figure 4.7: Window 3.1 Governing Internal Forces by Member

For each member, this window displays the governing internal forces, that is, those internal
forces that result in the maximum utilization in each design.

Location x
At this x-location of the member, the respective maximum design ratio occurs.

Load Case
This column displays the number of the load case, the load combination, or result combination
whose internal forces result in the maximum design ratios.

Forces / Moments
For each member, this column displays the axial and shear forces as well as the torsional and
bending moments producing maximum design ratios in the respective cross-section, stability
and serviceability limit state designs.

Design According to Formula
The final column provides information on the types of design and the equations by which the
designs according to [1] have been performed.
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4.7 Governing Internal Forces by Set of Members

Figure 4.8: Window 3.2 Governing Internal Forces by Set of Members

This window contains the individual internal forces that result in the maximum ratios of the
design for each set of members.
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4.8

Member Slendernesses

Figure 4.9: Window 3.3 Member Slendernesses

This results window is shown only when you have selected the respective check box in the
Other tab of the Details dialog box (see Figure 3.4, page 37).
The table lists the effective slendernesses of the designed members which can lose their stability as compression members, bending members or combinations of both. They were determined depending on the type of load and occurrence of buckling or lateral-torsional buckling.
At the end of the list, you find a comparison with the limit values that have been defined in the
Details dialog box, tab Other (see Figure 3.4, page 37).
This window is displayed only for information. No design of the slendernesses is carried out.
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4.9

Parts List by Member

Finally, RF-TIMBER CSA provides a summary of all cross-sections that are included in the design
case.

Figure 4.10: Window 4.1 Parts List by Member

By default, the list contains only the designed members. If you need a parts list for all members
of the model, select the corresponding option in the Details dialog box, tab Other (see Figure
3.4, page 37).

Part No.
The program automatically assigns item numbers to similar members.

Cross-Section Description
This column lists the cross-section numbers and descriptions.

Number of Members
This column shows how many similar members are used for each part.

Length
This column displays the respective length of an individual member.

Total Length
This column shows the product determined from the two previous columns.

Surface Area
For each part, the program indicates the surface area relative to the total length. The surface
area is determined from the Surface Area of the cross-sections that can be seen in Windows 1.3
and 2.1 through 2.5 (see Figure 2.16, page 20).
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Volume
The volume of a part is determined from the cross-sectional area and the total length.

Unit Weight
The Unit Weight of the cross-section is relative to the length of one meter.

Weight
The values of this column are determined from the respective product of the entries in column
C and G.

Total Weight
The final column indicates the total weight of each part.

Sum
At the bottom of the list, you find a sum of the values in the columns B, D, E, F, and I. The last
cell of the column Total Weight gives information about the total amount of timber required.

4.10 Parts List by Set of Members

Figure 4.11: Window 4.2 Parts List by Set of Members

The last results window is displayed if you have selected at least one set of members for design. It summarizes an entire structural group (for example a chord) in a parts list.
Details on the various columns can be found in the previous chapter. If there are different
cross-sections in the set of members, the program averages the surface area, the volume, and
the cross-section weight.
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5.

Evaluation of Results

You can evaluate the design results in different ways. For this, the buttons located below the
upper results tables are very useful.

Figure 5.1: Buttons for evaluation of results

The buttons have the following functions:
Button

Description

Function

ULS Design

Shows or hides the results of the ultimate limit
state design

SLS Design

Shows or hides the results of the serviceability
limit state design

Show Color Bars

Shows or hides the colored relation scales in
the results windows

Filter Options

Displays only rows with ratios greater than the
filter criterion set in text box: design ratios > 1,
maximum or user-defined limit

Result Diagrams

Opens the window Result Diagram on Member
 Chapter 5.2, page 52

Excel Export

Exports the table to MS Excel / OpenOffice
 Chapter 7.4.3, page 62

Member Selection

Allows you to graphically select a member to
display its results in the table

View Mode

Jumps to the RFEM work window to change
the view

Table 5.1: Buttons in results windows 2.1 through 2.5
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5.1

Results in RFEM Model

To evaluate the design results, you can also use the RFEM work window.

RFEM background graphic and view mode
The RFEM work window in the background is useful for finding the position of a particular
member in the model: The member selected in the RF-TIMBER CSA results window is highlighted in the selection color in the background graphic. Furthermore, an arrow indicates the member's x-location that is displayed in the selected window row.

Figure 5.2: Indication of the member and the current Location x in the RFEM model

If you cannot improve the display by moving the RF-TIMBER CSA module window, click [Jump
to Graphic] to activate the View Mode: Thus, you hide the module window so that you can
modify the display in the RFEM user interface. In the view mode, you can use the functions of
the View menu, for example zooming, moving, or rotating the display. The pointer remains
visible.
Click [Back] to return to the add-on module RF-TIMBER CSA.

RFEM work window
You can also graphically check the design ratios in the RFEM model: Click [Graphics] to exit the
design module. In the RFEM work window, the design ratios are now displayed like the internal
forces of a load case.
To turn the display of design results on or off, use the [Show Results] button known from the
display of internal forces in RFEM. To display the result values, click the [Show Values] toolbar
button to the right.
The RFEM tables are of no relevance for the evaluation of design results.
The design cases can be set by means of the list in the RFEM menu bar.
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The graphical representation of the results can be set in the Display navigator by clicking
Results → Members. The ratios are shown Two-Colored by default.

Figure 5.3: Display navigator: Results → Members

When you select a multicolor representation (options With/Without Diagram or Cross-Sections),
the color panel becomes available. It provides common control functions that are described in
detail in the RFEM manual, Chapter 3.4.6.

Figure 5.4: Design ratios with display option Without Diagram

The graphics of the design results can be transferred to the printout report (see Chapter 6.2,
page 55).
To return to the add-on module, click the [RF-TIMBER CSA] panel button.
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5.2

Result Diagrams

You can also evaluate the member results graphically in the result diagram.
To do this, select the member (or set of members) in the RF-TIMBER CSA results window by
clicking in the table row of the member. Then open the Result Diagram on Member dialog box
by clicking the button shown on the left. The button is located below the upper results table
(see Figure 5.1, page 49).
To display the result diagrams, select the command from the RFEM menu
Results → Result Diagrams for Selected Members
or use the button in the RFEM toolbar shown on the left.
A window opens, graphically showing the distribution of the maximum design values on the
member or set of members.

Figure 5.5: Dialog box Result Diagram on Member

Use the list in the toolbar above to select the relevant RF-TIMBER CSA design case.
This dialog box Result Diagram on Member is described in the RFEM manual, Chapter 9.5.
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5.3

Filter for Results

The RF-TIMBER CSA results windows allow you to sort the results by various criteria. In addition,
you can use the filter options for graphical evaluation of the results as described in Chapter 9.9
of the RFEM manual.
You can use the Visibility option also for RF-TIMBER CSA (see RFEM manual, Chapter 9.9.1) to filter the members in order to evaluate them.

Filtering designs
The design ratios can easily be used as filter criteria in the RFEM work window, which you can
open by clicking [Graphics]. To apply this filter function, the panel must be displayed. If it is
not, select
View → Control Panel (Color scale, Factors, Filter)
or use the toolbar button shown on the left.
The panel is described in the RFEM manual, Chapter 3.4.6. The filter settings for the results
must be defined in the first panel tab (Color spectrum). As this register is not available for the
two-colored results display, you have to use the Display navigator and set the display options
Colored With/Without Diagram or Cross-Sections first.

Figure 5.6: Filtering design ratios with adjusted color spectrum

As the figure above shows, the color spectrum can be set in such a way that only ratios higher
than 0.50 are shown in a color range between blue and red.
If you select the Display Hidden Result Diagram option in the Display navigator (Results → Members), you can display all design ratio diagrams that are not covered by the color spectrum.
Those diagrams are represented by dotted lines.
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Filtering members
In the Filter tab of the control panel, you can specify the numbers of particular members to
display their results exclusively, that is, filtered. The function is described in detail in the RFEM
manual, Chapter 9.9.3.

Figure 5.7: Member filter for ratios of diagonals

Unlike the partial view function (Visibilities), the graphic displays the entire model. The figure
above shows the ratios in the diagonals of a truss girder. The remaining members are displayed
in the model but are shown without design ratios.
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6.

Printout

6.1

Printout Report

Similar to RFEM, the program generates a printout report for the RF-TIMBER CSA results, to
which you can add graphics and descriptions. The selection in the printout report determines
what data from the design module will be included in the printout.
The printout report is described in the RFEM manual. In particular, Chapter 10.1.3.4 Selecting
Data of Add-on Modules describes how to select input and output data from add-on modules
for the printout report.
For complex structural systems with many design cases, it is recommended to split the data
into several printout reports, thus allowing for a clearly-arranged printout.

6.2

Graphic Printout

In RFEM, you can add every picture that is displayed in the work window to the printout report
or send it directly to a printer. In this way, you can prepare the design ratios displayed on the
RFEM model for the printout, too.
Printing of graphics is described in the RFEM manual, Chapter 10.2.

Designs in the RFEM model
To print the currently displayed design ratios, click
File → Print Graphic
or use the toolbar button shown on the left.

Figure 6.1: Button Print in RFEM toolbar

Result diagrams
You can also transfer the Result Diagram on Member to the report or print it directly by using
the [Print] button.

Figure 6.2: Button Print in the Result Diagram on Member

The Graphic Printout dialog box appears (see figure on next page).
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Figure 6.3: Dialog box Graphic Printout, tab General

This dialog box is described in the RFEM manual, Chapter 10.2. The RFEM manual also
describes the Options and Color Spectrum tab.
You can move a graphic anywhere within the printout report by using the drag-and-drop
function.
To adjust a graphic subsequently in the printout report, right-click the relevant entry in the
navigator of the printout report. The Properties option in the context menu opens the Graphic
Printout dialog box, offering various possibilities for adjustment.

Figure 6.4: Dialog box Graphic Printout, tab Options
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7.

General Functions

This chapter describes useful menu functions as well as export options for the designs.

7.1

Design Cases

Design cases allow you to group members for the design: In this way, you can combine groups
of structural components or analyze members with particular design specifications (for example changed materials, load duration or system factors, optimization).
It is no problem to analyze the same member or set of members in different design cases.
To calculate a RF-TIMBER CSA design case, you can also use the load case list in the RFEM
toolbar.

Create new design case
To create a new design case, use the RF-TIMBER CSA menu and click
File → New Case.
The following dialog box appears:

Figure 7.1: Dialog box New RF-TIMBER CSA-Case

In this dialog box, enter a No. (one that is still available) for the new design case. The corresponding Description will make the selection in the load case list easier.
Click [OK] to open the RF-TIMBER CSA window 1.1 General Data where you can enter the
design data.

Rename design case
To change the description of a design case, use the RF-TIMBER CSA menu and click
File → Rename Case.
The following dialog box appears:

Figure 7.2: Dialog box Rename RF-TIMBER CSA-Case

In this dialog box, you can enter a different Description and also a different No. of the design
case.
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Copy design case
To copy the input data of the current design case, use the RF-TIMBER CSA menu
File → Copy Case
The following dialog box appears:

Figure 7.3: Dialog box Copy RF-TIMBER CSA-Case

Define the No. and, if necessary, a Description for the new case.

Delete design case
To delete design cases, use the RF-TIMBER CSA menu
File → Delete Case
The following dialog box appears:

Figure 7.4: Dialog box Delete Cases

The design case can be selected in the list Available Cases. To delete the selected case,
click [OK].
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7.2

Cross-Section Optimization

The design module offers you the option to optimize overloaded or little utilized cross-sections.
To do this, select in the column D or E of the relevant cross-sections in the 1.3 Cross-Section window the option Yes (for parametric rectangular and circular sections) or From current row (for
standardized sections according to [1], see Figure 2.15 on page 19).
You can also start the cross-section optimization in the results windows by using the context
menu.

Figure 7.5: Context-menu for cross-section optimization

During the optimization process, the module determines the cross-section that fulfills the analysis requirements in the most optimal way, that is, comes as close as possible to the maximum
allowable design ratio specified in the Details dialog box (see Figure 3.4, page 37). The required
cross-section properties are determined with the internal forces from RFEM. If another crosssection proves to be more favorable, this cross-section is used for the design. Then, the graphic
in window 1.3 shows two cross-sections: the original cross-section from RFEM and the optimized one (see Figure 7.7).
For a parameterized cross-section, the following dialog box appears when you have selected
Yes from the drop-down list.

Figure 7.6: Dialog box Timber Cross-Sections - Rectangle : Optimize
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By selecting the check boxes in the Optimize column, you decide which parameter(s) you want
to modify. This enables the Minimum and Maximum columns, where you can specify the upper
and lower limits of the parameter. The Increment column determines the interval in which the
size of the parameter varies during the optimization process.
If you want to Keep current side proportions, select the corresponding check box. In addition,
you must select two parameters for optimization.
Please note that the internal forces are not automatically recalculated with the changed crosssections during the optimization: It is up to you to decide which cross-sections should be
transferred to RFEM for recalculation. As a result of optimized cross-sections, internal forces
may vary considerably because of the changed stiffnesses in the structural system. Therefore, it
is recommended to recalculate the internal forces of the modified cross-section data after the
first optimization, and then to optimize the cross-sections once again.
You can export the modified cross-sections to RFEM: Go to the 1.3 Cross-Sections window, and
then click
Edit → Export All Cross-Sections to RFEM
Alternatively, you can use the context menu in window 1.3 to export optimized cross-sections
to RFEM.

Figure 7.7: Context menu in window 1.3 Cross-Sections

Before the changed materials are transferred to RFEM, a security query appears as to whether
the RFEM results should be deleted.

Figure 7.8: Query before transfer of modified cross-sections to RFEM
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By confirming the query and then starting the [Calculation] in the RF-TIMBER CSA module, the
RFEM internal forces as well as the designs will be determined in one single calculation run.
If the changed cross-sections have not been exported to RFEM yet, you can reimport the original cross-sections in the design module by using the options shown in Figure 7.7. Please note
that this option is only available in the 1.3 Cross-Sections window.

7.3

Units and Decimal Places

Units and decimal places for RFEM and the add-on modules are managed in one dialog box. To
define the units in RF-TIMBER CSA, select menu
Settings → Units and Decimal Places.
The following dialog box appears that is familiar from RFEM. RF-TIMBER CSA is preset in the
Program / Module list.

Figure 7.9: Dialog box Units and Decimal Places

You can save the settings as a user profile to reuse them in other models. These functions are
described in the RFEM manual, Chapter 11.1.3.
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7.4

Data Transfer

7.4.1

Export Material to RFEM

If you have modified the materials in RF-TIMBER CSA for design, you can export the modified
materials to RFEM in a similar way as you export cross-sections: Open the 1.2 Materials window, and then click
Edit → Export All Materials to RFEM.
You can also export the modified materials to RFEM using the context menu of window 1.2.

Figure 7.10: Context menu of window 1.2 Materials

Before the changed materials are transferred to RFEM, a security query appears as to whether
the results of RFEM should be deleted. When you have confirmed the query and then start the
[Calculation] in RF-TIMBER CSA, the RFEM internal forces and designs are determined in one
single calculation run.
If the modified materials have not been exported to RFEM yet, you can transfer the original
materials to the design module, using the options shown in Figure 7.10. Please note, however,
that this option is only available in the 1.2 Materials window.

7.4.2

Export Effective Lengths to RFEM

If you have adjusted the materials in RF-TIMBER CSA for design, you can export the modified
materials to RFEM in a similar way as you export cross-sections: Open the 1.7 Effective Lengths Members window, and then select
Edit → Export All Effective Lengths to RFEM
or use the corresponding option on the context menu of window 1.7.

Figure 7.11: Context menu of window 1.7 Effective Lengths - Members

Before the modified materials are transferred to RFEM, a security query appears as to whether
the results of RFEM should be deleted.
If the modified effective lengths have not been exported to RFEM yet, you can reimport the
original effective lengths to the design module by using the options shown in Figure 7.11.
Please note, however, that this option is only available in the windows 1.7 Effective Lengths Members and 1.8 Effective Lengths - Sets of Members.

7.4.3

Export Results

The RF-TIMBER CSA results can also be used by other programs.

Clipboard
To copy selected cells of the results windows to the Clipboard, use the [Ctrl]+[C] keys. To insert
the cells, for example in a word processing program, press [Ctrl]+[V]. The headers of the table
columns will not be transferred.
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Printout Report
You can print the data of the RF-TIMBER CSA add-on module into the global printout report
(see Chapter 6.1, page 55) for export. Then, in the printout report, click
File → Export to RTF
The function is described in the RFEM manual, Chapter 10.1.11.

Excel / OpenOffice
RF-TIMBER CSA provides a function for the direct data export to MS Excel, OpenOffice.org Calc,
or the file format CSV. To open the corresponding dialog box, click
File → Export Tables
The following export dialog box appears.

Figure 7.12: Dialog box Export - MS Excel

When you have selected the relevant options, you can start the export by clicking [OK].
Excel or OpenOffice will be started automatically, that is, the programs do not have to be
opened first.

Figure 7.13: Results in Excel
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8.

Examples

8.1

Glulam Column

We perform the design according to CAN/CSA O86-09 for a glulam column that is subjected to
compression and bending. At its base, it provides a non-movable hinged support. At the top,
there is a hinged support which is movable along the local x-axis. The material is a SpruceLodgepole Pine-Jack Pine 20f-EX glulam in dry service conditions.
That example is described in [2].

8.1.1

System and Loads
Model
Cross-section:

b = 130 mm
d = 228 mm

Material:

Spruce-Lodgepole
Pine-Jack Pine 20f-EX
Glulam

Moisture Condition:

Dry

Load
LC 1 Dead:
LC 2 Snow:
LC 3 Wind:

10 kN
40 kN
10 kN

Load combinations ULS: 1.25D + 0.5S + 1.4W
1.25D + 1.5S + 0.4W
Load combination SLS: 0.75W
Figure 8.1: System and loads according to [2]

If beams are divided by nodes, it is necessary to verify them as a set of members. In this example, the beam is not divided because the wind load is defined as a Concentrated Member Load.
If a nodal load was used, we would have to design a set of members instead of a member (see
chapter 2.1).
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8.1.2

Calculation with RFEM

The system as well as the loads in all load cases is modeled in RFEM as a 2D-XZ model. We deactivate the automatic consideration of the self-weight when we create LC1.
We create the load combinations for ULS and SLS with the relevant factors for the defined load
cases. Then we calculate the model according to the linear static analysis.

Figure 8.2: Internal forces N, Vz and My (ULS)

8.1.3

Design with RF-TIMBER CSA

8.1.3.1

Ultimate Limit State Design

In window 1.1 General Data, we select combination CO1 for the Ultimate Limit State design.

Figure 8.3: Window 1.1 General Data
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The 1.2 Materials window presents the characteristic strengths of the selected material.

Figure 8.4: Window 1.2 Materials

In the 1.3 Cross-Sections window, the parameters of the cross-section can be checked.

Figure 8.5: Window 1.3 Cross-Sections
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In window 1.4 Load Duration, we define the load duration. For the dead load, we leave Long
term, for snow we change it to Standard term and for wind to Short term. According to [1]
Chapter 4.3.2.4, we choose Shortest load duration in a combination so the load duration
factor KD of the shortest duration will be considered for the load combination.

Figure 8.6: Window 1.4 Load Duration

In window 1.5 Service Conditions and Treatment - Members, we define the moisture and the
treatment parameters. The treatment factor KT will be taken as unity in this case.

Figure 8.7: Window 1.5 Service Conditions and Treatment - Members
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In the 1.7 Effective Lengths - Members window we specify the buckling lengths of the column.
About the main axis (Buckling About Axis y), we can leave the default value of 5.00 m (see [1]
Table A.5.5.6.1). For the minor axis (Buckling About Axis z), however, we define the buckling
length Lez = 2.50 m as the column is restrained in the middle of the member (see Figure 8.1).
In this case, we can deactivate Lateral-Torsional Buckling because the slenderness ratio CB does
not exceed 10 (see [1] Chapter 6.5.6.4.4) so that we get the lateral stability factor KL = 1.0.

Figure 8.8: Window 1.7 Effective Lengths – Members

In window 1.9 Additional Design Parameters, the use of the system factor KH is not required.

Figure 8.9: Window 1.9 Additional Design Parameters

We start the calculation by clicking the [Calculation] button.
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Results
After the calculation, the governing design is presented in the 2.1 Design by Load Case window.

Figure 8.10: Window 2.1 Design by Load Case

The Details in the lower part of the window correspond to the design results in [2]. All values
you need to comprehend the calculation are listed there.

Figure 8.11: Details - Factored Strength
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Factored Compressive Resistance

Mr1 = ϕ× Fb × S × K x × K Zbg

Pr = Φ × Fc × A × K Zcg × K C

Mr2 = ϕ× Fb × S × K x

Fc = fc,b × (K D × K Φ × K Sc × K T )

LTB is switched off in mask 1.7
→ no factor K L for Mr2

Fc = 25.2 × (1.15 ×1.0 ×1.0 ×1.0 )
Fc = 28.98 N − mm²
K Zcg =0.68 × Z

−0.13

Factored Bending Moment Resistance

Fb = fb,y × (K D × K H × K Sb × K T )
Fb = 25.6 × (1.15 ×1.0 ×1.0 ×1.0 )

≤ 1.0

K Zcg =
0.68 × 0.1482

−0.13

Fb = 29.44 N − mm²

≤ 1.0

K Zcg = 0.872

(

K Zbg,y = 1.03 × b × L sy

−1


FC × K Zcg × C3c 
=
K C 1.0 +

35 × E 05 × K SE × K T 

le,y
5.0
= =
= 21.93
Cc,y
d 0.228
l
2.5
Cc,z
= e,z
=
= 19.23
d 0.13
E 05 =
0.87 ×10300 =
8961 N − mm²

−0.18

K Zbg,y =1.03 × ( 0.13 × 5.0 )

≤ 1.0

−0.18

≤ 1.0

K Zbg,y = 1.0
Mr1,y = 0.9 × 29.44 ×1126320 ×1.0 ×1.0
Mr1,y = 29.84 kNm


28.98 × 0.872 × 21.933 
K=

C,y 1.0 +
35 × 8961×1.0 ×1.0 

K C,y = 0.541

28.98 × 0.872 ×19.233 
K=

C,z 1.0 +
35 × 8961×1.0 ×1.0 

K C,z = 0.636

)

−1

Mr2,y =
0.9 × 29.44 ×1126320 ×1.0
Mr2,y = 29.84 kNm

−1

Pr,y =
0.8 × 28.98 × 29640 × 0.872 × 0.541
Pr,y = 323.85 kN

Euler Buckling Load
PE =

π2 × E 05 × K SE × K T × I

PE,y =

L2e

π2 × 8961×1.0 ×1.0 ×1.284 ×108
50002

PE,y = 454.24 kN

Pr,z =
0.8 × 28.98 × 29640 × 0.872 × 0.636
Pr,z = 380.81kN

Combined Bending and Axial Load

 Pf  Mf  1
×
  +
 Pr  Mr 1− Pf
 PE
2



 ≤ 1.00



Buckling about axis y


2

1
 32.50  17.50 
×
 =0.64 ≤ 1.00

 +
 323.85  29.84 1− 32.50 
 454.24 
Buckling about axis z


2

1
 32.50  17.50 
×
 =0.64 ≤ 1.00

 +
32.50
 380.81  29.84 1−

 454.24 
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Factored Shear Resistance
Vr = Φ × Fv ×

2× A
3

Fv =fv × (K D × K Φ × K Sv × K T )
Fv = 1.75 × (1.15 ×1.0 ×1.0 ×1.0 )
Fv = 2.01 N / mm²
Vr,z =0.9 × 2.01×

2 × 29640
3

Vr,z = 35,79 kN

Shear Design
Vf ,z 7.00
=
= 0,20 ≤ 1.00
Vr,z 35.79

8.1.3.2

Serviceability Limit State Design

We check the deflection limit for the wind load.
In the Serviceability Limit State tab of the 1.1 General Data window, we select the load combination CO3 for design and assign the design situation Total.

Figure 8.12: Window 1.1 General Data, tab Serviceability Limit State
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Then we enter member No. 1 in the 1.12 Serviceability Data window.

Figure 8.13: Window 1.12 Serviceability Data

We do not modify the Reference Length but we restrict the Direction to z (in this case we could
leave y,z as well). As it is a simple span beam, we select the Beam in the Beam Type list.
The limiting deflection is L/180 according to the deflection limits in the Standard dialog box.

Figure 8.14: Dialog box Standard, tab Serviceability

In this example, we do not consider the deflection due to shear. Therefore, we deactivate the
shear stiffness in the Calculation Parameters dialog box of RFEM.

Figure 8.15: Dialog box Calculation Parameters in RFEM and deflection of CO3
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Deflection Design
∆z
≤ 1.0
∆ max, z
L
5000
∆ max, z = =
=
27.78 mm
180 180
∆z
14.77
=
= 0.53 ≤ 1.0
∆ max, z 27.78

Figure 8.16: Window 2.1 Design by Load Case
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8.2

Double-Tapered Beam

This example presents the design of a double-tapered beam that is laterally supported over its
entire length.

8.2.1

System and Loads

Figure 8.17: System and loads

Model
Material:

Douglas Fir-Larch 20f-E

Length:

24.0 m

Cross-section 1:

180 x 750 mm

Cross-section 2:

180 x 1800 mm

Moisture Condition:

Wet

Loads

74

LC1 Dead:

1.50 kN/m

LC2 Snow:

6.00 kN/m

Load Combination ULS:

1.25D + 1.5S
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8.2.2

Calculation with RFEM

The system as well as the loads in all load cases is modeled as a 3D model in RFEM. We deactivate the automatic consideration of the self-weight when we create LC1.
We create the considered load combination with relevant factors from the defined load cases.
Then we calculate the model according to the linear static analysis. RFEM determines the diagrams of internal forces shown in the following figure.

Figure 8.18: Internal forces My and Vz

8.2.3

Design with RF-TIMBER CSA

8.2.3.1

Ultimate Limit State Design

In Window 1.1 General Data, we select the result combination CO1 for the Ultimate Limit State
design.

Figure 8.19: Window 1.1 General Data
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Window 1.2 Materials presents the characteristic strengths of the material.

Figure 8.20: Window 1.2 Materials

In Window 1.3 Cross-Sections, the parameters of the two cross-sections can be checked.

Figure 8.21: Window 1.3 Cross-Sections
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In Window 1.4 Load Duration, we define the load duration. The dead and snow loads are uniformly distributed. Therefore, the loading distribution to determine the size factor, KZtp, for tension perpendicular to grain is to be set to Uniform.

Figure 8.22: Window 1.4 Load Duration

In Window 1.6 Service Conditions and Treatment - Sets of Members, we define the moisture and
treatment parameters. The treatment factor, KT, will be taken as unity in this case.

Figure 8.23: Window 1.6 Service Condition and Treatment - Sets of Members
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In Window 1.8 Effective Lengths - Sets of Members we specify the buckling lengths. The set of
members is laterally supported over its entire length. Thus, there is no risk of instability. We
clear the two check boxes Buckling Possible and Lateral-Torsional Buckling Possible.

Figure 8.24: Window 1.8 Effective Lengths - Sets of Members

In Window 1.9 Additional Design Parameters, the application of the system factor, KH, is not required.

Figure 8.25: Window 1.9 Additional Design Parameters
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In Window 1.10 Tapered Members, the two cross-sections are listed automatically, including the
preset angle of taper which is 5°. We activate the Radial Stress Design for both cross-sections.

Figure 8.26: Window 1.10 Tapered Members

We then start the calculation by clicking the [Calculation] button.
After the calculation, the governing design ratios can be checked in Window 2.3 Design by Set
of Members.

Figure 8.27: Window 2.3 Design by Set of Members
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Factored Shear Resistance
2
Vr = φ× Fv × × A
3
Fv = fv × (K D × K H × K Sv × K T )

Fv = 2.0 × (1.0 × 1.0 × 0.87 × 1.0 )
Fv = 1.74 MPa
2
Vr, z = 0.9 × 1.74 × × 135000
3
Vr , z = 140.94 kN

Factored Bending Moment Resistance
Mr = φ× Fb × S× K Χ × K Zbg ×

1
1 + 2.7 tanα

Fb = fb, y × (K D × K H × K Sb × K T )

Fb = 30.6 × (1.0 × 1.0 × 0.8 × 1.0 )
Fb = 24.48 MPa

(

K Zbg,y = 1.03 × B× L sy

)−0.18 ≤ 1.0

K Zbg,y = 1.03 × (0.18 × 24.00 )−0.18 ≤ 1.0
K Zbg,y = 0.791
1
1
=
= 0.809
1 + 2.7 tan α 1 + 2.7 tan 5°
Mr, y = 0.9 × 24.48 × 41067000 × 1.0 × 0.791× 0.809
Mr, y = 579.28 kNm

Factored Bending Moment Resistance in Tension Perpendicular to Grain
Mrt = φ× Ft p × S× K Ztp × K R

(

Ftp = ftp × K D × K H × K Stp × K T

)

Ftp = 0.83 × (1.0 × 1.0 × 0.85 × 1.0 )
Ftp = 0.706 MPa
K Ztp =

36

=

36

(A× d)0.2 (324000 × 1800 )0.2

2

d
d 
K R = A + B×   + C×   
 R  
R


= 0.636

−1

= [0.02 + 0 + 0]−1 = 50

Mr t, y = 0.9 × 0.706 × 97200000 × 0.636 × 50
Mr t, y = 1960.92 kNm
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Shear Design
Vf, z
Vr, z

=

130.49
= 0.93 ≤ 1.0
140.94

Bending Design
Mf, y
Mr, y

=

501.12
= 0.87 ≤ 1.0
579.28

Radial Stress Design
Mf, y
Mrt, y

=

783.0
= 0.40 ≤ 1.0
1960.92
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8.3

Curved Beam

According to the current standard, the cross-section resistance design is performed also for
curved portions of bending members with constant cross-section. In the module, the member
of this type is not allowed for stability calculations.

8.3.1

System and Loads

Figure 8.28: System and loads

Model
Material:

Douglas Fir-Larch 20f-EX

Length:

20.0 m

Radius of Curvature at Centerline

11.73m

Cross-section:

b = 215 mm
d = 1520 mm

Thickness of Lamination:

38 mm

Moisture Condition:

Dry

Loads

82

LC 1 Dead:

1.96 kN/m

LC 2 Snow:

5.00 kN/m

Load Combination ULS:

1.25D + 1.5S
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8.3.2

Calculation with RFEM

The system as well as the loads in all load cases is modeled in RFEM as a 3D model. We deactivate the automatic consideration of the self-weight when we create LC1.
We create the considered load combination with relevant factors from the defined load cases.
Then we calculate the model according to the linear static analysis.
RFEM determines the diagrams of internal forces shown in the following figure.

Figure 8.29: Internal forces N, Vz, My

Program RF-TIMBER CSA © 2014 Dlubal Software GmbH

83

8 Examples

8.3.3

Design with RF-TIMBER CSA

8.3.3.1

Ultimate Limit State Design

In Window 1.1 General Data, we select the result combination CO1 for the Ultimate Limit State
design.

Figure 8.30: Window 1.1 General Data

Window 1.2 Materials presents the characteristic strengths of the selected material.

Figure 8.31: Window 1.2 Materials

84

Program RF-TIMBER CSA © 2014 Dlubal Software GmbH

8 Examples

In Window 1.4 Load Duration, we allocate Long term to the dead load and Standard term to
the snow load. Both loads have a uniform distribution.

Figure 8.32: Window 1.4 Load Duration

In window 1.5 Service Conditions and Treatment - Members, we define the moisture and treatment parameters. The treatment factor, KT, will be taken as unity in this case.

Figure 8.33: Window 1.5 Service Conditions and Treatment - Members
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Since the beam is laterally supported, we deactivate the stability analysis in the Details dialog
box.

Figure 8.34: Dialog box Details, tab Stability

In Window 1.9 Additional Design Parameters, the application of the system factor, KH, is not required.

Figure 8.35: Window 1.9 Additional Design Parameters
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In Window 1.11 Curved Members, the Standard lamination thickness of 38 mm and the Curved
type of end are preset. These values are directly reflected in the check of the minimum inner
radius of curvature.

Figure 8.36: Window 1.11 Curved Members

To perform the Radial Stress Design, we check the corresponding check box in column F.
We start the calculation by clicking the [Calculation] button.
The governing design ratios can then be checked in Window 2.4 Design by Member.

Figure 8.37: Window 2.4 Design by Member
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Factored Compressive Resistance
Pr = φ× Fc × A× K Zcg
Fc = fc × (K D × K H × K Sc × K T )

Fc = 30.2 × (1.0 × 1.0 × 1.0 × 1.0 )
Fc = 30.2 MPa

K Zcg = 0.68 × (Z )−0.13 ≤ 1.0
K Zcg = 0.68 × (7.83)−0.13 ≤ 1.0
K Zcg = 0.520
Pr = 0.8 × 30.2 × 326800 × 0.520
Pr = 4108.9 kN

Factored Shear Resistance
2
Vr = φ× Fv × × A
3
Fv = fv × (K D × K H × K Sv × K T )

Fv = 2.0 × (1.0 × 1.0 × 1.0 × 1.0 )
Fv = 2.0 MPa

2
Vr, z = 0.9 × 2.0 × × 326800
3
Vr , z = 392.2 kN

Factored Bending Moment Resistance Based on Bending Strength
Mr b = φ× Fb × S× K Χ × K Zbg
Fb = fb, y × (K D × K H × K Sb × K T )

Fb = 25.6 × (1.0 × 1.0 × 1.0 × 1.0 )
Fb = 25.6 MPa
 t 
K Χ = 1− 2000 
 Ri 

2

 38 
K X = 1− 2000

 10969 
K X = 0.976

(

K Zbg, y = 1.03 × B× L sy

2

)−0.18 ≤ 1.0

K Zbg, y = 1.03 × (0.215 × 23.947)− 0.18 ≤ 1.0
K Zbg, y = 0.767

Mr b, y = 0.9 × 25.6 × 82789300 × 0.976 × 0.767
Mr b, y = 1427.7 kNm
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Factored Bending Moment Resistance Based on Radial Tension Strength
2
Mr t = φ× Ft p × × A× R× K Ztp
3

(

Ftp = ftp × K D × K H × K Stp × K T

)

Ftp = 0.83 × (1.0 × 1.0 × 1.0 × 1.0 )
Ftp = 0.83 MPa

K Ztp =

24

(A × R × β)0.2

The enclosed angle β is measured between those points where the factored bending moment
is 85% of the maximum factored bending moment.
If we define the angle β manually, we follow the next steps:
In our example, the angle is between the x-locations with the bending moment of
538.0 kNm × 0.85 = 457.3 kNm .
We can find those locations with the moment 457.3 kNm in the Result Diagram.

Figure 8.38: Result Diagram with internal force My

The two x-locations are

x1 = 7.89 m
x 2 = 16.06 m
Thus, the arc length of the circular sector is

l = x 2 − x1 = 16.06 − 7.89 = 8.17 m
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Now we can define the enclosed angle in radians as follows.

l = R× β
l 8.17
β= =
= 0.697 rad
R 11.73
In RFEM, the internal division for members is set to 10 by default. Therefore, the value of the
angle β is 0.745 rad in RF-TIMBER CSA. For more accurate results, it would be possible to increase the number of division for members in the RFEM dialog box Calculation Parameters
(see RFEM manual, Chapter 7.3.3).

K Ztp =

24

(215 × 1520 × 11729 × 0.745)0.2

= 0.308

2
Mr t, y = 0.9 × 0.83 × × 326800 × 11729 × 0.308
3
Mr t, y = 588.6 kNm

Combined Bending and Axial Load
2

Mf, y  20.5  2 419.7
 Pf 
=
+
= 0.29 ≤ 1.0
  +
Mrb, y  4108.9  1427.7
 Pr 

Shear Design
Vf, z
Vr , z

=

65.4
= 0.17 ≤ 1.0
392.2

Radial Stress Design

(

Mf, y

min Mrb, y ; Mrt, y

90

538.0

538.0

) = min(1427.7;588.6) = 588.6 = 0.91 ≤ 1.0
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