# Short Overview

<table>
<thead>
<tr>
<th>Chapter</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Introduction</td>
<td>6</td>
</tr>
<tr>
<td>2</td>
<td>Installation</td>
<td>9</td>
</tr>
<tr>
<td>3</td>
<td>User Interface</td>
<td>12</td>
</tr>
<tr>
<td>4</td>
<td>Model Data</td>
<td>35</td>
</tr>
<tr>
<td>5</td>
<td>Load Cases and Combinations</td>
<td>195</td>
</tr>
<tr>
<td>6</td>
<td>Loads</td>
<td>239</td>
</tr>
<tr>
<td>7</td>
<td>Calculation</td>
<td>287</td>
</tr>
<tr>
<td>8</td>
<td>Results</td>
<td>324</td>
</tr>
<tr>
<td>9</td>
<td>Results Evaluation</td>
<td>395</td>
</tr>
<tr>
<td>10</td>
<td>Printout</td>
<td>434</td>
</tr>
<tr>
<td>11</td>
<td>Program Functions</td>
<td>474</td>
</tr>
<tr>
<td>12</td>
<td>File Management</td>
<td>612</td>
</tr>
<tr>
<td>A</td>
<td>Literature</td>
<td>649</td>
</tr>
</tbody>
</table>

---

**Using the Manual**

There are many ways to reach a goal. This principle also applies for the work with RFEM, because graphics, tables, and the navigator are on equal footing. To meet the standards of a reference text, this manual follows the order and structure of the input and results tables. The chapters present the individual tables column by column. A description of general Windows functions is dispensed with in favor of practical information.

---

**Hint**

The text of the manual shows the described buttons in square brackets, for example [OK]. They are also depicted on the left. Expressions that appear in dialog boxes, tables, and menus are set in italics to clarify the explanations. You can also use the search function for the Knowledge Base and FAQs on our website to find a solution in the posts about RFEM.

---

**Topicality**

The high quality standards placed on the software are guaranteed by a continuous development of the program versions. This may result in differences between program description and the current software version you are using. Thank you for your understanding that no claims can be derived from the figures and descriptions. We always try to adapt the documentation to the current state of the software.
# Table of Contents

## 1 Introduction
1.1 New Features in RFEM 5 .......................... 6
1.2 Program Capacity ..................................... 7
1.3 Company Profile ..................................... 8
1.4 Using the Manual .................................... 8

## 2 Installation
2.1 System Requirements ................................. 9
2.2 Installation Process .................................. 9
2.2.1 Installation from USB Drive ....................... 10
2.2.2 Installation in Network ............................ 11
2.2.3 Installation of Updates and Add-On Modules .. 11
2.2.4 Parallel Installations of RFEM ..................... 11

## 3 User Interface
3.1 Overview ............................................ 12
3.2 Terminology ........................................ 13
3.3 Special Terms in RFEM ............................. 16
3.4 RFEM User Interface ............................... 17
3.4.1 Menu Bar ........................................ 17
3.4.2 Toolbars ......................................... 18
3.4.3 Project Navigator ................................. 20
3.4.4 Tables ........................................... 23
3.4.5 Status Bar ........................................ 24
3.4.6 Control Panel .................................... 25
3.4.7 Default Buttons ................................. 29
3.4.8 Keyboard Functions ............................... 30
3.4.9 Mouse Functions ................................ 32
3.4.10 Configuration Manager .......................... 33

## 4 Model Data
4.1 Nodes .............................................. 40
4.2 Lines ............................................... 46
4.3 Materials .......................................... 57
4.4 Surfaces ........................................... 76
4.5 Solids ............................................. 88
4.6 Openings .......................................... 96
4.7 Nodal Supports .................................... 98
4.8 Line Supports ...................................... 105
4.9 Surface Supports .................................. 110
4.10 Line Hinges ....................................... 115
4.11 Variable Thicknesses ............................... 117
4.12 Orthotropic Surfaces and Membranes .......... 119
4.13 Cross-Sections .................................... 124
4.14 Member Hinges ................................... 136
4.15 Member Eccentricities ............................. 143
4.16 Member Divisions ................................ 145
4.17 Members .......................................... 146
4.18 Ribs .................................................. 162
4.19 Member Elastic Foundations ....................... 165
4.20 Member Nonlinearities ............................. 167
4.21 Sets of Members ................................... 170
4.22 Intersections ....................................... 172
4.23 FE Mesh Refinements ............................. 176
4.24 Nodal Releases .................................... 181
4.25 Line Release Types ................................. 183
4.26 Line Releases ...................................... 185
4.27 Surface Release Types ............................. 187
4.28 Surface Releases .................................. 188
4.29 Connection of Two Members ....................... 190
4.30 Joints .............................................. 192
4.31 Nodal Constraints ................................ 192

## 5 Load Cases and Combinations
5.1 Load Cases ......................................... 195
5.2 Actions ............................................. 200
5.3 Combination Expressions ............................ 204
5.4 Action Combinations ............................... 217
5.5 Load Combinations ................................ 221
5.5.1 User-Defined Combinations ...................... 223
5.5.2 Generated Combinations .......................... 228
5.6 Result Combinations ................................ 230
5.6.1 User-Defined Combinations ...................... 230
5.6.2 Generated Combinations .......................... 236
5.7 Combination Scheme ................................ 238

## 6 Loads
6.1 Nodal Loads ........................................ 243
6.2 Member Loads ...................................... 247
6.3 Line Loads .......................................... 254
6.4 Surface Loads ....................................... 258
6.5 Solid Loads ......................................... 264
6.6 Free Concentrated Loads ............................ 266
6.7 Free Line Loads ..................................... 268
6.8 Free Rectangular Loads .............................. 270
6.9 Free Circular Loads ................................ 272
6.10 Free Polygon Loads ................................ 274
6.11 Free Variable Loads ................................ 276
6.12 Imposed Nodal Deformations ....................... 278
6.13 Imposed Line Displacements ....................... 279
6.14 Imperfections ...................................... 281
6.15 Generated Loads ................................... 285

## 7 Calculation
7.1 Checking Input Data ................................ 287
7.1.1 Plausibility Check ................................ 287
7.1.2 Model Check ..................................... 288
7.1.3 Regenerate Model ................................ 291
7.1.4 Deleting Unused Loads ............................ 292
7.2 FE Mesh ............................................. 292
7.2.1 Basics of Finite Elements in RFEM ............. 292
7.2.2 FE Mesh .......................................... 295
7.2.2.1 FE Mesh Settings ............................... 295
7.2.2.2 Mesh Quality Criteria .......................... 298
7.2.2.3 Adaptive mesh refinement ....................... 299
7.2.3 FE Mesh Refinements ............................ 300
<table>
<thead>
<tr>
<th>Chapter</th>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>7.2.4</td>
<td>FE Mesh Generation</td>
<td>301</td>
</tr>
<tr>
<td>7.3</td>
<td>Calculation Parameters</td>
<td>302</td>
</tr>
<tr>
<td>7.3.1</td>
<td>Load Cases and Load Combinations</td>
<td>303</td>
</tr>
<tr>
<td>7.3.1.1</td>
<td>Calculation Parameters</td>
<td>304</td>
</tr>
<tr>
<td>7.3.1.2</td>
<td>Modify Stiffness</td>
<td>308</td>
</tr>
<tr>
<td>7.3.1.3</td>
<td>Extra Options</td>
<td>309</td>
</tr>
<tr>
<td>7.3.1.4</td>
<td>Deactivate</td>
<td>311</td>
</tr>
<tr>
<td>7.3.2</td>
<td>Result Combinations</td>
<td>312</td>
</tr>
<tr>
<td>7.3.3</td>
<td>Global Calculation Parameters</td>
<td>313</td>
</tr>
<tr>
<td>7.3.4</td>
<td>Calculation Diagrams</td>
<td>320</td>
</tr>
<tr>
<td>7.4</td>
<td>Starting the Calculation</td>
<td>321</td>
</tr>
<tr>
<td>8</td>
<td>Results</td>
<td>324</td>
</tr>
<tr>
<td>8.1</td>
<td>Nodes - Support Forces</td>
<td>325</td>
</tr>
<tr>
<td>8.2</td>
<td>Nodes - Deformations</td>
<td>329</td>
</tr>
<tr>
<td>8.3</td>
<td>Lines - Support Forces</td>
<td>330</td>
</tr>
<tr>
<td>8.4</td>
<td>Members - Local Deformations</td>
<td>334</td>
</tr>
<tr>
<td>8.5</td>
<td>Members - Global Deformations</td>
<td>336</td>
</tr>
<tr>
<td>8.6</td>
<td>Members - Internal Forces</td>
<td>337</td>
</tr>
<tr>
<td>8.7</td>
<td>Members - Contact Forces</td>
<td>341</td>
</tr>
<tr>
<td>8.8</td>
<td>Members - Strains</td>
<td>343</td>
</tr>
<tr>
<td>8.9</td>
<td>Members - Coefficients for Buckling</td>
<td>345</td>
</tr>
<tr>
<td>8.10</td>
<td>Member Slendernesses</td>
<td>346</td>
</tr>
<tr>
<td>8.11</td>
<td>Sets of Members - Internal Forces</td>
<td>347</td>
</tr>
<tr>
<td>8.12</td>
<td>Cross-Sections - Internal Forces</td>
<td>348</td>
</tr>
<tr>
<td>8.13</td>
<td>Surfaces - Local Deformations</td>
<td>349</td>
</tr>
<tr>
<td>8.14</td>
<td>Surfaces - Global Deformations</td>
<td>352</td>
</tr>
<tr>
<td>8.15</td>
<td>Surfaces - Basic Internal Forces</td>
<td>353</td>
</tr>
<tr>
<td>8.16</td>
<td>Surfaces - Principal Internal Forces</td>
<td>357</td>
</tr>
<tr>
<td>8.17</td>
<td>Surfaces - Design Internal Forces</td>
<td>360</td>
</tr>
<tr>
<td>8.18</td>
<td>Surfaces - Basic Stresses</td>
<td>365</td>
</tr>
<tr>
<td>8.19</td>
<td>Surfaces - Principal Stresses</td>
<td>367</td>
</tr>
<tr>
<td>8.20</td>
<td>Surfaces - Other Stresses</td>
<td>369</td>
</tr>
<tr>
<td>8.21</td>
<td>Surfaces - Contact Stresses</td>
<td>371</td>
</tr>
<tr>
<td>8.22</td>
<td>Surfaces - Equivalent Stresses - von Mises</td>
<td>373</td>
</tr>
<tr>
<td>8.23</td>
<td>Surfaces - Equivalent Stresses - Tresca</td>
<td>375</td>
</tr>
<tr>
<td>8.24</td>
<td>Surfaces - Equivalent Stresses - Rankine</td>
<td>376</td>
</tr>
<tr>
<td>8.25</td>
<td>Surfaces - Equivalent Stresses - Bach</td>
<td>377</td>
</tr>
<tr>
<td>8.26</td>
<td>Surfaces - Basic Strains</td>
<td>378</td>
</tr>
<tr>
<td>8.27</td>
<td>Surfaces - Principal Strains</td>
<td>380</td>
</tr>
<tr>
<td>8.28</td>
<td>Surfaces - Maximum Strains</td>
<td>382</td>
</tr>
<tr>
<td>8.29</td>
<td>Surfaces - Strains - von Mises</td>
<td>383</td>
</tr>
<tr>
<td>8.30</td>
<td>Surfaces - Strains - Tresca</td>
<td>385</td>
</tr>
<tr>
<td>8.31</td>
<td>Surfaces - Strains - Rankine</td>
<td>386</td>
</tr>
<tr>
<td>8.32</td>
<td>Surfaces - Strains - Bach</td>
<td>387</td>
</tr>
<tr>
<td>8.33</td>
<td>Solids - Deformations</td>
<td>388</td>
</tr>
<tr>
<td>8.34</td>
<td>Solids - Stresses</td>
<td>389</td>
</tr>
<tr>
<td>8.35</td>
<td>Solids - Strains</td>
<td>392</td>
</tr>
<tr>
<td>8.36</td>
<td>Solids - Gas Pressure</td>
<td>394</td>
</tr>
<tr>
<td>9</td>
<td>Results Evaluation</td>
<td>395</td>
</tr>
<tr>
<td>9.1</td>
<td>Available Results</td>
<td>395</td>
</tr>
<tr>
<td>9.2</td>
<td>Results Selection</td>
<td>396</td>
</tr>
<tr>
<td>9.3</td>
<td>Results Display</td>
<td>397</td>
</tr>
<tr>
<td>9.3.1</td>
<td>Member Results</td>
<td>398</td>
</tr>
<tr>
<td>9.3.2</td>
<td>Surface and Solid Results</td>
<td>399</td>
</tr>
<tr>
<td>9.4</td>
<td>Value Display</td>
<td>401</td>
</tr>
<tr>
<td>9.4.1</td>
<td>Result Values</td>
<td>401</td>
</tr>
<tr>
<td>9.4.2</td>
<td>Settings</td>
<td>403</td>
</tr>
<tr>
<td>9.4.3</td>
<td>User-Defined Result Values</td>
<td>405</td>
</tr>
<tr>
<td>9.4.4</td>
<td>Object Info</td>
<td>407</td>
</tr>
<tr>
<td>9.5</td>
<td>Result Diagrams</td>
<td>408</td>
</tr>
<tr>
<td>9.6</td>
<td>Sections</td>
<td>410</td>
</tr>
<tr>
<td>9.6.1</td>
<td>Section Through Surface</td>
<td>411</td>
</tr>
<tr>
<td>9.6.2</td>
<td>Section Through Solid</td>
<td>413</td>
</tr>
<tr>
<td>9.7</td>
<td>Smoothing Results</td>
<td>414</td>
</tr>
<tr>
<td>9.7.1</td>
<td>Work Window</td>
<td>415</td>
</tr>
<tr>
<td>9.7.2</td>
<td>Result Diagrams</td>
<td>419</td>
</tr>
<tr>
<td>9.7.3</td>
<td>Average Region</td>
<td>420</td>
</tr>
<tr>
<td>9.8</td>
<td>Multiple Windows View</td>
<td>422</td>
</tr>
<tr>
<td>9.9</td>
<td>Filtering Results</td>
<td>423</td>
</tr>
<tr>
<td>9.9.1</td>
<td>Views</td>
<td>423</td>
</tr>
<tr>
<td>9.9.1.1</td>
<td>Views navigator</td>
<td>423</td>
</tr>
<tr>
<td>9.9.1.2</td>
<td>Visibility buttons and menu</td>
<td>427</td>
</tr>
<tr>
<td>9.9.2</td>
<td>Clipping Plane</td>
<td>429</td>
</tr>
<tr>
<td>9.9.3</td>
<td>Filter Functions</td>
<td>431</td>
</tr>
<tr>
<td>9.10</td>
<td>Animation of Deformations</td>
<td>432</td>
</tr>
<tr>
<td>10</td>
<td>Printout</td>
<td>434</td>
</tr>
<tr>
<td>10.1</td>
<td>Printout Report</td>
<td>434</td>
</tr>
<tr>
<td>10.1.1</td>
<td>Creating or Opening Printout Reports</td>
<td>434</td>
</tr>
<tr>
<td>10.1.2</td>
<td>Working in the Printout Report</td>
<td>436</td>
</tr>
<tr>
<td>10.1.3</td>
<td>Defining the Content of Printout Reports</td>
<td>438</td>
</tr>
<tr>
<td>10.1.3.1</td>
<td>Selecting model data</td>
<td>439</td>
</tr>
<tr>
<td>10.1.3.2</td>
<td>Selecting load cases and combinations</td>
<td>441</td>
</tr>
<tr>
<td>10.1.3.3</td>
<td>Selecting load data</td>
<td>442</td>
</tr>
<tr>
<td>10.1.3.4</td>
<td>Selecting results data</td>
<td>443</td>
</tr>
<tr>
<td>10.1.3.5</td>
<td>Selecting data of add-on modules</td>
<td>444</td>
</tr>
<tr>
<td>10.1.4</td>
<td>Adjusting Printout Report Headers</td>
<td>445</td>
</tr>
<tr>
<td>10.1.5</td>
<td>Inserting RFEM Graphics</td>
<td>448</td>
</tr>
<tr>
<td>10.1.6</td>
<td>Inserting Graphics and Texts</td>
<td>450</td>
</tr>
<tr>
<td>10.1.7</td>
<td>Printout Report Template</td>
<td>452</td>
</tr>
<tr>
<td>10.1.8</td>
<td>Adjusting Layouts</td>
<td>454</td>
</tr>
<tr>
<td>10.1.9</td>
<td>Creating Cover Sheets</td>
<td>455</td>
</tr>
<tr>
<td>10.1.10</td>
<td>Printing a Printout Report</td>
<td>456</td>
</tr>
<tr>
<td>10.1.11</td>
<td>Exporting a Printout Report</td>
<td>457</td>
</tr>
<tr>
<td>10.1.12</td>
<td>Language Settings</td>
<td>458</td>
</tr>
<tr>
<td>10.2</td>
<td>Direct Graphic Printout</td>
<td>461</td>
</tr>
<tr>
<td>10.2.1</td>
<td>General</td>
<td>461</td>
</tr>
<tr>
<td>10.2.2</td>
<td>Options</td>
<td>465</td>
</tr>
<tr>
<td>10.2.3</td>
<td>Color Scale</td>
<td>467</td>
</tr>
<tr>
<td>10.2.4</td>
<td>Factors</td>
<td>468</td>
</tr>
<tr>
<td>10.2.5</td>
<td>Border and Stretch Factors</td>
<td>468</td>
</tr>
<tr>
<td>10.2.6</td>
<td>Mass Print</td>
<td>469</td>
</tr>
<tr>
<td>10.2.7</td>
<td>Notes for Plotting</td>
<td>471</td>
</tr>
<tr>
<td>11</td>
<td>Program Functions</td>
<td>474</td>
</tr>
<tr>
<td>11.1</td>
<td>General Functions</td>
<td>474</td>
</tr>
<tr>
<td>11.1.1</td>
<td>Language Settings</td>
<td>474</td>
</tr>
<tr>
<td>11.1.2</td>
<td>Display Properties</td>
<td>475</td>
</tr>
</tbody>
</table>
Table of Contents

11.1.3 Units and Decimal Places 478
11.1.4 Comments 480
11.1.5 Measuring Function 482
11.1.6 Search Function 483
11.1.7 Viewpoint and View Angle 484
11.1.8 Determining the Centroid 485
11.1.9 Rendering 486
11.1.10 Lighting 488
12. Selection 489
12.1 Selecting Objects Graphically 489
12.2 Selecting Objects by Criteria 492
13. Work Window 493
13.1 Work Planes 493
13.2 Grid 496
13.3 Object Snap 498
13.4 Coordinate Systems 503
13.5 Dimensions 506
13.6 Comments 508
13.7 Guidelines 510
13.8 Line Grids 514
13.9 Visual Objects 516
13.10 Background Layers 517
13.11 Margins and Stretch Factors 520
14. Editing Objects 520
14.1 Move and Copy 521
14.2 Rotate 524
14.3 Mirror 525
14.4 Project 526
14.5 Scale 527
14.6 Shear 529
14.7 Dividing Lines and Members 530
14.8 Connecting Lines and Members 533
14.9 Merging Lines and Members 534
14.10 Extending Lines and Members 535
14.11 Joining Members 536
14.12 Inserting Nodes 537
14.13 Inserting Members 538
14.14 Assigning Member Properties Graphically 539
14.15 Rounding Corners 540
14.16 Splitting Surfaces 541
14.17 Applying Tangents to Circles 542
14.18 Changing the Numbering 543
15. Table Functions 545
15.1 Editing Functions 545
15.2 Selection Functions 547
15.3 View Functions 549
15.4 Table Settings 552
15.5.5 Filter Functions 553
15.6 Importing and Exporting Tables 554
16. Parametrized Input 557
16.1 Concept 557
16.2 Parameter List 557
16.3 Formula Editor 561
16.4 Formulas in Tables and Dialog Boxes 564
17. Model Generators 565
17.1 Copies and Extrusions 565
17.1.1 Parallel offset of lines and members 565

11.7.1.2 Extruding lines and members 566
11.7.1.3 Extruding surfaces 568
11.7.1.4 Generating solids 569
11.7.1.5 Splitting members into surfaces 572
11.7.2 Model Generators 574
11.7.2.1 Members 575
11.7.2.2 Surfaces 588
11.8 Load Generators 590
11.8.1 General Features 590
11.8.2 Member/Line Loads from Area Loads 594
11.8.3.1 Member loads from free line load 600
11.8.3.2 Member loads from coating load 601
11.8.3.3 Loads from accelerated movements 601
11.8.4 Snow Loads 602
11.8.4.1 Flat/Monopitch roof 602
11.8.4.2 Duopitch roof 604
11.8.5 Wind Loads 605
11.8.5.1 Vertical walls 605
11.8.5.2 Flat roof 607
11.8.5.3 Monopitch roof 608
11.8.5.4 Duopitch/Troughed roof 609
11.8.5.5 Vertical walls with roof 611

12 File Management 612

12.1 Project Manager 612
12.1.1 Project Management 614
12.1.2 Model Management 618
12.1.3 Data Backup 621
12.1.4 Settings 622
12.1.4.1 View 622
12.1.4.2 Recycle bin 624
12.1.4.3 Directories 625
12.2 Creating New Models 626
12.2.1 General 627
12.2.2 Options 632
12.2.3 History 633
12.3 Network Management 634
12.4 Block Manager 635
12.4.1 Creating a Block 636
12.4.2 Importing a Block 637
12.4.3 Deleting a Block 639
12.5 Interfaces 640
12.5.1 Direct Data Exchange 640
12.5.2 Formats for Data Exchange 641
12.5.3 RF-LINK Import *.step, *.iges, *.sat 648

13 Literature 649
1 Introduction

1.1 New Features in RFEM 5

The structural FEA software RFEM for analysis and design of plates, walls, shells, solids, and frame structures is a powerful program for various tasks of modern civil engineering. This program forms the basis of a modular software system: RFEM determines internal forces, deformations, and support reactions of general plate structures with or without member and solid elements.

The program version RFEM 5 provides a wide range of useful features and options for efficient and user-friendly work on your structural analysis projects. At this point, we would like to thank our customers for their valuable ideas and remarks based on real engineering experience.

RFEM 5 includes the following new features amongst others:

- Graphical user interface in Chinese, French, Italian, Dutch, Polish, Portuguese, Russian, and Spanish
- Direct setting of different opening types
- Member eccentricities from cross-section dimensions
- Diagrams and extended criteria for nonlinear nodal supports and hinges
- Orthotropic properties for quadrangle and membrane surfaces, as well as solids
- Input option for hybrid timber cross-sections
- Filter in cross-section and material libraries including favorites
- Modeling of solids by extruding surfaces with relation to plane or point (with tapered sides as well)
- Intersections of solids using Boolean operators
- Inserting a member on an existing member
- Import of files from Bentley ISM, Ansys Apdl, and Scia Engineer
- Import of 3D objects
- Graphical assignment of member properties
- Color symbols in tables for cross-sections, surfaces, solids, and surface and member types
- Selection with ellipse, circular ring, or intersection line
- Work planes defined by three points or line, member, and surface axes
- Color management for various types of surfaces, stiffnesses, members, and solids
- Entering inclination and precamber in absolute values
- Surface size and weight entries in input table
- Automatic generation of load and result combinations in compliance with the standard requirements
- Gradual FE mesh refinement in edge areas of surfaces
- Large deformation analysis according to Newton-Raphson, Picard, or as dynamic relaxation
- Results of load distribution, distortions, member coefficients, and member slenderness
- Average regions for evaluation of singularities
- User-defined settings for lighting
- Result evaluation via clipping plane
- Views navigator for user-defined and generated visibilities and viewing angles
1.2 Program Capacity

The following values are the upper limits in the RFEM data structure. Please note that the limits for efficient work are significantly lower and depend on hardware, if nothing else.

Model data
99,999 objects of each category (nodes, lines, surfaces, cross-sections, etc.)

Load data
999,999 objects of each load type per load case

Load cases and combinations

<table>
<thead>
<tr>
<th>Description</th>
<th>Limit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Load cases (linear calculation)</td>
<td>9,999</td>
</tr>
<tr>
<td>Load combinations (nonlinear calculation)</td>
<td>9,999</td>
</tr>
<tr>
<td>Result combinations</td>
<td>9,999</td>
</tr>
</tbody>
</table>

Table 1.1 Program limits of RFEM
1.3 Company Profile

Dlubal Software, established in 1987, develops powerful and user-friendly engineering software for structural and dynamic analysis and design. Since 1990, the company's headquarters is located in Tiefenbach in Eastern Bavaria, Germany. In 2010, a branch office was opened in Leipzig, Germany. In 2014 and 2015, branch offices were opened in Poland, France, Italy, and in the US.

The enthusiasm of all those involved in the development and continuous implementation of new ideas is also reflected in our company creed as well as in the programs. Dlubal's professional competence in engineering and the user-friendly software are the basis for the growing success of Dlubal Software.

The software is designed in such a way that users with basic computer skills can easily handle the software after a short while. We are proud to call more than 7,800 engineering offices, construction companies from various industries, and institutions of higher education from all over the world our satisfied customers. In order to meet the requirements of modern civil engineering, there are more than 200 internal and external employees that continuously work on the development and improvement of Dlubal Software applications. Should you have questions and problems for which you do not find an answer in our FAQs, you can always rely on our e-mail hotline service. It will help you quickly and easily.

The perfect price-performance ratio of our software and the excellent customer service provided by the company makes Dlubal Software's applications essential tools for anyone working in the areas of structural engineering, dynamics, and design.

1.4 Using the Manual

There are many ways to reach a goal. This principle also applies for work with RFEM because the graphics, tables, and navigators are all of equal importance. The descriptions in this manual follow the sequence and structure of the tables and windows provided for model, load, and results. The chapters describe the individual tables and windows column by column. Instead of presenting general Windows features, the manual focuses on practical hints and tips.

If you are not yet familiar with the program, you should use our Introductory Example for RFEM 5 to learn how to enter data step by step. This PDF document is available in the Downloads & Infos section of our website. In this way, you can quickly get familiar with the most important program features. Advanced program users can try our detailed tutorial that is also available for download.

The text of the manual shows the described buttons in square brackets, for example [View mode]. In addition, they are pictured on the left. Expressions that appear in dialog boxes, tables, windows, and menus are set in italics. This should clarify the explanation.

In the PDF manual, you can perform a full-text search as usual with [Ctrl]+[F]. However, if you still cannot find what you are looking for, please use the search function in our Knowledge Base to find a solution in the technical articles. Our FAQs also provide a variety of tips.
2 Installation

2.1 System Requirements

In order to use RFEM, the following system requirements should be met:

- Operating system Windows 7/8/10 64-bit
- x86 CPU with 2 GHz
- 2 GB RAM
- USB interface for the installation (if no installation via download link)
- 20 GB hard disk capacity, including approximately 4 GB required for the installation
- Graphics card with OpenGL acceleration and resolution of 1024 x 768 pixels. Onboard solutions and shared-memory technologies are not recommended.

RFEM is not supported by Windows 95/98/Me/NT/2000/XP/Vista, Linux, Mac OS, or server operating systems.

Except for the operating system, there are no product recommendations, since RFEM basically runs on all systems that meet the aforementioned system requirements. If you use RFEM for intensive calculations, the principle "the more the better" applies.

Calculations of complex structural systems have to process huge amounts of data. Once the main memory is no longer sufficient, the hard drive is used for processing the data, which may significantly slow down your computer. Therefore, a main memory upgrade usually speeds up calculation more than a faster processor.

Since the RFEM computation kernel supports several processor cores, you can completely use the potential of the 64-bit operating system. If your computer has sufficient RAM memory, you can use the fast and direct matrix solver method even for large models.

For a calculation of complex structural systems, we recommend the following configuration:

- Quad-core processor
- Windows 7/8/10 64-bit
- 8 GB RAM

2.2 Installation Process

The RFEM program family is available for download as an installation file or is delivered on a USB drive. This file includes not only the main program RFEM but also all add-on modules of the RFEM program family such as RF-CONCRETE, RF-STEEL, RF-STABILITY, and many others.

Before installing RFEM, please close all applications that are running in the background.

For the installation, it is necessary to log in as an administrator or to have administrator rights. For further work with RFEM, user rights are sufficient. You can find detailed instructions in the User Rights document and in the User Rights video available on our website.
2.2.1 Installation from USB Drive

- Insert the flash drive into the USB port of your computer.
- The installation process starts automatically. If the installation does not start immediately, the AutoRun functionality is probably inactive. In this case, start the `setup.exe` file on the stick by using the Windows Explorer.
- Select the language in the start dialog box.

![Image of language selection](Image)

In the next dialog box, select the program **RFEM**.
- Follow the instructions of the **Installation Wizard**.

After the installation is finished, connect the dongle to the USB port of your computer. The dongle driver is installed automatically.

The USB drive also includes the installation instructions in the PDF format.

**Full or trial version of RFEM**

When you start the program for the first time after a successful installation, you have to specify if you want to use RFEM as a full version or as a 90-day trial version.

To run the program as a full version, you need a dongle (hardlock) and an authorization file **Author.ini**. The dongle is a small device that is plugged into the USB port of your computer; the authorization file contains coded information about your license(s). We usually send you the **Author.ini** file in an e-mail. You can also download the authorization file from your Dlubal account at any time. Save the **Author.ini** file on your computer, USB stick, or network.

The authorization file is required for each workstation. You can copy the file as often as you want. However, if the content is modified, the file can no longer be used for authorization.

The full version of RFEM can also run as a software license without a dongle.
2.2.2 Installation in Network

In case of network licenses, you should first install the program on the workstations as described. The licenses are then unlocked by the SRM network dongle. You can find detailed information about installing the network dongle in the Installation Instructions available on our website.

2.2.3 Installation of Updates and Add-On Modules

The USB drive contains the complete program package including all add-on modules. When you purchase a new add-on module, you will not necessarily receive a new USB stick but always a new authorization file Author.ini. In order to avoid reinstalling the program, you can just update the authorization in the RFEM menu by selecting Help → Authorization → Load Authorization File.

In case of an update within one version series (e.g. 5.02.xxxx), the old program files are removed and replaced by new ones. Of course, your project data is preserved! If you update to the next version series (e.g. 5.03.xxxx), the new version is installed at the same time (see below).

If you use user-defined printout report headers, you should save them before installing the update. The headers are usually stored in the DlubalProtocolConfigNew.cfg file in the general master data folder C:\ProgramData\Dlubal\Global\General Data. When updating the program, this file is not overwritten. Nevertheless, it may be useful to save a backup file.

We also recommend to save your report templates before you install the update. You can find them in the RfemProtocolConfig.cfg file in the C:\ProgramData\Dlubal\RFEM 5.xx\General Data folder.

Projects linked in the Project Manager are available in the ASCII file PRO.DLP, which can usually be found in the folder C:\ProgramData\Dlubal\Global\Project Manager (see Figure 12.21). If you want to uninstall RFEM before the update installation, you should save this file beforehand as well.

2.2.4 Parallel Installations of RFEM

It is possible to run RFEM 4 and the individual RFEM 5 versions parallel on one computer, since the program files are in different directories. For a 64-bit operating system, the default folders are:

RFEM 4: C:\Program Files (x86)\Dlubal\RFEM 4
RFEM 5.01: C:\Program Files\Dlubal\RFEM 5.01
RFEM 5.02: C:\Program Files\Dlubal\RFEM 5.02
RFEM 5.03: C:\Program Files\Dlubal\RFEM 5.03, etc.

In RFEM 5, you can open and edit all models created in RFEM 4. The RFEM 4 models are not overwritten when saving them in RFEM 5, as both programs use different file name extensions: RFEM 4 model data is saved in *.rf4 format, RFEM 5 data in *.rf5 format.

Model files of RFEM 5 are downward compatible with certain restrictions. When opening an RFEM 5 model file in a previous program version, for example, a message appears indicating that compatibility problems for members with asymmetrical cross-sections may occur.
3 User Interface

3.1 Overview

When you open one of the model examples included in RFEM, the screen looks like in Figure 3.1. The graphical user interface corresponds to usual Windows standards.

The following screenshot shows the most important areas of the program interface.

![RFEM user interface screenshot](image-url)
### 3.2 Terminology

Various terms are used for the UI elements. This manual uses common expressions in compliance with the Microsoft Manual of Style. Some of the terms are combined if they do not need to be distinguished for the operation of RFEM.

The following table explains frequently used terms.

<table>
<thead>
<tr>
<th>Term</th>
<th>Figure</th>
<th>Synonym</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menu</td>
<td><img src="image" alt="Pulldown menu" /></td>
<td>Pulldown menu</td>
<td>Commands and functions below the title bar</td>
</tr>
<tr>
<td>Shortcut menu</td>
<td><img src="image" alt="Pop-up menu" /></td>
<td>Pop-up menu</td>
<td>Shortcut menu that appears when right-clicking an object. It contains useful commands and functions for the selected object.</td>
</tr>
<tr>
<td>Toolbar</td>
<td><img src="image" alt="Button bar" /></td>
<td>Button bar</td>
<td>Collection of buttons below the menu bar</td>
</tr>
<tr>
<td>Dialog box</td>
<td><img src="image" alt="Window" /></td>
<td>Window</td>
<td>Window opened in the main window for entering data</td>
</tr>
<tr>
<td>Tabs</td>
<td><img src="image" alt="Register" /></td>
<td>Register</td>
<td>Large dialog boxes are divided into several tabs. Click a tab to open the individual &quot;index cards&quot;.</td>
</tr>
</tbody>
</table>
### Section

<table>
<thead>
<tr>
<th>Group, frame</th>
<th>Elements in a dialog box that belong together logically</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Image" /></td>
<td><img src="image2.png" alt="Image" /></td>
</tr>
</tbody>
</table>

### Button

- **List button of toolbar**
  - ![Image](image3.png)

- **List buttons**
  - Click to open a list with similar functions.
  - The recently selected button is displayed at the top.

### Text box

- **Input box**
  - Field for entering text or numerical values

### Spin box

- **Spin button**
  - Two tiny buttons next to a text box
  - Numerical values can be changed gradually.
### Terms of the Graphical User Interface

<table>
<thead>
<tr>
<th>List</th>
<th>List Box, Combo Box</th>
<th>Options for Text Boxes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Check box</td>
<td>Control Box</td>
<td>Yes/No Decision by Selecting or Clearing the Check Box</td>
</tr>
<tr>
<td>Selection Field</td>
<td>Option Button</td>
<td>Only One of the Options Can Be Selected</td>
</tr>
</tbody>
</table>

**Table 3.1** Terms of the graphical user interface
# Special Terms in RFEM

This chapter explains some important terms specific to RFEM. They are described in detail in the following chapters.

<table>
<thead>
<tr>
<th>Term</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Nodes</td>
<td>In the 3D model, a node is defined by its coordinates (X/Y/Z). Nodes are used to model the geometry of a structure.</td>
</tr>
<tr>
<td>Line</td>
<td>Nodes are connected by lines. In addition to straight connections, high-grade lines such as arcs or splines are possible.</td>
</tr>
<tr>
<td>Member</td>
<td>A member represents the property of a line. Through material and cross-section properties, a certain stiffness is assigned to the member. A member is a 1D element.</td>
</tr>
<tr>
<td>Set of members</td>
<td>Members can be combined into a set of members. In a <strong>continuous member</strong>, members are continuously connected to the node like in a continuous beam. A <strong>group of members</strong> consisting of connected members can join more than two members on a single node.</td>
</tr>
<tr>
<td>Surface</td>
<td>A surface is limited by lines. Through material and thickness properties, a certain stiffness is assigned to the surface. A surface is a 2D element.</td>
</tr>
<tr>
<td>Solid</td>
<td>A solid is surrounded by boundary surfaces (usually type Null). The stiffness is defined by its material properties. A solid is split into 3D elements for the calculation.</td>
</tr>
<tr>
<td>Nodal support</td>
<td>The degrees of freedom are limited for the node.</td>
</tr>
<tr>
<td>Line support</td>
<td>The degrees of freedom of all FE nodes on a line are limited.</td>
</tr>
<tr>
<td>Surface support</td>
<td>The degrees of freedom of all FE nodes in a surface are limited.</td>
</tr>
<tr>
<td>Nodal load</td>
<td>Force or moment applied to a node.</td>
</tr>
<tr>
<td>Line load</td>
<td>A line is loaded by a uniform or variable distributed load or by a concentrated load. The load acts as a force or moment.</td>
</tr>
<tr>
<td>Member load</td>
<td>A member is loaded by a distributed or concentrated load. The load diagram can be either uniform, linearly variable, or parabolic. In addition to forces and moments, temperature actions and prestresses are possible.</td>
</tr>
<tr>
<td>Surface load</td>
<td>A surface is loaded by a uniform or linearly variable load. In addition to forces, temperature loads and imposed deformations can act on the surface.</td>
</tr>
</tbody>
</table>
Solid load
A solid is loaded by effects of temperature or imposed deformations.

Load case LC
The loads from an action are managed in a load case, for example "self-weight" or "wind". The loads should be defined as characteristic loads (i.e. without factors). Partial safety factors can be considered in load or result combinations. A load case is usually calculated according to the linear static analysis.

Load combination CO
A load combination is used to superimpose load cases, that means all loads of the load cases in question are summarized. A load combination is usually calculated according to the second-order or large deformation analysis.

Result combination RC
A result combination sums up the results of the contained load cases. It is also possible to determine the extreme internal forces and deformations from different load cases, load combinations, or result combinations using an Or combination. However, the additive principle of superposition does not apply for results calculated according to the second-order analysis.

| Table 3.2 | RFEM-specific terms |

## 3.4 RFEM User Interface

This chapter describes the individual operating elements of RFEM (see Figure 3.1). The program follows the general standards for Windows applications.

### 3.4.1 Menu Bar

The menu bar is below the title bar. All functions of RFEM can be accessed in the menu bar. It is organized into logical blocks.

You can open a menu by clicking it. You can also use the keyboard by holding down the [Alt] key in combination with the underlined letter of the menu title. The menu opens and you can access the menu items. Select the entries per mouse-click or by pressing the underlined letter. You can also select the desired function by using the [↑] and [↓] cursor keys and finally pressing the [↵] key.

When a menu list is opened, you can switch between the menus or subentries by using the [←] and [→] keys.

For some menu items, a key combination is additionally shown: These Hot Keys largely follow the Windows standard. Use them to execute functions directly with keyboard keys (e.g. [Ctrl]+[S] saves the data).
3.4.2 Toolbars

There are toolbars with various buttons below the menu bar. Use these buttons to access the most important functions directly by mouse-click. Brief information about a button’s function appears when you point to a button with the mouse pointer (ScreenTip, ToolTip).

Some buttons provide subentries like a menu: These list buttons contain topic-related functions. Click next to the button symbol to access the functions. The recently selected button is preset at the top of the list.

To change the position of a toolbar, "grab" it in its front area with the left mouse-button, then move it to the desired position.

When you drag a toolbar into the workspace, it becomes a "floating" toolbar and is above the graphics.

To re-dock the floating toolbar, move it to the window frame with the mouse button or double-click its headline.

You can click View –> Arrange Toolbars Customized in the menu to open a dialog box for changing the content and look of toolbars. Customizing toolbars follows Windows standards.

All commands of RFEM are sorted by Categories. Select an entry in the list to see the buttons of all associated Commands on the right. Click a button to get an explanation of the button function shown in the dialog section below. All buttons can be moved to any place in the toolbar by using the drag-and-drop function. It is recommended to integrate these additional buttons into a new toolbar [see Figure 3.6], as the remaining toolbars may be reset to the default entries when installing updates.
To remove a button from the toolbar, the Customize dialog box must be open. Then you can drag and drop the button from the toolbar to the workspace. It is also possible to use its shortcut menu shown on the left to Delete the button.

In addition to dragging commands into the toolbar, you can move them into the menus. In this way, you can create user-defined menus. Menu items can be deleted or customized as described for toolbars.

The Button Appearance option available in the shortcut menu opens the following dialog box:

![Button Appearance dialog box](image)

The dialog box helps you to change the text of the button or menu item. Moreover, you can replace the default symbol by a user-defined icon.

All available toolbars are listed in the Toolbars tab. You can switch off toolbars or create new ones by using the [New] button.

![Creating a new toolbar](image)

Enter the name of the new toolbar in the Toolbar dialog box. After clicking [OK], the new bar appears in a floating position. You can move the toolbar to an appropriate position and fill it with buttons by using the Commands tab (see Figure 3.4).

The [Reset All User-defined Toolbars] button resets the toolbar to its initial state. If the list contains a customized toolbar, it is removed. The default toolbars of RFEM cannot be removed, only switched off.
In the **Menu Items** tab, you can create custom pull-down menus. The procedure is the same as for creating a new toolbar (see Figure 3.6).

Use the final dialog tab, **Options**, to change the appearance of the RFEM user interface. The following **Designs** can be selected:

![Available designs for the user interface](image)

The new setting is active right away.

### 3.4.3 Project Navigator

To the left of the work window, there is a navigator that looks like the Windows Explorer. To display or hide the **Project Navigator**, use the **View → Navigator** menu option or the corresponding toolbar button.

![Navigator button in the Default toolbar](image)

The navigator shows the model data of opened files in a tree structure. Click 
+ to open a branch of the tree or - to close it. You can also double-click the entry.

The navigator is similar to a toolbar: You can use the mouse to "grab" the navigator in its title bar and move it to the workspace. To dock it again, double-click the title bar or move the navigator to the window frame. When moving the navigator, directional buttons shown on the left appear that facilitate the docking to one of the four sides of the work window: Drag the navigator to the arrow button of your choice and release the left mouse button as soon as the pointer is placed on the button.

If you do not want the navigator to be docked to the window frame, clear the corresponding selection in the shortcut menu of the navigator.

If the **Synchronized Selection** is active, an object marked in the navigator is also highlighted in color in the model graphic.

The shortcut menu option **Auto Hide** allows you to minimize a docked navigator: As soon as you click into the work window, the navigator slides to the edge and becomes a thin bar (see Figure 3.9). You can also use the pin button on the top right of the navigator to select this function (see Figure 3.10).

The navigator opens in full size when you move the pointer across the **Project Navigator** field highlighted in the docked navigator bar.
Figure 3.9 Navigator, tables, and panel in auto hide mode

At the bottom edge of the navigator, there are three tabs (four after the calculation). Use the tabs to switch between the Data, Display, Views, and Results navigators.

Figure 3.10 Data and Display tabs in the project navigator
Data navigator

This navigator manages model and load data, as well as calculated results. Double-click an entry (a "leaf" of the tree structure) to open a dialog box for changing the selected object. When you right-click an entry, a shortcut menu appears with helpful functions used to create or modify the object.

Incorrectly defined objects are displayed in red, unused objects are displayed in blue.

Display navigator

This navigator controls the graphical display in the work window. When you clear an entry’s check box, the corresponding object is hidden in the graphic.

Use the shortcut menu of the navigator shown on the left to save or import user-defined settings or use them as the default for new models.

Views navigator

This navigator manages user-defined views as well as user-defined and automatically created visibilities of objects (partial views, groups). Use the buttons to create user-defined views, set visibilities, integrate objects into user-defined visibilities, etc.

Working with views and visibilities is described in Chapter 9.9.1.

Results navigator

Use this navigator to control, which results are displayed in the graphic. Available entries depend on whether results of RFEM or of an add-on module are displayed.
3.4.4 Tables

The tables are at the bottom edge of the RFEM window. To display or hide the tables, click **Table → Display** on the menu or use the corresponding button.

![Figure 3.12 Table on/off button in the Default toolbar](image)

There are four groups of tables. To switch between them, use the first four buttons in the toolbar of the table or **Table → Go To** in the menu.

<table>
<thead>
<tr>
<th>Menu Table → Go To → Model Data</th>
<th>Tables for model data</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Table 1. Model Data" /></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Table 2. Load Cases and Combinations" /></td>
<td>Tables for load cases and combinations</td>
</tr>
<tr>
<td><img src="image" alt="Table 3. Loads" /></td>
<td>Tables for loads</td>
</tr>
<tr>
<td><img src="image" alt="Table 4. Results" /></td>
<td>Tables for results</td>
</tr>
</tbody>
</table>

The tables manage all model and load data numerically. Several powerful functions allow for efficient data input (see Chapter 11.5).

The tables represent the internal data structure of RFEM. By working through the tables successively, RFEM ensures that all data is recorded. Descriptions of input and output in the manual chapters 4, 5, 6, and 8 are also based on the structure of these tables.
The tables are similar to toolbars: You can use the mouse to "grab" tables in their title bar and move them into the workspace. To dock a table, double-click its title bar, or move the table to the window frame or one of the directional buttons shown on the left.

Docked tables can be minimized with the shortcut menu option Auto Hide as soon as you click into the work window (see Figure 3.9). You can also use the pin button on the top right of the table to select the minimize function. The tables open in full size again when you move the pointer over the docked bar.

When selecting a table row by mouse click, related objects are highlighted with colors in the graphic. Conversely, when an object is selected in the work window, the corresponding table row is also displayed and highlighted in a different color. To control the settings for the so-called "synchronization of selection", use the menu item Table → Settings or the table toolbar buttons shown on the left (see Chapter 11.5.4).

### 3.4.5 Status Bar

The status bar is at the bottom of the RFEM work window. To activate or deactivate the bar, click View → Status Bar on the menu.

The status bar consists of three areas.

**Left area**

The displayed text varies depending on the active program function. When the pointer moves across the work window, information appears about the object indicated by the pointer at a given time.

If you are an RFEM beginner, keep an eye on this section of the status bar: You may find useful hints and descriptions for toolbar buttons and dialog boxes.

**Center area**

Its functionality is similar to that of a toolbar, controlling the display of the work window.

**SNAP**

The button enables or disables the snap function of the grid. Use the shortcut menu to access the dialog box with specific settings for grid parameters (see Chapter 11.3.2).

**GRID**

Click the button to switch the grid on and off. Select Edit in the shortcut menu to open the dialog box shown in Figure 11.34.

In addition, the shortcut menu allows you to gradually maximize or minimize grid spacings.
ORTHO / CARTES / POLAR

Use this button to select the orthogonal, Cartesian, or polar grid. With this shortcut menu, you can open the dialog box shown in Figure 11.34. In addition, you can gradually enlarge and reduce grid spacings.

OSNAP

This button activates or deactivates the object snap (see Chapter 11.3.3).

GLINES

This button controls the display of guidelines (see Chapter 11.3.7).

DXF

Use this button to switch the display of background layers on and off (see Chapter 11.3.10).

Right area

Figure 3.15 Right area of status bar

The right area of the status bar shows the following information about graphically entered data:

- Visibility mode (if active)
- Coordinate system CS
- Work plane
- Coordinates of current pointer position

3.4.6 Control Panel

As soon as internal forces or deformations are displayed graphically, the panel appears in the work window, providing different options for display and control. To switch the panel on and off, select View → Control Panel in the menu or use the corresponding button.

The panel is similar to a toolbar: You can use the mouse to "grab" the panel in its title bar and move it into the workspace. To dock the panel, double-click its title bar or move it to the window frame or one of the directional buttons shown on the left.

The docked panel can be minimized with the Auto Hide shortcut menu option as soon as you click into the work window (see Figure 3.9). You can also use the pin button on the top right of the panel to select the minimize function. The panel opens in full size again when you move the pointer over the docked bar.

The control panel consists of the following tabs: Color scale, Factors, Filter, and Thicknesses, if available.
When a multi-color results display is set, the first tab shows the color scale with assigned ranges of values. Eleven color zones are set by default, covering the range between extreme values in equally spaced intervals.

To adjust the color scale, double-click one of the colors. You can also use the [Options] button available in the panel. The Options dialog box opens (Figure 3.16) where you can click the [Edit] button to access another dialog box for changing the ranges of colors and values.

Use the vertical sliders to the right of the values to reduce the number of color ranges at both ends of the color scale.

You can change colors individually by double-clicking a color field.
You can adjust scale values manually. Make sure you follow a strictly ascending or descending order. Use the buttons in the Value Scale dialog section to assign values. The buttons are defined as follows:

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default</td>
<td>The eleven color zones are set to default.</td>
</tr>
<tr>
<td>Empty</td>
<td>All values in the text boxes are deleted.</td>
</tr>
<tr>
<td>Fill</td>
<td>The values are equidistantly interpolated between maximum and minimum,</td>
</tr>
<tr>
<td></td>
<td>depending on the number of color zones.</td>
</tr>
<tr>
<td>Fill Max/Min</td>
<td>For a reduced color scale, the intermediate values are calculated in</td>
</tr>
<tr>
<td></td>
<td>relation to the absolute or manually entered extreme values.</td>
</tr>
<tr>
<td>Save</td>
<td>The value scale is saved as a global sample.</td>
</tr>
</tbody>
</table>

Table 3.4 Buttons in the Value Scale dialog section

The Apply to all result diagrams check box allows you to control if the current color scale for the results display of all load cases, load combinations, and result combinations is used. The value scale remains unaffected because a global assignment for deformations, forces, moments, and stresses is problematic. Click [Save] to save the modified color scale as user-defined.

Use the [Options] button as shown in Figure 3.16 to select further options in the Options dialog box.

The reference to limit values allows you to accurately evaluate results within a defined zone. Exceeding or falling below limits is respectively represented by a different color. With the values set in Figure 3.18, the moments $m_y$ are displayed in a fine gradation within the range of ±30 kNm/m. Values outside the defined zone appear in red or blue.

In the Options dialog box, select the Smooth color transition check box to make the distinct color zones disappear. This smoothed color scale can be set independently of the reference option selected for the result values.
Factors

The second panel tab controls the scaling factors for the graphic display. Depending on the currently set results graphic, you can access text boxes for scaling the Deformation, Member diagrams, Surface diagrams, Section diagrams, Reaction forces, and Trajectories.

Filter

With the Color Scale tab, you can filter result values in general. The Filter tab, however, allows you to select different result displays for specific surfaces, members, or solids.

The selection field below the button row specifies, which of the three object categories you can display result diagrams for. You have to enter the numbers of relevant members, surfaces, or solids into the Show diagrams for text box. With a click on the [Apply] button, you implement the filter in the graphic.
It is also possible to import object numbers from the graphic: First, select the members, surfaces, or solids (multiple selection via window or by holding down the [Ctrl] key) and click the [Import from Selection] button.

The filter settings of the panel also affect the objects in the results tables: For example, when you restrict the results display in the panel to two members, Table 4.6 Members - Internal Forces only lists the results of those two members.

**3.4.7 Default Buttons**

Buttons are used in many dialog boxes. When you move the pointer over a button, its function is displayed in a short description after a moment.

The following overview describes frequently used default buttons.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="New" /></td>
<td>New</td>
<td>Opens a dialog box to define an object</td>
</tr>
<tr>
<td><img src="image" alt="Edit" /></td>
<td>Edit</td>
<td>Opens a dialog box to modify an object</td>
</tr>
<tr>
<td><img src="image" alt="Delete" /></td>
<td>Delete</td>
<td>Deletes an object or entry</td>
</tr>
<tr>
<td><img src="image" alt="Select" /></td>
<td>Select</td>
<td>Graphical selection</td>
</tr>
<tr>
<td><img src="image" alt="Apply" /></td>
<td>Apply</td>
<td>Import from the current selection</td>
</tr>
<tr>
<td><img src="image" alt="Library" /></td>
<td>Library</td>
<td>Opens a collection of stored data</td>
</tr>
<tr>
<td><img src="image" alt="Help" /></td>
<td>Help</td>
<td>Opens the help function</td>
</tr>
<tr>
<td><img src="image" alt="Use" /></td>
<td>Use</td>
<td>Applies changes without closing the dialog box</td>
</tr>
<tr>
<td><img src="image" alt="Settings" /></td>
<td>Settings</td>
<td>Opens a dialog box for detailed settings</td>
</tr>
<tr>
<td><img src="image" alt="Comments" /></td>
<td>Comments</td>
<td>Access to default text modules</td>
</tr>
<tr>
<td><img src="image" alt="Units and Decimal Places" /></td>
<td>Settings for units and decimal places</td>
<td><img src="image" alt="Chapter 11.1.4" /></td>
</tr>
<tr>
<td><img src="image" alt="Default" /></td>
<td>Default</td>
<td>Restores default dialog settings</td>
</tr>
<tr>
<td><img src="image" alt="Set as Default" /></td>
<td>Set as Default</td>
<td>Saves the current settings as default</td>
</tr>
<tr>
<td><img src="image" alt="Font" /></td>
<td>Font</td>
<td>Option to set fonts and font sizes</td>
</tr>
<tr>
<td><img src="image" alt="Colors" /></td>
<td>Colors</td>
<td>Option to set colors</td>
</tr>
<tr>
<td><img src="image" alt="Info" /></td>
<td>Info</td>
<td>Displays information about an object</td>
</tr>
</tbody>
</table>
### 3.4.8 Keyboard Functions

In tables and the graphical user interface, frequently required functions can also be accessed via the keyboard.

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[F1]</td>
<td>Help</td>
</tr>
<tr>
<td>[F2]</td>
<td>Next table</td>
</tr>
<tr>
<td>[F3]</td>
<td>Previous table</td>
</tr>
<tr>
<td>[F4]</td>
<td>Plausibility check for current table</td>
</tr>
<tr>
<td>[F5]</td>
<td>Plausibility check for all tables</td>
</tr>
<tr>
<td>[F7]</td>
<td>Selection function in tables</td>
</tr>
<tr>
<td>[F8]</td>
<td>Copies the table cell above, or shows the entire model on screen</td>
</tr>
<tr>
<td>[F9]</td>
<td>Calculator</td>
</tr>
<tr>
<td>[F10]</td>
<td>Menu Bar</td>
</tr>
<tr>
<td>[F12]</td>
<td>Saves the model under a new name</td>
</tr>
<tr>
<td>[Alt]</td>
<td>Menu Bar</td>
</tr>
<tr>
<td>[Ctrl]+[2]</td>
<td>Copies a row of the table to the next row</td>
</tr>
<tr>
<td>[Ctrl]+[A]</td>
<td>Redo function</td>
</tr>
<tr>
<td>[Ctrl]+[C]</td>
<td>Copies to the clipboard</td>
</tr>
</tbody>
</table>
### Table 3.6: Keyboard functions

<table>
<thead>
<tr>
<th>shortcut</th>
<th>function</th>
</tr>
</thead>
<tbody>
<tr>
<td>[Ctrl]+[E]</td>
<td>Exports data</td>
</tr>
<tr>
<td>[Ctrl]+[F]</td>
<td>Searches within the table</td>
</tr>
<tr>
<td>[Ctrl]+[G]</td>
<td>Generates entries in the table</td>
</tr>
<tr>
<td>[Ctrl]+[H]</td>
<td>Replaces entries in the table</td>
</tr>
<tr>
<td>[Ctrl]+[I]</td>
<td>Inserts a row into the table or imports data</td>
</tr>
<tr>
<td>[Ctrl]+[L]</td>
<td>Jumps to a specific row number in the table</td>
</tr>
<tr>
<td>[Ctrl]+[N]</td>
<td>Creates a new model</td>
</tr>
<tr>
<td>[Ctrl]+[O]</td>
<td>Opens an existing model</td>
</tr>
<tr>
<td>[Ctrl]+[P]</td>
<td>Prints the graphic</td>
</tr>
<tr>
<td>[Ctrl]+[R]</td>
<td>Deletes rows in the table</td>
</tr>
<tr>
<td>[Ctrl]+[S]</td>
<td>Saves data</td>
</tr>
<tr>
<td>[Ctrl]+[U]</td>
<td>Clears selection in the table</td>
</tr>
<tr>
<td>[Ctrl]+[V]</td>
<td>Inserts from the clipboard</td>
</tr>
<tr>
<td>[Ctrl]+[X]</td>
<td>Cuts items in the table</td>
</tr>
<tr>
<td>[Ctrl]+[Y]</td>
<td>Deletes the content of the current table row</td>
</tr>
<tr>
<td>[Ctrl]+[Z]</td>
<td>(Undo) function</td>
</tr>
</tbody>
</table>

If no dialog box is open, the [Enter] key calls the last used function. Thus, reapplication of data is easier (placing model or load objects once more in the work window, for example).
### 3.4.9 Mouse Functions

The mouse functions follow the general standards for Windows applications: To select an object for editing, simply click it with the **left** mouse button. Double-click the object when you want to open its dialog box for editing. You can apply these functions to objects of the work window as well as to entries in the Data navigator.

Model and load objects can be moved in the work window via drag-and-drop or copied by holding down the [Ctrl] key. The drag-and-drop function can be switched on and off in the general shortcut menu (see Figure 11.53).

When you click an object with the **right** mouse button, its shortcut menu appears, providing object-related commands and functions. Shortcut menus are available in the graphic, navigator, and tables.

![Shortcut menu of Nodal Support in the graphic](image.jpg)

By scrolling the **wheel button**, you can maximize or minimize the current model display. The pointer position is always assumed as the center of the zoom area.

Press the wheel button to move the model directly within the workspace, that is, without activating the [Move] toolbar button beforehand. If you additionally press the [Ctrl] key, you can rotate the model. You can also rotate the model by using the wheel button and holding down the right mouse button. The pointer symbols shown on the left indicate the selected function.

To rotate the display around a particular node, select the node first. Then, hold down the [Alt] key and press the wheel button to rotate the model about the selected node.

The options offered by a 3D mouse can also be used for working with the graphical user interface of RFEM.

Furthermore, RFEM provides a useful function to quickly display selected objects in maximized view: First, select the objects in the work window. Then, hold down the shift key ([⇧]) and click one of the buttons available in the View toolbar shown on the left. The work window will display a maximized partial view of the object in the selected viewing direction.
3.4.10 Configuration Manager

The Configuration Manager provides access to all settings available for display properties, fonts, toolbars, print headers, etc. To open the Configuration Manager, select \textit{Options} \rightarrow \textit{Configuration Manager} in the menu or use the toolbar button shown on the left.

![Configuration Manager dialog box](image)

Available configurations

This dialog section lists all configurations that were user-defined or created during the installation. The setting currently used by the program is shown in bold and indicated as current.

The Standard configuration is preset; it cannot be deleted.

The buttons in this dialog section have the following functions:

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>✔️</td>
<td>Sets the entry selected above as new current configuration</td>
</tr>
<tr>
<td>📚</td>
<td>Creates a new configuration from current settings (Figure 3.23)</td>
</tr>
<tr>
<td>🍀</td>
<td>Renames the selected configuration</td>
</tr>
<tr>
<td>📖</td>
<td>Exports the selected configuration into a file</td>
</tr>
<tr>
<td>📚</td>
<td>Imports a configuration from a file</td>
</tr>
<tr>
<td>🛑</td>
<td>Resets the default values</td>
</tr>
<tr>
<td>✕</td>
<td>Deletes the selected configuration (not possible for Standard and current)</td>
</tr>
</tbody>
</table>

Table 3.7 Buttons for Available Configurations
Use the [New] button to save the current settings as a new configuration. A dialog box opens where you can enter a Description. An optional Comment makes it easier to select among various user-defined configurations later.

![New Configuration dialog box](image)

**Settings**

The buttons available in the Settings dialog section provide access to different dialog boxes with configuration parameters. They are described in the following table.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Display properties]</td>
<td>Display properties</td>
<td>Opens the Display Properties dialog box</td>
</tr>
<tr>
<td>![Program options]</td>
<td>Program options</td>
<td>Opens the Program Options multi-tab dialog box</td>
</tr>
<tr>
<td>![Toolbars and menus]</td>
<td>Toolbars and menus</td>
<td>Opens the Customize dialog box</td>
</tr>
<tr>
<td>![Margins and stretch factors]</td>
<td>Margins and stretch factors</td>
<td>Opens the Display Margins and Stretch Factors dialog box</td>
</tr>
<tr>
<td>![Table colors]</td>
<td>Table colors</td>
<td>Opens the Colors dialog box for the table colors</td>
</tr>
<tr>
<td>![Table fonts]</td>
<td>Table fonts</td>
<td>Opens the Font dialog box for the table fonts</td>
</tr>
<tr>
<td>![Header and footer of printout report]</td>
<td>Header and footer of printout report</td>
<td>Opens the Printout Report Header dialog box</td>
</tr>
</tbody>
</table>

*Table 3.8 Function of buttons in the Settings dialog section*
Model Data

Starting RFEM

To start the program, use the Windows start menu or the Dlubal icon on the desktop.

To enter data, a model must be created or opened (see Chapter 12.2).

RFEM provides different options for entering data: You can define objects in a dialog box, a table, and often directly in the graphic. All input is interactive, which means that graphical input is immediately reflected in the table and vice versa.

For first steps with RFEM, we recommend trying the introductory example that may be helpful for beginners; it can be downloaded on our website.

Opening input dialog boxes

You can access the input dialog boxes and the graphical input in various ways.

Insert menu

![Insert menu](image)

Figure 4.1 Insert → Model Data menu

Insert toolbar

![Insert toolbar](image)

Figure 4.2 Insert toolbar
Shortcut menu in Data navigator

![Shortcut menu of model data objects in the Data navigator](image)

Figure 4.3 Shortcut menu of model data objects in the Data navigator

Shortcut menu or double-click in table

![Shortcut menu in model data tables](image)

Figure 4.4 Shortcut menu in model data tables

The input dialog box can be accessed by means of the shortcut menu (or by double-click) of the row number.
Opening edit dialog boxes

RFEM provides different ways to open a dialog box for editing model objects.

**Edit menu**

![Edit menu](image)

**Shortcut menu or double-click in graphic**

![Shortcut menu](image)
Shortcut menu or double-click in the Data navigator

The edit dialog box can be accessed by using the shortcut menu of the row number. You can also double-click the number to open the dialog box for editing the object.
**Table input**

Input and modifications carried out in the graphical user interface are immediately shown in the tables, and vice versa. To open the model data tables, use the leftmost button in the table toolbar shown on the left.

![Table 1: Model Data](image)

Input in the form of spreadsheet data entered in tables can be quickly edited and imported (see Chapter 11.5).

Unused objects are highlighted in blue in the tables and Data navigator.

In each dialog box and table, it is possible to add a Comment that describes the object in detail. You can also use predefined comments (see Chapter 11.1.4). Moreover, comments are part of ScreenTips for graphical objects.
4.1 Nodes

General description

The geometry of the model is defined by nodes. They are essential for creating lines, and thus members, surfaces, and solids. Every node is specified by its coordinates X, Y, Z. The coordinates usually refer to the origin of the global coordinate system but it is also possible to define them in relation to another node.

The node number is automatically assigned in the New Node dialog box and can also be modified in it. The sequence of the node numbering is not important: Gaps in the numbering are permitted.

To adjust the order of node numbers retroactively, select Tools → Renumber in the menu (see Chapter 11.4.18).

The list button contains a special function. It allows you to create a node on the connection line of two existing nodes (see Chapter 11.4.12).
**Node Type**

**Standard**

This type of node is used most frequently. Standard nodes can be placed graphically in the work plane or anywhere in the workspace via coordinate specification. When you graphically enter lines or rotated surfaces, standard nodes are created.

Standard nodes are displayed in red in the graphic.

**On Line**

With this type of node, a line is not divided into two lines and remains complete instead. The nodal parameter $\delta$ describes the relative distance to the start node of the line.

By creating nodes on lines, it is possible to apply nodal loads anywhere on the line or to force an FE node.

Nodes on lines are displayed in light blue by default.

By using the **Tools → Generate Nodes on Intersection Point of Lines** menu option, you can create nodes on lines that intersect.

**On Surface**

For quadrangle surfaces, it is difficult to determine the coordinates of nodes on the curved surface. With the **Node on Surface** node type, you can place a node directly on a quadrangle surface displayed in the graphic. The nodal parameters $\delta_1$ and $\delta_2$ refer to the four corner nodes of the surface.

By creating nodes on surfaces, it is possible to apply nodal loads anywhere on the curved surface or to force an FE node.
Coordinates in the table are stored in the Cartesian coordinate system. Nodes on surfaces are graphically displayed in light blue by default.

If you work with plane surfaces, use standard nodes.

**Trajectory**

This type of node is created when you define a spiral trajectory curve (see Chapter 4.2). The nodal parameter $\delta$ describes the relative distance from the start node of the line.

![Figure 4.15 Trajectory](image)

Trajectory nodes are displayed in dark green by default.

**Reference node**

In general, the coordinates of a node are related to the origin 0 of the global coordinate system. You do not need to define the node (0/0/0) because RFEM automatically recognizes the origin.

Any node may serve as a reference node; even a node with a higher number is allowed to be used as a reference node. Referring to another node may be useful, for example, to define a new node at a certain distance to a known position. The table list with its Previous node option is especially useful in this case.

In the New Node dialog box, you can enter the reference node directly, select it from the list, or define it graphically using the button.

**Coordinate system**

The coordinates of a node always refer to a coordinate system that describes the position of the node in the workspace. Depending on the model geometry, you can select between different coordinate systems. All coordinate systems are oriented clockwise.

**Cartesian**

The global axes X, Y, and Z describe a translational expansion (linear). All directions of coordinates are on par with each other.

![Figure 4.16 Cartesian coordinate system](image)

In most cases, nodes can be defined in the Cartesian coordinate system.
X-Cylindrical

The X-axis describes a translational expansion. The radius R defines the distance of the node to the X-axis. The angle θ defines the rotation of the coordinates about the X-axis.

![X-cylindrical coordinate system](image)

It is applied, for example, for tubular models whose central axis is the X-axis.

Y-Cylindrical

This coordinate system is similar to the X-cylindrical system, but in this case the longitudinal axis is represented by the Y-axis.

![Y-cylindrical coordinate system](image)

Z-Cylindrical

The coordinate system is similar to the X-cylindrical system, but in this case the longitudinal axis is represented by the Z-axis.

![Z-cylindrical coordinate system](image)

Polar

In the polar coordinate system, the node position is described by a radius that specifies the distance to the point of origin and the angles θ and ϕ.

![Polar coordinate system](image)

If possible, organize the model input with regard to the global coordinate system in such a way that the XYZ-axes of the coordinate system are in line with the principal directions of the modeled framework. This allows for an easier definition of coordinates, conditions, and loads.
To define nodes directly in the workspace, open the floating New Node dialog box for graphical input. Usually, nodes snap to grid points that are aligned with the active user-defined or global coordinate system (CS).

![Floating New Node dialog box](image)

For more information about user-defined coordinate systems, see Chapter 11.3.4.

If the coordinate system is changed in the table, the node coordinates can be automatically converted to the new system. The following query is displayed.

![RFEM query](image)

You can analogously convert node coordinates with the Previous reference node in relation to the origin.

**Node coordinates**

Node coordinates are defined in the previously set coordinate system. When you model a 3D structure, the node is clearly defined by the coordinates X, Y, and Z, or the radius and angles. Coordinate parameters and table column titles change depending on the coordinate system.

When the model type is restricted to a 2D plate or wall, it is not possible to access all three text boxes or columns.

To adjust Lengths and Angles, select **Edit → Units and Decimal Places** on the menu or use the corresponding button in the dialog box.

With the following procedure, you can check if all nodes of a surface lie in one plane: Select the relevant nodes and double-click one of them to open the Edit Node dialog box. Coordinate data is filled only in the text boxes whose values are conform for all selected nodes. If this is not the case, you can now assign a uniform plane coordinate to the selected nodes.
It is also possible to import node coordinates from Excel (see Chapter 11.5.6) or determine them with the formula editor of RFEM (see Chapter 11.6). In addition, there are several model generators that facilitate the input (see Chapter 11.7.2).

To enter accurate, unrounded coordinates, select Full Precision in the New Node dialog box.

![Figure 4.23 Shortcut menu in the New Node dialog box and Full Precision dialog box](image)

**Comment**

This field allows you to enter user-defined notes. Use the button or [Apply Comment] to import saved comments (see Chapter 11.1.4).

A Generated comment is displayed for nodes that are generated by RFEM when creating an intersection or a rotated surface. Click the button shown on the left, available in the dialog box and table, to "unlock" generated nodes and make them accessible for modifications.
### 4.2 Lines

#### General description

The geometry of the model is defined by lines. They are essential for creating members, surfaces, and solids. Every line is defined by a start and end node. To define complex types of lines, additional intermediate nodes are required.

The line number is automatically assigned in the New Line dialog box and can be changed in it. The order of the line numbers is not important.

To adjust the order of line numbers retroactively, select **Tools → Renumber** in the menu (see Chapter 11.4.18).
Line Type

In RFEM, the following line types are available for selection in the menu and in the table list:

- Single line
- Polyline
- Arc
- Circle
- Ellipse
- Elliptical arc
- Parabola
- Hyperbola
- Spline
- NURBS
- Trajectory
- Line on surface

The different types of lines are described on the following pages.

Nodes No.

Every line is geometrically defined by a start and end node. They define the line orientation that also affects the position of the line coordinate system. The nodes can be entered manually, selected graphically, or redefined (see Chapter 4.1). If a line requires control points or intermediate nodes, they are also included in the nodes list.

The display of line orientations can be activated in the Display navigator.

The line orientation can be changed quickly in the graphic: Right-click the line and select Reverse Line Orientation in the shortcut menu. The numbers of the start and end nodes will be switched.

The coordinate systems of lines can be activated in the Display navigator: Go to Model → Lines and select Line Axis Systems x, y, z including Indexes (see Figure 4.102).
**Line Length**

This table column shows the total length of the line.

**Position**

Table column D provides information about the global axis the line is parallel to, or in which plane spanned by global axes the line lies. If there is no entry, the line is in an arbitrary spatial position.

**Comment**

This field allows you to enter user-defined notes. Use the [Apply Comment] button to import saved comments (see Chapter 11.1.4). A Generated comment appears for lines created by RFEM (e.g., a pipe).

**Line / Polyline**

Selecting the line entry in the pull-down menu opens the New Line dialog box shown in Figure 4.24. The figure above shows the general dialog box for entering lines graphically. Use the list button in the toolbar to open it.

A "real" line is defined by only one start node and one end node. Such a line represents a direct connection between both nodes.

A polyline is a polygonal chain consisting of several straight line sections. The intermediate nodes are therefore listed in addition to the numbers of the start and end nodes in the dialog box (see Figure 4.24). To simplify line management, "real" lines are handled as polylines.

When entering polylines graphically, existing nodes, grid points, or snap objects can be selected as definition nodes. It is also possible to set nodes freely into the work plane.

For example, if line loads or line supports are only effective for sections of a polyline, you can retroactively split a polyline into "real" lines: Right-click the polyline and select Explode Polyline in the shortcut menu. You can also access this function via Edit → Model Data → Lines → Explode Polyline.
In the second tab of the dialog box, you can define a Rotation of the line. Specify either an Angle $\beta$ or a Help node that the line axis y or z is to be aligned with. The help node can be selected in the list, defined graphically, or newly created.

A rotation of the line may facilitate the input of line loads acting in local line direction. Line rotation does not affect surfaces or members because they have their own coordinate system.

The local line axis systems are shown in Figure 4.102.

**Arc**
An arc can be defined by the following parameters:

- Three nodes
  - Center node, edge node, and opening angle
  - Edge nodes and radius, opening angle, or rise
  - Tangents and radius

In the Nodes at Arc dialog section, you can define the start, intermediate, and end nodes directly, select them graphically, or newly create them. The node order is shown in the small dialog graphic.

Based on these three nodes, RFEM determines the Arc Parameters specified in the dialog section below. It is possible to change the radius $r$, the rise $h$, and the opening angle $\alpha$. The node coordinates are adjusted accordingly.

The coordinates of the arc center that result from the arc nodes or parameters are displayed in the Center of Arc dialog section. When you change data manually or select nodes graphically with the button, the coordinates of nodes are adjusted as well.

In the Subsequent adjustment by displacing node at list, you can specify the node you want to change the coordinates of.

When you define the arc graphically using a toolbar button, the via Three Nodes option allows you to select or create the nodes directly in the graphic.

If you select one of the other input options, you have to select two nodes first, as shown on the left in Figure 4.30 and Figure 4.31. Then, another dialog box (shown on the right) appears where you define the arc parameters.

In the Options dialog section (in Figure 4.30 and Figure 4.31 on the right), you can select the arc’s plane from the list. The Included Angle can be defined directly in the graphic or entered manually and applied with [Apply].

To adjust an already defined arc, double-click its arc line. The Edit Line dialog box opens where you can modify the data in the Arc - Three Nodes dialog tab (see Figure 4.29).
In the Definition Type dialog section (right box), select the appropriate arc parameter from the list. Then, set the arc directly in the graphic or enter it manually and click the [Apply] button.

In the Step text box, you can enter the spacings after which the pointer snaps when dragging the arc radius, angle, or rise.

The orientation of the circular arc can be adjusted by selecting the Reverse orientation check box, which determines whether the arc is placed to the "right" or the "left" of both nodes.

**Circle**

A circle can be defined by the following parameters:

- Three nodes
- Center point and radius
You can enter the Circle Radius and the coordinates for the Center of Circle manually or graphically by using the button. The Point of Normal to Circle Plane determines the plane in which the circle is generated. Use the three buttons in the dialog section to select one of the global axes.

When you define the circle graphically by using one of the toolbar buttons, you can select or create the three nodes or the center and radius directly in the graphic.

**Ellipse**

To define an ellipse, three nodes are required.

The ellipse is generated by the Nodes on Ellipse: The largest distance between the three entered nodes is assumed to be the principal axis of the ellipse.

When you use the toolbar button to define the ellipse graphically, you can set it directly by selecting three nodes in the work plane.
Elliptical arc / Parabola / Hyperbola

The following curves of conic sections can be defined:

- Elliptical arc
- Parabola
- Hyperbola

Enter the curve parameters (focus, angle, axis rotation, etc.) manually in the corresponding tab of the New Line dialog box, or define them graphically.

When you enter line data graphically by using one of the toolbar buttons, you can define the curve parameters directly in the graphic.
Spline

Splines are used to model any kind of curves. Enter a spline line graphically by selecting determinant nodes of the curved line one after the other, or create nodes by mouse-click.

NURBS

NURBS (Non-Uniform Rational B-Splines) are required for modeling free form surfaces. NURBS are splines whose control points are not placed on the curve itself. Usually, these lines are entered graphically by selecting control points one after the other or by generating the points per mouse-click.
Trajectory curve

Use trajectory curves to create helical lines. Usually, they are entered graphically by using the toolbar button shown on the left. The following dialog box appears:

![New Trajectory Curve dialog box](image)

First, define the Coordinates of the line start. This enables the Parameters dialog section where you can specify the total Rotation of the helix.

Then you can define the Coordinates of the line end graphically or enter them manually and click the [Apply] button. Alternatively, you can use the Length text box. The coordinates of the line end are subsequently determined in consideration of the specified rotation in the work plane.

To adjust an already defined trajectory curve, double-click its trajectory line. The Edit Line dialog box opens where you can modify the data in the Trajectory dialog tab.
Line on surface

In general, lines in plane surfaces are automatically recognized as integrated objects, so the line type Polyline is usually sufficient. However, to set a line on a curved surface, use the line type Line On Surface. You can also use this option to insert lines in plane surfaces that are not parallel to the global axes, without having to create a new user-defined coordinate system.

The input dialog box is similar to that of a polyline (see Figure 4.24).

Enter the start and end nodes of the line in the dialog box or select them graphically. You can use the floating New Line dialog box of the type ‘On Surface’ to set nodes directly on a curved surface, if the surface was selected before and the model display option Solid or Solid Transparent is active. RFEM generates nodes of the type On Surface.

The surface where the line lies is defined in the On Surface tab. You can also check the parameters δ₁ and δ₂ of the start and end nodes (see Figure 4.14), but it is not possible to change them.

If you choose the graphical input by using the [Line on Surface] button, you can place the nodes directly on the curved surfaces. Please note that the Wireframe Display Model is not suitable for this.

Cut via Two Lines / Cut via Section

The line types Cut via Two Lines and Cut via Section represent special line functions that are relevant for the RF-CUTTING-PATTERN add-on module. They allow you to define cutting patterns via partial strips if the division of the membrane surface is too large for the cutting. These features are described in the RF-FORM-FINDING / RF-CUTTING-PATTERN Manual, Chapter 5.2.
4.3 Materials

General description

Materials are required to define surfaces, cross-sections, and solids. The material properties affect the stiffnesses of these objects.

A color is assigned to each material, which is used for the display of objects in the rendered model (see Chapter 11.1.9).

For new models, RFEM presets the two materials that were last used.

![New Material dialog box](image)

Figure 4.40 New Material dialog box

![Table 1.3 Materials](image)

Figure 4.41 Table 1.3 Materials

Material Description

Any name can be chosen as a Description of the material. When the entered name corresponds to an entry of the library, RFEM imports the material properties.

The import of materials from the library is described in the Opening the library section.
**Modulus of Elasticity $E$**

The modulus of elasticity $E$ describes the ratio between normal stress and strain.

To adjust the settings for Materials, click **Edit → Units and Decimal Places** on the menu or use the corresponding button.

**Shear Modulus $G$**

The shear modulus $G$ is the second parameter for describing the elastic behavior of a linear, isotropic, and homogenous material.

The shear modulus of the materials listed in the library is calculated from the modulus of elasticity $E$ and Poisson's ratio $\nu$ according to Equation 4.1. Thus, a symmetrical stiffness matrix is ensured for isotropic materials. The shear modulus values determined in this way may slightly deviate from the specifications in the Eurocodes.

**Poisson's Ratio $\nu$**

The following relation exists between modulus $E$ and $G$, as well as Poisson's ratio $\nu$:

$$ E = 2G(1 + \nu) $$

Equation 4.1

When you manually define the properties of an isotropic material, RFEM automatically determines Poisson's ratio from the values of the $E$ and $G$ modulus (or the shear modulus from $E$ modulus and Poisson's ratio).

Generally, Poisson's ratio of isotropic materials is between 0.0 and 0.5. Therefore, for a value of 0.5 or higher (e.g., rubber), we assume that the material is not isotropic. Before the calculation starts, a query appears asking if you want to use an orthotropic material model.

**Specific Weight $\gamma$**

The specific weight $\gamma$ describes the weight of the material per volume unit.

The specification is especially important for the load type 'self-weight'. The automatic self-weight of the model is determined from the specific weight and the cross-sectional areas of the used members or the surfaces and solids.

**Coefficient of Thermal Expansion $\alpha$**

This coefficient describes the linear correlation between changes in temperature and axial strains (elongation due to heating, shortening due to cooling).

The coefficient is important for the 'temperature change' and 'temperature differential' load types.

**Partial Factor $\gamma_M$**

This coefficient describes the safety factor for the material resistance; therefore, the index $M$ is used. Use the factor $\gamma_M$ to reduce the stiffness for calculations (see Chapter 7.3.1).

Do not confuse the factor $\gamma_M$ with the safety factors for the determination of design internal forces. The partial safety factors $\gamma$ on the action side take part in combining load cases for load and result combinations.
Material Model

Twelve material models are available for selection in the list. Use the [Details] button in the dialog box or table to access dialog boxes where you can define the parameters of the selected model.

If the add-on module RF-MAT NL@ is not licensed, you can only use the Isotropic Linear Elastic and Orthotropic Elastic 2D/3D material models.

Isotropic Linear Elastic

The linear-elastic stiffness properties of the material do not depend on directions. They can be described according to Equation 4.1. The following conditions apply:

- \( E > 0 \)
- \( G > 0 \)
- \( -1 < \nu \leq 0.5 \) (for surfaces and solids; no upper limit for members)

The elasticity matrix (inverse of stiffness matrix) for surfaces is the following:

\[
\begin{bmatrix}
\frac{1}{E} & -\frac{1}{E} & 0 & 0 & 0 \\
-\frac{1}{E} & \frac{1}{E} & 0 & 0 & 0 \\
0 & 0 & \frac{1}{G} & 0 & 0 \\
0 & 0 & 0 & \frac{1}{G} & 0 \\
0 & 0 & 0 & 0 & \frac{1}{G}
\end{bmatrix}
\]

Equation 4.2

Isotropic Nonlinear Elastic 1D

You can define the nonlinear elastic properties of the isotropic material in a dialog box.

You have to define the yield strengths separately for tension \( (f_{y,t}) \) and compression \( (f_{y,c}) \) of the ideally or bilinearly elastic material. You can also define a stress-strain Diagram to display the material behavior realistically (see Figure 4.44).
Isotropic Plastic 1D

If you have set the 3D model type (see Figure 12.23), you can define the plastic properties of the isotropic material in a dialog box. RFEM takes these properties for member elements into account, for example for the plastic calculation of a kinematic chain.

The nonlinear material behavior is only determined correctly in the calculation if a sufficient number of FE nodes are created on the member. For this purpose, the following options are available:

- Divide Member Using n Intermediate Nodes dialog box (see Figure 11.91), method of division: Place new nodes on the line without dividing it
- FE Mesh Settings dialog box (see Figure 7.10), option: Use division for straight members with a Minimum number of member divisions of 10

Define the parameters of the ideally or bilinearly plastic material. You can also define a stress-strain Diagram to display the material behavior realistically.
The material properties can be defined separately for the positive and the negative zone. The Number of steps determines the number of definition points respectively available. Enter the strains $\varepsilon$ and the corresponding normal stresses $\sigma$ into the two lists.

You have several options for the Diagram after last step: Tearing for material failure when exceeding a certain stress, Yielding for restricting the transfer of a maximum stress, Continuous as in the last step, or Stop for restricting to a maximum allowable deformation.

It is also possible to import parameters from an [Excel] worksheet.

Watch the dynamic graphic in the Stress-Strain Diagram dialog section to check the material properties. The dialog field $E$ below the graphic shows the modulus of elasticity $E$ for the current definition point.

Use the button in the dialog box to save the stress-strain diagram so that you can apply it to different models. To import user-defined diagrams, click the button.

For members with isotropic plastic material properties, the Activate shear stiffness of members (cross-sectional areas $A_y$, $A_z$) check box in the Calculation Parameters dialog box (see Figure 7.27) has no effect. This material model uses the beam theory according to Euler-Bernoulli where shear distortions are neglected.
Isotropic Nonlinear Elastic 2D/3D

With this material model, you can display the properties of nonlinear materials for surfaces and solids. No energy is delivered to the model (conservative analysis). As the same stress-strain relations apply for loading and relief of load, no permanent plastic distortions are available after a relief.

You have to define the yield strengths $f_y,t$ of the ideally or bilinearly elastic material. For the hypotheses according to von Mises and Tresca, they are equally applicable for tension and compression. For an authentic display of the material behavior, you can also define a stress-strain diagram (see Figure 4.44).

The elasticity matrix is damped isotropically in order for the stress-strain relations of the equivalent stresses and distortions to be fulfilled.

Four calculation theories are available in the Distortion-Hypothesis dialog section:

- **von Mises**
  \[
  eqv = \sqrt{\frac{2}{x} + \frac{2}{y} - \frac{x}{y} + \frac{3}{xy}} \]

  *Equation 4.3*

  \[
  eqv = \frac{eqv}{E} \]

  *Equation 4.4*

- **Tresca**
  \[
  eqv = \sqrt{(\frac{x}{y})^2 + 4\frac{2}{xy}} \]

  *Equation 4.5*
Drucker-Prager:

A criterion that tends to 1 is analyzed (in the plastic sense). Tension and compression stresses interact in the equations. During the evaluation, you should pay attention to the design ratio under the Criteria, not to the stresses.

Mohr-Coulomb:

Similar to the Drucker-Prager model, a stress circle is analyzed, though it is based on the Tresca hypothesis.

Generally, many iterations are required for this material model until convergence is reached. Therefore, it is recommended to specify a minimum value of 300 as the Maximum number of iterations in the calculation parameters (see Chapter 7.3.3).

With the Only linearly elastic option, it is possible to deactivate the nonlinear material properties, for example for comparative analyses.

The following technical article provides further explanations on the yield laws of this material model: https://www.dlubal.com/en-US/support-and-learning/support/knowledge-base/000968

Isotropic Plastic 2D/3D

This material model shows an isotropic material behavior in the elastic zone. The plastic zone is based on the yielding according to different distortion hypotheses with a user-defined Yield strength of the equivalent stress for surfaces and solids.

Specify the parameters of the ideally or bilinearly plastic material. You can also define a stress-strain Diagram to realistically display the material behavior (see Figure 4.44). According to von Mises and Tresca, the same yield strengths apply for tension and compression.

The yield conditions for 2D elements according to von Mises, for example, are mentioned in Equation 4.3. For 3D elements, they are as follows:

\[
eqv = \frac{1}{2} \sqrt{\left( x - y \right)^2 + \left( y - z \right)^2 + \left( z - x \right)^2 + 6\left( \frac{2}{xy} + \frac{2}{xz} + \frac{2}{yz} \right)}
\]

Equation 4.6
For plastic material properties, calculations are carried out iteratively and with load increments (see Chapter 7.3). If the stress is exceeded in a finite element, the modulus of elasticity is reduced there and a new calculation run starts. The process is repeated until a convergence is reached. When the calculation is done, stiffness reductions can also be checked graphically (see Chapter 9.3.2). When evaluating results, it is recommended to use the smoothing option Constant on Elements (see Figure 9.31). The setting ensures that the defined yield strength is displayed as a maximum in the results panel: in the calculation, plastic effects can only be considered element by element. For the remaining smoothing options, however, RFEM interpolates or extrapolates the results. This may lead to distortions that are more or less pronounced depending on the mesh.

In the elastic-plastic calculation, the total strain $\varepsilon$ is divided into an elastic component $\varepsilon_{el}$ and a plastic component $\varepsilon_{pl}$.

$$\varepsilon = \varepsilon_{el} + \varepsilon_{pl}$$

(Equation 4.7)

However, this breakdown is only valid when assuming that the plastic strains are small ($\varepsilon_{pl} < 0.1$). If the plastic strains exceed this limit value, the plastic results should be evaluated with caution. This has to be taken into account in particular for calculations according to the large deformation analysis.

**Orthotropic Elastic 2D**

You can define stiffness properties that appear differently in both surface directions $x$ and $y$. This way, you can model ribbed floors or stress directions of reinforced ceilings, for example. The surface axes $x$ and $y$ are perpendicular to each other in the surface plane (see Figure 4.75).

The RFEM 4 material models Orthotropic and Orthotropic Extra are converted into this model.

![Material Model - Orthotropic Elastic 2D dialog box](image)

With this material model, you can globally assign an orthotropic property to all surfaces that consist of a particular material. Alternatively, it is possible to individually define the parameters for each surface (see Chapter 4.12).

An orthotropic elastic material is characterized by the moduli of elasticity $E_x$ and $E_y$, the shear moduli $G_{yz}$, $G_{xz}$, and $G_{xy}$, as well as Poisson’s ratio $\nu_{xy}$ and $\nu_{yx}$. The elasticity matrix (inverse of stiffness matrix) is defined as follows:
The following correlation exists between principal Poisson’s ratio $\nu_{xy}$ and secondary Poisson’s ratio $\nu_{yx}$:

$$\frac{\nu_{xy}}{E_y} = \frac{\nu_{yx}}{E_x}$$

Equation 4.9

The following conditions must be met for a positively definite stiffness matrix:

- $E_x > 0; \ E_y > 0$
- $G_{yz} > 0; \ G_{xz} > 0; \ G_{xy} > 0$
- $|\ xy| < \sqrt{\frac{E_x}{E_y}}$

Orthotropic Elastic 3D

In a three-dimensional material model, you can define elastic stiffnesses separately in all directions of the solid. This way, you can display the strength properties of wood-based materials, for example.

| Material Model - Orthotropic Elastic 3D dialog box |
The elasticity matrix is defined as follows:

\[
\begin{bmatrix}
\frac{1}{E_x} & -\frac{\nu_{xy}}{E_y} & -\frac{\nu_{xz}}{E_z} & 0 & 0 & 0 \\
-\frac{\nu_{xy}}{E_y} & \frac{1}{E_y} & -\frac{\nu_{yz}}{E_z} & 0 & 0 & 0 \\
-\frac{\nu_{xz}}{E_z} & -\frac{\nu_{yz}}{E_z} & \frac{1}{E_z} & 0 & 0 & 0 \\
0 & 0 & 0 & \frac{1}{G_{yz}} & 0 & 0 \\
0 & 0 & 0 & 0 & \frac{1}{G_{xz}} & 0 \\
0 & 0 & 0 & 0 & 0 & \frac{1}{G_{xy}} \\
\end{bmatrix}
\]

Equation 4.10

The following correlations exist between principal Poisson’s ratios \(\nu_{yz}, \nu_{xz}, \nu_{xy}\) and secondary Poisson’s ratios \(\nu_{zy}, \nu_{xz}, \nu_{yx}\):

\[
\frac{\nu_{yz}}{E_z} = \frac{\nu_{xy}}{E_x} ; \quad \frac{\nu_{xz}}{E_z} = \frac{\nu_{xy}}{E_x} ; \quad \frac{\nu_{yz}}{E_z} = \frac{\nu_{xy}}{E_x}
\]

Equation 4.11

The following conditions must be met for a positively definite stiffness matrix:

- \(E_x > 0; \ E_y > 0; \ E_z > 0\)
- \(G_{yz} > 0; \ G_{xz} > 0; \ G_{xy} > 0\)
- \(|\nu_{yz}| < \sqrt{\frac{E_y}{E_z}} ; \ |\nu_{xz}| < \sqrt{\frac{E_x}{E_z}} ; \ |\nu_{xy}| < \sqrt{\frac{E_x}{E_y}}\)
- \(1 - \frac{2}{\nu_{yz}} \frac{E_z}{E_y} - \frac{2}{\nu_{xz}} \frac{E_z}{E_x} - \frac{2}{\nu_{xy}} \frac{E_y}{E_x} - 2 \frac{E_z}{E_x} \frac{E_z}{E_x} > 0\)
Orthotropic Plastic 2D / Orthotropic Plastic 3D

The material model according to Tsai-Wu unifies plastic with orthotropic properties. This way, you can enter special modelings of materials with anisotropic characteristics such as plastics or timber. When the material is yielding, stresses remain constant. A redistribution is carried out according to the stiffnesses available in the individual directions.

The elastic zone corresponds to the Orthotropic Elastic - 3D material model (see above). For the plastic zone, the yielding according to Tsai-Wu applies:

\[
 f_{\text{ct}}(\sigma) = \frac{1}{C} \left[ \left( \frac{x-x_0}{f_{t,x}^\text{c,x}} \right)^2 + \left( \frac{y-y_0}{f_{t,y}^\text{c,y}} \right)^2 + \left( \frac{z-z_0}{f_{t,z}^\text{c,z}} \right)^2 + \frac{2}{f_{\nu,zy}^2} + \frac{2}{f_{\nu,xz}^2} + \frac{2}{f_{\nu,xy}^2} \right]^{1/2}
\]

Equation 4.12

where

\[
 x_0 = \frac{f_{t,x} - f_{\text{c,x}}}{2}
\]
\[
 y_0 = \frac{f_{t,y} - f_{\text{c,y}}}{2}
\]
\[
 z_0 = \frac{f_{t,z} - f_{\text{c,z}}}{2}
\]
\[
C = 1 + \left[ \frac{1}{f_{t,x}} + \frac{1}{f_{c,x}} \right]^2 \frac{E_p}{E_X} + \frac{2}{f_{t,x} f_{c,x}} + \frac{2}{f_{t,y} f_{c,y}} + \frac{2}{f_{t,z} f_{c,z}}
\]

\(f_{t,x}, f_{t,y}, f_{t,z}\): Plastic ultimate tensile strength in direction x, y, or z
\(f_{c,x}, f_{c,y}, f_{c,z}\): Plastic ultimate compressive strength in direction x, y, or z
\(f_{v,yz}, f_{v,xz}, f_{v,xy}\): Plastic shear strength in direction yz, xz, or xy
\(E_{p,x}\): Hardening modulus
\(\alpha\): State variable of hardening

\[
= \sum_i^a
\]

All strengths must be defined positively.

The stress criterion can be imagined as an elliptical surface within a six-dimensional space of stresses. If one of the three stress components is applied as a constant value, the surface can be projected onto a three-dimensional stress space (see Figure 4.51).

![Figure 4.51 Projection of yielding surfaces for normal stresses according to Tsai-Wu](image)

If the value for \(f_y(\sigma)\) according to Equation 4.11 is lower than 1, stresses lie in the elastic zone. The plastic zone is reached as soon as \(f_y(\sigma) = 1\). Values higher than 1 are not allowed. The model behavior is ideal-plastic, which means no stiffening takes place.

Equation 4.11 is only valid for the local FE coordinate system. If this local coordinate system does not match the solid’s coordinate system used for the stress output in RFEM, the values must be transformed accordingly.
Isotropic Thermal-Elastic

Temperature-dependent stress-strain properties of an elastic isotropic material can be defined in a diagram or imported from Excel. These properties are considered for member and surface elements subjected to thermal load (changes or differences in temperature).

The Reference temperature defines stiffnesses for the members or surfaces that have no temperature loads. For example, if a reference temperature of 300 °C is set, the reduced elastic modulus of this point of the temperature curve is applied to all members and surfaces.

The Options dialog section allows you to control if the Poisson’s ratios that are applied to the complete temperature diagram are identical. Clear the check box to access the Poisson’s Ratio table column for individual entries.

Use the [Load] button to import predefined temperature diagrams for different steel alloys (see Figure 4.45).

Click the [Save] button to save user-defined temperature diagrams so that you can use them for other models.
**Isotropic Masonry 2D**

Use this material model to consider masonry walls not able to bear tension forces and reacting with formation of cracks.

The dialog box allows you to define the *Limit tension stresses* in direction of the surface axes x and y, which means parallel and perpendicular to the support interstices. In several iterations during calculation, RFEM then finds out, which finite elements become stress-free due to the failure criterion.

When the limit tension stress is set to zero, RFEM applies a value of $1 \cdot 10^{-11}$ N/mm$^2$ in calculations for stability reasons. Thus, minor tensile stresses are not completely excluded.

If numerical problems occur during calculation, you can try to reach convergence by increasing the *Hardening factor* $C_H$.

If the masonry material has already been defined in the library before you open the Material Model dialog box, the following limit values are preset:

<table>
<thead>
<tr>
<th>Standard</th>
<th>$\sigma_{x,\text{limit}}$</th>
<th>$\sigma_{y,\text{limit}}$</th>
</tr>
</thead>
<tbody>
<tr>
<td>DIN 1053-100</td>
<td>$f_{x2}$</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>Tensile strength parallel to interstice of support</td>
<td></td>
</tr>
<tr>
<td>EN 1996-1-1</td>
<td>$f_{x1}$</td>
<td>$f_{x2}$</td>
</tr>
<tr>
<td></td>
<td>Tensile strength parallel to interstice of support</td>
<td>Tensile strength perpendicular to interstice of support</td>
</tr>
</tbody>
</table>


Isotropic Damage 2D/3D

With this material model, you can model the material behavior of steel fiber concrete where a continuous reduction of strength occurs due to cracking.

The stress-strain curve of the steel fiber concrete is defined in a Diagram that can be accessed with the button. This diagram is shown in Figure 4.44.

In this material model ("Mazars' damage model"), the isotropic stiffness is reduced with a scalar damage parameter. This damage parameter is determined from the stress curve defined in the Diagram. The direction of the principal stresses is not taken into account. Rather, the damage occurs in the direction of the equivalent strain, which also covers the third direction perpendicular to the plane. The tension and compression area of the stress tensor is treated separately. Different damage parameters apply in each case.

The Reference element size controls how the strain in the crack area is scaled to the length of the element. With the default value zero, no scaling is performed. Thus, the material behavior of the steel fiber concrete is modeled realistically.

The following technical articles provide further explanations on the Isotropic Damage 2D/3D material model:

Material library

The properties of many materials are stored in a comprehensive, expandable database.

Opening the library

To access the library, click the [Material Library] button (see Figure 4.40) in the New Material dialog box. You can also open the database in Table 1.3 Materials (see Figure 4.41): Place the cursor into table column A and click the button shown on the left or use the [F7] key on the keyboard.

Select a material from the Material to Select list and check the corresponding parameters in the lower part of the dialog box. Click [OK] or [↵] to carry it over to the previous dialog box or the table.

You can use the Search text box for a full text search in the entries (see Figure 4.55).
Library filter

As the material library is very large, there are various selection options available in the Filter dialog section. You can filter the material list according to Material category group, Material category, Standard group, Standard, and Special application. This way, you can reduce the provided data.

With the Include invalid check box, you can select if materials of "old" standards are also displayed in the library.

With the \ and \ buttons, you can create and edit categories.

To adjust the sequence of the items, use the \ and \ buttons.
Creating favorites

Often, the use of a few materials is already sufficient for daily engineering work. You can mark these materials as your favorites. Use the [Create New Favorites Group] button to open the dialog box for defining preferred materials.

Enter the Name of the new favorites group. After clicking [OK], a new dialog box appears which is structured like the material library. The filter options described above are also available in this dialog box.

In the Material Library - Favorites dialog section, you can mark your preferred materials by selecting their check boxes. To change the sequence of materials, use the and buttons.

After closing the dialog box, the material library presents a clear overview of favorites as soon as you activate the Favorites group option and the group is specified in the list.
Extending the library

The material library can be extended. If you add a new material, you can use it for all available models.

Click the button in the library (to the left of the Search field, see Figure 4.60). The New Material dialog box opens. The parameters of the entry selected in the Material to Select list are preset. Creating a new material is easier when you choose a material with similar properties first.

![New Material dialog box](image)

Enter the Material Description, define the Material Properties, and assign the material to the appropriate groups and categories for Filter functions.

Saving user-defined materials

If you use custom materials, you should save the Materialien_User.dbd file before installing an update. The file can be found in the master data folder of RFEM 5 C:\ProgramData\Dlubal\RFEM 5.xx\General Data.
4.4 Surfaces

General description

In addition to structure geometry, surfaces describe the stiffness that results from material and thickness properties. When generating the FE mesh, 2D elements are created on surfaces. For detailed information about the used elements, see Chapter 7.2.1.

The stiffness type Null must be used for geometry descriptions of solids.

Different geometry and stiffness properties are available for structure modeling. It is possible to combine entries of both Surface Type lists or table columns – within type-specific limits and conditions.

Color symbols help you to assign various types for Geometry and Stiffness. You can use these colors in the model to display individual surface types. Colors are controlled in the Display navigator with the Colors in Rendering According to option (see Chapter 11.1.9).
Surface Type - Geometry

Plane surface

Plane surfaces can be defined graphically by drawing a rectangle, parallelogram, circle, annulus, polygon, etc. Use the menu or the list button shown on the left to access different shapes of plane surfaces.

The following dialog box appears when you graphically enter data by using one of the toolbar buttons:

![New Polygonal Surface dialog box](image)

First, enter the parameters for Material, Thickness, and Stiffness in addition to the surface number. Click [OK] and define the boundary lines of the surface in the work window by selecting relevant corner points.

The [Select Boundary Lines] function allows you to select existing lines graphically. The lines must be arranged in a polygonal chain that lies in one plane. The line types are described in Chapter 4.2.

![Selecting boundary lines in the graphic](image)

RFEM automatically recognizes the surfaces as soon as a sufficient number of boundary lines are defined.
Quadrangle surface

This type of surface represents a general quadrilateral surface. In addition to straight lines, you can use arcs, polylines, and splines as boundary lines. Use this surface type to model shells, since boundary lines do not have to be arranged in one plane.

You can select the boundary lines graphically after clicking [OK].

Rotated surface

A rotated surface is created by rotating a line about a fixed axis. The surface results from the start and end position of the line, as well as the line’s rotated definition points.

The New Rotated Surface dialog box consists of two tabs. In the General dialog tab, you can define the Material, Thickness, and Stiffness of the surface (see Figure 4.67). A variable surface thickness is not allowed.
In the Rotated tab, you can specify the Angle of rotation. Both points of the Rotation Axis can be defined either by entering their coordinates or graphically by using . Click [OK] and define the boundary line for rotation in the work window.

Rotated surfaces can also be created from generated lines.

Pipe

A pipe surface is created by rotating the center line of the pipe about the center axis at the distance of a specific radius.
The New Pipe dialog box has two tabs. In the General tab, you can enter the parameters for Material, Thickness, and Stiffness of the surface. In the Pipe tab, specify the Center line and Radius $r$. You can also define the center line graphically.

Use the pipe surface to create two circles and a polyline that is parallel to the pipe axis.

**B-Spline surface**

A B-Spline surface is similar to a quadrangle surface (see Figure 4.66). In addition, help nodes are created on the surface. The surface shape can be influenced by adjusting the coordinates of help nodes retroactively.

The input dialog box has two tabs. In the General tab, you can define the parameters for Material, Thickness, and Stiffness of the surface. A variable surface thickness is not allowed.

In the B-Spline tab, you can enter the number of help nodes into the Order of matrix text box: For example, if you enter "3", you create a grid of $3 \times 3$ help nodes across the surface. The Order of spline selection field specifies whether a polynomial of the third or fourth degree is used for the calculation of the surface.

**NURBS surface**

NURBS surfaces are defined by four connected NURBS lines (see Chapter 4.2). By using NURBS surfaces, you can model almost any free form surface.

When entering boundary lines, make sure that opposite pairs of NURBS lines are "compatible" with each other: Only if there is an equal number of control points are opposing NURBS lines arranged in the same order.
Trajectory surface

Use this type of surface to create a spatially curved surface from a certain start profile in relation to any trajectory.

The New Trajectory Surface dialog box has two tabs. In the General tab, you can define the parameters for Material, Thickness, and Stiffness of the surface.

In the Trajectory tab, you can enter the number of the Guide Line that represents the reference line of the surface or select it graphically. Then you can determine the Start Profile in the graphic. If necessary, define a second line as the End Profile. The Angle $\beta$ describes the rotation of the generated, parallel boundary line in relation to the trajectory.
**Component**

This entry appears in the table column and navigator if an intersection of surfaces has been created (see Chapter 4.22). The editing functions for components of intersection surfaces provided by RFEM are the same as for "normal" surfaces. Thus, it is possible to quickly modify properties of surface components without creating an intersection again.

The original surface of a component is indicated in the Component tab of the Edit Surface dialog box.

Use the [Go to Parent Surface] button to access the edit dialog box of the original surface.

**Surface Type - Stiffness**

The list available in the dialog box and table provides several stiffness models, which you can select to model the structure realistically.

- **Standard**
  
  The surface transfers moments and membrane forces. The approach describes the general behavior of a homogeneous and isotropic material. The stiffness properties of the surface do not depend on directions.

- **Without membrane tension**
  
  Only moments and membrane forces under pressure are transferred. For membrane forces that cause tension, however, a failure of affected surface elements occurs (example: hole bearing).

- **Orthotropic**
  
  Use this stiffness model for surfaces with different stiffnesses in both surface directions (see Chapter 4.12). Use the [Edit] button to define the parameters.

  Alternatively, you can assign an orthotropic property to the material (see Chapter 4.3). In this way, you can avoid defining properties for each individual surface.

- **Glass**
  
  This type of stiffness is required for the add-on module RF-GLASS. Moments and membrane forces are transferred, but stresses are not determined in RFEM. The actual stress calculation is carried out later in the add-on module RF-GLASS.

- **Laminate**
  
  This stiffness type transfers moments and membrane forces. The add-on module RF-LAMINATE is required to calculate the laminate model. The actual stress calculation is also carried out there. No stresses are included in the results output of RFEM.
Rigid

Use this type of stiffness to generate very stiff surfaces, which create a rigid connection between adjacent objects.

Membrane

The surface has a uniform stiffness in all directions. Only membrane forces are transferred.

Membrane Orthotropic

Only membrane forces are transferred. Stiffnesses are different in both surface directions [Chapter 4.12] and can be defined with the [Edit] button.

Null

Null surfaces are required for the definition of solids (see Chapter 4.5).

Boundary Lines No.

The boundary lines of a surface are listed in the corresponding text box or table column. The lines must form a closed continuous line.

When rotated surfaces were generated, generation parameters are displayed in the table column.

Material No.

You can select an entry from the list of materials that have already been created. Material colors make the assignment easier.

In the New Surface dialog box, there are three buttons below the list. Use the buttons to access the material library or to create and edit materials.

For more detailed information on materials, see Chapter 4.3.

Thickness

Type

You can select between two types of surface thickness.

- Constant
  The surface has the same thickness everywhere.

- Variable
  The thickness of the surface is linearly variable (see Chapter 4.11). Use the [Edit] button to define the parameters.
**Thickness d**

Specify the surface thickness $d$ in this text box, unless a variable thickness or a Null surface has been defined. The thickness is used to determine the self-weight and stiffness for the stiffness types Standard, Membrane without tension, Glass, and Membrane. For Orthotropic and Membrane-Orthotropic stiffnesses, this value is only used to calculate the self-weight (stiffnesses must be defined separately for orthotropic surfaces).

Surface thicknesses can be visualized with different colors in the model: In the Display navigator, select **Model → Surfaces**, and then select the **Color Scale of Thicknesses in Panel** check box (see figure below).

![Display navigator: Surfaces → Color Scale of Thicknesses in Panel](image)

**Eccentricity**

The plane in the surface center represents the reference surface for the thickness, which is assumed to be in equal proportions on both sides of the "centroidal plane". To check the center, use the Display navigator option **Rendering → Model → Solid Model → Surface and Filled incl. thickness** [see Figure 4.118](image).

By specifying an Eccentricity $e_z$, you can define an offset of height for the surface. In this way, you can create uniform top or bottom edges for adjoining surfaces that have different thicknesses.

The eccentricity in the form of additional moments has an influence on the surface’s internal forces.
Integrated Objects

In general, RFEM automatically recognizes all objects that lie on a surface and are not used for the surface definition. In the table columns or text boxes of the dialog box, all numbers of nodes, lines, and openings are displayed.

If an object is not recognized, it is possible to integrate it manually: Double-click the surface to open the Edit Surface dialog box: Then, deactivate Automatic object detection in the Integrated tab. The text boxes of the dialog sections to the left are thus enabled for access. Use $\#_1$ to select the objects graphically.

Area

The area of each surface is shown in the table column. Areas of openings are not taken into account, thus the value represents the net area.

Weight

The mass of each surface is indicated in the penultimate column. It is determined from the area and the material's specific weight.

Comment

Enter a user-defined note or select an entry from the list.

Axis system

Each surface has a local coordinate system. The axis system of the surface is significant for various input parameters such as orthotropic and foundation properties or directions of surface loads. The base internal forces are also related to a surface axis system.

RFEM displays the coordinate systems as soon as you move the pointer over a surface. They can also be displayed or hidden by using the shortcut menu of a surface (see Figure 4.76).
If required, you can adjust the local surface axes:

- **Reverse Local Axis System** shortcut menu option
  
The orientation of the local z-axis is reversed and the remaining axes are aligned according to the right-hand rule. As a result, foundations are put on the other side of the surface, or the "top" and "bottom" reinforcement layers for the reinforced concrete design change surface sides.

- **Edit Surface** dialog box
  
To open the *Edit Surface* dialog box, double-click the surface. In the Axes tab, you can adjust the local surface axes for Input as well as for Results.
In the two sub-tabs you can direct the local surface axis x or y parallel to a line, to the intersection of a line and the surface [Direct to line, for radial axis system], or direct the axes of the customized coordinate system [see Chapter 11.3.4].

**Grid**

Each surface is covered by a grid, which is used for the results output in the tables. This grid is independent of the FE mesh.

For detailed information about surface grid and customization options of the grid points, see Chapter 8.13.

**Modify Stiffness**

For the Standard and Without membrane tension surface types, the Modify Stiffness dialog tab is available. In it, you can influence the surface stiffnesses.

![Modify Stiffness dialog box](image)

You can select the Definition Type of the stiffness adjustment in the list. If you select None (no modification of stiffness), all stiffness components with the factor 1.00 are taken into account for the calculation.

Use the Multiplier Factors option to customize the stiffness factors $k$ for the surface's torsion, bending, shear, membrane, and eccentric stiffnesses. The surface stiffness elements are displayed in Equation 4.16.

The definition type According to ACI 318-14 Table 6.6.3.1.1(a) sets the reduction factors to be according to the American reinforced concrete standard and depending on the component type. The list provides different options to set the appropriate factors for walls or plates, for example.
4.5 Solids

General description

In RFEM, 3D objects are described by solids. When generating the FE mesh, 3D elements are created. You can also use solids to model orthotropic properties or contact problems between surfaces. In addition, solids can have gas properties.

In general, boundary surfaces of solids are defined with the stiffness type Null (see Chapter 4.4). However, if no other solid is connected to a model that represents the contact between two surfaces, both contact surfaces have to be characterized with a stiffness.

In the graphic, solids can quickly be created from surfaces. Corresponding generation functions are described in Chapter 11.7.1.3 and 11.7.1.4.

Reinforced concrete designs are currently not implemented for solids.
Solid Type

In the list of the dialog box and the table, several stiffness types to realistically model structures can be selected. Each type has its own color that can be used to differentiate solids in the model. Colors are controlled in the Display navigator using the Colors in Rendering According to option (see Chapter 11.1.9).

Material

The standard model is represented by a 3D object with the solid-specific properties of a homogeneous and isotropic material. Therefore, boundary surfaces should be defined by the stiffness type Null.

If the solid has orthotropic properties, stiffnesses are also derived from the material characteristics. Define the elastic stiffnesses of the three-dimensional material model in the Material Model - Orthotropic Elastic 3D dialog box (see Figure 4.49).

Gas

Use this option to model solids with properties of an ideal gas (e.g. tank, bouncy castle, insulating glass). The gas parameters have to be defined in a separate tab of the dialog box (see Figure 4.84).

Contact

The solid type Contact is suitable for modeling contact properties between two surfaces. The parameters have to be defined in a separate tab of the dialog box (see Figure 4.83).

Null

Neither a null solid nor its loads are considered for the calculation. Null solids are, for example, used to analyze changes in the model’s structural behavior if a solid is not effective. You do not need to delete the solid, the loading is kept as well.

Boundary Surfaces No.

A solid is defined by surfaces that completely enclose a certain space. Enter the numbers of the surfaces into the text box or select them in the graphic using the Show Figure or Rendering button.

When you have defined all boundary surfaces in the New Solid dialog box, use the [Show Figure or Rendering] button below the graphic to see a preview of the solid.

Material No.

You can select an entry from the list of materials that have already been created. Material colors make the assignment easier.

In the New Solid dialog box, you can see three buttons below the list. Use the buttons to access the material library or to create and edit materials.

For more detailed information about materials, see Chapter 4.3.
**Compound Solids**

When an intersection of solids has been created, this column is displayed in the table.

In addition to surfaces, you can generate intersections for solids. RFEM determines the intersection lines of intersecting solids and creates 3D solid objects as a union, a section, or as a pure intersecting set. In this way, a new solid is generated from the two original objects.

Determining the solid intersection is time-consuming and computationally intensive. Each time the model is changed, a recalculation of geometry is required.

**Creating intersections**

You can create intersections of solids quickly in the graphic: Select two solids by drawing a selection window across the objects or using a multiple selection by holding down the [Ctrl] key. Then, right-click one of the solids to open its shortcut menu where you select the menu item **Solid → New Compound Solid**.

The New Solid dialog box opens. With the settings in the Compound Solids dialog tab, you can specify how both solids are combined.

![New Solid dialog box, Compound Solids tab](image)

The numbers of the two selected solids have already been entered into the text boxes. Use the list or to change the entries.

**Boolean Operation**

There are three ways to combine solids into a new object:

- **Unite**: Solids A and B are merged into a unit.
- **Subtract**: Solid B is cut out of solid A.
- **Intersect**: RFEM determines the area shared by solids A and B.

The dialog graphic to the right demonstrates the principle of the individual combinations. Use the [Show Figure or Rendering] button to switch between scheme and model display.
The Option dialog section allows you to control how parts that were cut are displayed in the graphic of the work window. When subtracting solids, you can use the as hole option to model boreholes, for example.

Click [OK] to create the combined solid. As a result, intersections of surfaces (see Chapter 4.22) with active or inactive surface components (see Chapter 4.4) are generated. At the same time, RFEM sets the original solids to the type Null.

**Volume V**

This table column shows the volume of each solid.

**Weight W**

The mass of each solid is indicated in the penultimate column. It is determined from the volume and the material’s specific weight.

**Gas**

This dialog tab is available if you have selected the solid type Gas in the General dialog tab.

In this tab, you have to define the Gas Parameters pressure $p_p$ and temperature $T_p$.

You can model a vacuum by using values of $p_p$ between 0 and 1 bar. Different vacuum pressure ranges are described at https://en.wikipedia.org/wiki/Vacuum.

The following technical article provides background information on modeling an ideal gas:
**Contact**

This dialog tab is available if the Contact solid type has been selected in the General dialog tab.

The following points must be observed when entering a contact solid:

- Both contact surfaces must be arranged to be parallel and created identically. It is recommended to create the second contact surface by copying the first one.
- Each lateral connecting surface between the contact surfaces must be created as a simple surface consisting of four boundary lines. Splitting a connecting surface into two surface components at half of the height, for example, is not allowed.
- When modeling curved contact surfaces, you have to split the contact solid into several simple parts.
- RFEM generates undivided 3D elements (parallel "columns") between the finite elements of the contact surfaces, creating a direct connection. Therefore, the FE division of the surface needs to be adjusted to the spacing of the contact surfaces.
- Polygonal solids are preferable to triangular solids.

RFEM tries to find the contact surfaces automatically. In the Contact Between Two Surfaces dialog section, you can change Surface A by using the list or use to select it graphically. RFEM automatically enters Surface B as the solid surface that is parallel to the first surface.

In the Contact Perpendicular to Surfaces dialog section, you can select between three options:

- Full force transmission
- Failure under compression
- Failure under tension

The failure criteria Failure under compression and Failure under tension are taken into account in the calculation via the deformations of solid FE mesh nodes.

The Contact Parallel to Surfaces can be defined independently of the contact properties that act perpendicular to the two contact surfaces.
The contact criteria parallel to surfaces are defined as follows:

<table>
<thead>
<tr>
<th>Contact</th>
<th>Diagram</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Failure if contact perpendicular to</td>
<td><img src="image1" alt="Diagram" /></td>
<td>If the contact solid under tension or compressions fails, no shear forces are transmitted.</td>
</tr>
<tr>
<td>surfaces failed</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Full force transmission</td>
<td><img src="image2" alt="Diagram" /></td>
<td>All shear forces are transmitted.</td>
</tr>
<tr>
<td>Rigid friction</td>
<td><img src="image3" alt="Diagram" /></td>
<td>The rigid friction is immediately effective. The shear stress is dependent on the normal stress. You have to enter the friction factor $\mu$.</td>
</tr>
<tr>
<td>Rigid friction with limit</td>
<td><img src="image4" alt="Diagram" /></td>
<td>As soon as the maximum permitted shear stress $T_{\text{max}}$ is reached, the stress is not increased any further by extending the deformation, but remains constant.</td>
</tr>
<tr>
<td>Elastic friction</td>
<td><img src="image5" alt="Diagram" /></td>
<td>This friction represents an elastic behavior: The shear force increases proportionally to the deformation. There is no limit for deformation. The spring stiffness $C$ (the force required to move a 1 m² surface by 1 m) and the friction factor $\mu$ must be entered as parameters.</td>
</tr>
<tr>
<td>Elastic friction with limit</td>
<td><img src="image6" alt="Diagram" /></td>
<td>Unlike with the elastic friction, the maximum shear stress does not depend on the normal stress. Only one defined shear stress can be absorbed. The spring stiffness $C$ and the shear stress $T_{\text{max}}$ must be entered as parameters.</td>
</tr>
</tbody>
</table>
Elastic solid behavior

The properties of the elastic shear transfer can be described by entering the spring stiffness $C$.

Table 4.2 Contact properties parallel to contact surfaces

**FE Mesh**

The FE Mesh dialog tab allows you to set specific requirements for each solid concerning the FE mesh.

To allocate an FE Mesh Refinement to the solid, you have to select the checkbox. You can select the type of mesh refinement from the list. By defining the FE length, mesh refinements for solids are possible (see Chapter 4.23).

If the Layered Mesh option is selected, you can directly set the number of finite element layers between two opposite surfaces. You can select Surface A from the list or use to define it graphically; the parallel Surface B is entered automatically. Afterwards, it is possible to control the number of layers in a Defined way.

The following article presents an example for a layered FE mesh for solids:
Axis system

Each solid has a local coordinate system. This axis system is significant for orthotropic properties, for example. Stresses and distortions are related to the local axis system as well.

RFEM displays the coordinate systems as soon as you move the pointer over a surface. You can use the shortcut menu of a solid to switch them on and off.

In the Edit Solid dialog box, you can adjust the solid coordinate system. Double-click the solid to open the dialog box. The orientation of the local axes is managed in the Axes dialog tab.

The solid’s local axes x and y can be oriented to be parallel to the axes of a boundary surface, a line, a surface, or in direction of a user-defined coordinate system (see Chapter 11.3.4).
4.6 Openings

General description

Openings are used to create cutouts into surfaces. In areas where openings are placed, no finite elements are generated nor are surface loads applied.

Openings can be set graphically into surfaces. RFEM creates a polygonal chain for various types of openings and integrates it into the surface.

![New Opening dialog box](image1)

![Table 1.6 Openings](image2)

Boundary Lines No.

Enter the lines that enclose the opening in this text box. The lines must be defined as a polygonal chain. Openings on the edge of a surface are allowed as well.

When using the graphical selection, click the opening’s boundary lines one by one in the graphic. Once a sufficient number of boundary lines has been defined, RFEM automatically recognizes the opening.

You can use the Select Boundary Lines button in the openings menu list to graphically select previously defined lines. The lines must form a closed continuous line.
Openings can be placed directly into a surface that lies in the work plane by using one of the buttons shown on the left. The definition types for openings are, in a somewhat reduced form, based on the line types described in Chapter 4.2 (e.g. circle, ellipse). Once the contour lines have been determined, the opening is created. With this input option, it is not necessary to create lines for the opening in advance.

**In Surface No.**

For plane surfaces, the automatic integration is active by default. For curved surfaces, you have to integrate the opening manually. In the *Edit Surface* dialog box, go to the Integrated tab and enter the number of the opening into the text box (see Figure 4.75).  

**Area**

This table column shows the area of the opening.
4.7 Nodal Supports

General description

Supports are used to transfer loads applied on a structural system into the foundations. Without any supports, all nodes would be free and could be displaced or rotated unhindered. If you want a node to act as a support, at least one of its degrees of freedom must be restricted by a spring or blocked. In addition, the node must be part of a surface or member. The boundary conditions of members must be considered as well, in order to exclude double releases on the supported nodes.

Nodal supports are required in order to apply imposed deformations.

It is possible to provide nodal supports with nonlinear properties (failure criteria for tensile or compressive forces, working and stiffness diagrams).

Figure 4.90 - New Nodal Support dialog box

Figure 4.91 - Table 1.7 Nodal Supports
To open the following dialog box, go to the menu and select **Insert → Model Data → Nodal Supports → Graphically** or use the toolbar button shown on the left.

![New Nodal Support dialog box](image)

The following support types are predefined and can be selected from the list:

- Hinged \( \{YYY NNY\} \)
- Rigid \( \{YYY YYY\} \)
- Sliding in \( X' \) \( \{NYY NNY\} \)
- Sliding in \( Y' \) \( \{YNY NNY\} \)

After clicking [OK], you can assign the selected support type to nodes in the graphic.

Use the [New] button to create another type of support. The dialog box shown in **Figure 4.90** is displayed.

**On Nodes No.**

Singular supports can only be defined on nodes. Enter the node number into the table column or the text box of the dialog box, or select it graphically.

**Support rotation**

Each nodal support has a local coordinate system. It is oriented parallel to the global axes \( X, Y, \) and \( Z \) by default. You can use the shortcut menu of a nodal support to display the support coordinate systems.

Use the **User-defined axis system** option to rotate the support's local axis system. Different options are available in the list.
It is possible to rotate the support about the support axes X', Y', and Z', to refer to a user-defined coordinate system or to certain nodes. In addition, you can align the support according to the position of a member or a line. In each case, it is possible to define the objects graphically in the work window by using 

The support rotation is displayed in the dynamic dialog graphic.

When the calculation is complete, you can evaluate the support reactions of a rotated nodal support in relation to the global as well as the local axis system.

**Column in Z**

Often, real structural conditions are inaccurately represented by a nodal support, for example when the support zone has large dimensions. Such support conditions can be represented in RFEM by special column macro elements considering material and geometry of the column. RFEM calculates the spring stiffnesses and adjusts the support conditions. Due to the realistic modeling, you can avoid singularities that would be produced in a single FE node when a rigid support is defined.
The **Model of support** can be realized in three different ways, each symbolized in the dialog graphic:

- With the **Elastic surface foundation** model, a surface is cut out internally in the column dimensions and supported elastically. The foundation coefficients are calculated from the column's geometry and material data.

- With the **Elastic nodal support** model, a surface is also cut out. This surface is only supported at one node, however. The support is modeled by means of translational and rotational springs, which are calculated from the column geometry and its material. Internally, the surface thickness is duplicated to account for higher bending rigidity within the column area.

- The **Node support with adapted FE mesh** model corresponds to the elastic nodal support, but no springs are applied to the punctiform supports.

In the RF-CONCRETE Surfaces and RF-LAMINATE add-on modules, cut-out surfaces cannot be designed for any of these model options. The internal forces at the column's boundary lines are used instead.

When modelling as an "Elastic surface foundation" or "Elastic nodal support", you have to enter the data for the column that is required to determine the spring stiffnesses. The column head's geometry can be **Rectangular** or **Circular**. If there is a steel cross-section as the **Column cross-section**, the cross-section can be set in the [Library] after activating the check box in the second line.

The **Column material** can be selected in the list of the defined materials or created with [New] (see Chapter 4.3). The **Column height** H influences the constants of the vertical and rotational springs. The **Support conditions** at the column head or column base have some influence on the determination of the translational and rotational springs of the support, just like the possible **shear stiffness** of the column.

The spring constants C that result from the column parameters are listed on the right in the dialog box.
Support or Spring

To define a support, select the corresponding option in the dialog box or table. The check mark indicates that the corresponding degree of freedom is blocked and the node displacement in the corresponding direction is not possible.

If you do not want to define supports, clear the corresponding check box. Then, RFEM sets the constant of the translational spring to zero in the Nodal Support dialog box. It is always possible to modify the spring constant in order to display an elastic support of the node. In the table, enter the constant directly into the table column.

The spring stiffnesses have to be entered as design values.

Assigning nonlinear support properties is described below.

Restraint or Spring

Restraints are defined analogously to supports. The check mark indicates once again that the corresponding degree of freedom is blocked and the node displacement in the corresponding direction is not possible. In the same way, constants for rotational springs can be defined once the check box is cleared. In the table, enter the spring constant directly into the corresponding table column.

The New Nodal Support dialog box (see Figure 4.90) provides buttons for different support types, making the definition of degrees of freedom easier.

The following support properties are assigned to the buttons:

<table>
<thead>
<tr>
<th>Button</th>
<th>Support Type</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image.png" alt="Button" /></td>
<td>Rigid</td>
</tr>
<tr>
<td><img src="image.png" alt="Button" /></td>
<td>Hinged with restraint about Z'</td>
</tr>
<tr>
<td><img src="image.png" alt="Button" /></td>
<td>Sliding in X' and Y' with restraint about Z'</td>
</tr>
<tr>
<td><img src="image.png" alt="Button" /></td>
<td>Sliding in X' with restraint about Z'</td>
</tr>
<tr>
<td><img src="image.png" alt="Button" /></td>
<td>Sliding in Y' with restraint about Z'</td>
</tr>
<tr>
<td><img src="image.png" alt="Button" /></td>
<td>Sliding in Z' and Y' with restraint about Z'</td>
</tr>
<tr>
<td><img src="image.png" alt="Button" /></td>
<td>Free</td>
</tr>
</tbody>
</table>

Table 4.3 Nodal support buttons
Nonlinearities

To control the transfer of internal forces in detail, it is possible to provide nodal supports with nonlinear properties. The list of nonlinearities includes the following options:

- Failure of component if support force or moment is negative or positive
- Complete failure of support if support force or moment is negative or positive
- Partial activity
- Diagram
- Friction depending on remaining support forces

The nonlinear properties can be accessed in the dialog box and table via the list (see Figure 4.90 and Figure 4.91). For each support’s degree of freedom, you can specify whether and which forces or moments are transferred at the supported node.

Nonlinear effective supports are displayed with a different color in the graphic. In the table, support elements with nonlinear properties are indicated by a blue check box.

Failure if support force/moment is negative or positive

Both options represent an easy way to control whether the support can only take positive or negative forces/moments: If a force or a moment acts in the prohibited direction, that particular component of the support fails. The remaining retentions and restraints stay effective.

The negative or positive directions refer to the forces or moments that are placed in the nodal support with regard to the respective axes (they do not refer to the reaction forces of the support). Thus, algebraic signs result from the direction of the global axes. If the global Z-axis is oriented downwards, the load case “Self-weight” results in a positive support force $P_z$.

Failure all if support force/moment is negative or positive

In contrast to the abovementioned failure of a single component, the support fails completely once the component is ineffective.

To access the following dialog boxes, use the [Edit Nonlinearity] button in the dialog box or in the table, which are to the right of the list.

Partial activity

![Figure 4.97 Nonlinearity - Partial Activity dialog box](image)
The support’s effect can be defined separately for the Positive and Negative Zone. The sign convention is described in the previous paragraph. In addition to complete activity or complete failure, the support can be set to only be effective when it is displaced or rotated to a certain degree (in this case, a translational or rotational spring has to be defined in the Nodal Support dialog box beforehand). Furthermore, Tearing (failure of support when exceeding a certain force or moment) and Yielding (effective only until force or moment is reached) can be set in combination with a Slippage.

Look at the dynamic Activity Diagram to check the support properties.

**Diagram**

![Nonlinearity - Diagram - Nodal Support u-Y dialog box](image)

The support’s effect can be defined separately for the Positive and Negative Zone. First, define the number of steps (i.e., definition points) for the working diagram. Then, enter the abscissa values of the displacements or rotations with corresponding support forces or moments into the list.

There are several options for the Diagram after last step: Tearing for support failure on exceeding, Yielding for restricting the transfer to a maximum allowable support force or moment, Continuous like in the last step, or Stop for the restriction to a maximum allowable displacement or rotation followed by a rigid or restrained support activity.

**Friction depending on support force**

Use the four friction options to set the transferred support forces to be in relation to the compressive forces that act in a different direction. Depending on your selection, the friction depends on only one support force or on the total force of two simultaneously acting support forces.

Click the button to open a dialog box where you can define the Friction Coefficient $\mu$. 

![Friction in $\mu$ dialog box (partial view)](image)
The following relation exists between axial force and friction force of the support:

\[ P_{\text{Support}} = P_{\text{Axial force}} \]

**Equation 4.13**

**Scaffolding**

For restraints about the axes X' and Y', there is the additional entry *Scaffolding* in the list. With this option, it is possible to model the structural behavior of support plates at scaffoldings or bracings. This function is described in the following technical article:


**Line Supports**

**General description**

Line supports describe the boundary conditions of all FE nodes available along a line. Displacements and rotations on these internal nodes can be prevented or limited by translational and rotational springs.

You can assign nonlinear properties to displacements of line supports so that supports are ineffective in case of tension or compression.

Use the menu option **Insert → Model Data → Line Supports → Graphically** or the toolbar button shown on the left to open the following dialog box:

![New Line Support dialog box](image)

The support types **Hinged (YYY NNN)** and **Rigid (YYY YYY)** are predefined and can be selected from the list. After clicking [OK], you can graphically assign the selected support type to the lines.

Use the [New] button to create another type of support. The dialog box shown in Figure 4.100 is displayed.

**On Lines No.**

Line supports can only be defined on lines that belong to a surface or a solid. Enter the line number into the table column or text box of the dialog box, or select it graphically.

**Reference System**

The support parameters can be related **Locally** to the line axes x,y,z or **Globally** to the axes X,Y,Z. Indexes in the **Support Conditions** dialog section as well as headlines of table columns E to J change depending on the selected setting.
The display of the local axis system of lines including numbering can be set in the Display navigator. You can also use the shortcut menu of a line support.

**Support rotation**

It is possible to rotate the axis system of a local line support. The Rotation about a positive angle $\beta$ rotates the support clockwise around the positive line axis $x$.

The entered support rotation is shown in the dynamic dialog graphic.

When the calculation is complete, it is possible to evaluate support reactions of a rotated line support in relation to the global and the local axis system.
Wall in Z

When a surface is supported by a wall, it is considered an elastic support that depends on the stiffness of the wall. A fixed line support would not represent the flexibility correctly. For such a support type, you can define a Wall: RFEM calculates the constants of translational and rotational springs from the wall’s material and geometry. This option is especially useful for 2D plates in order to avoid singularities, which would occur for a rigidly supported line.

![Edit Wall dialog box](image)

Define the geometry in the Wall Size dialog section. In addition to the Width t, the Height h affects the constants of the translational and rotational springs.

In the Parameters dialog section, select the Material of wall from the list of already defined materials or create a [New] wall material (see Chapter 4.3 ).

To determine the spring stiffnesses, specifications for Support conditions at wall head and wall base are required. If you consider the shear stiffness of the wall, it is also considered for the constants of the Support Springs Due to Wall.

The spring constants determined from the parameters are displayed on the right in the dialog box. The wall widths on the supported line are displayed in the RFEM graphic.

Support or Spring

To define a support, select the corresponding option in the dialog box or table. The check mark indicates that the relevant degree of freedom is blocked and the line displacement in the respective direction is not possible.

If you do not want to define supports, clear the corresponding check box. RFEM sets the constant of the translational spring to zero in the Line Support dialog box. The spring constant can be modified anytime, in order to represent an elastic support of the line. In the table, enter the constant directly into the table column.

The spring stiffnesses are considered design values.

Assigning a failure criterion is described below.
Restraint or Spring

Restraints are defined analogously to supports. Again, the check mark indicates that the relevant degree of freedom is blocked and the line displacement in the respective direction is not possible. In the same way, the constants for rotational springs can be defined once the check boxes are cleared. In the table, enter the spring constant directly into the corresponding table column.

The New Line Support dialog box (see Figure 4.100) provides buttons for different support types, making the definition of degrees of freedom easier.

![Figure 4.106 Buttons in the New Line Support dialog box](image)

The buttons have the following functions for support properties:

<table>
<thead>
<tr>
<th>Button</th>
<th>Support Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>![image]</td>
<td>Rigid</td>
</tr>
<tr>
<td>![image]</td>
<td>Hinged with restraint about Z'</td>
</tr>
<tr>
<td>![image]</td>
<td>Sliding in X' and Y' with restraint about Z'</td>
</tr>
<tr>
<td>![image]</td>
<td>Sliding in X' with restraint about Z'</td>
</tr>
<tr>
<td>![image]</td>
<td>Sliding in Y' with restraint about Z'</td>
</tr>
<tr>
<td>![image]</td>
<td>Sliding in Z' and Y' with restraint about Z'</td>
</tr>
<tr>
<td>![image]</td>
<td>Free</td>
</tr>
</tbody>
</table>

Table 4.4 Line Support buttons

Nonlinearities

You can assign the following nonlinear properties to the components of a line support:

- Failure of component if support force or moment is negative or positive
- Complete failure of support if support force or moment is negative or positive
- Partial activity
- Diagram
- Friction depending on remaining support forces

The nonlinear properties essentially correspond to the nonlinearities available for nodal supports (see Chapter 4.7).

The nonlinear properties can be accessed in the dialog box and table by using the list (see Figure 4.100 and Figure 4.101). For each of the support's degree of freedom, you can define whether and which forces or moments are transferred on the supported line using these settings.
Positive or negative refers to the forces that are introduced to the support in direction of the respective axes (they do not refer to the reaction forces of the line support). The algebraic signs therefore result from the direction of the local or global axes. For example, if the local z-axis of a line is directed downwards, the load case "Self-weight" results in a positive support force $p_Z$.

Nonlinear effective supports of lines are displayed with a different color in the graphic. In the table, you can recognize support elements with a failure criterion by a blue check box.

### 4.9 Surface Supports

#### Theoretical background

An elastic surface foundation represents an elastic support of all 2D elements of a surface.

In the Winkler foundation model, the soil is assumed to be an ideal liquid upon which the slab floats. This model is based on significant differences between the moduli of elasticity for concrete and (linearized) soil, which are typically 1000:1 and more. Mathematically, the assumption by Winkler is the following:

$$ p_z = C_z w_z $$  \hspace{1cm} \text{Equation 4.14}

In each point, the contact pressure $p_z$ is put into relation to the displacement $w_z$ by means of the foundation constant $C_z$. However, the assumption implies that each point is displaced independently of all other nodes of the floor plan. Thus, the surrounding soil is irrelevant for the deformation of a surface (Figure 4.107 a).

This rudimentary foundation model is no longer up to modern requirements.

An improved type of modeling elastic foundations is based on the stiffness modulus approach: In this model, the soil is considered an elastic half-space with all its nodes correlating mathematically and mechanically. This results in an "infinitely" expanded subsidence basin, which decreases the influence of the more distant soil areas (see Figure 4.107 b). However, the advantage of this mechanically superior foundation soil model is offset by numerical disadvantages - a considerably larger system matrix.

![Correlation between deformation figure and bandwidth of the stiffness matrix](image)
The effective soil model according to Kolar/Nemec unifies the advantages of the two aforementioned models without having any disadvantages. This foundation soil model is based on the theory of Pasternak [1]:

- For the slab that is in contact with the soil, only the mechanical properties of the nonlinear elastic or plastic half-space in the contact gap are important. The three-dimensional foundation effects are therefore condensed into the contact gap, i.e. transferred to a 2D problem.

- The Winkler model carries out the 2D condensation (see Equation 4.13), but is defective in terms of energy. By including a second coefficient $C_v$ for the shear capacity of soil, the coaction of soil beyond the slab’s edge is established. A natural subsidence basin with limited dimensions is formed, as it can be verified in reality.

- A two-parameter system $\{C_u, C_v\}$ is created, where $C_{u,z}$ approximately corresponds to the Winkler foundation constant and can be applied in this way in practical calculations. In detail, the entire system consists of five parameters: $C_{u,x}, C_{u,y}, C_{u,z}, C_{v,x},$ and $C_{v,y}$.

Figure 4.107c shows this soil model in comparison. Numerically, the FE model is as stable as the Winkler model. However, incorporating the soil elements in the subsidence basin results in a larger system matrix.

The foundation soil model according to Kolar/Nemec has been enhanced as well. Experience has shown that soil elements can be eliminated from the system with the help of appropriate measures. The result is the effective soil model implemented in RFEM, symbolically shown in Figure 4.107d. Thus, the disadvantage of the larger system matrix is eliminated. You can find a detailed description of the effective foundation soil model in [2].

Figure 4.108 Converting the surrounding soil into line and corner nodal supports

The surrounding soil (“wedge of soil”) is eliminated from the surface model by converting its rigidity into an elastic boundary line and corner node support.

In a first approximation, the spring constants $k$ and $K$ of the line and corner node support are calculated according to the following equations:

Spring constant of line support:

$$k = \sqrt{C_{u,z} C_{v,\perp}}$$

Equation 4.15

Spring constant of corner nodal support:

$$K = \frac{C_{u,x} + C_{v,y}}{4}$$

Equation 4.16

In Equation 4.14, you have to insert the parameter $C_v$ that acts perpendicular to the border line.

Equation 4.15 is used for corners with an angle $\alpha = 90^\circ$ (see [3] for other angle sizes). Larger angles $\alpha$ result in smaller values $K$. However, if $\alpha = 0^\circ$, $K = 0$ as well.
The springs determined in this way must be arranged as line and nodal supports in the model in addition to the elastic foundation of the surface.

![New Surface Support dialog box](image)

**On Surfaces No.**

Enter the numbers of the supported surfaces into this table column or text box, or select them graphically.

### Spring constants by RF-SOILIN

Every soil has more or less distinctive nonlinear elastic or plastic features. To determine foundation coefficients easily, use the RF-SOILIN add-on module. The program carries out calculations of settlements, which are based on load actions and results of test borings, and determines the spring coefficients in each finite element. In the add-on module, different layers of soil can be considered at several recording points.

If the option is selected and no results of RF-SOILIN are available, the foundation coefficients are determined before the RFEM calculation is carried out.
**Support or Spring** $C_{u,x} / C_{u,y} / C_{u,z}$

Directions of supports or springs refer to the surfaces’ local axes $x$, $y$, and $z$. Use the Display navigator or the shortcut menu of a surface to show them in the graphic (see Figure 4.76).

The spring stiffnesses have to be entered as design values.

If the support acts perpendicularly to the surface, enter the support or spring constant into the text box $C_{u,z}$. The parameter is practically equal to the Winkler modulus of foundation $C_z$. It can be taken from a soil expertise.

The parameters $C_{u,x}$ and $C_{u,y}$ represent translational springs that describe the foundation’s resistance against displacement in the surface directions $x$ or $y$. In case of a floor slab, they define the (load-independent) resistance in the horizontal directions.

In the graphic, springs are always placed in direction of the positive surface axis $z$. If spring symbols are on the “wrong” side of the surface, you can change the orientation of the local $z$-axis quickly: Right-click the surface to open the shortcut menu and select Reverse Local Axis System. This option is only available for 3D models, not for planar models. When changing settings, please note that the failure criterion changes the action direction as well.

Rigid supports make it possible to display only one part of the model, for example for symmetrical solid models. In this way, you can increase the calculation speed considerably.

**Shear Spring** $C_{v,xz} / C_{v,yz}$

These text boxes are used to consider the shear capacity of soil in direction of the surface axes $x$ or $y$. In most cases, the Pasternak constant $C_v$ lies between $0.1 \cdot C_{u,z}$ (minor shear capacity) and $0.5 \cdot C_{u,z}$ (medium shear capacity). Generally, $C_{v,xz} = C_{v,yz}$ can be applied.

If the support $u_z$ is rigidly fixed, the corresponding shear elements for the stiffness matrix are activated automatically.

Kolar [3] provides a table with reference values for different soils. However, this information cannot replace the values of a soil survey or a calculation with RF-SOILIN!

<table>
<thead>
<tr>
<th>Soil Consistence</th>
<th>Foundation $C_{u,z}$ [kN/m³]</th>
<th>Shear Capacity $C_v$ [kN]</th>
<th>Shear Capacity $C_v$ [kN]</th>
<th>Shear Capacity $C_v$ [kN]</th>
</tr>
</thead>
<tbody>
<tr>
<td>none</td>
<td></td>
<td>medium</td>
<td>high</td>
<td></td>
</tr>
<tr>
<td>very soft</td>
<td>1,000</td>
<td>0</td>
<td>500</td>
<td>1,000</td>
</tr>
<tr>
<td>medium-dense</td>
<td>10,000</td>
<td>0</td>
<td>5,000</td>
<td>10,000</td>
</tr>
<tr>
<td>compact</td>
<td>100,000</td>
<td>0</td>
<td>50,000</td>
<td>100,000</td>
</tr>
</tbody>
</table>

**Table 4.5:** Reference values for $C_{u,z}$ and $C_v$.

The New Surface Support dialog box (see Figure 4.109) provides buttons for different support types, making the definition of degrees of freedom easier.
The following support properties are assigned to the buttons:

<table>
<thead>
<tr>
<th>Button</th>
<th>Support Type</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Rigid</td>
</tr>
<tr>
<td></td>
<td>Sliding in x and y</td>
</tr>
<tr>
<td></td>
<td>Sliding in x</td>
</tr>
<tr>
<td></td>
<td>Sliding in y</td>
</tr>
<tr>
<td></td>
<td>Sliding in z</td>
</tr>
<tr>
<td></td>
<td>Free</td>
</tr>
</tbody>
</table>

Table 4.6 Surface Support buttons

**Nonlinearity**

The support can be excluded for positive or negative contact stresses that occur in direction of the displacement $u_z$: The foundation fails, for example, in case of lifting forces. Specify settings with the list in the dialog box or table (see Figure 4.110).  

Positive or negative refer to the stresses acting in direction (or opposite direction) of the local z-axis of the surface: Positive contact stresses are produced when a floor slab is stressed by self-weight and the global axis Z as well as the local axis z are both oriented downwards. If the surface axis z were orientated upwards, the contact stress would be negative.

The display option of the local surface axes is shown in Figure 4.76. Nonlinear effective surface supports are displayed in a different color in the graphic and table.

Use the [Edit] button in the dialog box (see Figure 4.109) to define specific nonlinearities such as creeping (limitation of the contact stress) and friction.
In case of a nonlinearity, RFEM calculates the deformations and stresses in several iterations. The program determines, which finite elements become stress-free if the foundation is no longer active due to the failure.

For result combinations with nonlinear acting supports, there is a danger of results being combined with the locally-different support failure. In those cases, it is recommended to use load combinations (see example in Figure 5.28).

### 4.10 Line Hinges

#### General description

Surfaces that touch each other on one line are rigidly connected at it. With a line hinge, you are able to exclude particular degrees of freedom from the transfer.

Line hinges can not just be arranged on boundary lines of surfaces. They can also be assigned to lines integrated in a surface, as shown on the left.

A line hinge is an attribute of a surface, not of a line. Thus, the hinge must be assigned to a surface. You can also assign it graphically with the menu option **Insert → Model Data → Line Hinges → Assign to Lines Graphically**.

**Figure 4.113** New Line Hinge dialog box (for integrated line)

**Figure 4.114** Table 1.10 Line Hinges
Line No.

Enter the number of the line where you want to define the hinge. You can also use the list or select the line graphically. When you select the surface before defining the settings in the dialog box, you can import any boundary line of the surface by clicking the [All Boundary Lines] button.

Surface No.

The line hinge is assigned to a surface. As the hinge is a surface property, you can retroactively adjust it in the Edit Surface dialog box.

Side

The options in the dialog box or the column in the table are only accessible if the line is an integrated object of the surface. The arrangement of the hinge determines the way the finite elements on the line sides are taken into account for the stiffness.

To allocate the hinge to the Left or Right of the line, check the direction of the line (▲ in the figure below) and the direction of the local surface axis z. If the global Z-axis is oriented downward, the following rule applies: "Stand on the line with surface axis z pointing in direction of your feet. Then look in the direction of the line. Left and right are the directions of your arms". If the Z axis is oriented upward, this rule applies with the condition "Look in the opposite direction of the line".

Axial/Shear Hinge or Spring

The text boxes and table columns control the degrees of freedom for axial and shear forces. If a check box is selected, it means that displacement in the relevant direction is possible and the force is thus not transferred. It is also possible to enter the constant of a translational spring.

The degrees of freedom are based on the following definition of the axis system: The x-axis points in direction of the line; the y-axis represents the tangent of the surface plane and the z-axis the normal to the surface.

Moment Hinge or Spring

The degrees of freedom for moments refer to the local axis system of the hinge (x-axis in direction of the line, y-axis as tangent, and z-axis as normal to the surface plane). The check mark means that the rotation is free and the internal force is not transferred. It is also possible to enter the constant of a rotational spring.
The graphic in the dialog box shows the local axis directions. For a "hinge joint" between two surfaces, for example, the release type $\phi_x$ should be selected. Thus, a moment hinge about the longitudinal axis of the line is created.

If you want to apply nonlinear properties to a line hinge, you have to convert the hinge into a Line Release (see Chapter 4.26). For this purpose, you can use a special function in the shortcut menu of the line release, presented in the following article: https://www.dlubal.com/en-US/support-and-learning/support/knowledge-base/001143.

### 4.11 Variable Thicknesses

#### General description

A variable thickness describes a linear decrease or increase of the surface thickness. Use variable thicknesses to model tapered surfaces. The variable thickness must be defined on three points in order to interpolate linearly between them.

A variable thickness is not entered directly, but set as a parameter when defining a surface. When you create a surface, define the Thickness as **Variable** (see Chapter 4.4). In doing so, the [Edit] buttons shown on the left become active in the dialog box and table.
Surface

Variable thicknesses can only be used for plane surfaces, but not for curved surfaces, for example.

Variable Thickness at Three Nodes

To define a variable thickness, specify three nodes so that RFEM can interpolate linearly between them. You can select any nodes within the plane of the surface for the thickness definition. They do not need to belong to the surface, but it is necessary that FE nodes can be generated on these definition points.

Select the three nodes from the list, or use [ ] or [ ] to select them graphically. It is also possible to create [New] nodes. Then, assign the corresponding Thickness d.

The Node-Thickness-Assignment dialog section represents a short overview of the input: Node number and thickness are separated by a comma, individual node-thickness pairs by a semicolon.

It is possible to display the distribution of surface thicknesses in the rendering mode to check data: Select the Filled incl. thickness option in the Display navigator.

![Figure 4.118](https://www.dlubal.com/contents/images/RFEM-5/Manual/Model%20Data/4-Model%20Data/4-Model%20Data.png)

**Figure 4.118** Display navigator: Rendering → Model → Solid Model → Surface → Filled incl. thickness
Orthotropic Surfaces and Membranes

General description

Orthotropic surfaces have different stiffnesses in direction of the local surface axes x and y. Use orthotropic surface properties to model, for example, glued-laminated girders or ribbed floors. Orthotropic properties can be set for plane and quadrangle surfaces.

You can define orthotropic properties via material (material orthotropy with invariable geometry), geometry (irregular shape of surface with isotropic material), or as a combination of both.

The general stiffness matrix of an orthotropic surface in RFEM is as follows.

\[
\begin{bmatrix}
    m_x & D_{11} & D_{12} & D_{13} & 0 & 0 & D_{16} & D_{17} & D_{18} \\
    m_y & D_{22} & D_{23} & 0 & 0 & D_{26} & D_{27} & D_{28} \\
    m_{xy} & D_{33} & 0 & 0 & D_{36} & D_{37} & D_{38} & {} \\
    v_x & D_{44} & D_{45} & 0 & 0 & 0 & 0 & {} \\
    v_y & D_{55} & 0 & 0 & 0 & 0 & 0 & {} \\
    n_x & D_{66} & D_{67} & D_{68} & {} & {} & {} & {} \\
    n_y & D_{77} & D_{78} & D_{88} & {} & {} & {} & {} \\
    n_{xy} & D_{88} & D_{88} & D_{88} & {} & {} & {} & {} \\
\end{bmatrix}
\]

Orthotropic surfaces can be calculated according to the linear static analysis, second-order analysis, or large deformation analysis. In case of matrices with pure membrane coefficients, only a large deformation analysis is possible.

You can find detailed information about Orthotropy in an English document that you can request from Dlubal Software.

An orthotropy is not entered directly but set as a parameter when defining a surface: When creating a new surface, define the Stiffness as Orthotropic or Membrane orthotropic (see Chapter 4.4). Then the [Edit parameters] buttons shown on the left become active in the dialog box and table.
The dialog box is divided into several tabs, which depend on the selected Orthotropy Type.

In the Stiffness Multiplication Factors dialog section, you can either reduce stiffnesses globally using the factor $k$, or individually for bending, torsion, shear, and membrane stiffness elements (see paragraph Stiffness Multiplication Factors).

In the Stiffness Matrix tab, the respective elements of the matrix are displayed (see Figure 4.121).

During the RFEM 4 import, stiffness matrix elements are adjusted according to Equation 4.1.

Orthotropy Type

You can define orthotropic surfaces through material and geometry parameters or directly with coefficients of the local stiffness matrix. Depending on your specifications, tabs of the dialog box change.

The orthotropy types are described on the following pages. For each definition type, you have to specify the Thickness that you want to apply for determining the self-weight.

Constant thickness

RFEM uses the orthotropic material properties that have been defined in the Material Model - Orthotropic Elastic 2D dialog box (see Figure 4.48). This type is only suitable for homogenous surfaces of equal thickness whose material has distinctive orthotropic properties.

Effective Thicknesses

In the Effective Thicknesses dialog tab, you can define different thicknesses in the directions $x'$ and $y'$ to represent unequal stiffness conditions.

The self-weight is not determined from the thicknesses entered in this dialog box; instead, RFEM uses the surface thickness entered in the Edit Surface dialog box or in Table 1.4 Surfaces.

RFEM displays the moduli of elasticity and shear for the material that is used (see Chapter 4.3) so that you can check corresponding data. Alternatively, it would be possible to control the orthotropic properties by means of material settings and to define the same thicknesses for the directions $x'$ and $y'$.

No stresses are calculated for orthotropic surfaces: The different stiffness coefficients would cause “blurred” results because they refer to an average value of the thickness. These stresses do not correspond to the orthotropy model.

Stiffness Matrix

The coefficients of the local stiffness matrix can be defined manually.

With this option, you can also customize generated coefficients (e.g. a coupling or ribbed floor).
The [Info] button provides information about the relevance of coefficients in the stiffness matrix.

If the axes of the orthotropy are not consistent with the axes of the coordinate system of elements, you have to transform the matrices (see [4], page 305 - 313).

If you find out that the stiffness matrix is not positively definite when checking data before performing calculations, appropriate adjustments of coefficients are required.

**Coupling**

Use this setting to model connections between surfaces or members, which are represented by coupling elements consisting of isotropic or orthotropic materials.

In the Coupling dialog tab, you can enter the parameters for coupling thickness $d_p$, coupling spacing $a$, and coupling width $b$ according to the scheme. A realistic coupling model is given when the distance $a$ is larger than the width $b$ of the coupled elements.

The effective thickness $d^*$ is determined according to the following equation:

$$d^* = \frac{d_p}{a}$$

**Unidirectional ribbed plate**

The orthotropic properties of a ribbed floor are based on the principle of an uniaxially stressed T-beam ceiling. RFEM determines the stiffnesses from the geometry parameters of slab thickness $d_s$, rib height $d_r$, rib spacing $a$, and rib width $b$, which you have to specify according to the scheme shown in the Unidirectional Ribbed Plate dialog tab.

Please note that crack development (e.g. state II for concrete) is not taken into account when the stiffnesses are determined. Only isotropic materials are allowed.
**Bidirectional ribbed plate**

This type of ceiling is characterized by webs that cross each other orthogonally in a uniform grid, thus dividing the floor into coffers. As with ribbed floors (see above), the orthotropic properties can be described by means of the geometry. You need to specify the stiffness parameters for two directions.

In the **Bidirectional Ribbed Plate** dialog tab, specify the parameters for slab thickness $d_p$, rib height $d_r$, rib spacing $a$, and rib width $b$ for the directions $x'$ and $y'$ according to the scheme.

**Trapezoidal sheet**

The option to display trapezoidal sheets as surfaces with orthotropic properties considerably facilitates the modeling of surfaces. RFEM determines the stiffness coefficients from the geometry parameters of the cross-section. Only isotropic materials are allowed.

In the **Trapezoidal Sheet** dialog tab, specify the parameters for the sheet thickness $t$, total profile height $h$, rib spacing $a$, top flange width $b_t$, and bottom flange width $b_b$ according to the scheme.

**Hollow core slab / Unidirectional box floor**

Hollow units built in a ceiling reduce the self-weight, but produce orthotropic structural behavior. RFEM determines the stiffnesses from the geometry parameters for the slab thickness $d_p$, or total profile height $h$, and the top/bottom flange width $d_p$, the rib or void spacing $a$, as well as the void diameter or rib width $b$. You have to specify these parameters according to the scheme shown in the **Hollow Core Slab** dialog tab.

Like for the remaining geometric orthotropies (effective thickness, trapezoidal sheet, unidirectional and bidirectional ribbed plate, grillage), only isotropic materials are allowed.

**Grillage**

It is not only possible to display a grillage as a member model but also as an orthotropic surface. As for the remaining geometric orthotropies, only isotropic materials are allowed.

RFEM determines the stiffness coefficients from the geometry parameters for slab thickness $d_p$, rib spacing $a_x$ and $a_y$, as well as rib width $b_x$ and $b_y$, which you have to specify according to the scheme shown in the **Grillage** dialog tab.

You can find details regarding the determination of stiffness components from geometric specifications in an English document that you can request from Dlubal Software.

**Orthotropy Direction $\beta$**

The orthotropic direction refers to the surface’s local axes $x$ and $y$. The angle $\beta$ describes the rotation of the $x'$-axis to the local $x$-axis of the surface. It is responsible for transforming the matrices available in the **Transformed Stiffness Matrix** dialog tab.

Use the **Display navigator** or the shortcut menu of a surface to display the coordinate systems of surfaces in the graphic (see Figure 4.122 @).
The positive angle $\beta$ is defined clockwise around the positive local z-axis of the surface.

**Stiffness Multiplication Factors**

You can reduce stiffnesses globally with the factor $k$, or individually for bending, torsion, shear, and membrane elements of the matrix (see Equation 4.16).  

**All stiffness elements**

All coefficients of the stiffness matrix are globally multiplied by a factor.

**Bending stiffness elements**

Use the factor $k_b$ to adjust the coefficients $D_{11}$, $D_{12}$, $D_{22}$, and $D_{33}$ of the stiffness matrix, which represent the bending components. Entering factors between 0 (no flexural resistance) and 1 (full flexural resistance) is allowed.

**Torsion stiffness elements**

The text box $k_{33}$ allows you to control the factor for torsional rigidity $D_{33}$ about the axes $x'$ and $y'$. The input ranges from 0 (no twisting rigidity) to 1 (full twisting rigidity). For example, a small value is recommended for composite constructions with semi-rigid connections.

**Shear stiffness elements**

The factors $k_{44}$ and $k_{55}$ affect the coefficients $D_{44}$ and $D_{55}$ of the matrix (shear components).

**Membrane stiffness elements**

Use the factor $k_m$ to adjust the coefficients $D_{66}$, $D_{77}$, $D_{67}$, and $D_{88}$ of the stiffness matrix, which represent the axial force components. The input of factors between 0 (no membrane stiffness) and 1 (full membrane stiffness) is allowed.
4.13 Cross-Sections

General description

Before you can enter a member, you have to define a cross-section. The cross-section properties and assigned material characteristics determine the stiffness of the member.

Each cross-section has its own Color that can be used to represent different profiles in the model. Colors are controlled in the Display navigator with the Colors in Rendering According to option (see Chapter 11.1.9).

You do not have to use each defined cross-section in the model. Thus, when modeling the structure, it is possible to experiment without deleting cross-sections. Please note, however, that the cross-sections cannot be renumbered.

To display a tapered beam, you have to define different start and end cross-sections for the member. RFEM automatically determines the variable stiffnesses along the member.

![New Cross-Section dialog box, Cross-Section Properties tab](image1)

![Table 1.13 Cross-Sections](image2)
You do not need to enter the cross-section properties manually. RFEM provides an extensive and expandable cross-section library, as well as import options.

**Cross-Section Description**

The cross-section’s Description can be freely chosen. When the entered cross-section name corresponds to an entry of the cross-section library, RFEM imports the cross-section parameters. In this case, it is not possible to change the values for the Moments of Inertia and area Axial . For user-defined cross-section descriptions, you can enter moments of inertia and cross-section areas manually.

The characteristic values of parametrized cross-sections are also imported automatically. For example, when you enter “Rectangle 80/140”, the parameters of this cross-section appear. The selection of cross-sections from the library is described below.

It is also possible to use a rigid dummy cross-section to model couplings. For this cross-section type, RFEM applies the stiffnesses as for a coupling member. Enter the name “Dummy Rigid” as the description for the cross-section without defining the cross-section values in detail. This way, you can use members with a high degree of stiffness, taking releases or other member properties into account. A new variant in RFEM 5 is the member type Rigid Member Rigid, so the definition of a Dummy Rigid is no longer necessary.

**Material No.**

The cross-section’s material can be selected from the list of previously defined materials. The assignment is facilitated by material colors that are by default used for the rendered graphical display.

In the New Cross-Section dialog box, there are three buttons below the material list. They allow you to access the material library, create a new material, or edit materials.

For more detailed information on materials, see Chapter 4.3.

The Hybrid option can only be accessed for parametrized timber profiles. Use this option to assign specific material properties to cross-section elements if different material grades are provided (e.g. timber of low class for webs).

Click the [Edit] button to open the Edit Hybrid Material dialog box.

Assign materials to the individual cross-section parts according to the graphical scheme. They can be selected from the list. One of these materials must be defined as a Reference Material to determine the ideal cross-section properties.
Moments of Inertia

The moments of inertia are required for the cross-section stiffness: The torsional constant \( I_T \) describes the stiffness against rotation about the longitudinal axis. The second moments of area \( I_y \) and \( I_z \) describe the stiffness against bending about the local axes \( y \) and \( z \). Axis \( y \) is considered to be the "strong" axis. The local cross-sectional axes are shown in the graphic of the New Cross-Section dialog box.

For asymmetrical sections, the moments of inertia are displayed around the cross-section’s principal axes \( u \) and \( v \).

Moments of inertia as well as cross-sectional areas can be adjusted with the help of factors in the Modify dialog tab. In the table, you can access the tab with the button that appears when you click into the table cell. The adaption factor for the cross-sectional area \( A \) does not affect the cross-section weight.

![Figure 4.126 New Cross-section dialog box, Modify tab](image)

With the specification set in Figure 4.126, RFEM only considers the torsional moment of inertia with 5%.

By default, the multiplication factor of the cross-section values is only considered for load combinations (see Figure 7.21). However, for load cases, all stiffness factors are deactivated by default so that the corresponding Options have to be selected if necessary.

Cross-Sectional Areas

The cross-section parameters of the cross-sectional areas are subdivided into the total area Axial \( A \) and the shear areas Shear \( A_y \) and Shear \( A_z \).

Shear area \( A_y \) is in relation to the moment of inertia \( I_z \), shear area \( A_z \) accordingly to \( I_y \). Using a correction factor \( \kappa \), there is the following correlation between the shear areas \( A_y \) and \( A_z \), as well as the total area \( A \).

\[
A_y = \frac{A}{\kappa_y} \quad A_z = \frac{A}{\kappa_z}
\]

Equation 4.19

\[
y/z = \frac{A}{I_{y}/A} \cdot \int_A \frac{S_{y/x}^2}{I_{y}(x)} \, dA
\]

Equation 4.20
where

\[
\begin{align*}
A & : \text{Total area of cross-section} \\
I_{z/y} & : \text{Moments of inertia of cross-section} \\
S_{z/y}(x) & : \text{Static moments of cross-section at location } x \\
t(x) & : \text{Width of cross-section at location } x
\end{align*}
\]

The shear areas \( A_y \) and \( A_z \) affect the shear deformation, which should especially be taken into account for short, massive members. When the shear areas are set to zero, the influence of shear is not considered. The parameters can also be controlled in the Global Calculation Parameters dialog tab of the Calculation Parameters dialog box (see Figure 7.27). If extremely low values are set for shear areas, numerical problems may arise, because the shear areas are contained in the denominator of equations.

For more detailed information, take a look at this technical article: https://www.dlubal.com/en-US/support-and-learning/support/knowledge-base/000966

Select realistic values for the cross-section areas: Extreme differences in the cross-sectional areas of sections involve significant differences in stiffness that may lead to numerical problems when solving the equation system.

**Angle of principal axes \( \alpha \)**

The principal axes are described with \( y \) and \( z \) for symmetrical sections and with \( u \) and \( v \) for asymmetrical sections (see above). The rotation angle of principal axes \( \alpha \) describes the position of the principal axes in relation to the standard system of coordinates for symmetrical sections. For asymmetrical sections, this is the angle between the \( y \)-axis and the \( u \)-axis (see graphic on previous page shown in the left margin). This angle is defined clockwise as a positive angle. For symmetrical cross-sections, \( \alpha = 0^\circ \). The inclination of principal axes for sections from the library cannot be edited.

The angle of rotation for the principal axes is determined with the following equation:

\[
\tan 2 \alpha = \frac{2 I_{yz}}{I_z - I_y}
\]

*Equation 4.21*

When you work with 2D models, only \( 0^\circ \) and \( 180^\circ \) are allowed.

**Cross-section rotation \( \alpha' \)**

The angle of rotation \( \alpha' \) describes the angle by which the sections of all members that use this cross-section are rotated. Thus, the angle represents a global cross-sectional angle of rotation. In addition, each member can be separately rotated about a member rotation angle \( \beta \).

Moreover, the Rotation dialog tab (see Figure 4.127) provides the option to Mirror asymmetrical cross-sections. You can use this option to put an L-section into the correct position, for example.
When importing a section from the cross-section library or from the SHAPE-THIN add-on module, you do not need to care about the angle $\alpha'$. RFEM automatically imports this angle in the same way as the other cross-sectional values. For user-defined sections, however, you have to determine the principal axes angle yourself and adjust it manually by means of the cross-section rotation.

**Overall dimensions**

The cross-section’s Width $b$ and Depth $h$ are significant for temperature loads.

**Cross-section library**

Numerous cross-sections are already available in a data base.

**Opening the library**

In the New Cross-Section dialog box and in Table 1.13 Cross-Sections, you have direct access to frequently used cross-sections:

Use the [Import Cross-Section from Library] button to access the complete cross-section database. When working in the table, place the cursor into table column A to enable the button which, just like the function key [F7], opens the cross-section library.
The cross-section library is divided into several sections, which are described on the following pages.

**Rolled cross-sections**

The table values of many rolled cross-sections are stored in a database.

First, click one of the twelve buttons to define the Cross-Section Type. Another dialog box opens where you select the table. Then, select an appropriate Cross-Section.
In the Filter dialog section, you can filter the library according to the following criteria: Manufacturer/Standard group, Manufacturer/Standard, Cross-section shape, and Cross-section note. That way, it is easier to overview the offered tables and cross-sections. Displayed data can be sorted by clicking the headings of table columns.

If cross-sections of old standards are needed, select the Include invalid checkbox in the Filter dialog section to display them.

Creating favorites

Preferred cross-sections can be set as favorites. To access the dialog box for creating favorite cross-sections, use the [Create New Favorites Group] button at the bottom of the Filter dialog section. When the name for the new group has been defined, the following dialog box appears.

![Figure 4.131 Rolled Cross-Sections - I-Sections - Favorites dialog box, filtered by EN](image)

The dialog box looks like the cross-section library. You can use the filter options described above. In the Select Favorites dialog sections, you can tag preferred tables and cross-sections with a check mark.

After closing the dialog box, the cross-section library presents a clear overview of favorites, once you activate the Favorites group option.

In this way, it is possible to create different groups of favorites available for selection in the list at the bottom of the Filter dialog section.
Built-up cross-sections

Rolled cross-sections can be combined by specifying parameters.

![Built-up Cross-Sections - I-Sections dialog box](image)

Use the [Save] button to save a built-up cross-section. RFEM stores it with its accurate description (e.g. 2IK HE B 300 + HE A 340 in the figure above) in the User-Defined category, where you can later reimport it from.

Parametric cross-sections - thin-walled

In the text boxes, you can freely define parameters for a cross-section composed of sheets. The cross-section values are calculated according to the theory for thin-walled cross-sections. The theory only applies to cross-sections whose element thickness is clearly smaller than the respective element length. If this condition is not fulfilled, define the cross-section in the Massive category (see Figure 4.134), if possible.

Parameter a represents the weld root, not the fillet radius (see Figure 4.133). The weld thicknesses only have an influence on the lengths of the c/t parts. They are not included in the cross-section properties.
Use the button shown on the left to import the parameters of a rolled cross-section. The selection function allows you to preset certain geometry data.

Use the [Save] button to save a parametric cross-section with its exact name, for example IS 330/160/8/12/0 in the figure above. Click the [Load] button to import it again.

**Parametric cross-sections - solid**

In the text boxes, you can freely define parameters for solid cross-sections (e.g. reinforced concrete sections). The cross-section values are calculated according to the theory for massive cross-sections, which presupposes elements with distinct wall thicknesses.
Parametric cross-sections - timber

In the text boxes, you can freely define parameters for timber cross-sections. The cross-section values of both solid and combined cross-sections are calculated according to the theory for massive cross-sections.

If the cross-section is combined by a Coefficient of compliance, you can use the effective stiffnesses of flexural members according to EN 1995-1-1, Annex B.2. For this, you need to specify the reduction factors \( \gamma \). For the modeling, the restrictions according to Annex B.1.2 apply. Composed compression members according to Annex C are not considered with this option!

When you work with a material of the type Hybrid, use the [Edit] button to assign the properties of the cross-section parts (see Figure 4.125). 

Standardized cross-sections - timber

In the Standardized Timber Cross-Sections dialog box, you can select standardized rectangle cross-sections for boards, battens, as well as sawn and solid timber. Standardized American timber cross-sections are also available for designs according to AWC and CSA.
User-defined cross-sections

- Importing saved cross-sections

Click the [Load] button shown on the left to open a dialog box where all cross-sections created with the Save function are displayed.

- Creating user-defined cross-sections

You can freely enter user-defined cross-section properties in a dialog box.

Enter the Table to define the place where the cross-section is managed, and the Name to describe the new cross-section. Then, enter the cross-section parameters and define the buckling curves.
Cross-sections from cross-section programs

It is also possible to import cross-sections from the Dlubal cross-section programs SHAPE-THIN and SHAPE-MASSIVE.

Please note that the cross-sections must be calculated and saved in SHAPE-THIN or in SHAPE-MASSIVE before the cross-section values can be imported.

Importing cross-section tables from ASCII files

Use the button in the bottom left corner of the library to import an entire cross-section table from a file. The file must be a CSV file, i.e. a text file where the table columns are separated by a semicolon (;). Any Excel file can be saved in this format. Make sure that the syntax of the ASCII table corresponds to the definition parameters of the corresponding RFEM cross-section table.

Example: Import of double symmetrical I-sections.

The cross-sections are managed in the IS table (see Figure 4.133). For IS cross-sections, the following parameters are required: h, b, s, t, a. The table in Excel is structured as shown below:

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>h</td>
<td>b</td>
<td>s</td>
<td>t</td>
<td>a</td>
</tr>
<tr>
<td>Cross-section 1</td>
<td>400.00</td>
<td>200.00</td>
<td>10.00</td>
<td>10.00</td>
<td>0.00</td>
</tr>
</tbody>
</table>

In the import dialog box, specify the directory of the CSV file and use the list to select the cross-section table where you want to manage the imported cross-sections.

The imported cross-sections are subsequently available in the User-Defined Cross-Sections category (see Figure 4.137).

When importing cross-sections, RFEM calculates the cross-section values and stress points in such a way that stress designs can be performed as well.
4.14 Member Hinges

General description

Member hinges limit the internal forces that are transferred from one member to others. Hinges are only assigned to member ends (nodes); they can never be assigned to other locations such as the middle of the member.

Some member types are already provided with hinges: A truss, for example, does not transfer moments and a cable transfers neither moments nor shear forces. When entering data, the assignment of hinges is therefore blocked for members of such member types.

![New Member Hinge dialog box](figure)

![Table 1.14 Member Hinges](figure)
Reference System

A member hinge can be related to one of the following axis systems:

- Local member axis system x,y,z
- Global coordinate system X,Y,Z (optionally as scissors hinge)
- User-defined axis system X',Y',Z'

Use the Display navigator (see Figure 4.169) or the member shortcut menu shown on the left to display the local member axes.

For detailed information about the orientation of local member axes in the global coordinate system XYZ, see Chapter 4.17.

Normally, hinges are related to the local axis system x,y,z. Scissors hinges (see Figure 4.144) can only be defined in relation to the global or user-defined coordinate system.

Axial/Shear Hinge or Spring

To define an axial or shear force hinge, set the respective displacement free by selecting the relevant check box in the dialog box or table. The check mark therefore indicates that the axial or shear force cannot be transferred at the member end because a hinge has been set. This becomes apparent in the Member Hinge dialog box: In the text box to the right of the check mark, the constant of the translational spring is zero.

You can change the spring constant anytime to represent, for example, a semi-rigid connection. In the table, enter the constant directly into the table column. The stiffnesses of the springs are considered design values.

Moment Hinge or Spring

Hinges for torsion and bending moments must be defined like hinges for forces. The check mark once again indicates that the torsion is free and the internal force is not transferred.

Elastic connections can be modeled through spring constants, which you can enter directly. Pay attention not to use extreme stiffness values, because otherwise numerical problems may arise during the calculation: Instead of very big or small constants, use rigid connections (no check mark) or hinges (check mark).

The option for defining nonlinear hinge properties is described at the end of this chapter.

Assigning hinges graphically

To graphically assign hinges in the work window, use the menu item

```
Insert → Model Data → Member Hinge → Assign to Members Graphically
```

or

```
Edit → Model Data → Member Hinges → Assign Graphically to Members.
```

First, select a hinge type from the list or create a new one. After clicking [OK], members are divided graphically at one-third division points.
Now you can click the member sides you want to apply the selected hinge to. To assign the hinge to both member ends, click the member in its center area.

**Scissors hinge**

With scissors hinges, you can model the crossing of beams. For example: You have four members connected in one node. Each of the two member pairs transfers moments in its "continuous direction", but they do not transfer any moments to the other pair. Only axial and shear forces are transferred in the node.

In this case, the hinge must be assigned either to members 1 and 2 or to members 3 and 4. The other crossing member pair is modeled as bending-resistant without hinge.
**Nonlinearities**

Nonlinear properties can be assigned to member hinges. In this way, you can control the transfer of internal forces in detail. The list of nonlinearities provides various options.

In the table, hinge types with nonlinear properties are marked in blue.

**Fixed if internal force is negative or positive**

With these two options, you can control the hinge activity for each internal force depending on the direction. For example: An axial force hinge defined with the nonlinearity Fixed if positive \(N\) has the effect that tensile forces (positive) can be transferred at the end of the member, but compressive forces (negative) cannot. In case of negative axial forces, the hinge is effective.

The internal forces are related to the local member axis system xyz.

The remaining entries of the Nonlinearity list provide detailed modeling options for hinge properties. To access the options, use the [Edit] dialog buttons to the right of the list or \(\checkmark\) in the table (see Figure 4.142)

**Partial activity**

The activity of the release can be defined separately for the positive and negative zone. In addition to full effectiveness or failure, the release can lose its effect when a certain displacement or rotation is reached; then it begins to act as a fixed or rigid connection. Tearing [no internal force is transferred
after exceeding a certain value) and Yielding (internal forces are transferred only up to a certain value, even in case of larger deformations) are also possible in combination with Slippage.

The limit values can be defined in the text boxes below. In the Activity Diagram dialog section, the release properties are shown in a dynamic graphic.

**Diagram**

![Diagram image]

The activity of the release can be defined separately for the Positive and Negative Zone. First, enter the Number of steps [i.e. definition points] represented in the diagram. Then you can enter the abscissa values of the internal forces with the assigned displacements or rotations into the list to the right.

You have several options for the Diagram after last step: Tearing for the failure of the release (no internal force is transferred any longer), Yielding for restricting the transfer to a maximum allowable internal force, Continuous as in the last step, or Stop for restricting to a maximum allowable displacement or rotation followed by a fixed or rigid release activity.

In the Diagram dialog section, the release properties are shown in a dynamic graphic.

**Friction depending on force**

With these four options, the forces transferred by the hinge are related to the compression forces that act in a different direction. Depending on your selection, the friction depends on only one normal force or on the total force of two simultaneously acting forces. For example, the friction force for the x-direction can be calculated from just the y-component or the z-component, but also from both or even from the addition of both forces.

The button opens a dialog box where you can define the spring constant C and the friction coefficient μ.
Plastic hinge

The plastic properties of the hinge can be defined in a separate dialog box.

Scaffolding

This nonlinearity type allows for the mechanical simulation of a tube joint with an inner stub between two members. The equivalent model transfers the bending moment via the overpressed outer pipe and after positive locking additionally via the inner stub, depending on the compression state at the member end. Use the button to open a dialog box where you can separately define the parameters for the Inner Tube and the Outer Tube.

The following technical articles provide detailed information about nonlinearities at scaffoldings:
Example: Rafter roof

A planar system is used. The hinge must be defined as follows:

The hinge type can then be assigned to the members.
4.15 Member Eccentricities

General description

The length of a member corresponds to the distance between two nodes defined by the member line. However, for connections of cross-sections or downstand beams, reality is represented only to a certain degree. With member eccentricities, you can connect members eccentrically due to special member end sections. You can, for example, reduce design moments on horizontal beams for frames with large column cross-sections. Member eccentricities are taken into account through a transformation of the degrees of freedom in the local element stiffness matrix.

To check the entered eccentricities, use the photo-realistic imaging of the 3D rendering.

![New Member Eccentricity dialog box](image)

**Figure 4.155** New Member Eccentricity dialog box

![Table 1.15 Member Eccentricities](image)

**Figure 4.156** Table 1.15 Member Eccentricities

Reference System

The member eccentricity can be related to one of the following axis systems:

- Local member axis system x,y,z, in consideration of member and cross-section rotation
- Global coordinate system X,Y,Z

Use the Display navigator or the shortcut menu of the member to display the local member axes xyz (see Figure 4.169 in).
Eccentricity member start / member end

In the Absolute Offset dialog section or in table columns B to G, define the eccentricities for the Member start i and the Member end j. The distances refer to the selected axis system, indicated by the upper- and lower-case indexes, which are also shown in the dialog graphic.

In the dialog box, you can use the button to transfer the values from one side to the other.

Cross-Section Alignment

In the Relative Automatically Offset dialog section, use the nine selection options to define the cross-section point relevant for determining the eccentricity. In the table, specify the position of the point in columns H and I. The point defines the distance by which the cross-section is moved on the start or end node.

By defining the point in the middle of the top flange, as shown in the figure on the left, you can, for example, attach a horizontal beam with its top edge to a column with a flush connection (without extension).

Transverse offset from cross-section of another object

With a Transverse offset, you can arrange a member in a particular distance parallel to an object (member in surface, member in same direction). Select the number of the relevant object - a Member or a Surface - from the list or use in the work window. The eccentricity is determined from the Cross-section alignment defined above and the Axis offset (cross-sectional geometry or surface thickness) that you define by selecting one of the available nine or three check boxes. In the table, define the axis offset in the columns L and M.

For example, by defining the points on the edge of the top flange and on the bottom side of the surface as shown in the figures on the left, you can arrange a steel cross-section on the edge under a plate with a flush connection.

Axial offset from adjoining members

The last option in the Relative Automatically Offset dialog section allows you, for example, to easily connect a member eccentrically to the flange of a column. The offset can be arranged separately for Member start and Member end. The eccentricity is automatically determined from the cross-section geometry of the adjacent members. In the table, assign the axial offset in the columns N and O.

The Axial Offset dialog graphic is interactive with the input, illustrating the effectiveness of the selected check boxes.

You may prefer the input in the Relative Automatically Offset dialog section, because you can directly adjust the eccentricities when cross-sections are changed. RFEM automatically takes modified surface or cross-section dimensions into account.

Assigning eccentricities graphically

Furthermore, eccentricities can be graphically assigned to members in the work window. Use the menu option

Insert → Model Data → Member Eccentricities → Assign to Members Graphically

or

Edit → Model Data → Member Eccentricities → Assign Graphically to Members.

First, define the reference system and the eccentricities.

After clicking [OK], members are divided graphically at one-third division points. Then you can click the member sides you want to apply the eccentricity to (see Figure 4.143 ⊗). To assign an eccentric connection to both member ends, click the member in its center area.
4.16 Member Divisions

General description

Member divisions are used to define points on members for which internal forces and deformations are later displayed in the results tables and numerical printout. A member division neither influences the determination of extreme values nor the graphical results diagram (RFEM internally uses a more refined partition). Member divisions are therefore not required in most cases.

Do not confuse member divisions with FE divisions for members. FE nodes on “free” lines (not belonging to a surface) with member properties are only generated if the lines have an FE mesh refinement [see Chapter 4.23].

Number of Points

You can enter a maximum number of 99 division points in the dialog box. An entry divides the member into the desired number of equidistant points.

Relative distance of point from the member start

When you create a new division in the dialog box, the distances of three intermediate points are preset. They represent the relative distances in the interval of 0 (member start) to 1 (member end).
It is also possible to define irregular divisions for the specified points, as you can enter the relative distances freely. Be sure to follow the correct order of intervals: $x_1 < x_2 < x_3 \ldots$

Graphically, any x-location on the member can be specifically evaluated (see Chapter 9.5). Thus, in most cases, manually entering member divisions and tediously determining relative distances is unnecessary.

**Members**

**General description**

Members are attributes of lines. By assigning a cross-section (which also defines a material), the member receives a stiffness. When generating the FE mesh, 1D elements are created on members.

Members can only be connected with each other on nodes. When members cross each other without sharing a common node, no connection exists. No internal forces are transferred on such crossings.

Graphically, you can apply members as Single, Continuous, or to already existing Lines. The Inserted Member option is described in Chapter 11.4.13.

![Figure 4.159](image1.png) New Member dialog box, General tab

![Figure 4.160](image2.png) Table 1.17 Members
**Line No.**

Enter the number of the line with member properties into the text box of the dialog box or the column in the table. In the New Member dialog box, you can also select the line graphically.

The start and end nodes of the line define the member orientation, which also affects the position of the member's local coordinate system (see “member rotation” in this chapter). The member orientation can quickly be changed in the graphic: Right-click the member and select Reverse Member Orientation in the shortcut menu.

**Member Type**

The member type allows you to define the way internal forces are absorbed, or which properties are assumed for the member.

Different options are available for selection in the Member Type list. Each member type has an assigned Color that can be used to display different kinds of members in the model. Colors are controlled in the Display navigator with the Colors in Rendering According to option (see Chapter 11.1.9).
<table>
<thead>
<tr>
<th>Member Type</th>
<th>Short Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beam</td>
<td>Bending-resistant member that can transmit all internal forces</td>
</tr>
<tr>
<td>Rigid</td>
<td>Coupling member with rigid stiffness</td>
</tr>
<tr>
<td>Rib</td>
<td>Downstand beam considering the effective slab width</td>
</tr>
<tr>
<td>Truss</td>
<td>Beam with moment hinges at both ends</td>
</tr>
<tr>
<td>Truss (only N)</td>
<td>Member with stiffness $E \cdot A$ only</td>
</tr>
<tr>
<td>Tension</td>
<td>Truss (only N) with failure in case of compression force</td>
</tr>
<tr>
<td>Compression</td>
<td>Truss (only N) with failure in case of tension force</td>
</tr>
<tr>
<td>Buckling</td>
<td>Truss (only N) with failure when compression force $&gt; N_{cr}$</td>
</tr>
<tr>
<td>Cable</td>
<td>Member that only transfers tension forces. Calculation is performed according to the large deformation analysis.</td>
</tr>
<tr>
<td>Cable on Pulleys</td>
<td>Member on polyline, can only be shifted in longitudinal direction, absorbing only tensile forces (pulley)</td>
</tr>
<tr>
<td>Result Beam</td>
<td>Member for integration of surface, solid, or member results</td>
</tr>
<tr>
<td>Definable Stiffness</td>
<td>Member with user-defined stiffnesses</td>
</tr>
<tr>
<td>Coupling Rigid-Rigid</td>
<td>Rigid coupling with bending-resistant connections at both ends</td>
</tr>
<tr>
<td>Coupling Rigid-Hinge</td>
<td>Rigid coupling with bending-resistant connection at member start and hinged connection at member end</td>
</tr>
<tr>
<td>Coupling Hinge-Hinge</td>
<td>Rigid coupling with hinged connections at both ends (only axial and shear forces are transmitted, but no moments)</td>
</tr>
<tr>
<td>Coupling Hinge-Rigid</td>
<td>Rigid coupling with bending-resistant connection at member end and hinged connection at member start</td>
</tr>
<tr>
<td>Spring</td>
<td>Member with spring stiffness, definable activity zones, and damping coefficients</td>
</tr>
<tr>
<td>Dashpot</td>
<td>Member with viscous damping properties for RF-DYNAM Pro ®</td>
</tr>
<tr>
<td>Null</td>
<td>Member that is ignored in the calculation</td>
</tr>
</tbody>
</table>

Table 4.7 Member types
Beam

A beam does not have any releases defined on its member ends. When two beams are connected with each other and no release has been defined for the common node, the connection is bending-resistant. Beams can be stressed by all types of loads.

Rigid

This member type couples the displacements of two nodes with a rigid connection. Thus, in principle, it corresponds to a Coupling member. You can use a rigid member to define members with a high stiffness while considering hinges that may also have spring constants and nonlinearities. Hardly any numeric problems occur, as the stiffnesses are adjusted to the system. RFEM also shows internal forces for rigid members.

The following stiffnesses are assumed (also applies for couplings and Dummy Rigid):

- Longitudinal and torsional stiffness:
  \[ E \cdot A \quad \text{and} \quad G \cdot I_T : 10^{13} \cdot \epsilon \quad [\text{SI unit}] \quad (\epsilon = \text{member length}) \]
  \[ \text{Equation 4.22} \]

- Flexural resistance:
  \[ E \cdot I : 10^{13} \cdot \epsilon^3 \quad [\text{SI unit}] \]
  \[ \text{Equation 4.23} \]

- Shear stiffness (if activated):
  \[ G_A y \quad \text{or} \quad G_A z : 10^{16} \cdot \epsilon^3 \quad [\text{SI unit}] \]
  \[ \text{Equation 4.24} \]

Due to this type of member, it is no longer necessary to define a Dummy Rigid (see Chapter 4.13) and assign it as a cross-section.

Rib

Ribs are described in Chapter 4.18.

Truss (only N)

This type of a truss member absorbs axial forces in the form of tension and compression. A truss member has internal moment hinges on its member ends. Therefore, an additional release definition is not allowed. RFEM only shows node internal forces (which are transferred to the connecting members). The member itself shows a linear distribution of internal forces. An exception is the concentrated load on the member, which means that no moment diagram is visible as a result of self-weight or a line load. The boundary moments are zero because of the release; a linear distribution is assumed along the member. The nodal forces, however, are calculated from the member loads, which guarantees correct transmission.

The reason for special treatment is that a truss girder, according to general understanding, only transfers axial forces. Moments are of no interest. Therefore, they are deliberately not shown in the output, nor are they calculated as a part of the design. To display moments from the member loads, use the member type Truss.

For the member type Truss (only N), buckling perpendicular to the principal axes is not possible. Effects of member buckling are therefore not considered in the calculation!
**Tension / Compression**

A tension member can only absorb tension forces, and a compression member only compression forces. The calculation of a framework structure with these types of members is carried out iteratively: In the first iteration, RFEM determines the internal forces of all members. If tension members have negative axial forces (compression), or if compression members have positive axial forces (tension), an additional iteration step is started in which the rigidity of these members is no longer considered - they have failed. This iteration process continues as long as tension or compression members fail. Depending on modeling and loading, a system may become unstable due to failure of tension or compression members.

A failed tension or compression member can be considered again in the stiffness matrix if it is reactivated in a later iteration step due to redistributions in the system. In the menu, select **Calculate → Calculation Parameters** to open the **Global Calculation Parameters** dialog tab where you can set the **Reactivation of Failing Members**. You can find detailed information about these functions in Chapter 7.3.

**Buckling**

A buckling member absorbs unlimited quantities of tensile forces. Compressive forces, however, can only be absorbed until the critical Euler load is reached.

\[
N_c = \frac{\pi^2 E I}{c_r^2}
\]

where \( c_r = c' \)

**Equation 4.25**

With this type of member, you can often avoid instabilities that occur in nonlinear calculations according to the second order theory or large deformation analysis due to buckling of truss members. If you realistically replace trusses by buckling members, the critical load is increased in many cases.

**Cable**

Cables only absorb tension forces. They are used to analyze cable chains with longitudinal and transversal forces through iterative calculation and by taking the cable theory into account (large deformation analysis - see Chapter 7.3.1). For that purpose, it is required to define the complete cable as a cable chain consisting of several cable members.

To quickly create a catenary, go to the menu and select **Tools → Generate Model - Members → Arc** (Chapter 11.7.2). The more accurately the starting shape of the catenary corresponds to the real cable chain, the more stable and the faster you can perform the calculation.

It is recommended to prestress cable members in order to prevent compression forces that would result in failure. Furthermore, cables should only be used if deformations have a considerable part in changes of the internal forces, that is, when large deformations can occur. For simple, straight riggings such as transverse bracings (projecting roof), tension members are completely sufficient.

When evaluating deformations of cable members, set the scaling factor in the control panel (see Figure 3.19) to "1" so that tightening effects are represented realistically.
Cable on Pulleys

This cable type only absorbs tensile forces and is calculated according to the cable theory (large deformation analysis). In contrast to a cable, it can only be applied to a polyline with at least three nodes. This member type is suitable for flexible tension elements whose axial forces are passed on by means of deviating points (e.g., pulley).

In contrast to a normal cable member, only a displacement within the internal nodes in the longitudinal direction $u_x$ is possible. The member must therefore not be stressed by member loads acting in the local directions $y$ or $z$.

The displacement in longitudinal direction is not allowed to be free at the ends of the cable.

For the internal nodes of the polyline, it does not matter whether a nodal support is available or if the member is connected to another construction: RFEM analyzes the total model of the cable member along the length of the polyline.

For members of the member type Cable on Pulleys, RFEM only considers displacements $u_x$ and axial forces $N$.

Result Beam

Like a cut through the model, a result beam can be placed anywhere in the model as a virtual member. Use it to display the internal forces of surfaces, members, and solids in the form of integrated results. This allows you, for example, to read the resulting shear forces of a surface used for masonry design in the display.

The result beam requires neither a support nor a connection to the model. It is not possible to apply loads to a result beam.

The integration parameters must be set in a dialog box [see Figure 4.163] that you open by using the [Edit] button.

In the Integrate Stresses and Forces dialog section, define the result beam’s zone of influence. The dialog graphic illustrates the parameters relevant for the individual options.
The Include Objects dialog section allows for a specific selection of model elements whose results should be taken into account for the integration: surfaces, solids, members.

When the result beam is defined, you can activate and deactivate the display of integration areas in the Display navigator (see figure shown on the left).

**Definable Stiffness**

The member stiffnesses can be directly specified in a dialog box that you open with the [Edit] button. Thus, the assignment of a cross-section is unnecessary.

To display the definition of the stiffness matrix, use the [Info] button.
**Coupling**

A coupling member is a virtual, very stiff member with definable rigid or hinged properties. It is possible to couple the degrees of freedom of the start and end nodes in four different ways. The axial and shear forces, or torsional and bending moments, are transferred directly from one node to the other. Couplings can be used to model special situations for the transfer of forces and moments.

Stiffnesses of couplings are calculated depending on the model to preclude numerical problems.

With the Rigid variant, you can also define coupling members while considering springs and nonlinearities of releases.

To control the display of coupling results, use the Display navigator.

**Spring**

If Spring members are set, you can open a new dialog box by using the [Edit] button or in the table.
Define the spring properties via Parameters or in a Diagram. The spring constant \( C_{1,1} \) describes the stiffness of the member in its local x-direction according to the following relation:

\[
k = \frac{E A}{L}
\]

Equation 4.26

The Slippage specifies a zone of the deformation where the spring does not absorb any forces.

You have two options for defining the spring Limits:

- **Deformation**: The values \( u_{\text{min}} \) and \( u_{\text{max}} \) define the geometric activity zone of the spring. The spring acts as a rigid member (stop) for deformations outside of the specified zone.
- **Force**: The values \( N_{\text{min}} \) and \( N_{\text{max}} \) define the activity zone for the forces that can be absorbed by the spring. If the axial force is beyond the defined limits, the spring fails.

Use the Diagram tab to define spring properties more precisely. These settings are largely identical with the parameters available for nonlinear member releases (see Chapter 4.14).

**Dashpot**

This member type is relevant for time history analyses in the dynamics add-on modules RF-/DYNAM Pro - Forced Vibrations and RF-/DYNAM Pro - Nonlinear Time History. You can specify the member properties in a dialog box that you can access by using the [Edit] button in the dialog box or in the table.

This linear viscous damping element corresponds to the member type "Spring" described above. In the Dashpot tab, the Viscous damping coefficient \( c \) must also be specified. The forces that are dependent on the velocity can thus be considered in the dynamics modules. With regard to viscoelasticity, the member type "Dashpot" is similar to the Kelvin-Voigt model, which consists of the damping element and an elastic spring (both connected in parallel).
Null

A dummy member with its loads is not considered in the calculation. Use dummy members to, for example, analyze changes in structural behavior if certain members are not effective. You do not need to delete these members; their loading is kept as well.

Cross-Section No. member start / member end

The two text boxes or table columns are used to define the cross-sections for the member start and end. The cross-section numbers refer to the entries in Table 1.13 Cross-Sections (see Chapter 4.13). Assignment is made easier by colors related to different cross-sections.

When you enter different numbers for the start and end cross-section, a taper is created. RFEM interpolates the variable stiffnesses along the member according to polynomials of a higher grade. Input of nonsense such as a taper consisting of an IPE cross-section and a round steel will be identified by the plausibility check before the calculation starts.

The internal determination of tapered cross-section values is controlled by the Taper Shape in the Options tab or the corresponding table column (see Chapter 4.17).

Member Rotation

The member-related coordinate system xyz is defined clockwise by right angles. The local axis $x$ always represents the centroidal axis of the member, connecting the start node with the end node of the line (positive direction). Member axes $y$ and $z$, or $u$ and $v$ for asymmetrical cross-sections represent the principal axes of the member.

The position of the local axes $y$ and $z$ is set automatically: Axis $y$ is perpendicular to the longitudinal axis $x$ and parallel to the global plane XY. The position of the axis $z$ is determined by the right-hand rule. The $z'$ component of the $z$-axis is always pointed “downwards” (i.e. in direction of the gravity), irrespective of whether the global axis $Z$ is oriented downward or upward.
To check the member position, use the 3D rendering. You can also use the Display navigator or the member shortcut menu to display the Member Axis Systems x,y,z.

Table column N provides information on the global axis the member is parallel to or in which plane spanned by the global axes the member lies. If there is no entry, the member is in an arbitrary spatial position.

If a member is aligned parallel to the global axis Z, and therefore in vertical position, the local axis z naturally has no Z-component. In this case, the following rule applies: The local axis y is aligned parallel to the global axis Y. Then the position of the z-axis is determined by the right-hand rule (see Figure 4.170).

When a member in a continuous set of column members is not precisely in vertical position (due to minor deviations of the nodal coordinates X or Y), the axes of the member can change their orientation: RFEM classifies the position of a member that is minimally inclined as "general". If you still want to classify members in general position as vertical, select Tools → Regenerate Model in the menu (see Chapter 7.1.3).

Member rotations can be applied in two ways:

- **Member rotation via angle β**

  Define an Angle β by which the member is rotated. If the rotation angle β is positive, the axes y and z are rotated clockwise around the longitudinal member axis x.

  Please note that the member rotation angle β and the cross-section rotation angle α' (see Chapter 4.13) are summed up.

  In 2D models, only member rotation angles of 0° and 180° are allowed.
Member rotation via help node

The member axis system is directed to a particular node. First, select the axis [y or z] you want affected by the help node. Accordingly, the help node defines the plane xy or the plane xz of the member. Then, enter the help node, select it graphically, or create a new one. However, the node may not lie on the straight line that is defined by the x-axis of the member.

The following example shows columns that are aligned towards the center point.

Changes of the local member axis system may affect the algebraic signs of internal forces. The following figure illustrates the general sign convention.

The bending moment $M_y$ is positive if tensile stresses occur on the positive member side (in direction of the z-axis). $M_z$ is positive if compressive stresses occur on the positive member side (in direction of the y-axis). The sign definition for torsional moments, axial forces, and shear forces conforms to the usual conventions: These internal forces are positive if they act on the positive section in a positive direction.

Hinge No. member start / member end

In these two text boxes or table columns, you can define hinges that control the transfer of internal forces on nodes. The hinge numbers refer to the entries available in Table 1.14 Member End Hinges (see Chapter 4.14).

For specific member types, entries are not possible because internal releases already exist.
Eccentricity No.

In this table column or text box of the Options dialog tab (see Figure 4.161), you can assign an eccentric connection to the member. The numbers of the eccentricities refer to Table 1.15 Member Eccentricities (see Chapter 4.15). A connection type determines the eccentricities of both member start and member end.

Division No.

Member divisions control the numerical output of internal forces and deformations along the member (see Chapter 4.16). Use the settings in the table column or the text box of the Options dialog tab to assign divisions or create new ones. The numbers of the divisions refer to the entries in Table 1.16 Member Divisions.

A member division neither has any influence on the determination of extreme values nor on the graphical results diagram (RFEM internally uses a more refined partition). As member divisions are not required in most cases, the default setting is 'None' or '0'.

Member elastic foundation

In this text box of the Options tab (see Figure 4.161), you can assign an elastic foundation to the member. The numbers of the elastic foundations are managed in Table 1.19 Member Elastic Foundations (see Chapter 4.19).

Member nonlinearity

This text box in the Options dialog tab (see Figure 4.161) makes it possible to provide the member with nonlinear properties. The numbers of the nonlinearities refer to the entries in Table 1.20 Member Nonlinearities (see Chapter 4.20).

Taper Shape

If different cross-sections are defined for the member start and member end, this table column or text box in the Options tab provides a choice between a Linear and a Quadratic taper application. This allows you to describe the taper geometry for the determination of the interpolated cross-section values.

In most cases, there is a linear taper course: The height of the cross-section changes evenly from the start of the cross-section to its end; the width remains more or less constant. However, if the width of the cross-section also changes distinctly along the member (e.g. taper made of solid sections), it is recommended to use a square function for the interpolation of cross-section values.

Length

This table column states the absolute length of the member as the distance between start and end node. Eccentricities are taken into account.

You can also read the member length in the work window: Place the mouse pointer on a member and wait a moment until the ScreenTip of the member appears.

Weight

The mass of a member is determined from the product of the cross-sectional area A and the specific weight of the material. RFEM applies $g = 10 \text{ m/s}^2$ as the gravitational acceleration. If necessary, you can adjust this value in the Options tab of the General Data dialog box (see Figure 12.32).
**Position**

Table column \(N\) provides information about the global axis parallel to the member, or in which plane spanned by the global axes the member lies. If there is no entry, the member is in an arbitrary spatial position.

When a member located in a continuous set of column members is not exactly in vertical position (because of minor deviations of the nodal coordinates \(X\) or \(Y\)), the axes of the member can change their orientation: RFEM classifies the position of a member that is slightly inclined as "general". If you still want to classify members in general position as vertical, select **Tools → Regenerate Model** in the menu (see Chapter 7.1.3).

If continuous members do not have a uniform member position, problems may arise, for example, when applying aligned imperfections. The following FAQ provides an example including a solution: [https://www.dlubal.com/en-US/support-and-learning/support/faq/000619](https://www.dlubal.com/en-US/support-and-learning/support/faq/000619)

**Effective Lengths**

The Effective Lengths dialog tab manages the Effective Length Factors \(k_{cr,y}\) and \(k_{cr,z}\).

![Figure 4.173](image)

**Figure 4.173** Edit Member dialog box, Effective Lengths tab

The effective length factors can be adjusted separately for both member axes. The dialog fields on the right show the Effective Lengths that result from the entered factors and the member length.

Effective length factors are significant for add-on modules such as RF-STEEL EC3 where stability analyses are performed, but they play a secondary role for RFEM, because buckling lengths for buckling members, for example, are determined internally from the boundary conditions and taken into account accordingly.

The Critical Buckling Load dialog section allows you to specify if the flexural buckling load of the member is checked during the calculation. By default, the check box is selected for truss, compression, and buckling members. The Global Calculation Parameters dialog tab of the Calculation Parameters dialog box (see Figure 7.27) provides a global setting option for this kind of control.
Modify Stiffness

With the Modify Stiffness dialog tab, you can influence member stiffnesses.

If you have made any changes at cross-section stiffnesses (see Chapter 4.3), they will additionally be taken into account during the calculation.

![Modify Stiffness dialog tab](image)

You can select the Definition Type of the stiffness adjustment from the list. If you select None (no modification of stiffness), all stiffness components with the factor 1.00 are taken into account for the calculation.

Use the Multiplier Factors option to customize the stiffness factors $k$ for torsional, bending, axial, and shear stiffnesses of the member (see Figure 4.174). If you select the According to AISC 360-10 C2.3(2) definition type, there are different options in the dialog tab, which are in alignment with the American Steel Standard.

![Multiplier Factors dialog section for AISC 360-10](image)

When determining internal forces according to ANSI/AISC 360-10, you have to consider a reduction factor $\tau$ for all members whose bending stiffnesses contribute to the stiffness of the structure. This factor is dependent on the member’s axial force: The larger the axial force, the larger $\tau$ is as well.
If \( \tau \) is to be determined iteratively, you have to specify the Design Method — LRFD or ASD. The factor is calculated according to equation (C2-2a) or (C2-2b) of AISC 360-10 in several steps until a convergence is reached.

Independent of the factor \( \tau \), the reduction factor 0.8 is applied for all members for the bending and axial stiffnesses, as required in AISC 360-10. Use the Set to 1 check box to avoid the iterative determination of \( \tau \) so that only a stiffness reduction of 0.8 is applied.

The definition type According to ACI 318-14 Table 6.6.3.1.1(a) shows the reduction factors according to the American reinforced concrete standard depending on the component type. The list provides different options to select the corresponding factors for columns or beams, for example.

To assign stiffness modifications to several members, select them using the multiple or window selection, then double-click one of the members to edit them.

**Member as surface model**

The Generate Surfaces from Member feature can be used to convert a member (1D elements) into adequate surface elements for detailed designs. The feature is described in Chapter 11.7.1.5.

**Double members**

Generally, overlapping members in the model are not desired. If you define a new member on the nodes of an existing member, RFEM automatically deletes the old member.

To prevent RFEM from deleting previously defined members, select Edit → Allow Double Members in the menu. With this, RFEM considers the stiffnesses of both members in the calculation.
Ribs

General description

Ribs are a special type of members. To create a rib, a member must already exist. Ribs can be used to display T-beams in the FEA model by defining eccentricities and effective widths.

Ribs are primarily suited for models with reinforced concrete elements: You can use the rib internal forces and rib cross-sections for design in the RF-CONCRETE Members add-on module. However, when you want to model a steel plate with a welded "rib", use a surface with an eccentrically connected member.

You can define a rib directly with the Ribs navigator shortcut menu or through dialog input. When you create a new member and you select the Member Type Rib (see Chapter 4.17), you can use the [Edit] button to define the parameters. It is also possible to access the dialog box below by using the shortcut menu in the navigator or the menu.

![New Rib dialog box (for model type 2D - XY)](image1)

![Table 4.18 Ribs](image2)
Position of Rib

Generally, a rib is a member that is eccentrically arranged. The eccentricity is determined automatically from half of the surface thickness and half of the member height (Table 1.15 Member Eccentricities is not affected). You can also define it manually. The rigidity of the model is increased due to the eccentricity of the rib.

The following arrangement options are available:

On +/−z-side of surface

The eccentricity as the sum of half of the surface thickness and half of the web height is automatically applied in direction of the positive or negative surface axis z. To display and check the surface axes x,y,z in the graphic, use the Display navigator (see Figure 4.122).

Centric

The rib is modeled without eccentricity. The centroidal axis lies in the center of the surface.

User-defined via member eccentricity

You can define the member eccentricity perpendicular to the plate plane in the New Member Eccentricity dialog box, or in Table 1.15 (see Chapter 4.15). Then you can assign it to the member.

You can check the rib position in the rendering mode without problems: In the Display navigator, select the two display options for solid models: Members → Cross-sections and Surface → Filled incl. thickness.
Effective Width

When modeling 3D structures, the effective width has no influence on the stiffness because the increased stiffness is already taken into account due to the eccentric member. The effective width only affects the internal forces. For 2D models (model type 2D - XY), however, the stiffness is controlled by the settings applied for the Stiffness Reduction (see paragraph below).

If an eccentrically connected beam is used instead of a rib, the RFEM model yields internal forces of both the member and the slab. But in reinforced concrete design, the member and a certain part of the surface are considered a single unit — T-beams. To determine the internal forces for the floor beam, the bending moment in the member must be increased by the product of the axial force in the slab and the eccentricity. To determine the axial force in the plate, you have to know the area where the axial forces are summed up. Therefore, you have to specify the effective widths as well as the surfaces.

Connecting surface

The effective widths of the rib must be defined separately for the left and right side. In most cases, you can keep the Autodetect setting in the Connecting surface list of the New Rib dialog box. Only if more than two surfaces adjoin each other along the line of the rib do you have to explicitly determine the connecting surfaces.

Effective width

The effective Width b1 or b2 can be entered directly into the text box or calculated automatically from the member length by selecting the options L/6 and L/8. When confirming the dialog box, RFEM determines the effective widths and fills in the values.

Please note: When the member length is modified retroactively, the effective widths are not adjusted automatically!

After the calculation, the effective components of the surfaces can be considered for the member results in the Display navigator: Results → Ribs - Effective Cooperation Surface/Member. The member result diagrams also allow for a specific evaluation of the rib internal forces (see Chapter 9.5).

Stiffness Reduction

This dialog section and these table columns are only shown if the model type 2D - XY has been set in the general data (see Figure 12.23). In contrast to spatially defined models where ribs can be taken into account as eccentrically arranged members in the FE analysis anyway, RFEM uses a different analysis approach for floor beams.

Without activity of plate component

For the calculation, RFEM applies a substitute cross-section whose stiffness is determined from the member cross-section and the effective plate component of the surfaces. Thus, the stiffness of the plate is determined twice for eccentrically arranged ribs because it is effective in the substitute cross-section as well as directly through the surface elements. If the Without activity of plate component check box is selected, the stiffness component of the plate is not considered in the substitute cross-section.

Torsion stiffness activity

This text box is used to reduce the torsional rigidity of the rib.
4.19 Member Elastic Foundations

General description

While nodal supports provide a support on both member ends, member elastic foundations provide an elastic support of the member along its entire length. You can use elastic member foundations to model foundation beams while considering soil properties, for example. If the elastic foundation is not effective in case of tensile or compressive stresses, it is possible to consider nonlinear effects in the calculation.

On Members No.

Member elastic foundations can only be defined for the member type Beam. Enter the number of the member into the table column or text box, or select it graphically.

Spring Constants

Translational spring constant

You have to specify the parameters of translational springs in direction of the local member axes x, y, and z.

The stiffness moduli $E_i$ of Table 4.8 serve as reference values. Please note that input in RFEM refers to the bedding modulus, which must be determined while taking the form factor into account.
The values of Table 4.8 represent area-related characteristic values: They describe the area force in \([\text{N/mm}^2]\) that is required to compress the soil by 1 mm. Thus, the unit would be interpreted in a solid-related way as \([\text{N/mm}^3]\). The spring stiffnesses are considered design values.

For foundation beams used to model strip foundations, for example, you have to determine the spring coefficient while taking the cross-section width into account. Thus you obtain a translational spring related to the member in \([\text{N/mm}^2]\). The spring indicates the member force in \([\text{N/mm}]\) required to compress the soil by 1 mm, hence the unit \([\text{N/mm}^3]\) for the input. The result must be entered as the translational spring \(C_{1,z}\): For strip foundations (members in horizontal position), the local z-axis is usually directed downwards.

Use the Display navigator or the shortcut menu of the member to display the local member axes (see Figure 4.169).

**Shear spring constant**

Shear springs can be used to determine the shear capacity of the soil. The spring constants \(C_2\) are determined with the product \(\nu \cdot C_{1,z}\), with Poisson’s ratio \(\nu\) being between 0.125 and 0.5 for sand and gravelly soil, and between 0.2 and 0.4 for clay soil.

**Rotational spring constant**

Enter the constant of a rotational spring into the text box or table column. The constant hinders the member’s rotation about its longitudinal axis.

**Foundation ineffective**

If the elastic foundation is not effective in case of tensile or compressive stresses, assign the nonlinear property Failure to the foundation type.

Please note that the failure criterion Failure if negative or positive only refers to the local member axis \(z\). The nonlinearity does not apply to the translational springs in direction of the local axes \(x\) or \(y\)! Thus, a biaxially effective failure of foundation members is not possible.

Failure in case of a negative contact stress has the following meaning: The foundation is without effect if a member element moves in the opposite direction of the local axis \(z\).

If failure criteria are applied, it is recommended to check position and orientation of the local \(z\)-axes (see Figure 4.169). It might be necessary to rotate members.

The division of members with elastic foundations can be adjusted in the Global Calculation Parameters dialog tab of the Calculation Parameters dialog box (see Chapter 7.3).
4.20 Member Nonlinearities

General description

Member nonlinearities can be used to represent nonlinear relations between forces (or moment) and strains in members.

Some nonlinear properties can already be specified when defining the member type: A tension member, for example, is a truss for which the strain increases proportionally with the tension force, but whose strain may rise under compression without a verifiable force being required for it.

In principle, member nonlinearities can be assigned to any type of member. Of course, combinations have to make sense. A compression member with the design criterion "Failure under compression" would cause problems during the calculation. Member nonlinearities are therefore not allowed for tension members, compression members, buckling members, and cable members, as well as for members with cross-sections of the type Dummy Rigid.

![New Member Nonlinearity dialog box](image1)

![Table 1.20 Member Nonlinearities](image2)
<table>
<thead>
<tr>
<th>Nonlinearity</th>
<th>Diagram</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Failure under tension</td>
<td><img src="image1" alt="Diagram" /></td>
<td>The member cannot absorb tensile forces.</td>
</tr>
<tr>
<td>Failure under compression</td>
<td><img src="image2" alt="Diagram" /></td>
<td>The member cannot absorb compressive forces.</td>
</tr>
<tr>
<td>Failure under tension with slippage</td>
<td><img src="image3" alt="Diagram" /></td>
<td>The member cannot absorb tensile forces. Compressive forces are not absorbed until the slippage $u_s$ is overcome.</td>
</tr>
<tr>
<td>Failure under compression with slippage</td>
<td><img src="image4" alt="Diagram" /></td>
<td>The member cannot absorb compressive forces. Tensile forces are not absorbed until the slippage $u_s$ is overcome.</td>
</tr>
<tr>
<td>Slippage</td>
<td><img src="image5" alt="Diagram" /></td>
<td>The member only absorbs axial forces after having exceeded a strain or shortening by the value $u_s$. <strong>Please note:</strong> A line refinement on a member with Slippage causes an internal member division into small member parts. The slippage criterion is applied to each of these partial members.</td>
</tr>
<tr>
<td>Tearing under tension</td>
<td><img src="image6" alt="Diagram" /></td>
<td>The member absorbs compressive forces without limitation, but fails if tensile forces exceed $N_{t_0}$.</td>
</tr>
<tr>
<td>Yielding under tension</td>
<td><img src="image7" alt="Diagram" /></td>
<td>The member absorbs compressive forces without limitation, but only a maximum tensile force of $N_{t_0}$. If the strain increases, the tensile force remains constant in the member.</td>
</tr>
<tr>
<td>Member Nonlinearities</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>-----------------------</td>
<td>-------------</td>
<td></td>
</tr>
<tr>
<td><strong>Tearing under compression</strong></td>
<td>The member absorbs tensile forces without limitation but fails if compressive forces exceed $N_{torn}$.</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Graph" /></td>
<td><img src="image" alt="Graph" /></td>
<td></td>
</tr>
<tr>
<td><strong>Yielding under compression</strong></td>
<td>The member absorbs tensile forces without limitation, but only a maximum compressive force of $N_{torn}$. If the strain increases, the compressive force remains constant in the member.</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Graph" /></td>
<td><img src="image" alt="Graph" /></td>
<td></td>
</tr>
<tr>
<td><strong>Tearing</strong></td>
<td>The member fails when the compressive force $N_{torn}$ or the tensile force $N_{to}$ is reached.</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Graph" /></td>
<td><img src="image" alt="Graph" /></td>
<td></td>
</tr>
<tr>
<td><strong>Yielding</strong></td>
<td>The member starts to yield if the compressive force $N_{torn}$ or the tensile force $N_{to}$ is reached: If the strain increases, the force remains constant.</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Graph" /></td>
<td><img src="image" alt="Graph" /></td>
<td></td>
</tr>
<tr>
<td><strong>Plastic hinge</strong></td>
<td>If a plastic design force is reached on a location of the member, a plastic hinge for the internal force is formed there. The internal forces must be entered as absolute values. For components of internal forces not resulting in plastifications, you have to enter high values.</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Graph" /></td>
<td><img src="image" alt="Graph" /></td>
<td></td>
</tr>
</tbody>
</table>
4.21 Sets of Members

General description

Sets of members must be understood as combined members. Use them to treat several members as one member, as this may be preferable for some locations in the structural system (e.g., for lateral-torsional buckling analysis, design of continuous beams, load application).

The figure above shows a trapezoidal load that acts on the complete length of a set of members.

Description

You can enter any name for the set of members. You can also use the list to select a name. Manually entered descriptions are saved in the list and immediately available for selection.
Type

There are two different types of member sets: continuous members and groups of members.

A **continuous member** is created by connected members that do not branch out. It would be possible to draw them with a pencil without having to lift it once.

![Continuous members](image)

A **group of members** consists of connected members that may branch out.

![Group of members](image)

In some add-on modules, you can design sets of members. Usually, the design can only be performed for continuous members because parameters such as buckling lengths must be clearly definable.

**Members No.**

Enter the numbers of the members that form the set of members into the text box of the dialog box or the column in the table. You can also use to select them graphically in the work window. Use the button to change the order of member numbers and thus the direction of the member set.

The quickest way to define a set of members is as follows: Select the relevant members in the work window by using the pointer to draw a window, or with the multiple selection by holding down the [Ctrl] key. Then, right-click one of the selected members. The shortcut menu of the member opens where you select **Member → Create Set of Members** or **Create Set of Members**. The **New Set of Members** dialog box opens where the numbers of the selected members are preset.
Length

The total length of the set of members is determined from the sum of the individual member lengths.

Weight

The mass of the set of members is determined from the sum of the individual member masses.

**Intersections**

**General description**

If surfaces intersect and internal forces are transferred on the common line, you have to create an intersection. Otherwise, you would have two independent subsystems without any connection. The following example demonstrates the effect.

![Diagram of intersecting surfaces](image)

Each time the model is changed, RFEM must recalculate the intersections. When complex models are designed, recalculating data is very time-consuming for the graphical representation. The input is slowed down accordingly.

![New Intersection dialog box](image)
Intersection through two surfaces

In the text boxes or table columns, enter the numbers of the two intersecting surfaces. In the New Intersection dialog box, you can select the surfaces from the list. You can also use Ctrl to select them graphically.

Intersections (of more than two surfaces, if need be) can be created quickly in the graphic: Select the surfaces by drawing a window. You can also use the multiple selection by holding down the [Ctrl] key. Then, right-click one of the selected surfaces. The shortcut menu opens where you select Surface ➔ Create Intersection. RFEM creates the intersection automatically.

Line Numbers Generated by Intersection

When creating an intersection, RFEM generates a line that is shared by both surfaces ("intersection line"). The number of the new line is shown in the dialog field and table column.

Intersection lines are labeled as the line type Intersection in Table 1.2 Lines. The comment identifies them as Generated lines. The Edit Line dialog box can also be used for intersection lines so you can assign member or support properties.
Active surface components

An intersection line divides a surface into components that can be individually set active or inactive. Inactive surface components are not displayed in the work window. Neither are finite elements created nor is loading applied for this. Only active surface components exist for the equation solver.

Components of intersections can be activated and deactivated as follows:

- **Edit Surface dialog box**
  
  Double-click the original surface in the Data navigator. When you double-click the surface in the work window, use the [Go to] button available in the Component dialog tab (see Figure 4.72) to open the edit dialog box of the original surface.

  The Active Surface Components section of the Integrated / Components dialog tab lists all surface components created during the intersection’s generation.

  ![Edit Surface dialog box, Integrated tab](image)

  The surface component marked in the list is highlighted in color in the work window. To deactivate a component, clear the corresponding check box. The inactive surface component is subsequently displayed without filling color.
Shortcut menu of surface component in the Data navigator / shortcut menu

Directly right-click the Surfaces navigator entry or the component in the work window. Then, use the shortcut menu to activate or deactivate the surface component.

The shortcut menu provides further useful features for editing the component or original surface. The geometric information of the original surface is kept internally by the program as it is needed for recalculating the intersection after modifications. Therefore, inactive surface components cannot be deleted, only hidden.
4.23 FE Mesh Refinements

General description

If no FE mesh refinements have been defined, the FE mesh is generated with the preset target FE length. The global parameters of the FE mesh are described in Chapter 7.2.2.

The concept of the FE-mesh generator does not allow retroactive adjustments to the mesh. However, you can use FE mesh refinements to influence the mesh generation for specific areas. With this, a user-defined discretization is done, which may be required, for example, in nooks, for connections of members to surfaces, or for a dynamic analysis of members.

The Adaptive mesh refinement function (see Chapter 7.2.2.3) allows you to automatically create refinement areas in the FE mesh, in which case you do not have to manually define FE mesh refinements.

Figure 4.195 New FE-Mesh Refinement dialog box

Figure 4.196 Table 1.23 FE Mesh Refinements
**FE Mesh Refinement Applied To**

The settings in this dialog section or table column allow you to control, which objects are included by the FE mesh refinement and how the refinement is carried out. Different options are available for selection.

**Circular refinement around a node**

Define a radial refinement area around a node that is extended in all spatial directions.

![Circular refinement around a node](image)

**Rectangular refinement around a node**

Instead of a circular refinement area, you can specify a rectangular zone for refinement.

![Rectangular refinement around a node](image)

**Refinement on a line via FE length**

Define regular spacings of FE nodes on a line.

![Refinement on line via FE length](image)
Refinement on a line via division

The FE mesh of a line can be refined in regular intervals. This type of refinement is especially useful for lines with member properties.

Gradual refinement on a line

The finite elements adjoining the line can be divided by a defined number of n rows. In this way, you can, for example, cover boundary areas of surfaces with a refinement. This type of refinement is comparable to the FE mesh refinement generation along lines generation option (see Chapter 7.2.2) available for 2D plates.
Refinement on surface

Specify a lateral length of finite elements that is set as the target mesh size for the entire surface. Conversely, this type of refinement can also be used for surfaces with low significance for the analysis: As a "refinement", enter a mesh size that is larger than the global target FE length.

Refinement on a solid

FE mesh refinements can also be defined for solids to influence the generation of 3D elements.
**Nodes / Lines / Surfaces / Solids No.**

In the text box of the dialog box or the column of the table, enter the numbers of the objects that the refinement of the FE mesh should be applied to. In the New FE Mesh Refinement dialog box, you can use \( \text{select} \) to select the objects graphically.

**Parameters**

**Radius**

When you select a circular refinement around a node, you have to specify the radius of the refinement area. In addition, you have to define the Target FE Length in the center (Inner) and at the periphery (Outer) of the circle. If the FE length on the boundary of the refinement area corresponds to the global target length, RFEM gradually refines the mesh from the outside to the inside.

If there is a major difference between the inner and outer FE length, specify a broader radius. In this way, you can avoid generating acute-angled triangular elements within the refinement area.

**Side length**

When you select a rectangular refinement around a node, you have to define the area of refinement by its side length. In addition, you have to specify the Target FE length in the center (Inner).

**Number of division nodes**

When you select a line refinement by division, you have to define the number of division nodes. Then, the defined number of equally spaced FE nodes is generated on the line.

**Number of rows**

When you select a gradual line refinement, you have to define the number of rows \( n \). Then, RFEM divides the finite elements of the surface that directly adjoin the line into the corresponding number of rows. Thus, a refinement in direction of the line is generated.

**FE Length for Line / Surface / Solid**

If the refinement on a line, surface, or solid has been selected, the target FE length for the corresponding object must be entered.
4.24 Nodal Releases

General description

With a nodal release, the model can be decoupled at a location. It is thus possible to consider, for example, that a beam lies only loosely on another one. You need to define a release with appropriate conditions for the nodal release. You can also consider nonlinear effects.

For nodal releases, RFEM generates nodes which belong to different parts of the model. An invisible member is generated between these nodes. The internal forces are the same as for a member with the start in the original node and end in the decoupled node.

![New Nodal Release dialog box](Image)

![Table 1.24 Nodal Releases](Image)
**Node**

The number of the relevant node can be entered, selected from the list, or defined graphically in the work window using ![button](image).

**Member Hinge**

The hinge properties can be assigned by means of the member hinges, which are available in the list. Use the ![button](image) or ![button](image) button to open the New Member Hinge dialog box for entering another hinge type. This dialog box is described in Chapter 4.14 ![chapter](image).

**Local Axis System**

If you refer to a local axis system, you have to specify, which Member or Line is used as a reference. For hinges defined with regard to the global axis system, you cannot enter data in the text boxes.

**Released Objects**

The released Members, Surfaces, and Solids can be directly entered or graphically selected in the work window with ![button](image).

**Release Location**

As already mentioned, RFEM creates a copy of the node. You can define whether the member end release should be placed at the Original node or at the Released node. This definition should not affect the results.

**Example: Beam crossing with lifting forces**

A cantilever lies loosely on a downstand beam. For lifting loads, the node is released if a shear force release in direction $u_z$ with nonlinear action is defined.
4.25 Line Release Types

General description

By using a line release, it is possible to decouple the model along a line – for example, if surfaces are loosely connected or if only compression forces can be transferred.

First, you have to define a release with specific properties in a Line Release Type. Then you can assign them to members, surfaces, and solids that jointly use one line (see Chapter 4.26).
Axial/Shear Release or Spring $u_x / u_y / u_z$

A release oriented longitudinally or transversely to the line direction is defined by selecting the corresponding displacement in the dialog box or in the table. With the properties of a Spring, you can also model flexible releases.

The directions of displacements $x$, $y$, and $z$ refer to the line's axis system. Use the Display navigator or the shortcut menu of a line to display the line axes (see Figure 4.103). You can also assign nonlinear properties to the releases. Select the Nonlinearity from the list and define it with the button in the dialog box. The input of nonlinear release properties is described in Chapter 4.14.

Moment Release or Spring $\phi_x$

With a moment hinge about the longitudinal line axis $x$, you can release the rotation of the line (torsion) between objects.

You can find an example of the definition of a line release in the following article: https://www.dlubal.com/en-US/support-and-learning/support/knowledge-base/001110
4.26 Line Releases

General description

By creating line releases, it is possible to decouple a model at a location or to transfer only certain forces or moments along a line.

For a line release, you have to define a Line release type first (see Chapter 4.25).

![New Line Release dialog box](image1)

![Table 1.26 Line Releases](image2)
**Line**

You can enter the number of the relevant line manually, select it from the list, or use the button to select it graphically in the work window.

**Line Release Type**

In this table column or text box, you have to assign a release type to the line that has been defined in Table 1.25 (see Chapter 4.25). Use the button for the selection. It is also possible to create a New Line Release Type in the list. The dialog box shown in Figure 4.203 appears.

**Local Axis System**

For the line release, you have to specify which local axis system is used as a reference. You can select different options in the list or in the dialog section. If the axis refers to a surface or a help node, you have to specify the corresponding objects.

**Rotation**

It is possible to rotate the line release by an angle $\beta$, if required.

**Released Objects**

The released Members, Surfaces, and Solids can be directly entered or graphically selected in the work window using the button.

You can find an example of the definition of released objects in the following technical article: https://www.dlubal.com/en-US/support-and-learning/support/knowledge-base/001137

**Release Location**

RFEM internally generates a copy of the line at the same location that allows the released displacements. You can specify whether the release should be positioned at the Original line or at the Released line. This definition should not affect the results.

**Released Line**

The number of the line that RFEM generates for the line release is displayed. In Table 1.2 Lines and in the navigator, this generated line is marked by the line type Copy; you cannot edit it.

The line release is shown as a transparent cuboid in the model.
4.27 Surface Release Types

General description

With a surface release, it is possible to decouple the model at a surface – for example, if surfaces are linked flexibly or transfer only compression forces. So it is possible to define nonlinear contact properties for surfaces, for example, without generating a contact solid between surfaces.

You have to define a release with specific properties in a Surface Release Type first. You can then assign them to members, surfaces, and solids that share a surface (see Chapter 4.28).

Release or Spring $u_x$, $u_y$, $u_z$

You can define a release within the surface plane ($u_x$, $u_y$) or perpendicular to the surface ($u_z$) by selecting the corresponding displacement in the dialog box or table. With the properties of a Spring, you can also model flexible releases.
The directions of the displacements $x$, $y$, and $z$ refer to the axis system of the surface. You can display the surface axes by using the surface shortcut menu or the Display navigator (see Figure 4.75).

You can also assign nonlinear properties to the releases. Select the Nonlinearity from the list and define it with the button in the dialog box. The input of nonlinear release properties is described in Chapter 4.14.

### Surface Releases

#### General description

Surface releases allow you to decouple the model at a surface or only transfer certain forces at surfaces. Unlike with contact solids, you do not need to model artificial distance between the surfaces.

For the surface release, you have to define a Surface Release Type first (see Chapter 4.27).

---

**Figure 4.214** New Surface Release dialog box

**Figure 4.215** Table 1.28 Surface Releases

---

**Surface**

You can enter the number of the relevant surface manually, select it from the list, or use to define it graphically in the work window.
Surface Release Type

In this table column or text box, you have to assign a release type that has been defined in Table 1.27 (see Chapter 4.27) to the surface. Use the button for the selection. You can also create a New Surface Release Type in the list. The dialog box shown in Figure 4.208 appears for this purpose.

Released Objects

The released Members, Surfaces, and Solids can be directly entered or graphically selected in the work window with .

Release Location

At the same location that allows the released displacements, RFEM internally generates a copy of the surface. You can specify whether the release should be positioned at the Original surface or at the Released surface. This definition should not affect the results.

Released Surface

The number of the surface generated by RFEM for the surface release is displayed. In Table 1.4 Surfaces and in the navigator, this generated surface is marked by the surface type Copy.

Example: Funnel model

For a funnel-shaped component, the cap should only act with compression forces. For this, you have to define a surface release type with the action Fixed if positive pz and then assign it to the conic boundary surfaces.

![Funnel-shaped cap component with nonlinear contact properties](image)
Connection of Two Members

General description

If two members with bigger cross-section depths are connected at a node, the eccentricities and, if applicable, the connection stiffnesses affect the determination of the internal forces (at connections in timber construction, for example). You can define the connection as a unit to jointly manage eccentricities and releases of the connection.

This option is primarily important for the import from the RF-JOINTS Timber add-on modules: The connection parameters are available as a result of the geometric conditions; you can export them to RFEM. However, you can also define connections manually.

Figure 4.217 New Connection of Two Members dialog box

Figure 4.218 Table 1.29 Connections of Two Members
Main Member

In accordance with RF-JOINTS Timber, this member has the highest priority: It controls the parameters of the other members and the cutting (e.g. purlin). You can use a button to select the member graphically in the work window.

Connected Member

The second member is classified as a Connected member. A graphical selection is possible here as well.

Eccentricity

You can define the connection eccentricity for the main member as well as for the connected member. Use the [ ] or [ ] button to open a dialog box where you can define the Offset with reference to the local or global axes.

Member Hinge

You can define the degrees of freedom for the main member and the connected member by using hinges that control the transfer of internal forces at the ends of the rigid member. You can select the hinge type from the list or use the [ ] or [ ] button to open the New Member Hinge dialog box, where you can define it (see Chapter 4.14).

Options

With the default setting Unlock, you can generate a nodal release for the main member (see Chapter 4.24).

Optionally, you can Deactivate the connection without deleting the parameters by selecting the option in the check box.
### 4.30 Joints

The functions of the New Connection dialog box and Table 1.30 Joints are described in the previous Chapter 4.29.

### 4.31 Nodal Constraints

#### General description

A nodal constraint correlates the displacements and rotations between two or more nodes. This makes it possible, for example, to display wall or ceiling slabs in member models without using surfaces.

![New Nodal Constraint dialog box](image1)

![Table 1.31 Nodal Constraints](image2)
Nodal Constraint Type

You have two options for the coupling: In the case of a Diaphragm Constraint, the displacements in the constraint plane as well as the rotations perpendicular to the plane are coupled. Thus, you can model stiffening slabs, for example.

With the constraint type Equal Condition Constraint, it is possible to individually specify the coupled displacements and rotations between the nodes.

For diaphragm constraints, the degrees of freedom are automatically set in the Constraint Condition dialog section or in the table columns E to J. For equal degrees of freedom, you can access all six check boxes to define the constraint conditions.

On Nodes

You can enter the numbers of coupled nodes manually, select them from the list, or use $\text{Select}$ to define them graphically in the work window.

If you want to model a slab with the coupling, you have to enter all corner nodes of the plane.

Coordinate System

You have to define the reference axis system for the coupling. You can select the global XYZ Coordinate System or the user-defined UVW coordinate systems from the list or the dialog section. You can also create a New Coordinate System by using the $\text{New}$ button. The dialog box shown in Figure 11.49 appears.

To adjust the user-defined coordinate systems, use the $\text{Edit}$ and $\text{Delete}$ buttons.

User-defined coordinate systems make it easier to enter inclined diaphragm constraints for roofs (see Figure 4.218).
Constraint Plane

This dialog section and the table column D can only be accessed for diaphragm constraints. You have to specify, in which plane a coupling of the displacements or rotations takes place. For the global coordinate system, you can select the planes XY, YZ, and XZ. For a user-defined coordinate system, you can select the planes UV, VW, and UW.

This setting controls, which constraint conditions are automatically activated in the dialog section below and in the table columns E to J.

Translational constraints $u_X / u_Y / u_Z$

The check mark at a component of the translational constraints indicates that the displacement is coupled in direction of the corresponding global (or user-defined) axis.

The fields are only accessible for the constraint type Equal Condition Constraint. In the case of diaphragm constraints, RFEM automatically defines the constraint conditions through the constraint plane.

Rotational constraints $\phi_X / \phi_Y / \phi_Z$

You can also define constraint conditions for rotations that control the transfer of moments. The three global (or user-defined) axes are available for selection.
5 Load Cases and Combinations

The loads that act on the model are managed in different load cases. It is possible to superimpose these load cases in load and result combinations - either manually or automatically (see Chapter 12.2.1).

Before you can define loads (see Chapter 6), you have to create a load case.

5.1 General description

The loads from a particular action are stored in a load case (LC). Load cases can be, for example, self-weight, snow, or live load.

The loads in the load case should be defined as characteristic actions, which means without factors. The partial safety factors can be considered later when the load cases are superimposed in load or result combinations.

For each load case, you can separately define, which calculation method (linear static, second order, or large deformation analysis), approach, and calculation parameters (load increment factor, stiffness reduction by partial safety factor of material) you want to use.

Creating a new load case

There are several ways to open the dialog box for creating a new load case:

- The Insert → Loads Cases and Combinations → Load Case menu option
- The [New Load Case] button in the toolbar
- Shortcut menu of the Load Cases navigator entry
The *Edit Load Cases and Combinations* dialog box appears. A new load case is preset in the *Load Cases* dialog tab.

![Edit Load Cases and Combinations dialog box, Load Cases tab](image)

It is also possible to enter a new load case in an empty row of Table 2.1 *Load Cases*.

![Table 2.1 Load Cases](image)

**Load Case No.**

The number of the new load case is preset but can be modified in the *LC No.* text box. If the entered number has already been assigned, RFEM displays a warning when you close the dialog box.

The creation of load cases should be well organized. Gaps in the numbering are allowed so that you can insert additional load cases later. The order of load cases can be changed retroactively with the [Renumber] dialog button (see Table 5.1 and Chapter 11.4.8).
Load Case Description

You can enter any name manually. You can also choose a name from the list to briefly describe the load case.

To Solve

The check box allows you to control if the load case is taken into account as an independent load case in the calculation. In this way, it is possible to exclude load cases from the calculation which do not occur in isolation (e.g. wind without considering self-weight) or whose results are not relevant for a preliminary design.

Action Category

The standards mention different action categories that control the superposition of load cases, as well as the partial safety factors and combination coefficients. Each load case must be assigned to a category.

The list in the dialog box or table provides several categories for selection. They depend on the standard set in the Model - General Data dialog box (see Chapter 12.2.1).

Self-Weight

If you want to take the construction’s self-weight into account as a load, select the Active check box. The load’s direction of action can be defined in one of the three text boxes by means of the self-weight factor. The default setting is 1.00 in the direction Z or -1.00 if the global axis Z points upwards.

If the automatic self-weight is applied in several load cases, you have to consider this for the combination of load cases.

Comment

Here you can enter a user-defined note or select an entry from the list to describe the load case in detail.

Calculation Parameters

The Calculation Parameters tab in the Loading dialog box provides different options for controlling the calculation. You can find a detailed description of these parameters in Chapter 7.3.1.
Editing the general data of a load case

There are several ways to change the general data of an existing load case:

- **Menu option** Edit → Load Cases and Combinations → Load Case - General Data (current load case)
- **Menu option** Edit → Load Cases and Combinations → Load Cases (selection from all load cases)
- **Shortcut menu** or double-click of a load case in the Data navigator

![Shortcut menu of a load case](image)

- **The [Edit load cases and combinations] button** in the toolbar of the loads tables (current load case).

![Edit load cases and combinations button in the toolbar of the loads tables](image)
Buttons

In the Edit Load Cases and Combinations dialog box, there are several buttons available below the load case list (see Figure 5.3). The buttons have the following functions:

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Create new load case" /></td>
<td>Creates a new load case.</td>
</tr>
<tr>
<td><img src="image" alt="Copy load case" /></td>
<td>Creates a new load case as a copy of the selected load case (see below).</td>
</tr>
<tr>
<td><img src="image" alt="Copy all load cases" /></td>
<td>If several load cases are selected, all contained loads are copied to a new load case (see below).</td>
</tr>
<tr>
<td><img src="image" alt="Number load case" /></td>
<td>Assigns a new number to the selected load case. Specify the number in a separate dialog box. You may not enter a number that has already been assigned.</td>
</tr>
<tr>
<td><img src="image" alt="Select all load cases" /></td>
<td>Selects all load cases.</td>
</tr>
<tr>
<td><img src="image" alt="Cancel selection" /></td>
<td>Cancels the selection in the list.</td>
</tr>
<tr>
<td><img src="image" alt="Invert selection" /></td>
<td>Inverts selection of load cases.</td>
</tr>
<tr>
<td><img src="image" alt="Delete load case" /></td>
<td>Deletes the selected load case.</td>
</tr>
</tbody>
</table>

Table 5.1 Buttons in the Load Cases tab

Copying and adding load cases

You can use existing load cases to create new ones.

To copy a load case, select the relevant load case in the Existing Load Cases list. By clicking the [Copy] button, you can create a copy of the load case with the next available number. You can subsequently adjust the description of the new load case and the loads.

When adding load cases, the loads of several load cases are copied into a new load case. First, select the relevant load cases in the Existing Load Cases list (multiple selection by holding down the [Ctrl] key). Then, use the [Add] button to copy the loads into a new load case.
5.2 Actions

General description

When using the latest standards, such as EN 1990 or ASCE 7-16, it is often time-consuming to consider all eligible load situations and to select the decisive situations for the designs. In the Model - General Data dialog box, you can automatically create the combinations (see Figure 12.23).

The load cases defined in Table 2.1 (see previous Chapter 5.1) represent the base data for the automatic superpositioning. RFEM distinguishes between two load case categories: standard load cases and load cases of the type Imperfection. Moreover, for combining load cases, it is important to know, which action category the standard load cases have been organized into.

Standards provide rules for the combination of independent actions in various design situations. Actions are independent of each other if they arise from different origins and if the correlation between them may be neglected with regard to the reliability of the structural system.

In accordance with this concept, Actions to which load cases are assigned must be defined for the automatic superposition in RFEM. The action type defined for the load cases (see Chapter 5.1) controls the assignment to action categories in accordance with the standard.
**Action No.**

The actions are already created when you define load cases. They are numbered consecutively. The sequence is not important but, if necessary, it can be modified by means of the [Renumber] button available in the dialog box.

In the table, you can add actions manually in order to, for example, assign load cases by user-defined specifications when huge models are designed.

**Action Description**

The description of the action is derived from the action type that has been selected for the load cases. The preset description can be changed, if necessary.

**Action Category**

The standards mention different action categories that control the partial safety factors and combination coefficients (see Chapter 5.1 [1]).

The list in the dialog box and table only provides the categories that were used for the definition of the individual load cases. Therefore, in order to create a new category, a new action type must be assigned in the general data of a load case.

**Acting**

Two or more load cases can be defined as acting Simultaneously, Alternatively, or Differently. The following example serves to illustrate the differences between these three options:

<table>
<thead>
<tr>
<th>LC1</th>
<th>Action A1</th>
<th>Action category &quot;Permanent&quot;</th>
</tr>
</thead>
<tbody>
<tr>
<td>LC2, LC3, LC4</td>
<td>Action A2</td>
<td>Action category &quot;3. A Imposed&quot;</td>
</tr>
</tbody>
</table>

Depending on the definition of the Action A2, different possible combinations arise.

**Simultaneously**

All load cases of the action can be combined as required. It is also possible to use them simultaneously in a combination. The following load combinations are generated in the example:

- CO1: $1.35LC1$
- CO2: $1.35LC1 + 1.50LC2$
- CO3: $1.35LC1 + 1.50LC2 + 1.50LC3$
- CO4: $1.35LC1 + 1.50LC2 + 1.50LC3 + 1.50LC4$
- CO5: $1.35LC1 + 1.50LC2 + 1.50LC4$
- CO6: $1.35LC1 + 1.50LC3$
- CO7: $1.35LC1 + 1.50LC3 + 1.50LC4$
- CO8: $1.35LC1 + 1.50LC4$
Alternatively

Only one of the load cases of the action can be effective (e.g. wind from different directions). The following load combinations are generated in the example:

- CO1: \(1.35LC1\)
- CO3: \(1.35LC1 + 1.50LC3\)
- CO2: \(1.35LC1 + 1.50LC2\)
- CO4: \(1.35LC1 + 1.50LC4\)

Differently

You can define detailed relations between the load cases of an action. If you select this option, an additional column appears in the Load Cases in Action dialog section. There you can assign load cases to a Group so that they are mutually exclusive (as is the case for the action Alternatively). You can select the number of the group from the list.

If you define LC2 and LC3 as a group in the example, the following load combinations are generated:

- CO1: \(1.35LC1\)
- CO2: \(1.35LC1 + 1.50LC2\)
- CO3: \(1.35LC1 + 1.50LC2 + 1.50LC4\)
- CO4: \(1.35LC1 + 1.50LC3\)
- CO5: \(1.35LC1 + 1.50LC3 + 1.50LC4\)
- CO6: \(1.35LC1 + 1.50LC4\)

Load Cases in Action

Load cases are assigned according to the specifications of the LC action type, so assignment is largely automatic.

To remove a load case from an action, select the load case in the Load Cases in Action column of the dialog box. Use the [ ] button or double-click the entry to transfer it to the Unassigned Load Cases dialog section. You can also set a load case inactive in the table: Select the empty entry in the list of the relevant table cell.

Manually removed load cases are transferred to the Unassigned Load Cases list while considering the action type. This also means that only load cases of the same action type can be included in an action category. For example, it is not possible to select load cases of the type "Imposed" for actions of the type "Snow" — neither in the dialog box nor in the list of the table (see figure on the left). Type-different load cases are therefore not visible in the Existing Load Cases list. Use the [Show Unused] button to display load cases of other categories. They are shown as locked and cannot be selected.

Load cases that are not assigned to any action are not taken into account when generating combinations.
Comment

Enter a user-defined note or select an entry from the list.

The buttons in the Actions tab of the Edit Load Cases and Combinations dialog box have the following functions:

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="create_new_action.png" alt="Image" /></td>
<td>Creates a new action.</td>
</tr>
<tr>
<td><img src="reorder_actions.png" alt="Image" /></td>
<td>Renumerates the selected actions.</td>
</tr>
<tr>
<td><img src="select_all_actions.png" alt="Image" /></td>
<td>Selects all actions.</td>
</tr>
<tr>
<td><img src="cancel_selection.png" alt="Image" /></td>
<td>Cancels the selection in the list.</td>
</tr>
<tr>
<td><img src="assign_load_cases.png" alt="Image" /></td>
<td>Automatically assigns unassigned load cases to actions.</td>
</tr>
<tr>
<td><img src="delete_selected_actions.png" alt="Image" /></td>
<td>Deletes the selected actions.</td>
</tr>
</tbody>
</table>

Table 5.2 Buttons in the Actions tab
5.3 Combination Expressions

General description

The standards describe how to combine actions. For example, EN 1990 requires the design of the ultimate and the serviceability limit states. Ultimate limit states for load bearing capacity have to be designed in four design situations, which are subject to certain combination rules:

- Permanent situations that comply with the common conditions of use of a structural system, as well as temporary situations that refer to time-limited stages of the structure (e.g. construction stage, repairs)

As a combination rule for permanent and temporary situations (basic combination), you have to apply either

$$\sum_{j=1}^{2} a_j G_{kj} + p P_k + q_{1,1} Q_{k,1} + \sum_{i=1}^{2} q_{i,1} Q_{k,i}$$

Equation 5.1

or the more unfavorable combination with Equation 5.2 and Equation 5.3 for the limit states STR and GEO.

$$\sum_{j=1}^{2} a_j G_{kj} + p P_k + q_{1,1} Q_{k,1} + \sum_{i=1}^{2} q_{i,1} Q_{k,i}$$

Equation 5.2

$$\sum_{j=1}^{2} a_j G_{kj} + p P_k + q_{1,1} Q_{k,1} + \sum_{i=1}^{2} q_{i,1} Q_{k,i}$$

Equation 5.3

- Extraordinary situations referring to extraordinary actions of the structural system or its environment (e.g. fire, explosion, collision)

$$\sum_{j=1}^{2} H_{kj} + P + A_{ed} + (1,1 \text{ or } 2,2) Q_{k,1} + \sum_{i=1}^{2} z_i Q_{k,i}$$

Equation 5.4

- Situations in case of earthquakes

$$\sum_{j=1}^{2} G_{kj} + P_k + A_{ed} + \sum_{i=1}^{2} z_i Q_{k,i}$$

Equation 5.5

According to EN 1990, you have to design serviceability limit states in three design situations which are subject to the following combination rules.

- Rare situations with irreversible (lasting) effects on the structural system

$$\sum_{j=1}^{2} G_{kj} + P_k + Q_{k,1} + \sum_{i=1}^{2} Q_{k,i}$$

Equation 5.6
- Frequent situations with reversible (non-lasting) effects on the structural system

\[
\sum_{j=1} G_{kj} + P_{k} + \sum_{i=1}^{1} O_{k,i} + \sum_{j=1} Q_{k,i}
\]

Equation 5.7

- Quasi-permanent situations with long-term effects on the structural system

\[
\sum_{j=1} G_{kj} + P_{k} + \sum_{j=1} Q_{k,i}
\]

Equation 5.8
Combination Expression No.

When you access the dialog box or table, the combination rules of the following design situations are preset for EN 1990:

- **ULS**: Ultimate limit state for permanent or temporary situation
- **SLS**: Serviceability limit state for characteristic situation
- **SLS**: Serviceability limit state for frequent situation
- **SLS**: Serviceability limit state for quasi-permanent situation

You can create a new combination rule in another table row or in the dialog box by using the [New] button. The design situations described below are available for selection.

Combination rules marked in the dialog list can be deleted with the [Delete] button.

Combination Expression Description

The short descriptions of combination rules can be changed retroactively. The list provides some suggestions for selection.

Use

The check box allows you to control if the selected combination rule is considered when creating result combinations. In this way, it is possible to reactivate design situations or exclude them from the generation.

Design Situation

The standards describe the situations for which designs of structural systems must be fulfilled. These design situations determine the conditions expected during the construction and use of the building.

The following design situations for EN 1990 are available for selection in the list:

```
Design Situation    EN 1990 / DIN
ULS (STR/GEO) - Permanent / trans (Glu. 6.10)
ULS (STR/GEO) - permanent / trans
ULS (STR/GEO) - Accidental - pi 1.1
ULS (STR/GEO) - Accidental - pi 2.1
ULS (STR/GEO) - Seismic

EN 1990 + DIN EN 1995
ULS (STR/GEO) - Permanent / trans (Bl. 6.10a and 6.10b)
ULS (STR/GEO) - Accidental - pi 1.1
ULS (STR/GEO) - Accidental - pi 2.1
ULS (STR/GEO) - Seismic
ULS - Characteristic
ULS - frequent
ULS - Quasi-permanent
```

For the standards DIN 1055-100, DIN EN 1990, and EN 1990 + DIN EN 1995, RFEM additionally provides the design situations **Accidental - Snow** where the factors for the North German Plain are taken into account.
Use the [Info] button to check the combination rule of the current design situation. A dialog box opens explaining the equation with the relevant parameters.

![Info About Design Situation dialog box](image)

**Favorable permanent actions**

With this option, RFEM distinguishes between favorably and unfavorably acting permanent actions during the generation. They are considered in the superpositioning along with different partial safety factors; additional combinations are generated.

The settings of this check box only affect design situations for load bearing capacity. The distinction between favorably and unfavorably acting permanent actions is done automatically for the design situation "Static equilibrium", whereas permanent actions are not differentiated for the design situation "Serviceability".

**Imperfection load cases**

RFEM distinguishes between two load case categories: standard load cases and load cases of the type Imperfection. Due to this special treatment of imperfections, it is possible to form any possible load combination once with an imperfection and once without.

Imperfection load cases are only taken into account when generating load combinations.

With the Differently for each combination expression check box, it is possible to separately assign imperfections for the combination expressions: According to EN 1992-1-1, for example, imperfections have to be considered for the ultimate limit state designs. Serviceability limit state designs can be performed without imperfections.
When the check box is selected, the [Settings] button or the □ button is enabled. Use the buttons to access the Settings dialog box with specific settings for imperfection load cases.

![Settings dialog box with Select Load Cases dialog box for selecting load cases](image)

Figure 5.14 Settings dialog box with Select Load Cases dialog box for selecting load cases

The **Use Load Cases of Type 'Imperfection'** dialog section lists all load cases that were classified as the action type "Imperfection" [see Chapter 5.1](#). Use the check boxes in the Use column to specifically control, which of the load cases is included in the generation of load combinations.

The **Use Load Cases of Type 'Imperfection'** dialog section lists all load cases that were classified as the action type "Imperfection" [see Chapter 5.1](#). Use the check boxes in the Use column to specifically control, which of the load cases is included in the generation of load combinations.

The **Options** dialog section controls how imperfection load cases are taken into account. If **All imperfection load cases act as alternative**, RFEM applies only one imperfection load case for each load combination.

You can reduce the number of generated load combinations by selecting the **Remove co-existence of the same load combination with and without imperfection** check box: The constellations without an imperfection load case are suppressed for similar combinations. It is also possible to **Remove all load combinations without imperfection**.

If several imperfection load cases are available, you can select the **Prefer common assignment of imperfections** check box to prevent separate assignment to load combinations.

With the **Subject to specific load cases** option, you can further reduce the number of generated load combinations. If the option is selected, the two columns **Only with Load Cases** and **Never with Load Cases** are additionally shown in the dialog section above. Click into a cell to enable the □ button, which opens the Select Load Cases dialog box where you can define a relation between the imperfection load case and one or more related or mutually exclusive load cases [see Figure 5.14](#).
Individually/Simultaneously Acting Load Cases

To further reduce the number of created load combinations, it is possible to classify load cases as mutually exclusive or occurring only together. By selecting the Differently for each combination expression check box, you can separately define the constellations of the load cases for combination expressions.

If you select the check box, the and buttons become available, which open a dialog box with more detailed settings for assigning load cases.

First, enter a load case into the Select Load Cases column in the Individually Acting Load Cases dialog section or define it with the button in the Select Load Cases dialog box. Then, in the Not to combine with load cases column, define the load case(s) that you never want taken into account together with the load case in the load combination. In this way, it is possible, for example, to avoid the combination of snow with human load cases.

In the Simultaneously Acting Load Cases dialog section, you can analogously specify settings for load cases that you want to always have appear together in each load combination. However, these relations are only effective if the Reduce number of generated combinations due to Examine results option (see below) is not activated.

Specifications in the Simultaneously Acting Load Cases dialog section are only taken into account for the generation of load combinations, not for result combinations.
Reduce number of generated combinations

The complexity of the structural system as well as the number of actions and load cases have a significant influence on the number of generated combinations. RFEM provides three ways to reduce the number of constellations effectively. The first two procedures are only available for the generation of load combinations, not for result combinations. They are described in an example.

Reducing number of load cases

With this option, you can generally limit the number of load cases that occur in the load combinations. Access to the check box is available in the General tab of the Combination Expressions (see Figure 5.10). RFEM examines, which load cases provide positive or negative internal forces and deformations. Then, all positively acting and all negatively acting load cases are combined. Thus, combinations take only the load cases into account that are relevant for the maximum or minimum values.

The advantage of this method is that it is possible to considerably reduce the number of combinations, which has a positive impact on the speed of the calculation and evaluation. A disadvantage may be the fact that if there are unfavorable load arrangements and specifications for the reduction, there is a certain factor of uncertainty for finding the extreme values.

When you select the check box, the additional Reduce - Number of Load Cases tab appears. In this tab, you can specify in detail, which load cases, internal forces, and objects you want considered for the creation of governing combinations.

The load cases can be selected Manually or determined Automatically on the basis of relevance criteria. Clicking the [Determine automatically] button starts a calculation for determining the maximum and minimum internal forces, deformations, and support reactions in the load cases.

When the automatic determination is selected, specify the Results (deformations, internal forces of members and surfaces, support reactions) and Objects (nodes, surfaces, members, etc.) that you want considered for the evaluation of the load cases. The relevant objects can be selected graphically using once the All check box is disabled. You can use the Assign separately for each object check box to assign specific result types to objects for the analysis.
The number of load cases contained in a Group after calculation depends on the settings defined in the Choice of Load Cases dialog section:

- When the **Maximum number of the most relevant load cases** option is selected, a group provides either the specified maximum number of load cases or only positively or negatively acting load cases in a smaller number.

- It is possible to **Neglect load cases**, which only contribute slightly to the maximum and minimum values. The percentage refers to the internal forces, deformations, and support forces of the load cases that respectively provide the extreme values.

Imperfection load cases are not considered when the automatic creation of groups is set.

**Examining results**

RFEM only creates the governing load combinations (this option is not available for result combinations).

When selecting the check box, the new **Reduce - Examine Results** tab is added to the dialog box.

![Figure 5.17 Reduce - Examine Results tab for combination rules](image)

With the first **Reduction Method**, you can automatically evaluate generated temporary result combinations. Temporary result combinations include all load cases created in the model and consider all existing relations between them. By means of the results available on each FE node, RFEM analyzes, which simultaneously acting load cases produce a maximum or minimum at the corresponding locations. The reduction method is based on the assumption that only the combinations that contain exactly these simultaneously acting load cases can be governing.

Alternatively, it is possible to use the results of a user-defined result combination for the results reduction.

In the **Examining Results** dialog section to the right, you can define the deformations, internal forces, stresses, or support reactions that you want taken into account for the determination of extreme values.

The **Examining Results of Objects** section provides options to restrict the extreme value analysis to results of selected members, surfaces, and solids. You can use ▼ to select the objects graphically.
Selecting leading variable actions

The third way to reduce the number of generated combinations is to only classify selected actions as leading actions. This option is available for the generation of both load and result combinations.

When selecting the check box, the new Reduce - Leading Variable Actions tab is added to the dialog box.

The list of leading actions contains only variable actions.

When you remove the check mark of an entry in the Leading Actions column, the corresponding action is only superimposed as an accompanying variable action.

Numbering of Generated Combinations

Entering data in this section of the Edit Load Cases and Combinations dialog box (see Figure 5.10) affects the First number of generated Load combinations or Result combinations that are created in RFEM.

Result Combinations

Optionally, you can Generate additionally an 'Either/Or' result combination (results envelopes). This result combination superimposes the extreme values of all load or result combinations according to the following scheme:

"CO1/permanent or CO2/permanent or CO3/permanent, etc."

If several combination expressions are specified for the generation, it is possible to Generate additionally a separate 'Either/Or' result combination for each combination expression.

Method of analysis

Use the list to decide, which method of calculation you want to apply for analyzing combinations (see Chapter 7.3.1.1). RFEM presets the nonlinear calculation according to the second order analysis (P-Delta) for load combinations.

Generated Action Combinations

This dialog section or table column is filled during the generation, which starts automatically when closing the dialog tab or table. The dialog field shows a short overview of the number of generated combinations.

With the data entered in the dialog box or table, RFEM creates "Action Combinations" (AC). They are described in the following chapter. You can use the entries shown in the current dialog box to estimate how combination rules affect the number of combinations.

In the example shown on the left, a total of 47 action combinations are generated for the four specified design situations.
Load Cases and Combinations

- **ULS (STR/GEO):**
  AC1 to AC13

- **SLS - characteristic:**
  AC14 to AC26

- **SLS - frequent:**
  AC27 to AC39

- **SLS - quasi-permanent:**
  AC40 to AC47

When jumping to the next tab with the dialog button, RFEM automatically determines the action combinations. The first action combination created with the current combination expression is selected in that dialog tab.

**Comment**

Enter a user-defined note or select an entry from the list.

**Example: Reduce number of generated combinations**

The aim of combining actions is to find the most unfavorable load arrangement for each location in the structural system. To that end, you can

- either determine all combinations that are mathematically possible
- or try to find logical relationships before combining the actions to reduce the number of possible combinations.

For example, a symmetrical two-hinged frame has the following load cases:

![Figure 5.19 Two-hinged frame with four load cases](image-url)
Reducing number of load cases option

The load cases result in the following axial forces available in the columns:

<table>
<thead>
<tr>
<th>Load Case</th>
<th>Description</th>
<th>Acting</th>
<th>Axial Force Left Column</th>
<th>Axial Force Right Column</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Self-weight</td>
<td>Permanent</td>
<td>Compression</td>
<td>Compression</td>
</tr>
<tr>
<td>2</td>
<td>Wind to the right</td>
<td>Alternative</td>
<td>Tension</td>
<td>Compression</td>
</tr>
<tr>
<td>3</td>
<td>Wind lifting</td>
<td>Alternative</td>
<td>Tension</td>
<td>Tension</td>
</tr>
<tr>
<td>4</td>
<td>Snow</td>
<td>Alternative</td>
<td>Compression</td>
<td>Compression</td>
</tr>
</tbody>
</table>

Table 5.3  Tensile and compressive forces of columns

The following eight combinations are theoretically possible:

CO1:  \( LC1 + LC2 + LC3 + LC4 \)
CO2:  \( LC1 \)
CO3:  \( LC1 + LC2 \)
CO4:  \( LC1 + LC3 \)
CO5:  \( LC1 + LC4 \)
CO6:  \( LC1 + LC2 + LC3 \)
CO7:  \( LC1 + LC3 + LC4 \)
CO8:  \( LC1 + LC2 + LC4 \)

These eight combinations can be reduced if we only want to find the arrangements with the extreme values of the columns' axial forces, for example. It is possible to create a group of load cases that provides only tensile and compressive forces for each column in consideration of the permanently acting LC1.

<table>
<thead>
<tr>
<th>Group</th>
<th>Left Column</th>
<th>Right Column</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tension forces</td>
<td>( LC1, LC2, LC3 )</td>
<td>( LC1, LC3 )</td>
</tr>
<tr>
<td>Compression forces</td>
<td>( LC1, LC4 )</td>
<td>( LC1, LC2, LC4 )</td>
</tr>
</tbody>
</table>

Table 5.4  Groups of load cases

Thus, the result is no longer eight but just four combinations of load cases.
This reduction can be done in the Edit Load Cases and Combinations dialog box (see Figure 5.10) by

- selecting the Reduce number of load cases check box,
- selecting only the axial forces in the Examining Results dialog section of the Reduce - Number of Load Cases tab,
- and entering only the numbers of the column members in the Examining Results of Objects dialog section (see Figure 5.20).

After clicking the [Determine automatically] button, RFEM performs a short calculation. Then the table in the Considered Load Cases dialog section lists the four groups of load cases that are also shown in Table 5.4.

**Examining results option**

With this method, a linear result combination is created from the load cases. For each point, RFEM evaluates the extreme values and the involved load cases so that a max- and a min-combination of load cases is available in each case. These extreme combinations are then used for creating the load case combinations.
The load cases result in the following axial forces $N$ in the columns:

<table>
<thead>
<tr>
<th>LC</th>
<th>Description</th>
<th>Acting</th>
<th>N Left Column</th>
<th>N Right Column</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Self-weight</td>
<td>Permanent</td>
<td>Compression ($−10$ kN)</td>
<td>Compression ($−10$ kN)</td>
</tr>
<tr>
<td>2</td>
<td>Wind to the right</td>
<td>Alternative</td>
<td>Tension ($5$ kN)</td>
<td>Compression ($−5$ kN)</td>
</tr>
<tr>
<td>3</td>
<td>Wind lifting</td>
<td>Alternative</td>
<td>Tension ($3$ kN)</td>
<td>Tension ($3$ kN)</td>
</tr>
<tr>
<td>4</td>
<td>Snow</td>
<td>Alternative</td>
<td>Compression ($−12$ kN)</td>
<td>Compression ($−12$ kN)</td>
</tr>
</tbody>
</table>

Table 5.5 Tensile and compressive forces of columns

RFEM creates the following temporary result combination: LC1/permanent + LC2 + LC3 + LC4

For the axial forces of the columns, the following extreme values result when superimposing:

<table>
<thead>
<tr>
<th>Group</th>
<th>Left Column</th>
<th>Right Column</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximum $N$</td>
<td>$−2$ kN (LC1, LC2, LC3)</td>
<td>$−7$ kN (LC1, LC3)</td>
</tr>
<tr>
<td>Minimum $N$</td>
<td>$−22$ kN (LC1, LC4)</td>
<td>$−27$ kN (LC1, LC2, LC4)</td>
</tr>
</tbody>
</table>

Table 5.6 Groups of load cases

Again, the result is no longer eight, but just four combinations of load cases.

Setting specifications in the Reduce - Examine Results tab is similar to Figure 5.20.
5.4 Action Combinations

General description

When you open this dialog tab or Table 2.4, actions are automatically superimposed according to the combination rules and identified as so-called "action combinations". This overview is sorted by actions. It corresponds to the way actions are described in the standards. Now you can define the action combinations that will eventually be worth considering for the generation of load or result combinations.

An action combination includes all ways how load cases can be combined in the action. It should therefore not be confused with a load or result combination that represents only a single variant of these possibilities.
Action Combination No.

The combinations generated from actions are numbered consecutively. An action combination includes all the possibilities how the load cases contained in the action can be considered. These possibilities depend on the action category and the combination expressions.

In the bottom left corner of the Existing Action Combinations section in the Edit Load Cases and Combinations dialog box, it is possible to filter generated combinations by design situation or relevance.

Action Combination Description

RFEM automatically assigns short descriptions that are based on the safety factors and symbols of the actions, and that express combination rules. You can change these descriptions, if necessary.

Click the dialog button to jump to the previous dialog tab where the combination expression is selected that the current action combination was created with.

Use

The check box allows you to control if the selected action combination is considered for creating load or result combinations. In this way, it is possible to exclude action combinations from the generation or reactivate them.

If RFEM creates an action combination twice because of special constellations, one of them is automatically deactivated.

Design Situation

The design situation of the current action combination is indicated once more so that you can check data. Use the [Info] button to look at the combination rule of the design situation. A dialog box with explanations opens (see Figure 5.13).

Actions in Action Combination

The columns provide information about actions with the corresponding partial safety factors and combination coefficients.

If an action is assumed to be Leading in the combination, it is marked accordingly in the dialog box. In this case, it is inserted as the action $Q_{k,1}$ in Equation 5.1 to Equation 5.7 (see Chapter 5.3 Combination Expressions).

The values shown in the Factor table column are based on coefficients that depend on the selected standard. For EN 1990, they are the partial safety factors $\gamma$, the combination factors $\psi$, the reduction factors $\xi$, and, if applicable, the reliability factors $K_{r_i}$ of each action, which result from the design situation and action category.
Use the [Settings] button to check and, in case of a user-defined standard, adjust the partial safety factors and combination coefficients. The factors are organized in several tabs of the Coefficients dialog box. The first tab, Partial Safety Coefficients, is shown in Figure 12.27. The Combination Coefficients tab manages the factors $\psi$ and $\xi$.

The Actions in Action Combination dialog section lists the Load Cases contained in the actions, with all possibilities how they can be taken into account in the action. These possibilities depend on the action type and the defined action (simultaneous or alternative). It is assumed that all assigned load cases are always used together for the action types "Permanent loads" and "Prestress", unless the relation is defined as "Alternative". In case of variable, extraordinary, and seismic actions, assigned load cases can be superimposed in all relevant combinations.

**Generated load/result combinations**

This dialog section or table column is filled during the generation that starts automatically when closing the dialog tab or table. The entries provide a short overview of the numbers and quantity of generated load or result combinations.

Load and result combinations are described in the following Chapters 5.5 and 5.6.
Example

In the example shown on the left, a total of 47 load combinations are generated for the design situation ULS. For the action combination **AC12** (penultimate row), the four load combinations CO40 to CO43 occur with the following background:

The first action A1 has been categorized as the "Permanent loads" action category and is provided with the factor $\gamma = 1.35$ in the generated load combinations. The contained load cases 1 and 2 occur together in all load combinations.

As the second action A2, we have the "Snow" action category, included in the load combinations with the factor $\gamma \cdot \psi = 1.50 \cdot 0.50 = 0.75$.

The third action A3 doubles the number of generated load combinations, because the "Wind" category is available with the two alternatively acting load cases 4 and 5. This action is multiplied with the factor $\gamma \cdot \psi = 1.50 \cdot 0.60 = 0.90$ in the load combinations.

The fourth action A4 is classified as the "Imposed load category B" action type and provided with the factor $\gamma = 1.50$ in all four load combinations. This action is a leading action.

In addition, we have to take the two imperfection load cases 7 and 8 into account, which are coupled with the directions of both wind load cases. We want to create load combinations, once with imperfections and once without.

With these specifications, RFEM forms the following load combinations for AC12:

- CO40: $1.35LC1 + 1.35LC2 + 0.75LC3 + 0.9LC4 + 1.5LC6$
- CO41: $1.35LC1 + 1.35LC2 + 0.75LC3 + 0.9LC4 + 1.5LC6 + LC7$
- CO42: $1.35LC1 + 1.35LC2 + 0.75LC3 + 0.9LC5 + 1.5LC6$
- CO43: $1.35LC1 + 1.35LC2 + 0.75LC3 + 0.9LC5 + 1.5LC6 + LC8$

Click the dialog button to jump to the Load Combinations dialog tab where the first combination created from the current action combination is selected.

Comment

Enter a user-defined note or select an entry from the list.
5.5 Load Combinations

General description

Load cases can be superimposed in a load combination (CO) and in a result combination (RC).

Whilst taking partial safety factors into account, a load combination combines the loads of the contained load cases into “one big load case”, which is subsequently calculated. In a result combination (see Chapter 5.6), the included load cases are calculated first. Then these results are superimposed in consideration of the partial safety factors.

Load cases can be combined manually (see Chapter 5.5.1) or superimposed automatically by RFEM (see Chapter 5.5.2), depending on settings in the Model - General Data dialog box (see Figure 12.23). These Settings also affect the appearance of the Result Combinations dialog tab in the Edit Load Cases and Combinations dialog box.

If you want to calculate combined load cases according to the second-order or large deformation analysis, you generally have to create load combinations. The same applies to models with nonlinear elements. The following example is used to demonstrate the subject.

Two load cases act on a slab with elastic foundations: In load case 1, the surface load acts on the entire plate; in load case 2, it stresses only part of the surface. The self-weight is not taken into account. The elastic foundation of the slab is ineffective in case of tension. Hence, no lifting forces are absorbed.

The foundation in load case 1 is effective for the entire surface.

The foundation in load case 2 is only effective for the right part of the surface. The left part of the slab is lifting.
When combining both load cases in a **result combination**, a warning appears because adding up results would be unacceptable due to nonlinear effects: Deformations in both load cases are based on different structural systems. For a result combination, you would see the lifting in the left zone shown in the second case.

It is therefore correct to superimpose the two load cases in a **load combination**. The figure below shows that the elastic foundation is effective for the added loads without failure.
5.5.1 User-Defined Combinations

Creating new load combinations

There are several ways to open the Edit Load Cases and Combinations dialog box to create a load combination:

- **Menu option** Insert → Load Cases and Combinations → Load Combination
- **[New Load Combination] button in toolbar**

![Figure 5.29 New Load Combination button in toolbar](image)

- **Shortcut menu of Load Combinations navigator entry**

![Figure 5.30 Shortcut menu for Load Combinations in Data navigator](image)

The Edit Load Cases and Combinations dialog box appears. A new load combination is preset in the Load Combinations dialog tab.
The following description relates to the General tab. The Calculation Parameters dialog tab is described in Chapter 7.3.1.

It is also possible to enter a new load combination in an empty row of Table 2.5 Load Combinations.

**Load Combination No.**

The number of the new load combination is preset but can be modified in the CO No. text box. The order of the load combinations can be adjusted retroactively with the [Renumber] dialog button (see Table 5.7 and Chapter 11.4.18).

**Load Combination Description**

You can enter any name manually or select it from the list to briefly describe the load combination. Since manually entered descriptions are stored in the list, they are also available for other models.
To Solve

You can use the check box to control if the load combination is considered in the calculation. In this way, it is possible to enable load combinations or exclude them from the calculation.

Load Cases in Load Combination

The columns provide information about the load cases with the corresponding factors. The values indicated in the Factor table column are based on coefficients that depend on the selected standard. For EN 1990, they are the partial safety factors $γ$, the combination factors $ψ$, the reduction factors $ξ$, and, if applicable, the reliability factors $K_{FI}$ of each action, which result from the design situation and action category.

To check or adjust the partial safety factors and combination coefficients, use the [Details] button. The Coefficients dialog box opens where the various factors are organized in several tabs. The first tab, Partial Safety Coefficients for EN 1990, is shown in Figure 12.27. The Combination Coefficients tab manages the factors $ψ$ and $ξ$ (see Figure 5.24). The reliability factor $K_{FI}$ can be selected in a list of the Consequence Classes dialog tab, or you can enter a user-defined value.

Combining load cases

In the Edit Load Cases and Combinations dialog box, you can assimilate load cases in combinations as follows: Select the relevant load cases in the Existing Load Cases list by clicking them. You can use a multiple selection by pressing the [Ctrl] key (as familiar from MS Windows). Use the button to transfer selected load cases to the right into the Load Cases in Load Combination list; at the same time, partial safety factors and combination coefficients are added automatically.

The factors are created in accordance with the standard set in the Model - General Data dialog box (see Chapter 12.2.1).

The preset factors can be checked and, if necessary, customized in the Coefficients dialog box that you open with the [Details] button (see Figure 5.24 and Figure 12.27).

To modify the coefficient of a load case that has been transferred into a load combination, select the load case in the Load Cases in Load Combination list. Now you can enter the appropriate factor into the text field below or select it from the list. Click the [Set Factor] button to apply the new factor to the load case.
To remove a load case from a load combination, select the load case in the Load Cases in Load Combination column of the dialog box. Use the \( \text{[C] button or double-click the entry to return it to the Existing Load Cases column.}

Several filter options are available at the bottom of the Existing Load Cases list. These options make it easier to assign the load cases sorted by action categories or to select them from load cases that are still unassigned. The buttons are described in Table 5.7.

To manually define load combinations, use the \([\text{Edit}]\) button in the bottom right corner of the Loading dialog box.

![Load Combination dialog box for definition via editing field](Figure 5.34)

In the Load Cases in Load Combination text box, load cases can be added (or subtracted, if necessary) by any factor. Nesting of input is not permitted.

Example: \( \text{LC1 + 0.5*LC3} \)

To the simple loading of load case 1, half the load of load case 3 is added.

Use the \([\text{Set Input}]\) button to transfer the entry to the Load Cases in Load Combination list of the initial dialog box.

**Comment**

Enter a user-defined note or select an entry from the list to describe the load combination in detail.

**Calculation Parameters**

The Calculation Parameters tab in the Loading dialog box provides different options for controlling the calculation. You can find a detailed description of these parameters in Chapter 7.3.1.
Editing load combinations

There are several ways to change load combinations retroactively:

- **Menu option** Edit → Load Cases and Combinations → Load Combinations
- **Shortcut menu** or double-click of a load combination in the Data navigator

![Shortcut menu of a load combination](image)

In the Edit Load Cases and Combinations dialog box (see Figure 5.31), select the CO by clicking it. Then you can edit the definition criteria.

**Buttons**

In the Edit Load Cases and Combinations dialog box, there are different buttons below the Existing Load Combinations and Existing Load Cases lists. They have the following functions:

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Create new load combination" /></td>
<td>Creates a new load combination.</td>
</tr>
<tr>
<td><img src="image" alt="Create new load combination as copy" /></td>
<td>Creates a new load combination as a copy of the selected combination.</td>
</tr>
<tr>
<td><img src="image" alt="Assign new number" /></td>
<td>Assigns a new number to the selected load combination, which must be specified in a separate dialog box. This CO number must be unassigned.</td>
</tr>
<tr>
<td><img src="image" alt="Delete selected load combination" /></td>
<td>Deletes the selected load combination.</td>
</tr>
<tr>
<td><img src="image" alt="Select all load cases" /></td>
<td>The list only shows the load cases that are not yet contained in the load combination.</td>
</tr>
<tr>
<td><img src="image" alt="Select load cases" /></td>
<td>Selects all load cases in the list.</td>
</tr>
<tr>
<td><img src="image" alt="Invert selection" /></td>
<td>Inverts selection of load cases.</td>
</tr>
</tbody>
</table>

*Table 5.7* Buttons in the Load Combinations tab
5.5.2 Generated Combinations

When switching to the Load Combinations dialog tab or to Table 5.5, RFEM automatically creates the combinations. As the load cases are not superimposed manually, the General tab looks different (see Figure 5.31, for user-defined combinations).

Load Combination No.

Load combinations generated from action combinations are consecutively numbered.

You can filter the generated combinations according to specific criteria using the selection field in the bottom of the Existing Load Combinations dialog section.

Load Combination Description

RFEM assigns short descriptions that express combination rules and are based on the safety factors and load case numbers. You can change these descriptions, if necessary.

Click the dialog button to jump back into the Action Combinations dialog tab (see Chapter 5.4) where the action combination that the current load combination was created with is selected.

To Solve

This check box controls the result determination for the load combination(s) selected in the Existing Load Combinations dialog section.
Load Cases in Load Combination

The columns show the load cases including the corresponding partial safety factors and combination coefficients. It is not possible to modify the factors of generated combinations.

A load case acting as Leading in the combination is marked accordingly in the dialog box.

To check the partial safety factors and combination coefficients, use the [Details] button. The Coefficients dialog box is divided into several tabs (see Figure 12.27 and Figure 5.24).

Adding load combinations

The generated load combinations cannot be edited, only deleted or excluded from the calculation with the To Solve check box.

You can add a user-defined combination with the [New] button in the bottom left corner of the Existing Load Combinations dialog section (see Figure 5.37). For the manual definition, the General dialog tab’s look is adjusted.

Figure 5.37 Adding a user-defined load combination

Chapter 5.5.1 describes how load combinations can be created manually.
5.6 Result Combinations

General description

Load cases can be superimposed in a load combination (CO) and in a result combination (RC).

In a result combination, included load cases are calculated first. Then the results are superimposed while considering the partial safety factors. A load combination (see Chapter 5.5) combines the loads of the contained load cases into “one big load case” while taking the partial safety factors into account, and then calculates it.

Load cases can be combined manually (see Chapter 5.6.1) or superimposed automatically by RFEM (see Chapter 5.7), depending on settings in the Model - General Data dialog box (see Figure 12.23). These Settings also affect the appearance of the Result Combinations dialog tab in the Edit Load Cases and Combinations dialog box.

Result combinations are not suitable for nonlinear calculations because they lead to falsified results: In most cases, failure of nonlinear elements (e.g. tension members, foundations) happens differently in the individual load cases. Redistribution effects occur, so the internal forces from different models would be combined (see example in Chapter 5.5).

In a result combination, you can superimpose the results of load cases, load combinations, and results of other result combinations.

The internal forces are usually summed up. In principle, subtractions are also possible. Please note, however, that in this case, signs of the internal forces are reversed: Tensile forces become compressive forces, etc. As an alternative, it is therefore recommended to copy the load case (see Chapter 5.1) and to set the load factor to -1.00 for the load case copy in the Calculation Parameters dialog tab. Then the load case can be added in a result combination.

5.6.1 User-Defined Combinations

Creating new result combinations

There are several ways to open the loading dialog box for creating a result combination:

- Menu option Insert → Load Cases and Combinations → Result Combination
- [New Result Combination] button in the toolbar
Shortcut menu of the Result Combinations navigator entry

Figure 5.39  Shortcut menu of Result Combinations in the Data navigator

The Edit Load Cases and Combinations dialog box appears. A new result combination is preset in the Result Combinations dialog tab.

Figure 5.40  Edit Load Cases and Combinations dialog box, Result Combinations tab

The following description refers to the General tab. The Calculation Parameters dialog tab is described in Chapter 7.3.2.

www.dlubal.com
It is also possible to enter a new result combination in an empty row of Table 2.6 Result Combinations.

![Table 2.6 Result Combinations](image)

**Result Combination No.**

The number of the new result combination is preset but can be modified in the RC No. text box. The order of the result combinations can also be adjusted retroactively with the [Renumber] dialog button (see Table 5.8 and Chapter 11.4.18).

**Result Combination Description**

You can enter any name manually or select one from the list to briefly describe the result combination. As manually entered descriptions are stored in the list, they are also available for other models.

**To Solve**

Use the check box to control if the result combination is considered in the calculation. In this way, it is possible to exclude result combinations from the calculation or reactivate them.

**Loading in Result Combination**

The columns provide information about the load cases, load combinations, and result combinations, including related factors.

The values indicated in the Factor table column are based on the coefficients that depend on the selected standard, among other things. For EN 1990, they are the partial safety factors $\gamma$, the combination factors $\psi$, the reduction factors $\xi$, and, if applicable, the reliability factors $K_{FI}$ of each action, which result from the design situation and action category.

To check and, if necessary, adjust the partial safety factors and combination coefficients conforming to standards, use the [Details] dialog button. The Coefficients dialog box opens where you can find various factors, organized in several tabs. The Partial Safety Coefficients tab for EN 1990 is shown in Figure 12.27. The Combination Coefficients tab manages the factors $\psi$ and $\xi$ (see Figure 5.24). The reliability factor $K_{FI}$ can be defined in a list in the Consequence Classes dialog tab, but you can also enter a user-defined value.

**Combining loadings**

In the Edit Load Cases and Combinations dialog box, you can superimpose load cases, load combinations, and result combinations in a combination as follows: Select the relevant entries in the Existing Loading list by clicking them. As familiar from MS Windows, you can use a multiple selection by pressing the [Ctrl] key (see Figure 5.42). Use the and dialog buttons to transfer the selected entries into the Loading in Result Combination list on the right.
The load case factors are applied according to the standard set in the Model - General Data dialog box. If required, you can adjust the preset partial safety factors (see Chapter 12.2.1) by using the [Edit Settings] dialog button.

To remove a load from a result combination, select the load case in the Load Cases in Load Combination column of the dialog box. Use the \[\text{button}\] or double-click the entry to return it to the Existing Loading dialog section.

The load cases, load combinations, and result combinations contained in the result combination can be superimposed in accordance with their effect:

### Loading Criterion

- **Permanent Effect**
  
  If you want to apply the loading permanently or unconditionally, the Permanent criterion or \(\text{/p}\) must be added to the loading.

- **Variable Effect**
  
  A loading with the Variable criterion is only considered in the superposition if its internal forces make an unfavorable contribution to the result.

### Criterion for Superposition

- **Additive Combination**
  
  The results of loadings are combined additively with the "+" criterion. Use the \[\text{button}\] in the dialog box to transfer the marked load cases, load combinations, and result combinations into the definition list of the result combination.

- **Alternative Combination**
  
  For the alternative analysis using the "or" criterion or the abbreviation "o", RFEM treats the results of particular loadings as mutually exclusive. RFEM only considers the values of the loading that makes the maximum unfavorable contribution. Use the \[\text{dialog button}\] to transfer selected loadings to the definition list of the result combination.

  Loadings that act alternatively are marked with the same number in the Group table column.

  The criterion "orto" ("or to") combines a list of alternative loadings from the first to the last object. Objects that lie in-between are not listed.

  All loadings listed in the alternative combination group must be uniformly marked as 'Permanent' or 'Variable'. Thus, it is not allowed to, for example, enter "LC1/p or LC2".

  It is possible to individually adjust the factors of transferred loadings: Select the loading(s) in the Loading in Result Combination list, and then enter a suitable factor into the text box or select it from the list. Finally, click the [Set Factor] button to apply the new factor to the loading(s).

  Analogously, you can retroactively change the loading criterion (permanent or variable effect) or the group affiliation of an alternative loading. To assign the new criterion to the selected loading, use the [Set] dialog button.
Several filter options are available below the Existing Loading list. They make it easier to assign loadings sorted by load cases, load combinations, action combinations, and action categories. In addition, it is possible to restrict the listing to unassigned loadings. The buttons are described in Table 5.8.

You can manually define result combinations in a separate dialog box by using the [Edit] button in the bottom right of the Edit Load Cases and Combinations dialog box.

In the Loading in Result Combination text box, load cases can be added with any factor or combined with the "or" criterion. Nesting of input is not permitted.

**Examples:**

- **LC1/p + LC2/p + LC3**
  Load cases 1 and 2 are superimposed as permanent, load case 3 as variable.

- **LC1/p + CO2 + LC3 or LC4 or LC5** (corresponds to LC1/p + CO2 + LC3 or LC5)
  Load case 1 is considered permanent in the superposition and load combination 2 variable. The most unfavorable among load cases 3, 4, or 5 is also variably superimposed with the criterion (i.e. only one of them is effective - if it increases the result values).

- **1.2CO1/p + 0.2RC1 or -0.2RC1**
  The 1.2-fold of load combination 1 is superimposed as permanent with the most unfavorable contribution of the positive or negative 0.2-fold of result combination 1.

- **RC1/p or RC2/p or RC3/p or RC4/p** (corresponds to RC1/p or RC4/p)
  Result combinations 1 through 4 are compared among each other as permanently acting. The envelope is determined as the most unfavorable result.

The [Set] button transfers the entry into the Loading in Result Combination list of the initial dialog box.

**Comment**

Enter a user-defined note or select an entry from the list to describe the result combination in detail.
Calculation Parameters

The Calculation Parameters tab in the Loading dialog box provides different options for controlling the calculation. You can find a detailed description of these parameters in Chapter 7.3.1.

Editing result combinations

There are several ways to change result combinations retroactively:

- Menu option **Edit → Load Cases and Combinations → Result Combinations**
- Shortcut menu or double-click of a result combination in the Data navigator

In the **Edit Load Cases and Combinations** dialog box (see Figure 5.40), select the RC by clicking it. Then you can edit the definition criteria.

Buttons

In the **Edit Load Cases and Combinations** dialog box, several buttons are available below the Existing Result Combinations and Existing Loading lists. The buttons have the following functions:

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Button" /></td>
<td>Creates a new result combination.</td>
</tr>
<tr>
<td><img src="image" alt="Button" /></td>
<td>Creates a new result combination as a copy of the selected combination.</td>
</tr>
<tr>
<td><img src="image" alt="Button" /></td>
<td>Assigns a new number to the selected result combination, which must be specified in a separate dialog box. It is not allowed to enter an RC number that has already been assigned.</td>
</tr>
<tr>
<td><img src="image" alt="Button" /></td>
<td>Deletes the selected result combination.</td>
</tr>
<tr>
<td><img src="image" alt="Button" /></td>
<td>The list only shows load cases not contained in the result combination.</td>
</tr>
<tr>
<td><img src="image" alt="Button" /></td>
<td>Selects all load cases in the list.</td>
</tr>
<tr>
<td><img src="image" alt="Button" /></td>
<td>Inverts the selection of load cases.</td>
</tr>
</tbody>
</table>

Table 5.8 | Buttons in the Result Combinations tab |
5.6.2 Generated Combinations

When switching to the Result Combinations dialog tab or to Table 2.6, RFEM automatically creates the combinations. As the load cases are not superimposed manually, the General tab looks different (see Figure 5.40 for user-defined combinations).

![Edit Load Cases and Combinations dialog box, Result Combinations tab](image)

**Result Combination No.**

The result combinations generated from action combinations are numbered consecutively.

In the bottom left of the Existing Result Combinations dialog section in the Loading dialog box, you can filter the generated combinations according to different criteria.

**Result Combination Description**

RFEM assigns brief descriptions, which are based on the combination rules (safety factors and load case numbers). You can change these descriptions, if necessary.

Click the dialog button to jump back to the Action Combinations dialog tab (see Chapter 5.4) where the action combination that the current result combination was created with is selected.

**To Solve**

The check box controls the result determination for the result combination(s) selected in the Existing Result Combinations dialog section.
Loading in Result Combination

The columns provide information about the load cases, including the corresponding partial safety factors and combination coefficients. It is not possible to modify the factors of generated combinations.

If a load case is assumed to be Leading in the combination, it is marked accordingly in the dialog box.

To check and, if necessary, adjust the partial safety factors and combination coefficients, use the [Details] dialog button. The Coefficients dialog box is divided into several tabs (see Figure 12.27 and Figure 5.24).

Adding result combinations

The generated result combinations cannot be edited, only deleted or excluded from the calculation by using the To Solve check box.

With the [New] button in the bottom left of the Existing Result Combinations dialog section, you can add a user-defined combination. The look of the General dialog tab is adjusted to enable the manual definition.

Chapter 5.6.1 describes how result combinations can be created manually.
5.7 Combination Scheme

Load case constellations can be saved as a Combination Scheme and reused for similar applications. To open the corresponding dialog box, select **Tools → Combination Scheme.**

![Combination Scheme dialog box](image)

In the Description dialog section, you can select a combination scheme from the list or use the [New] button to create a new one.

When load cases have already been defined in the model, they are entered in the Load Cases dialog section. Load cases can be added by confirming the last row of the list with the [Enter] or [Tab] key. In the LC Description dialog column, you can select predefined descriptions from a list.

The Load Combinations and Result Combinations dialog sections manage the conditions of superpositioning for load combinations (see Chapter 5.5) and result combinations (see Chapter 5.6).

To save the combination scheme, click the button shown on the left. Click [OK] to create the load cases, load combinations, and result combinations.

Do not forget to enter the loading: The combination scheme only generates a frame of load cases, load combinations, and result combinations!

For models based on the same load scheme, you can generate all load cases, load combinations, and result combinations without entering more data: Open this dialog box, select the scheme from the Description list, and import it by clicking [OK].
6 Loads

Just as with the model data, there are different ways to enter loads: You can define loads in a dialog box, a table, and often directly in the graphic.

Opening the input dialog box

You can access the input dialog boxes and the graphical input in different ways.

Insert menu

![Figure 6.1](image1)

Insert toolbar

![Figure 6.2](image2)

Shortcut menu in Data navigator

![Figure 6.3](image3)
Shortcut menu or double-click in table

The input dialog box can be accessed by means of the shortcut menu (or by double-click) of the row number.

Opening an edit dialog box

There are different ways to open the dialog box for editing a load object.

Edit menu

The Dialog Box option can only be accessed if the load object was selected beforehand.
Shortcut menu or double-click in graphic

![Image of load in work window](image1)

Figure 6.6  Shortcut menu of a load in the work window

Shortcut menu or double-click in Data navigator

![Image of Data navigator with shortcut menu](image2)

Figure 6.7  Shortcut menu of load objects in Data navigator

Shortcut menu or double-click in table

![Image of load table](image3)

Figure 6.8  Shortcut menu in load tables

The edit dialog box can be accessed by means of the shortcut menu (or by double-click) of the row number.
Table input

Input and modifications carried out in the graphical user interface are immediately shown in the tables and vice versa. To access the load tables, use the third button from the left in the table toolbar.

Spreadsheet data in tables can be quickly edited or imported (see Chapter 11.5).

In each dialog box and table, it is possible to add a comment that specifies the load. You can also use predefined comments (see Chapter 11.1.4).

To control whether loads in the current table or in all tables are summarized or listed row-by-row, select Table → Optimize Load Data on the menu. You can also use the buttons in the table toolbar shown on the left to activate these settings; they can be found to the right of the load case list.
6.1 Nodal Loads

General description

Nodal loads are forces and moments that act on nodes (see Chapter 4.1). To apply a nodal load, a node must already be defined.

The nodal load's number is automatically assigned in the New Nodal Load dialog box and can also be changed there. The numbering's sequence is not important.

On Nodes No.

In this text box, specify the numbers of the nodes on which the load acts. You can also select nodes graphically with ( ).

When you have selected the graphical input by clicking the toolbar button, you have to enter the load data first. After clicking [OK], you can select the relevant nodes one by one in the work window.
**Definition Type**

It is possible to define nodal loads **by components** with reference to the axes of the global or user-defined coordinate system or **by direction** with reference to an object.

**Coordinate System**

In most cases, forces and moments are related to the global coordinate system as vectors **by components**. A user-defined coordinate system can also serve as a reference.

**Force \( P_X / P_Y / P_Z \)**

For the **by components** definition type, you have to enter the values of the forces in these text boxes or table columns. If the model type has been restricted to a planar system in the general data, you can only access the relevant boxes.

**Moment \( M_X / M_Y / M_Z \)**

These text boxes and table columns manage the values of the moments.

A positive moment acts clockwise about the corresponding positive global or user-defined axis. Input is facilitated by the global axes of coordinates in the RFEM graphic.

Moments can not only be displayed as vectors but also as arcs. To control the display properties (see Chapter 11.1.2), use the menu option **Options → Display Properties → Edit**.

The Display Properties dialog box opens where you set the Category **Loads → Nodal Loads → Nodal Moments**. Then the Arc display option is available for selection on the right.

It is also possible to import nodal loads from Excel spreadsheets (see Chapter 12.5.2).
Direction Type

For the definition type By direction, it is possible to describe the load direction independent of a coordinate system. For this, there are different definition options available in the list.

When you select an option, the Edit Direction dialog box opens where you can enter additional parameters.

![Edit Direction dialog box](image)

Force P

For the definition type By direction, you have to enter the values of the forces in these text boxes or table columns.

Moment M

These text boxes and table columns manage the values of the moments.
Converting nodal loads into surface loads

Nodal loads often result in singularities because the load is concentrated when introduced in a single FE node. To reduce this effect, select the **Convert Nodal/Line Load to Surface Load** option in the Tools menu. You can also use the shortcut menu of a nodal load shown on the left to access the dialog box for converting nodal loads. As usual, right-click the object to open the shortcut menu.

A dialog box opens (see Figure 6.14) where you can define the parameters for distributing the load. After clicking [OK], the corresponding free rectangular or circular load is created.

![Convert Nodal Load to Surface Load dialog box](image)
6.2 Member Loads

General description

Member loads are forces, moments, temperature actions, or imposed deformations that act on members.

To apply a member load, a member must already be defined.

The member load’s number is automatically assigned in the New Member Load dialog box, but it can also be changed there. The numerical order is not important.
Reference to

Define the model elements to which you want to apply the member load. The following options can be selected:

Members

The load acts on one member or on each member among several.

List of members

The load acts on all members, which have to be specified in a list. Thus, when trapezoidal member loads are used, load parameters are not applied individually to each member but as a total load to all members of the member list. The load effects of a trapezoidal member load on single members in contrast to a member list are shown in Figure 6.17.

You can use a member list to apply loads over all members without defining continuous members. Moreover, it is possible to quickly change the load reference to individual members.

Sets of members

The load acts on a set of members or on each among several sets of members. Similar to the member list described above, load parameters are applied to all of the members included in the member set.

Sets of members are divided into continuous members and groups of members (see Chapter 4.21). While it is no problem to apply loads on sets of members to continuous members, member groups have to be handled with care: The reference to a member group is usually problematic for trapezoidal loads.

Figure 6.17 Trapezoidal load with reference to members (left) and to a list of members (right)

On Members No.

In the text box, enter the numbers of the members or sets of members on which the load acts. You can also select nodes graphically in the dialog box.

If you have selected graphical input by clicking the toolbar button, you have to enter the load data first. After clicking [OK], you can select the relevant members or sets of members one by one in the work window.

For trapezoidal or variable loads with load reference to a member list, you can adjust the member numbers by using the [Reverse Orientation of Members] dialog button shown on the left.
## Load Type

Specify the load type in this dialog section. Depending on your selection, certain parts of the dialog box and columns of the table are disabled. The following load types can be selected:

<table>
<thead>
<tr>
<th>Load Type</th>
<th>Short Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Force</td>
<td>Concentrated load, distributed load, or trapezoidal load</td>
</tr>
<tr>
<td></td>
<td>The [\text{\textit{button}}] allows you to set a load eccentricity.</td>
</tr>
<tr>
<td>Moment</td>
<td>Concentrated moment, distributed moment, or trapezoidal moment</td>
</tr>
<tr>
<td>Temperature</td>
<td>Temperature load uniformly distributed over member cross-section, or temperature difference between top and bottom side of member. Load applied as uniform or trapezoidal over member length or as trapezoidal over cross-section. A positive load value means that the member or the upper side is heating.</td>
</tr>
<tr>
<td>Axial strain</td>
<td>Imposed tensile or compressive strain (\varepsilon) of member</td>
</tr>
<tr>
<td></td>
<td>A positive load value means that the member is extended. Thus, a prestress as a member contraction must be entered negatively. Use the dialog button shown on the left to determine the strain due to shrinkage from the parameters for contraction and drying shrinkage (see Figure 6.25).</td>
</tr>
<tr>
<td>Axial displacement</td>
<td>Imposed tensile or compressive strain (\Delta l) of member</td>
</tr>
<tr>
<td>Precamber</td>
<td>Imposed curvature of member</td>
</tr>
<tr>
<td>Initial prestress</td>
<td>Prestressing force that acts on the member before calculation</td>
</tr>
<tr>
<td></td>
<td>A positive load value means that the member is extended.</td>
</tr>
<tr>
<td>End prestress</td>
<td>Axial force expected to be available on member after calculation (not possible for rigid members and cables). A positive load value means that the member is extended.</td>
</tr>
<tr>
<td>Displacement</td>
<td>Displacement by quantity (\Delta) for determination of influence lines</td>
</tr>
<tr>
<td>Rotation</td>
<td>Rotation about angle (\phi) for influence lines</td>
</tr>
<tr>
<td>Pipe content - full</td>
<td>Distributed load due to complete filling of pipe</td>
</tr>
<tr>
<td></td>
<td>Specify weight density (\gamma) of pipe content.</td>
</tr>
<tr>
<td>Pipe content - partial</td>
<td>Distributed load due to partial filling of pipe</td>
</tr>
<tr>
<td></td>
<td>In addition to weight density (\gamma) of pipe content, specify filling height (d).</td>
</tr>
<tr>
<td>Pipe internal pressure</td>
<td>Constant internal pressure of a pipe</td>
</tr>
<tr>
<td>Rotary motion</td>
<td>Centrifugal force from mass and angular velocity (\omega) on member</td>
</tr>
<tr>
<td></td>
<td>The rotation axis can be defined by using the [\text{\textit{button}}] button.</td>
</tr>
</tbody>
</table>

*Table 6.1 Load types*
The graphic in the upper right of the dialog box shows the selected load type including the influence of the signs of forces and strains.

**Load Distribution**

The Load Distribution dialog section provides different options for displaying the effect of the load. The dialog graphic in the top right corner may be helpful.

<table>
<thead>
<tr>
<th>Load Distribution</th>
<th>Diagram</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Concentrated $P$</td>
<td><img src="image" alt="Concentrated Load Diagram" /></td>
<td>Concentrated load, concentrated moment. Specify the size of the concentrated load or concentrated moment and the distance of the point of load application in relation to the member start as Member Load Parameters.</td>
</tr>
<tr>
<td>Concentrated $n \times P$</td>
<td><img src="image" alt="Multiple Loads Diagram" /></td>
<td>Multiple concentrated loads or moments. The list provides several arrangement options for load pairs or multiple concentrated loads such as axle loads. You can also define User-defined loads in a separate dialog box, which can be opened with the button. The option shown on the left is suitable for single forces, which are equal in size and act at a uniform distance. Define the size of the concentrated load, the distance between first load and member start, and the spacing between the load as Member Load Parameters.</td>
</tr>
<tr>
<td>Uniform</td>
<td><img src="image" alt="Uniform Load Diagram" /></td>
<td>Uniformly distributed load, uniformly distributed moment. Specify the size of the uniform member load or uniform moment as Member Load Parameters.</td>
</tr>
<tr>
<td>Trapezoidal</td>
<td><img src="image" alt="Trapezoidal Load Diagram" /></td>
<td>Trapezoidal load, trapezoidal moment. As Member Load Parameters, define both load values and distances for a linearly variable load distribution as shown in the dialog graphic. A triangular load is created by setting one load value to zero. If the Relative distance in % check box is selected, the distances can be specified relative to the member length.</td>
</tr>
<tr>
<td>Tapered</td>
<td><img src="image" alt="Tapered Load Diagram" /></td>
<td>Triangular-trapezoidal load, triangular-trapezoidal moment. For a linearly variable load distribution, specify the load values and distances as Load Parameters as shown in the dialog graphic.</td>
</tr>
</tbody>
</table>
Parabolic

Parabolic load, parabolic moment
The load acts as a parabolic load on the entire member. The load values at the member start and member end, as well as in the member center must be entered as Load Parameters.

Varying

Polygonally distributed load
Clicking the button opens the dialog box shown in Figure 6.18 where you can enter or import the parameters of the load distribution.

If you want to display a variable load, you can freely define the x-locations on the member with the corresponding load ordinates p. You only have to make sure that the x-locations are defined in an ascending order. Use the interactive graphic to check your input immediately.

The buttons in this dialog box have the following functions:

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Table export to MS Excel" /></td>
<td>Table export to MS Excel</td>
</tr>
<tr>
<td><img src="image2" alt="Table import from MS Excel" /></td>
<td>Table import from MS Excel</td>
</tr>
<tr>
<td><img src="image3" alt="Inserts a blank line above pointer" /></td>
<td>Inserts a blank line above pointer</td>
</tr>
<tr>
<td><img src="image4" alt="Deletes active row" /></td>
<td>Deletes active row</td>
</tr>
<tr>
<td><img src="image5" alt="Deletes all entries" /></td>
<td>Deletes all entries</td>
</tr>
</tbody>
</table>
Load Direction

The load can be effective in the direction of the global axes X, Y, Z, or the local member axes x, y, z or u, v (see Chapter 4.13). For a calculation according to the linear static analysis, it does not matter whether a load is defined as local or equivalent global. For geometrically nonlinear calculations, however, differences between locally and globally defined loads are possible: If the load is defined with a global direction of action, it keeps this direction when the finite elements start to twist. In case of a local direction of action, however, the load twists on the member according to the distortion of elements.

If the model type has been reduced to a planar system in the general data, you cannot access all load directions.

Local

The orientation of member axes is described in Chapter 4.17, paragraph Member Rotation. The local axis x represents the longitudinal axis of the member. For symmetrical sections, axis y represents the so-called ‘strong’ axis of the member cross-section, axis z accordingly the ‘weak’ axis. In case of asymmetrical cross-sections, loads can be related to the principal axes u and v, as well as the standard input axes y and z.

Examples for loads defined as local are temperature loads, wind loads that act on roof structures, or prestresses.

Global

The position of the local member axes is irrelevant for the load input if the load acts in direction of an axis of the global coordinate system XYZ.

Examples for loads defined as global are snow loads acting on roof constructions and wind loads on wall and gable columns.

The load impact can be related to different reference lengths:

- Related to true member length
  The load is applied to the entire member length.

- Related to projected member length in X / Y / Z
  The application length of the load is converted to the projection of the member in one of the directions of the global coordinate system. Select this option to, for example, define a snow load on the projected ground-plan area of a roof.

RFEM always applies member loads in the shear center. An intended torsion originating from the cross-sectional geometry (centroid unequal shear center) is not considered. Therefore, when asymmetrical cross-sections are used, a torsion moment determined from load multiplied by distance to the shear center must additionally be applied if, for example, loading is introduced in the centroid.

Member Load Parameters

In this dialog section / these table columns, the load values and, potentially, additional parameters are managed. The text boxes are labeled and accessible depending on the previously activated selection fields.

Load $p_1 / p_2$

Enter load values into the fields. Match the algebraic signs with the global or local orientations of axes. For prestresses, temperature changes, and axial strains, a positive value means that the member is strained and consequently extended.

When a trapezoidal load is selected, specify two load values. The dialog graphic in the upper right corner illustrates the load parameters.
**Distance A / B**

For concentrated and trapezoidal loads, enter the distances from the member start into these fields. The distances can also be defined relative to the member length by selecting the **Relative distance in %** check box (see below).

The dialog graphic in the upper right corner and the button in the graphic below are useful when entering parameters.

If the **Load Direction** is projected to the member length XP, YP, or ZP, you also have to define the distances A and B in relation to the projected member length.

**Relative distance in %**

Select this check box to define the distances for concentrated or trapezoidal loads relative to the member length. Otherwise, the entries in the **Distance** text boxes described above represent absolute ranges.

**Over Total Length**

The check box can only be activated for trapezoidal loads. Select this option to arrange the linearly variable load from the member start to the member end. The **Load Parameters A / B** text boxes are no longer relevant and therefore disabled.

**Example**

In the following example, member loads are applied to a planar frame structure. You can see that it is not necessary to divide members by intermediate nodes to apply concentrated loads.

![Framework with uniform load on upper chord and concentrated loads on diagonals](image-url)
6.3 Line Loads

General description

Line loads are forces and moments that act on lines (see Chapter 4.2). To apply a line load, a line must already be defined.

Line loads are very similar to member loads. For line loads, however, it is not possible to allocate material properties (e.g. temperature loads, axial strains).

Line loads can act on members because a member is the property of a line. However, to apply a line load to a member, the line must belong to a surface. Consequently, line loads cannot be applied to members in models that only consist of members.

The number of the line load is automatically assigned in the New Line Load dialog box but can also be changed there. The numerical order is not important.
Reference to

Define the objects to which you want to apply the line load. The following options can be selected:

**Lines**

The load acts on one line or on each among several lines.

**List of lines**

The load acts on all lines, which have to be specified in a list. Thus, when trapezoidal line loads are used, load parameters are not applied individually to each line but as a total load to all lines of the line list (see Figure 6.17).

**On Lines No.**

In the text box, enter the numbers of the lines on which the load acts. You can also select them graphically by using . If you have selected the graphical input by clicking the toolbar button, you have to enter the load data first. After clicking [OK], you can select the relevant lines one by one in the work window.

**Load Type**

Define the type of load in this dialog section. Depending on your selection, certain parts of the dialog box and columns of the table are disabled. The following load types can be selected:

<table>
<thead>
<tr>
<th>Load Type</th>
<th>Short Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Force</td>
<td>Concentrated, distributed, trapezoidal, or variable load</td>
</tr>
<tr>
<td>Moment</td>
<td>Concentrated, distributed, or trapezoidal moment</td>
</tr>
</tbody>
</table>

Table 6.4 Load types

**Load Distribution**

The Load Distribution dialog section provides different options for displaying the effect of the load. The graphic in the right corner of the dialog box may be useful as an illustration. Use the button in the graphic below to display the load in the rendering.

<table>
<thead>
<tr>
<th>Load Distribution</th>
<th>Short Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Concentrated</td>
<td>Concentrated load, concentrated moment, or multiple concentrated loads/moments</td>
</tr>
<tr>
<td>Uniform</td>
<td>Uniformly distributed load, uniformly distributed moment</td>
</tr>
<tr>
<td>Trapezoidal</td>
<td>Trapezoidal load, trapezoidal moment</td>
</tr>
<tr>
<td>Tapered</td>
<td>Triangular-trapezoidal load, triangular-trapezoidal moment</td>
</tr>
<tr>
<td>Parabolic</td>
<td>Parabolic load, parabolic moment</td>
</tr>
</tbody>
</table>
Varying

Polygonally distributed load

The dialog box shown in Figure 6.18 opens where you can enter the parameters of the load distribution.

Table 6.5 Load distributions

The load distributions of line loads largely correspond to the ones of member loads. The diagrams are described in detail in Table 6.2.

Load Direction

The load can be effective in the direction of the global axes X, Y, Z or the local line axes x, y, z. For a calculation according to the linear static analysis, it does not matter whether a load is defined as local or equivalent global. For geometrically nonlinear calculations, however, differences between locally and globally defined loads are possible: If the load is defined with a global direction of action, it keeps this direction when finite elements start to twist. In case of a local direction of action, however, the load twists on the line according to the distortion of elements.

Local

The orientation of line axes is illustrated in Figure 4.103. The local axis x represents the longitudinal axis of the line. The axis z is usually aligned parallel to the global axis Z.

Global

The position of the local line axes is irrelevant for the load input if the load acts in direction of an axis of the global coordinate system XYZ. The load impact can be related to different reference lengths:

- Related to true line length
  
  The load is applied to the entire, true line length.

- Related to projected line length in X / Y / Z
  
  The application length of the load is converted to the projection of the line in one of the directions of the global coordinate system. The projection lengths are illustrated in the dialog graphic to the right.

Line Load Parameters

In this dialog section / these table columns, the load values and, possibly, additional parameters are managed. The text boxes are labeled and accessible depending on the previously activated selection fields.

Load P / p / \( p_2 \) / M / m / \( m_2 \)

Enter the load values into these fields. Adjust the signs to the global or local orientations of axes. When a trapezoidal load is selected, specify two load values. The dialog graphic in the upper right corner illustrates the load parameters.

Distance A / B

For concentrated and trapezoidal loads, enter the distances from the line start into these fields. You can also define the distances in relation to the line length by selecting the Relative distance in % check box on the right (see below).

The dialog graphic in the upper right corner and the button in the graphic below are useful when entering parameters.
Relative distance in %

Select this check box to define the distances for concentrated and trapezoidal loads relative to the line length. Otherwise, the entries in the above-described Distance text boxes represent absolute ranges.

Over Total Length

The check box can only be activated for trapezoidal loads. Select this option to arrange the linearly variable load from the line start to the line end. The Load Parameters A / B text boxes are no longer relevant and therefore disabled.

Converting line loads into surface loads

Often, line loads result in singularities because the load is concentrated when introduced in a single line. To reduce this effect, select the Convert Nodal/Line Load to Surface Load option in the Tools menu. The option can be used for straight lines. You can also use the shortcut menu of a line load shown on the left to access the dialog box for converting line loads. As usual, right-click the object to open the shortcut menu.

A dialog box opens where you can define the parameters for distributing the load. The corresponding free rectangular or polygonal load is created after clicking [OK].
6.4 Surface Loads

General description

Surface loads act on all 2D elements of a surface (see Chapter 4.4). To apply a surface load, a surface must already be defined.

If a surface is divided into surface components because of an intersection (see Chapter 4.22), the surface load does not act on components that are set inactive. Openings are omitted from the surface load as well.

The number of the surface load is automatically assigned in the New Surface Load dialog box but can also be changed there. The numerical order is not important.
On Surfaces No.

In this text box, define the numbers of the surfaces on which the load acts. You can also select them graphically by using "

If you have selected the graphical input by clicking the toolbar button, you have to enter the load data first. You can select the relevant surfaces one by one in the work window after clicking [OK].

Load Type

Define the type of load in this dialog section. Certain parts of the dialog box and columns of the table are disabled depending on your selection. The following load types can be selected:

<table>
<thead>
<tr>
<th>Load Type</th>
<th>Short Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Force</td>
<td>Uniformly distributed, linearly variable, or radially acting force on surface</td>
</tr>
<tr>
<td>Temperature</td>
<td>Temperature load that is radially arranged or distributed uniformly or linearly variable over thickness of surface. A positive load value means that the surface or its upper side is heating.</td>
</tr>
<tr>
<td>Axial strain</td>
<td>Imposed tensile or compressive strain $\varepsilon$ of surface</td>
</tr>
<tr>
<td>Precamber</td>
<td>Imposed curvature of surface</td>
</tr>
<tr>
<td>Rotary motion</td>
<td>Centrifugal force from mass and angular velocity $\omega$ on surface</td>
</tr>
</tbody>
</table>

The parameters for surface and member loads due to shrinkage can be defined in a separate dialog box, accessible with the button [Figure 6.25](#).
Shrinkage as a time-dependent change in volume without external load action or effects of temperature can be classified into drying shrinkage, autogenous shrinkage, plastic shrinkage, and carbonation shrinkage. The shrinkage $\varepsilon_{cs}(t, ts)$ at the moment of the considered concrete age $t$ is determined from the essential influencing variables in the shrinkage process (relative humidity RH, effective structural thickness $h$, concrete strength $f_{cm}$, type of cement $Z_{Type}$, age of concrete at beginning of shrinkage $ts$).

Click [OK] to transfer the value to the New Surface Load dialog box as the axial strain $\varepsilon$.

**Load Distribution**

The load can act on the surface as Uniform, Linearly variable, or Radial.

**Linear**

Define load values for three nodes. The nodes are used to define a plane.

**Linear in X / Y / Z**

If the surface load is variable in the direction of an axis of the global coordinate system, load values of two nodes are required. The nodes may lie outside of the stressed surface, provided that FE nodes are generated there (i.e. the nodes are not allowed to be free).
Radial

For radially acting forces and temperature loads, you have to define the axis of the radial distribution in a separate dialog box. Use the button to open the dialog box.

**Figure 6.28** Axis of Radial Distribution dialog box

Load Direction

The load can act in the direction of the local surface axes x, y, z or the global axes X, Y, Z.

**Local related to true area**

Loads that act perpendicular to the surface are usually defined as local in direction z. Examples of application are wind loads that act on roof surfaces or internal pressure on tank shells.

To display the axes, use the Display navigator where you select **Model → Surfaces → Surface Axis Systems x,y,z**. You can also use the shortcut menu of a surface (see **Figure 4.122**).

**Global related to true area**

The orientation of the local surface axes is irrelevant for the calculation according to the linear static analysis, if the load acts in direction of an axis of the global coordinate system XYZ. For nonlinear calculations, however, differences between locally and globally defined loads are possible: If the load is defined with a global direction of action, it keeps this direction when finite elements start to twist. In case of a local direction of action, however, the load twists according to the distortion of elements.

**Global related to projected area**

The load is converted to the projection of the surface in one of the directions of the global coordinate system. Select this option to define a snow load on the projected ground-plan area of a roof, for example.

The graphic in the lower right of the dialog box illustrates the projected surfaces.

**Surface load parameters**

In this dialog section or these table columns, the load values and, if applicable, the assigned nodes are managed. The text boxes are labeled and accessible depending on the previously activated selection fields.
Load \( p \), \( p_2 \), \( p_3 \), \( T \), \( \Delta T \), \( \varepsilon \), \( R \), \( \omega \), \( \alpha \)

Enter the load values into these fields. Adjust the signs according to the global or local orientations of axes.

If a linearly variable load is selected, you have to specify several load values. The dialog graphic in the upper right corner illustrates the load parameters.

**Node No.**

If a linearly variable load is selected, specify three nodes on which the load magnitudes can be determined. The nodes are used to define a plane. You can also select nodes graphically with the button.

**Load of multilayer structure**

It is possible to create loads from area weights of materials that act as laminated layers. In this way, you can easily determine the structure of floorings or floor coverings, for example.

You can access the function in the New Surface Load dialog box (Figure 6.23) by using the button to the right of the text box of the magnitude. In the shortcut menu, select Multilayer Composition.

The Multilayer Composition Library opens where you can select material layers or define new compositions.

![Multilayer Composition Library dialog box](image)
The concept of the multilayer database matches that of the material library (see Chapter 4.3). Use the and buttons to create or modify user-defined multilayer compositions.

![Image of New Multilayer Composition dialog box, Layers section]

The Layers can be composed individually. Moreover, you can use the button to access the material library (see Chapter 4.3).

RFEM determines the area weight (table column E) from the Thickness and Specific Weight. An arrow shown in the dialog graphic indicates the current layer.

Confirm all dialog boxes with [OK] to import the area weight into the initial dialog box. A green triangle appears in the text box (see graphic shown on the left in the page above), indicating the parameterized input value. Click the triangle to once more access the input parameters for modifications.
### 6.5 Solid Loads

#### General description

Solid loads act on all 3D elements of a solid (see Chapter 4.5). To apply a solid load, a solid must already be defined.

![New Solid Load dialog box](image)

The number of the solid load is automatically assigned in the New Solid Load dialog box, but can also be changed there.

#### On Solids No.

In the text box, enter the numbers of the solids on which the load acts. You can also select them graphically by using `.`.

When you have selected the graphical input by clicking the toolbar button, you have to enter load data first. After clicking [OK], you can select the relevant solids one by one in the work window.
### Load Type

Specify the load type in this dialog section. The load types and definition parameters are visualized dynamically in the dialog box. The following load types can be selected:

<table>
<thead>
<tr>
<th>Load Type</th>
<th>Short Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Force</td>
<td>Solid load acting uniformly in one of the global directions</td>
</tr>
<tr>
<td>Temperature</td>
<td>Uniformly distributed or linearly variable temperature change in the solid. A positive load value signifies a heating.</td>
</tr>
<tr>
<td>Strain</td>
<td>Imposed tensile or compressive strain of the solid that is uniformly distributed or linearly variable. A positive load value means that the solid is extended.</td>
</tr>
<tr>
<td>Buoyancy</td>
<td>Weight of displaced material whose density can be entered or selected in a [Library]. The Environment Density of Air refers to a standard atmosphere of 15 °C at sea level.</td>
</tr>
<tr>
<td>Rotary motion</td>
<td>Centrifugal force from mass and angular velocity ( \omega ) on the solid. The rotation axis can be defined in a separate dialog box that you can open with the ( \text{button} ).</td>
</tr>
</tbody>
</table>

Additional forces can be applied on a solid in the form of surface or line loads.

### Load Distribution

The load can act on the solid as Uniform or Linearly variable. It refers to one of the global axes X, Y, or Z.

If linearly variable loads are selected, specify the load values of two nodes. Nodes are allowed to lie outside of the stressed solid, provided that FE nodes are generated there.

### Load Magnitude

In this dialog section / these table columns, the load values and, if applicable, the assigned nodes are managed. The text boxes are labeled and accessible depending on the previously activated selection fields.

**Node No.**

If linearly variable loads are selected, specify two nodes that the load magnitudes refer to. These nodes are used to define a plane. You can also select them graphically using \( \text{button} \).

**Magnitude**

For a uniform load distribution, only one numerical value is required. For a linearly variable change in temperature or axial strain, specify two load values.
6.6 Free Concentrated Loads

General description

A free concentrated load acts as a force or moment on any location of the surface. No FE nodes are generated at the point of load application.

To apply a free concentrated load, a surface must already be defined.

Nodal support forces imported from another model by using the Import Support Reactions as Load function (see Figure 8.13) are handled as free concentrated loads.

In this text box, enter the numbers of the surfaces on which the load acts. You can also select them graphically using .

Starting from the defined Load Position, an imaginary straight line is "set" perpendicular to the projection plane. If the line intersects any of the listed surfaces, the concentrated load is applied at the point of intersection. In this way, it is possible to quickly allocate similar loads to several surfaces.
**Projection Plane**

The load can be projected onto one of the global planes XY, YZ, or XZ. As described above, an imaginary line is generated, starting from the load position and running perpendicular to the projection plane. The load is applied wherever the imaginary line intersects a surface.

The projection plane may not be perpendicular to a surface on which the load acts: There is no clear intersection point with the surface.

![Free concentrated load acting on ceiling: load projection plane XY with impact on ceiling slab and floor slab](image)

**Load Type**

Specify whether a single force or concentrated moment is applied. In the dialog text box below, you can enter the numerical value of the load.

**Load Direction**

The load can act in the direction of the global axes X, Y, Z or the local surface axes x, y, z. To display the axes, use the shortcut menu (see Figure 4.122) or the Display navigator where you select Model → Surfaces → Surface Axis Systems xyz.

**Load Position**

Enter the coordinates of the load position into the text boxes. In the dialog box, you can also select the position of the load graphically by using the button.

**Magnitude**

In the table column or text box, enter the numerical value of the concentrated force or moment.
6.7 Free Line Loads

General description

A free line load acts as a uniform or linearly variable force along any freely definable line of a surface. No FE nodes are generated along this line.

To apply a free line load, a surface must already be defined.

Line support forces imported from another model by using the Import Support Reactions as Load function (see Figure 8.13) are handled as free line loads.

On Surfaces No.

This text box manages the numbers of the surfaces on which the load acts. You can also select them graphically by using .

Starting from both points defined by the Load Position, two imaginary straight lines are "set" perpendicular to the projection plane. If the lines intersect any of the listed surfaces, the load is applied to the connecting line of both intersection points. In this way, it is possible to quickly allocate similar loads to several surfaces.
Projection Plane

The load can be projected onto one of the global planes XY, YZ, or XZ. As described above, two imaginary lines are generated, starting from both load positions and running perpendicular to the projection plane. The start and end points of the free line load are assumed wherever the lines intersect a surface. The projection plane may not be perpendicular to a surface on which the load acts: There are no clear points of intersection with the surface.

Load Distribution

Specify whether a uniform or linearly variable force is applied. In the dialog text box below, you can enter one or two numerical values.

Load Direction

The load can act in direction of the local surface axes x, y, z or the global axes X, Y, Z. Loads acting perpendicular to the surface must generally be defined as local in direction z.

If a globally acting load is not perpendicular to the line, then the load impact can be related to different reference lengths:

- **Related to true line length**
  The load is applied to the entire true line length.

- **Related to projected line length in X / Y / Z**
  The application length of the load is converted to the projection of the line in one of the directions of the global coordinate system. The projection lengths are illustrated in the dialog graphic in the lower right.

Load Position

Enter the coordinates of the load position into the text boxes. In the dialog box, you can also select the position of the load graphically by using the button.

Magnitude

In this table column or text box, enter the numerical value of the line load.
6.8 Free Rectangular Loads

General description

A free rectangular load acts as a uniform or linearly variable surface load on a rectangular, freely definable zone of a surface.

![New Free Rectangular Load dialog box](image1)

On Surfaces No.

This text box manages the numbers of the surfaces on which the load acts. You can also select them graphically by using .

Starting from the corner points defined by the Load Position, imaginary straight lines are “set” perpendicular to the projection plane. When these lines intersect any of the listed surfaces, the boundary line of the load that is to be applied is the connecting diagonal of both intersection points. In this way, it is possible to quickly allocate loads of a similar type to several surfaces.

![Figure 6.39 - Table 3.8 Free Rectangular Loads](image2)
**Projection Plane**

The load can be projected onto one of the global planes XY, YZ, or XZ. As described above, imaginary straight lines are generated, starting from both load positions and running perpendicular to the projection plane. The definition points of the rectangle are assumed wherever the imaginary straight lines intersect a surface.

The projection plane may not be perpendicular to a surface on which the load acts: There are no clear points of intersection with the surface.

**Load Distribution**

Specify whether a uniform or linearly variable force is applied. In the dialog text box below, you can enter one or two numerical values.

**Load Direction**

The load can act in the direction of the local surface axes X, Y, Z or the global axes x, y, z.

- **Local related to true area**
  Loads that act perpendicular to the surface are usually defined as local in direction z.

- **Global related to true area**
  The orientation of the local surface axes is irrelevant for the calculation according to the linear static analysis if the load acts in the direction of an axis of the global coordinate system XYZ. An example of a load reference to the true area is self-weight.

- **Global related to projected area**
  The load is converted to the projection of the surface in one of the directions of the global coordinate system. A case of application is, for example, snow load. The graphic in the lower right of the dialog box illustrates the projected surfaces.

**Load Position**

Enter the coordinates of the load position into the text boxes. In the dialog box, you can also select the position of the load graphically by using the button.

**Magnitude**

Enter the numerical value of the area load in this table column or text box.
6.9 Free Circular Loads

General description

A free circular load acts as a uniform or linearly variable surface load on a circular, freely definable part of a surface.

On Surfaces No.

This text box manages the numbers of the surfaces on which the load acts. You can also select nodes graphically by using .

Starting from the defined Load Position, an imaginary straight line is "set" perpendicular to the projection plane. When the line intersects any of the listed surfaces, the circular load is applied at the point of intersection as the circle center with the radius R. In this way, it is possible to quickly allocate loads of a similar type to several surfaces.
**Projection Plane**

The load can be projected onto one of the global planes XY, YZ, or XZ. As described above, an imaginary straight line is generated, starting from the load position and running perpendicular to the projection plane. The center of the circular load is assumed wherever the imaginary straight line intersects a surface.

The projection plane may not be perpendicular to a surface on which the load acts: There are no clear points of intersection with the surface.

**Load Distribution**

Specify whether a uniform or linearly variable force is applied. In the dialog text box below, you can enter one or two numerical values.

**Load Direction**

The load can act in the direction of the global axes X, Y, Z or the local surface axes x, y, z. The load directions are described in the previous Chapter 6.8.

**Load Position**

Enter the coordinates of midpoint C of the circle load into the text boxes. In the dialog box, you can also select this point graphically by using the button.

**Radius**

Enter the radius R of the circular area load into the text box or table column. You can also define it graphically in the work window by using the button in the dialog box.

**Magnitude**

In this table column or text box, enter the numerical value of the area load.
6.10 Free Polygon Loads

General description

A free polygon load acts as a uniform or linearly variable surface load on a polygonal, freely definable zone of a surface.

This text box manages the numbers of the surfaces on which the load acts. You can also select nodes graphically by using  

Starting from the corner points defined by the Load Position, imaginary straight lines are "set" perpendicular to the projection plane. If these lines intersect any of the listed surfaces, the boundary line of the applied load is the connecting diagonal of both intersection points. In this way, it is possible to quickly allocate loads of a similar type to several surfaces.
Load Projection

The load can be projected onto one of the global planes XY, YZ, or XZ. As described above, imaginary straight lines are generated, starting from the load positions and running perpendicular to the projection plane. The corner points of the polygon load are assumed wherever the lines intersect a surface.

The projection plane must not be perpendicular to a surface on which the load acts: There are no clear points of intersection with the surface.

Load Distribution

Specify whether a uniform or linearly variable area load is applied. In the Corner Point Numbers and Load Magnitudes dialog section below, you can enter one (Uniform), two (Linear in X / Y / Z), or three (Linear) numerical values.

Load Direction

The load can act in direction of the global axes X, Y, Z or the local surface axes x, y, z. The load directions are described in Chapter 6.8.

Load Position

Enter the Corner point coordinates into the text boxes. It is recommended to graphically define the polygonal chain by using the button in the dialog box. In the text box or table column, enter the corner point coordinates separated by commas; coordinate pairs must be separated by a semicolon.

Example: corner point coordinates X, Y [m] 2, 3; 1.6, 4.7; 5, 45; 6, 25; 3, 2

The third coordinate component is automatically defined by the plane of load projection. In the example, it is the Z-coordinate that can be specified separately in a text box of the dialog box. When defining coordinates graphically, the component is irrelevant because the active work plane is decisive.

Corner Point Numbers

When defining linearly variable area loads, enter two (Linear in X / Y / Z) or three (Linear) corner points with the corresponding load values. You can only define or graphically select corner points that are used to define the boundary lines in the Load Position dialog section. It is not possible to select RFEM nodes. Thus, the numbers of corner points are related to the sequence of the Corner point coordinates.

Load Magnitude

In this table column or text box, enter the numerical value of the area load. For a linearly variable distribution, two or three values must be entered.
Free Variable Loads

General description

With this function, you can define surface loads that act uniformly or variably over the depth and perimeter of surfaces. You can use free variable loads to, for example, model tank and wind loads for rotationally symmetric components.

![New Free Variable Load dialog box](image)

![Table 3.11 Free Variable Loads](image)

On Surfaces No.

This text box manages the numbers of the surfaces on which the load acts. You can also select them graphically by using .

Starting from the corner points defined by the Load Position, imaginary straight lines are "set" perpendicular to the projection plane. If these lines intersect any of the listed surfaces, the boundary line of the applied load is the connecting diagonal of both intersection points. In this way, it is possible to quickly allocate loads of a similar type to several surfaces.
Projection Plane

The load can be projected onto one of the global planes XY, YZ, or XZ. As described above, imaginary straight lines are generated, starting from the load positions and running perpendicular to the projection plane. The points of the rectangle are then assumed as a surface at all intersection points of the straight line.

The projection plane must not be perpendicular to a surface on which the load acts.

Load Distribution

The surface loads can act in Z-direction and/or Along perimeter as uniform or varying. You can define the parameters of varying loads in separate dialog boxes by using the buttons.

![Figure 6.47 Edit Varying Load Along Perimeter dialog box](image)

The factor $k_a$ in Figure 6.47 establishes the relation to the load magnitude $p$ of the initial dialog box (see below).

Load Direction

The load can act in the direction of the local surface axes x, y, z or the global axes X, Y, Z. The load directions are described in Chapter 6.8.

Load Position

The coordinates of a rectangle according to the dialog graphic determine in which area the load can act. You can define these corner points in the dialog box by using .
Magnitude

In this table column or text box, enter the numerical value of the area load. For a linearly varying distribution, you can define the load ordinates in the Edit Varying Load dialog box (see Figure 6.47).

You can find examples for free variable loads in the following articles of our Knowledge Base:

6.12 Imposed Nodal Deformations

General description

An imposed nodal deformation is a displacement of a supported node, for example, due to a column settlement.

Imposed nodal deformations can only be applied to nodes that have a support in the direction of the deformation.

The number of the load is automatically assigned in the New Imposed Nodal Deformation dialog box, but it can also be changed there.
On Nodes No.

In this text box, define the numbers of the nodes on which the imposed deformation acts. You can also select them graphically by using [ ].

If you have selected the graphical input by clicking the button, you have to enter the deformations first. After clicking [OK], you can select the relevant nodes one by one in the work window.

Imposed displacement $u_x' / u_y' / u_z'$

Imposed displacements can be applied in directions parallel to the global coordinate system. If a displacement of the supported node does not act parallel to one of the global axes, its components $X$, $Y$, and $Z$ must be determined and entered into the corresponding text boxes.

For support rotations, imposed displacements are related to the rotated axes.

The graphic in the dialog box explains how displacements and signs are effective.

Imposed rotation $\phi_x' / \phi_y' / \phi_z'$

Node rotations refer to the global coordinate system $XYZ$ as well. A skew imposed rotation requires the division in $X$, $Y$, and $Z$ components.

A positive imposed rotation acts clockwise about the corresponding positive global axis.

6.13 Imposed Line Displacements

General description

An imposed line displacement is the displacement of a supported line due to, for example, a foundation settlement.

Imposed line displacements can only be applied to lines that are supported in the direction of the displacement or rotation.

![New Imposed Line Deformation dialog box](image)
The number of the load is automatically assigned in the *New Imposed Line Displacement* dialog box and can also be changed there.

**On Lines No.**

In this text box, define the numbers of the lines on which the imposed displacement acts. You can also select them graphically by using 

If you have selected the graphical input by clicking the button, you have to enter the values of the Displacement or Rotation first. After clicking [OK], you can select the relevant lines one by one in the work window.

**Displacement \( u_x' / u_y' / u_z' \)**

**Line start**

Imposed displacements refer to the global coordinate system XYZ. Three text boxes are provided for the displacement on the start node of the supported line.

If a displacement of the supported line does not act parallel to one of the global axes, its X, Y, and Z components must be determined.

**Line end**

In these text boxes, enter the displacement on the end node of the supported line.

To visualize the line orientation, use the Display navigator: Activate Model \( \rightarrow \) Lines \( \rightarrow \) Line Orientations in it (see Figure 4.26).

**Rotation \( \Phi_x \)**

**Line start**

In the text box, you can specify an imposed rotation at the start of the line. It acts locally about the longitudinal axis \( x \) of the line.

**Line end**

In this text box, you can enter the imposed rotation at the end of the line.
6.14 Imperfections

General description

There are two ways how imperfections can be determined in RFEM:

- **Equivalent loads** are applied to members.
- A pre-deformed **equivalent model** is used.

This chapter describes imperfections in the form of equivalent loads. For detailed information on how to generate equivalent models using the **RF-IMP** add-on module, see Chapter 7.3.1.3.

To apply an imperfection, a member must already be defined. Imperfections represent manufacturing deviations in model geometry and material properties. In EN 1993-1-1, clause 5.3, the application of imperfections is organized into precamber (deflection) and inclination (sway). Thus, imperfections are taken into account by equivalent loads.

Equivalent loads are also taken into account by RFEM when calculations are performed according to the linear static analysis. Please note, however, that a pure imperfection load case does not produce any internal forces. The model must additionally have some "real" loads that induce axial forces in the imperfect member.

It is recommended to manage loads and imperfections in separate load cases. They can be suitably combined with each other in load combinations. Load cases with pure imperfections must be categorized as the action type **Imperfection** in the base data for load cases [see Figure 5.3]. Otherwise, the plausibility check would display a message due to missing loads.

Generally, imperfections must be set affine to the lowest buckling eigenvalue in the most unfavorable direction.
The number of the imperfection is automatically assigned in the New Imperfection dialog box and can also be changed there. The numerical order is not important.

Reference to
Define the objects to which you want to apply the imperfection. The following options can be selected:

Members
The imperfection acts on one member or on each among several selected members.

List of members
The imperfection acts on all members, which have to be defined in a list. Thus, predeformations and inclinations are not individually applied to each member but as a total imperfection to all members of the member list. Load effects of an imperfection on single members in contrast to a member list are shown in Figure 6.55.

Figure 6.53 New Imperfection dialog box

Figure 6.54 Table 3.14 Imperfections
With a list of members, you can apply imperfections across members without having to define continuous members.

**Sets of members**

The imperfection acts on a set of members or on each among several sets of members. Similar to the member list described above, parameters are applied to all members included in the member set.

Sets of members are divided into continuous members and groups of members (see Chapter 4.21). Imperfections for sets of members can only be applied to continuous members that lie on one line. They are not adequate for member groups or continuous members that are buckled.

Precambers are assigned along the total length of the set of members. However, the equivalent loads for inclinations refer to the contained single members.

**On Members No.**

In the text box, enter the numbers of the members or sets of members on which the imperfection acts. You can also select them graphically by using .

If you have selected the graphical input by clicking the button, you have to enter all imperfection data first. After clicking [OK], you can select the relevant members or sets of members one by one in the work window.

For imperfections referring to a list of members, it is possible to suitably arrange the member numbers by using the [Reverse Member Orientation] dialog button to, for example, reverse the inclination for the graphic display. However, the sequence is irrelevant for calculations because of the identical equivalent loads.

**Direction**

The imperfection can only be applied in the direction of the local member axes y or z. When asymmetrical cross-sections are used, the principal axes u and v are additionally available for selection (see Chapter 4.13). It is not possible to define a globally acting inclination or precamber. The reference to the local member axes means: The imperfection is adjusted to the direction of the deformation that occurs in the course of a nonlinear calculation. Thus, imperfections in RFEM are not conservative, i.e. the original direction of the load changes with the member deformation.

The orientation of member axes is described in Chapter 4.17. For symmetrical sections, the axis y represents the so-called 'strong' axis, axis z accordingly the 'weak' axis of the member cross-section.

If the model type has been reduced to a planar system in the general data, you can only access the
direction z.

Reference

The values for inclination and precamber can be defined in two ways: Relative allows for entering the reciprocal values of $\phi_0$ and $e_0$ in relation to the member length, Absolute allows for directly specifying geometric dimensions.

Inclination $1/\phi_0$

$\phi_0$ indicates the degree of inclination as it is described, for example, in EN 1993-1-1, clause 5.3.2. Enter the reciprocal value of $\phi_0$ or the absolute value into the text box. An illustration of parameters can be displayed in the dialog box by using the [Info] button.

In addition, the [Calculate inclination] button in the dialog box allows you to determine inclinations according to different standards in a separate dialog box.

Precamber $L/e_0$

The precamber $w_0$ or $e_{0,d}$ defines the degree of deflection to be applied according to the standard (e.g. DIN 18800 part 2, el. (204) or EN 1993-1-1, clause 5.3.2). The precamber depends on the buckling stress curve of the cross-section and is related to the member length $L$ or entered as an absolute value.

Activity Criterion

The following options are available to select how precambers are handled in the interaction with member inclinations:

- Always

Precamber is taken into account in all cases.
EN 1993-1-1 (5.8)
The influence of the precamber $e_{0,d}$ is applied to members with a slenderness $\lambda$ determined according to EN 1993-1-1:2005, clause 5.3.2 (6), Eq. (5.8).

DIN 18800
$w_0$ is only applied if the member coefficient $\varepsilon$ exceeds a certain value. This regulation refers to DIN 18800, part 2, el. (207).

Manually
The activity criterion can be specified by the user.

To display the criteria in the dialog graphic, use the [Info] button.

Apply $w_0$ from $\varepsilon_0$
A precamber is considered in addition to the inclination if the member coefficient $\varepsilon$ is higher than the value defined in this text box. DIN 18800-2 el. (207) specifies $\varepsilon > 1.6$ for most cases.

Generated Loads
RFEM provides several generators that you can use to easily create loads (see Chapter 11.8). Generated member or surface loads can be found in Table 3.15 and in the Data navigator.
The original generator dialog boxes are stored as specific load objects and can also be accessed for modifications: Double-click a navigator item or use the button to once more open the initial dialog box (see for example Figure 11.194) where you can adjust the load generation parameters.

In the load shortcut menu and the Display navigator, you can select whether the generated loads are displayed as a surface load symbol or Separately as member loads.
7 Calculation

7.1 Checking Input Data

Before you start the calculation, it is recommended to check the model and load data as well as the modeling. RFEM checks if data for each model and load object is completely available, if references of data sets are alright, and if the modeling is correct.

Possible input errors can be quickly corrected, as you can directly access the table row with the relevant problem (see Figure 7.2).

7.1.1 Plausibility Check

You can check both model data and load data for their coherency of input. To open the dialog box for the plausibility check, use the menu option

Tools → Plausibility Check

or the corresponding toolbar button.

A dialog box opens where you can define the input data that you want to check.

In the Type of Check dialog section, you can choose between three options:

- **Normal**
  
  The standard option checks the completeness of input parameters and the correctness of data records.

- **With warnings**
  
  Select this option to carry out a detailed check of the input data that also searches for nodes with identical coordinates or releases with unlimited degrees of freedom.

  When a discrepancy is detected, a message appears with detailed information about the problem. You can interrupt the check in order to correct the mistake.

![Plausibility Check dialog box](image)

![Plausibility check with warnings](image)
### None, only statistic

Only a summary of input data is reported (model dimensions, total weight, number of nodes, lines, supports, surface and member loads, etc.).

If the Generate FE mesh check box is selected, the FE mesh can be generated during the plausibility check. For more detailed information, see Chapter 7.2.

If the plausibility check was successful, the check's result appears, showing you a summary of input data.

![Figure 7.3: Result of plausibility check, Model Data tab](image)

### 7.1.2 Model Check

In addition to the general plausibility check, you can use the model check to specifically search for discrepancies produced during the modeling. Go to the menu and select

**Tools → Model Check**

where you can select one of several check options.

### Identical Nodes

RFEM filters all nodes with identical coordinates. They are combined into groups and shown in a dialog box.

![Figure 7.4: Result of model check for identical nodes](image)
In the What is to happen with identical nodes? dialog section, you can decide how double nodes are treated. In the Apply action to dialog section, you can define whether your selection applies to all groups listed above or only to the selected row.

In the Tolerance dialog section, a fine tuning is available to define the zone where coordinates are evaluated as being identical. This feature is especially useful for models imported from CAD programs. In such a case, lines are often short because of nodes that lie closely together. If such nodes are filtered with a suitable tolerance and then unified, it is possible to avoid numerical problems due to short members or lines.

**Overlapping Members**

Use this option to filter all members that overlap partially or entirely in their lengths.

If overlapping members are detected, they are shown in a dialog box where they are sorted by groups. In the work window, the current group is indicated by an arrow. After clicking [OK], you can fix the problem.

**Crossing Not Connected Members**

The check searches for members that cross each other but do not have a common node at the point of intersection.

The check’s results are shown in the Groups of Crossing Not Connected Members dialog section. The crossing members are listed in groups. The group that is currently selected is indicated by an arrow in the graphic.

In the What is to happen with dialog section, you decide what you want to do with the crossing members. The Connect members option is useful for actual ways to transfer internal forces, but not for ordinary diagonal crossings with ties, for example.

**Overlapping Lines**

Use this option to filter all lines that overlap partially or entirely in their lengths.

If overlapping lines are detected, they are shown in a dialog box where they are sorted by groups. In the work window, the current group is indicated by an arrow. After clicking [OK], you can fix the problem.
Crossing Not Connected Lines

Use this option to search for lines that cross each other without sharing a common node at the point of intersection. As with members, the result is shown in the Groups of Crossing Not Connected Lines dialog section (see Figure 7.5). The crossing lines are listed in groups; the currently selected group is indicated by an arrow in the graphic.

The What is to happen with dialog section allows you to decide how to handle the crossing lines.

Overlapping Surfaces

Use this option to filter all partially or entirely overlapping surfaces.

If overlapping surfaces are detected, they are shown in a dialog box where they are sorted by groups. In the work window, the current group is indicated by its selection color. After clicking [OK], you can fix the problem.

Minimally Curved Surfaces

With this control option, you can search for surfaces that have a minor plane deviation.

If surfaces with minor curvatures are detected, they are shown in a dialog box where they are sorted by groups. In the work window, the current group's node that deviates from the plane is indicated by an arrow.

The What is to happen with dialog section provides specific control options for handling such surfaces. The Apply action to dialog section allows you to decide whether your settings apply to all groups listed above or only to the selected surface.

In the Tolerance dialog section, a fine tuning of the plane definition is available. In case of modifications, it is possible to Check again with other tolerance on curved surfaces.
Buttons

The buttons in the dialog boxes of the model check have the following functions:

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Image" /></td>
<td>Applies changes of What is to happen with dialog section.</td>
</tr>
<tr>
<td><img src="image2.png" alt="Image" /></td>
<td>Jumps to RFEM work window to adjust the view.</td>
</tr>
<tr>
<td><img src="image3.png" alt="Image" /></td>
<td>Exports listed objects to Excel table.</td>
</tr>
<tr>
<td><img src="image4.png" alt="Image" /></td>
<td>Creates a new partial view for each object group.</td>
</tr>
</tbody>
</table>

| Table 7.1 | Buttons in dialog boxes of model check |

7.1.3 Regenerate Model

RFEM automatically revises small inconsistencies in the model produced during the modeling process or arising from data exchange with CAD programs. To access this function, use the menu option Tools → Regenerate Model.

In the Unite Close Lying Nodes dialog section, define a threshold for the distances of nodes: When values fall below the Tolerance, nodes are considered to be identical and combined into a single node. Since redundant nodes are deleted, a renumbering of objects may result.

The Consider Lines/Members as Vertical dialog section allows you to control the position of local line and member axes. The orientation of axes for members in vertical position differs fundamentally from members in general (inclined) position (see Chapter 4.17). To impose a vertical position for a general position, you can use the Tolerance text box. Thus you prevent the member axes from "switching", which is also favorable for load input and output of internal forces.

Use the options in the Integrate Nodes Automatically in Surfaces dialog section for nodes with only a very small distance to a surface or boundary line to automatically include them in the list of integrated objects of the surface (see Integrated Objects). As a result, a manual integration of the nodes is unnecessary. Please note that an internal check is carried out before the calculation starts: If the nodes' distance to the surface is too large, they are considered as not belonging to the surface.

You can activate a feature to automatically Round Node Coordinates in the dialog section. For this, define the relevant number of decimal places.
7.1.4 Deleting Unused Loads

Loads can only be defined on objects that exist in the model. During the modeling process, members or surfaces with assigned loads may be removed from the system. Normally, RFEM automatically deletes their loads as well. If the plausibility check should still detect a flaw, it is possible to remove loads on non-existent objects by using the menu and selecting 

**Tools → Delete Loads → Not Used.**

The menu is shown on the left. In this menu, you can specifically select other load objects for removal.

FE Mesh

With RFEM, you can analyze member elements, plates, walls, shells, and solids. Before you calculate data, the FE mesh must be generated to create the corresponding 1D, 2D, and 3D elements.

The FE analysis requires the division of the structural system into small subsystems represented by finite elements. Equilibrium conditions are set up for each element. A linear system of equations with a lot of unknown factors is created. The more refined the mesh size of the finite elements is, the more precise the results will be. On the other hand, computing time increases enormously due to the amount of calculated data, as additional equations must be solved for every additional FE node.

The FE mesh is created automatically. However, there are some options that can be used to control the mesh generation.

Useful information regarding discretization and the finite element method can be found in [5].

7.2.1 Basics of Finite Elements in RFEM

1D elements

For member elements, it is assumed that the cross-section remains planar when deforming. 1D member elements are used to display beams, trusses, ribs, cables, and rigid couplings. In total, a 1D member element has 12 degrees of freedom: six at the start and six at the end of the element. They refer to displacements \((u_x, u_y, u_z)\) and rotations \((\phi_x, \phi_y, \phi_z)\). When calculating structural data linearly, tension, compression, and torsion are expressed as linear functions of the member axis \(x\), independent of bending and shear. They are approximated by a 3rd order polynomial in \(x\), including influence of shear stresses resulting from the shear forces \(V_y\) and \(V_z\). The stiffness matrix \(K_{f(12,12)}\) describes the linear behavior of the 1D elements. The mutual interaction between axial force and bending in case of geometrically nonlinear problems is expressed in the stiffness matrix \(K_{nl(12,12)}\). You can find more information in [6] and [7].

For calculations according to the large deformation analysis, it is recommended to use an FE mesh refinement of lines (see Chapter 4.23) so that results can be calculated accurately.
2D elements

Usually, quadrangle elements are used as 2D elements. The mesh generator adds triangular elements where required.

The degrees of freedom in corner nodes of quadrangle and triangular elements are the same as for 1D elements: degrees of freedom of displacement (ux, uy, uz) and rotation (φx, φy, φz). In this way, the compatibility of 1D and 2D elements in nodes is guaranteed. The parameters are defined in the planar local coordinate system of elements and are converted into the global coordinate system when creating the global stiffness matrix.

![Figure 7.8 Shell elements of RFEM (quadrangle)](image)

The planar shell elements are based on the Mindlin/Reissner theory. Figure 7.8 shows the approaches of elements graphically. To ensure a direct coupling with member elements, a square approach in the shell plane (ux, uy) is chosen. By eliminating the intermediate nodes, a four-node element with an additional degree of freedom φz is created. This allows for wall elements to be directly coupled with beam elements. Based on a mixed interpolation of transversal deformations, cross-section rotations, and transversal shear strains, the MITC4 elements (Mixed Interpolation of Tensortial Components) as presented by Bathe and Dvorkin [8] are also applied.

Presently, member elements are considered by directly solving the differential equation according to the second-order analysis. Drilling effects cannot be considered when using the Saint Venant torsion.

The analysis of membranes is based on the principles of Bergan [9], [10], [11]. For triangular elements, for example, the basic functions are divided into three rigid-body deformations, three constant conditions of strain, and three special linear gradients of stress and strain. Within an element, the deformation field is quadratic and the stress field is linear. The element stiffness matrix KL is subsequently transformed into nine collective parameters of the types ux, uy, φz. The components of this matrix are added to the overall stiffness matrix (18, 18) together with the components that cause bending and shear effects. This matrix is the result of the Lynn/Dhillon concept. Then, so-called Mindlin plates are applied, which means that plates with distinct shear distortion are analyzed according to Timoshenko. Thus, RFEM is able to find the correct solution for both thick and thin plates (Navier plates).

In case of geometrically nonlinear problems, the above-mentioned split of the stress-strain condition into a planar state and bending with shear is not possible. The mutual influences of these states are
considered in the matrix $K_{NL}$. RFEM uses a rather simple but effective type of the $K_{NL}$ matrix that is based on the approaches of Zienkiewicz [12]. The square component $\varepsilon_2$ of the Green/Lagrange strain tensor $\varepsilon = \varepsilon_1 + \varepsilon_2$ is applied. A linear distribution of $u_2(x, y)$ of the planar stress condition and linear distributions of $u_x(x, y)$ and $u_y(x, y)$ of the interaction with bending is assumed. This assumption is possible, because the main effect of the interaction depends on the first derivation of the differential equation, and because the influence of components of a higher order decreases quickly with the division into smaller elements. The correctness of this procedure has been proven in several numerical analyses.

For shell elements, the thickness of the elements must be considerably smaller than their expansion. If this is not the case, it is recommended to model objects as solids. Furthermore, when using shell elements, a point-by-point introduction of torsional stresses should be avoided: The rotational degree of freedom about the surface normal reacts very sensitively.

### 3D elements

The following 3D elements are implemented in RFEM: tetrahedron, pentahedron (prism, pyramid), and hexahedron. For detailed information about applied elements and matrices, see [13]. Corresponding documentation can be requested from Dlubal Software.

Generally, all rotational degrees of freedom must be regarded as critical for solids. As the deformation of a solid is solely determined from the displacement vectors, the rotation of a mesh node, for example due to singularly introduced torsion, does not affect the deformation within the solid.
7.2.2 FE Mesh

To open the dialog box for setting and checking FE mesh parameters, select the menu option `Calculate → FE Mesh Settings`.

This dialog box consists of three tabs.

### 7.2.2.1 FE Mesh Settings

![FE Mesh dialog box, FE Mesh Settings tab](image)

#### General

The `Target length of finite elements` controls the global target length of the mesh. The finer the mesh is, the more precise the results generally are. However, the amount of data to be calculated and the computing time are increased as well, since additional equations must be solved for every additional FE node. Furthermore, singularity effects occur more frequently in a fine-meshed FE mesh.

The discretization is important for the subsequent FE analysis: A mesh size that is too fine slows down the calculation without significantly improving the quality of results. A target length that is too long cannot determine boundary conditions in a satisfying way. The following recommendation can be made for the appropriate lateral length of finite elements: Eight to ten finite elements should be generated between the boundary lines of a surface. If possible, avoid defining less than four elements.

Specify the mesh node’s allowable distance from a line in the second text box of this dialog section. If the distance of a node is larger than the entered value, a new FE node is created for it.

The `Maximum number of mesh nodes` is defined with an upper limit in the last text box of the dialog section to restrict the number of generated nodes and thus ensure the efficiency of the program and computer.
**Members**

For cable, foundation, and tapered members or members with plastic properties, you can specify the number of internal divisions. They lead to a real division of the member by intermediate nodes. However, if a member is arranged on the boundary line of a surface or if the definition line has an FE mesh refinement, the specification has no effect.

To also divide beams by intermediate nodes for a calculation according to the large deformation analysis, select the Activate member divisions for large deformation or post-critical analysis option so that these members are calculated with a higher accuracy. The number of member divisions is determined in the text box above.

If you Use division for straight members, which are not integrated in surfaces, FE nodes are generated on all free members and considered for calculations according to the linear static and second-order analysis. The length of the finite elements is either determined by the global target length $l_{FE}$ set in the General dialog section or entered manually.

With the Use division for members with nodes lying on them option, RFEM generates FE nodes on the locations of the member where end nodes of other members are located, without there being any connection between these members.

**Surfaces**

The most accurate results are determined for elements that are as close as possible to the shape of a square. For a square, the ratio of diagonals is $D_1/D_2 = 1$. In the Maximum ratio of FE rectangle diagonals text box, enter the limit value $\Delta_D$ for the diagonal ratio. If the value is set too high, there is a risk that elements are generated with very acute or reflex angles. This may result in numerical problems.

$$\Delta_D = \frac{D_1}{D_2} \quad D_1 \geq D_2$$

**Figure 7.11** Elements with diagonals $D_1$ and $D_2$

A curved surface is transformed into planar elements when creating the FE mesh. The inclination angle $\alpha$ defines the Maximum out-of-plane inclination of a single quadrangle element. This value describes the angle between the normals of two elements (see the following figure with normals between two triangular elements). If the allowable inclination angle is exceeded, it is divided into additional triangular elements.

**Figure 7.12** Inclination angle $\alpha$
If the model is defined as a plate of the type 2D - in XY, you can specify an FE mesh refinement along lines to create smaller finite elements on all lines and thus better approximate, for example, results along supported lines. The relation \( \Delta b \) refers to the global mesh size. It describes the edge distance of the refinement from the lines.

![FE mesh refinement along the boundary lines of a 2D slab](image)

Select the Integrate unutilized objects into surfaces check box to also generate FE nodes on objects that do not have any specific function for a surface (e.g. free nodes without support or load, constructional lines in surfaces). This function is disabled by default so that structurally irrelevant objects do not warp the FE mesh.

The Shape of finite elements can be determined with the following three options:

- Triangles and quadrangles: default setting
- Triangles only: option in case quadrangles cause strong mesh distortions
- Quadrangles only: option for higher accuracy of results

Use the Same squares where possible and Triangles for membranes check boxes to additionally control the generation of the FE mesh.

The Mapped mesh preferred option tries to align the FE mesh with the boundary lines of surfaces. This type of FE mesh generation can be individually defined for each surface (Edit Surface dialog box, FE Mesh tab).

A mapped mesh is exclusively composed of quadrangles. In general, a mapped mesh provides "more accurate" results. Since less unknown factors also occur in the equation system, this method is recommended for generating the mesh.

**Solids**

If nodes are very close together on a solid, you can define an automatic FE mesh refinement. This way, the FE mesh determines the nodes correctly. The mesh size of the solid is determined from the shortest distance of the nodes. You can use the text box to limit the number of generated 3D elements.

It is possible to enter specific requirements regarding the FE mesh for each solid. This option is described in Chapter 4.5.
7.2.2.2 Mesh Quality Criteria

The parameters of this tab allow you to evaluate the result of the automatic FE mesh generation.

You can set quality criteria for 2D elements of Surfaces as well as for 3D elements of Solids. Furthermore, you can define the criteria that specify when a Warning or a Failure should be displayed.

The quality of the FE mesh can be displayed graphically by using the Display navigator.
### 7.2.2.3 Adaptive mesh refinement

This function allows you to automatically adjust the FE mesh to the requirements of the calculation. The program performs a mesh refinement in several steps. In each step, the FE mesh is recreated based on an error comparison of the results in the previous calculation step. The error indicator for the surface element results is based on the method according to Zienkiewicz-Zhu.

An adaptive mesh refinement eliminates the need to define refinement areas manually. The program does this automatically, reliably, and flexibly.

![FE Mesh dialog box, Adaptive Mesh Refinement tab](image)

After selecting the check box, the parameter fields can be accessed. The **Maximum number of refinement iterations** controls how many steps are carried out during the mesh refinement. The larger the number, the finer the FE mesh becomes in the areas of significant result changes - which can also have an unfavorable effect on the extreme values of singularities. The default setting is therefore only one refinement iteration, which is usually sufficient. The **Average error tolerance** represents the error indicator for the surface elements described above.

To avoid an FE mesh that is too rough, it is possible to specify a **Minimum length of elements**.

The error comparison is carried out for a linear structural analysis. To do this, use the list to define a load case or load combination whose results are the basis for adjusting the FE mesh. This FE mesh is then used for the calculation of all other load cases and combinations.
The following FAQs provide more information about adaptive mesh refinement:

### 7.2.3 FE Mesh Refinements

The generation of the FE mesh can be influenced by FE mesh refinements to refine the mesh on relevant points such as in connection zones. Refinements are also used to achieve a good compromise between result accuracy and computing time.

Basically, there are four types of FE mesh refinements:

- Refinement around a node
- Refinement on a line
- Refinement on a surface
- Refinement on a solid

The definition of FE mesh refinements is described in Chapter 4.23.
7.2.4 FE Mesh Generation

To start the FE mesh generation, select the menu item

**Calculate → Generate FE Mesh.**

Moreover, the FE mesh is generated automatically once you start the calculation of a load case. Before the calculation, however, it is strongly recommended to check the generated mesh regarding whether a sufficient, “harmonic” discretization is present or if refinement areas are still needed.

Conversely, areas of minor relevance for the results evaluation can be covered by a more course-meshed FE mesh. For example, you can define a surface “mesh refinement” with a mesh size larger than the target length $l_{FE}$. This makes it possible to accelerate the calculation as well as the evaluation.

When the FE mesh generation has been successful, select

**Calculate → FE Mesh Statistic**

to open a dialog box with information about the generated FE mesh.

![FE Mesh Statistic dialog box](image)

The statistics show the type and number of the generated finite elements, which is useful for selecting the appropriate equation solving method and to estimate the approximate calculation time (see Chapter 7.3). The FE mesh is automatically deleted when model data is modified. Additionally, it is possible to specifically delete the mesh by selecting

**Calculate → Delete FE Mesh.**

Please note that all results that may be available are deleted as well.
7.3 Calculation Parameters

**Edit Load Cases and Combinations dialog box**

It is possible to define the calculation parameters as early as during the creation of a load case or load combination. Settings can be respectively specified in the Calculation Parameters tab of the Edit Load Cases and Combinations dialog box.

In addition to providing an overview of all load cases and combinations, the Edit Load Cases and Combinations dialog box controls the calculation parameters for each load case, load combination, and result combination.

**Calculation Parameters dialog box**

The calculation parameters can also be accessed in a separate dialog box.

To open the Calculation Parameters dialog box, select *Calculate → Calculation Parameters* in the menu or use the corresponding toolbar button.

The Calculation Parameters dialog box consists of five dialog tabs. The first three tabs manage the calculation parameters of each load case or each load and result combination. In the fourth tab, *Global Calculation Parameters* (see Figure 7.27), you can check and, if necessary, adjust specifications that are universally valid. The fifth tab manages the Calculation Diagrams.
7.3.1 Load Cases and Load Combinations

The Existing Load Cases or Existing Load Combinations dialog section lists all defined load cases and combinations. You can adjust the Calculation Parameters of the selected entry in the dialog section to the right.

The [Apply settings] button assigns the current specifications to all load cases and combinations.

This dialog tab is divided into the Calculation Parameters tab and, if applicable, the Modify Stiffness (see Figure 7.22), Extra Options (see Figure 7.23), and Deactivate tabs (see Figure 7.25).
7.3.1.1 Calculation Parameters

Method of Analysis

This dialog section allows you to control whether the load case/combination is calculated according to the Geometrically linear static, Second-order, or Large deformation analysis. Select the Postcritical analysis option to carry out a stability analysis according to the large deformation analysis with regard to postcritical failure of the entire structure.

RFEM presets the linear calculation according to the linear static analysis for load cases and the nonlinear calculation according to the second-order analysis for load combinations.

If the model includes cable members, the calculation according to the large deformation analysis is preset in all cases.

Second-order analysis

The common "structural" second-order analysis is used to determine the equilibrium on the deformed system. Deformations are assumed to be small. If axial forces are available in the system, they lead to an increase in bending moments. Thus, the calculation according to the second-order analysis by Timoshenko [14] only has an effect if axial forces are considerably higher than shear forces. The additional bending moment $\Delta M$ results from the axial force $N$ and the elastic lever $e_{el}$.

$$ M = N \cdot e_{el} $$

Equation 7.1

For structural systems subjected to pressure, there is an overlinear relation between loading and internal forces. Normally, you also have to calculate with $\gamma$-fold actions.

The axial force difference in the iterations represents the break-off criterion. For member elements, the stiffness-modifying axial force decisive for the second-order analysis is assumed to be constant along the entire member. The calculation stops as soon as you fall short of a certain value of the normal force difference. It is possible to influence this break-off limit in the Precision and Tolerance dialog section of the Global Calculation Parameters dialog tab.

For nonlinear calculations according to the second-order analysis, assumptions of the linear elastic analysis are the same, with the following additions:

- No plastic deformations occur.
- The external forces stay true to the direction.
- For members with a non-constant axial force (e.g. columns), the mean value of the axial force $N$ is applied for determining the member coefficient $\varepsilon$.

Large deformation analysis

The large deformation analysis ("third-order theory") takes longitudinal and transversal forces into account during the analysis of internal forces. If the calculation according to the large deformation analysis is selected, all surfaces and members are calculated according to this calculation theory.

After each iteration step, the stiffness matrix for the deformed system is created. There are significant differences between loads that are defined as local and global: For example, if a surface load defined as global in $Z$ acts on a floor, it keeps its direction if the finite elements warp. But when the load is effective in direction of the local surface axis $z$, it warps on each element according to the element's warping.
Postcritical analysis

A stability analysis with regard to postcritical failure is performed. The method represents a modified calculation according to the large deformation analysis by Newton-Raphson where the influence of axial forces is considered for changes in shear and bending stiffness. The tangential stiffness matrix is saved in each iteration step. If there are singularities (i.e. an instability), the stiffness matrix of the previous iteration step is used for new, geometric, incremental iterations until the tangential stiffness matrix of the current setting becomes regular (stable).

Method for solving of system of nonlinear equations

There are six available methods for solving the nonlinear, algebraic system of equations:

Newton-Raphson

The approach according to Newton-Raphson is preset for the large deformation analysis. The nonlinear equation system is solved numerically by means of iterative approximations with tangents. The tangential stiffness matrix is determined as a function of the current state of deformation; it is inverted in each cycle of iterations. In the majority of cases, a fast (quadratic) convergence is reached.

You can influence the convergence behavior with the number of load increments set in the Global Calculation Parameters dialog tab.

Newton-Raphson combined with Picard

First, the approach according to Picard is applied (see below). After a few iterations, the program changes to the Newton-Raphson method. The basic idea of this approach is to use the relatively strong Picard method for the first iteration steps to avoid instability messages. This initial approximation is followed by the fast method according to Newton-Raphson to find the ultimate state of equilibrium.

In the Settings dialog section of the Global Calculation Parameters dialog tab, you can define the percentage that is used for iterations according to Picard when the combined method is applied (see Figure 7.27).\footnote{Figure 7.27}

Picard

The method according to Picard, also known as secant method, can be understood as a finite difference approximation of the Newton method. The program takes the difference between the current and original iteration run in the current load increment step into account.

Often, converging is slower than in the calculation method according to Newton-Raphson. But the method proves to be stronger in regard to nonlinear problems, making the calculation more stable.

Newton-Raphson with constant stiffness matrix

This version of the Newton-Raphson method can be selected for calculations according to the large deformation analysis. The stiffness matrix is created only once in the first iteration step and then used in all subsequent calculation loops.

Thus, the calculation runs faster but is not as stable as calculations according to the normal or modified Newton-Raphson method.

Modified Newton-Raphson

This method is used to perform the postcritical analysis (see Method of Analysis dialog section above) where a range with instability must be overcome. If an instability is available and the stiffness matrix cannot be inverted, the program uses the stiffness matrix of the last stable iteration step. The program continues to calculate with this matrix until a stability range is reached again.
Dynamic relaxation

The final method is suitable for calculations according to the large deformation analysis and for solving problems regarding the postcritical analysis. In this approach, an artificial time parameter is introduced. Taking inertia and damping into account, the failure can be handled as a dynamic problem. This approach uses the explicit time-integration method; the stiffness matrix is not inverted. No part of the model is allowed to have a specific weight of zero when calculating with dynamic relaxation.

This method includes the Rayleigh damping that can be defined by means of the constants $\alpha$ and $\beta$ according to the following equation with the time derivatives:

$$M \frac{d^2 u}{dt^2} + C \frac{du}{dt} + K(u)u = f$$

Equation 7.2

where

- $M$: Concentrated (diagonal) mass matrix
- $C$: Diagonal damping matrix $C = \alpha M + \beta \text{diag}[K_{11}(u), K_{22}(u), ..., K_{nn}(u)]$
- $K$: Stiffness matrix
- $f$: Vector of external forces
- $u$: Discretized displacement vector

Options

Modify loading by factor

After selecting the check box, you can enter a factor into the text box, which all the loads contained in the load case or combination will be multiplied with (does not apply to imperfections). The factor is also reflected in the load vectors and values of the graphic. Generally, negative factors are also permitted.

Older standards claim to multiply loads globally by a certain factor in order to increase effects for stability designs according to the second-order analysis. On the other hand, design must be carried out with the characteristic loads. Both requirements can be fulfilled by entering a factor larger than 1 and selecting the Divide results by loading factor check box.

When analyzing structures according to current standards, loading should not be edited with any factors. Instead, partial safety factors and combination coefficients must be applied for the superposition in the load and result combinations.

Activate stiffness factors

With these check boxes, you can respectively apply or deactivate the stiffness factors of the materials (see Chapter 4.3), cross-sections (see Chapter 4.13), members (see Chapter 4.17), and surfaces (see Chapter 4.4) in the calculation.

You can find more information about this feature in the following FAQ:

Activate special settings

When selecting the Modify stiffnesses, Extra options, and Deactivate check boxes, additional tabs are accessible. You can set specific requirements for stiffnesses (see Chapter 7.3.1.2) and Objects (see Chapter 7.3.1.4) or activate the initial deformations of a load case or the results of an add-on module for the calculation (see Chapter 7.3.1.3).
Consider favorable effects due to tension of members

Tensile forces have a favorable effect on pre-deformed structural systems. Thus, the pre-deformation is reduced and the structure is stabilized.

There are different opinions on how to consider tensile forces that act in a favorable way. The standards contain regulations, which stipulate that relieving actions must be considered with a smaller partial safety factor than unfavorable effects.

Partial safety factors that vary from one member to the other cannot be realized with an acceptable computational effort. Therefore, RFEM provides the option to generally set tensile forces to zero for calculations according to the second-order analysis. With this approach, you are on the safe side. If you want to use this option, clear the check box.

On the other hand, one can say that standards refer to actions, not to internal forces. Therefore, it is necessary to decide if the action as a whole is favorable or unfavorable. Consequently, if an unfavorable action has a favorable effect in certain zones of the model, it can definitely be considered. Hence, if you want to take account of the axial forces without any changes in the calculation according to this approach, the check box must be selected (default setting).

In the majority of cases, the favorable effect of tensile forces should be considered for halls with bracings or structural systems affected by bending, for example. Relief due to tension force effects for beams with supporting cables may result in an unwanted reduction of deformations and internal forces.

Refer internal forces to deformed structure

For nonlinear calculations, the Refer internal forces to deformed structure option enables the output of axial and shear forces, as well as bending and torsion moments of members in relation to the rotated coordinate systems of the deformed system. There are three check boxes available for the internal force types Normal forces, Shear forces, and Moments.

Calculation of kinematic mechanism

You can try to make an unstable model calculable with this check box: Internally, small springs are applied that stabilize the model for the first iteration. Once a stable initial state is reached, the springs are removed for the subsequent iterations.

Separate number of load increments

You can define an individual number of load increment steps for each load case and each load combination. Thus, the number specified in the Global Calculation Parameters dialog tab is no longer valid (see Chapter 7.3.3).
7.3.1.2  Modify Stiffness

This dialog tab is only displayed when the Modify Stiffness check box is selected in the previous tab, Calculation Parameters.

The settings in this dialog tab only affect the load case or load combination that is selected in the list to the left. The [Apply settings] button transfers the current parameters to all load cases or combinations.

**Materials and Cross-Sections / Supports / Releases**

In the three dialog sections, you can specify how the stiffnesses of the different model parameters are taken into account in the calculation:

- **Multiply all with factor**: Specify a factor that the stiffness of the materials, cross-sections, supports, and releases is globally multiplied with.
- **Individually**: The button opens a new dialog box where a specific stiffness factor can be assigned to every object.
7.3.1.3 Extra Options

This dialog tab is only displayed if the Extra options check box is selected in the Calculation Parameters tab (see Figure 7.21).

**Initial Deformation from Other LC/CO**

Select a load case or load combination whose deformations you want to consider as the initial strain in the calculation. FE nodes are moved accordingly before the calculation starts. If no results are available for the selected load case or combination yet, they are automatically included in the calculation.

Specify the factor with which you want to scale the deformations:

- **Multiply all with factor**: Deformations of members, surfaces, and solids are globally multiplied by the specified factor.
- **Individually**: The button opens a dialog box where a specific scaling factor of the deformation can be assigned to every member, every surface, and every solid.

**Initial Forces for Geometric Stiffness**

You can select a load case or load combination whose axial forces you want to use for an initial deformation. In this way, you can consider the stabilizing effect of a different load case (than the one specified above in the Initial Deformation dialog section), for example.

Access to this dialog section is only available for a calculation according to the second-order analysis.
Stiffness from Module RF-CONCRETE

Stiffnesses of reinforced concrete elements, which result from reinforcements and crack analyses according to the nonlinear design method performed in the RF-CONCRETE modules, can be taken into account in the calculation. After selecting the check box, specify the analysis case of the RF-CONCRETE Members or RF-CONCRETE Surfaces add-on module.

A calculation with the stiffnesses from RF-CONCRETE only succeeds if design cases have been created and if designs are possible without non-designable situations.

Initial Deformation from Module RF-IMP

Imperfections can be considered in the form of a pre-deformed equivalent model created in the RF-IMP add-on module. If this module is not licensed, equivalent imperfections for members (see Chapter 6.14) or initial deformations of a load case (see above) can be applied manually.

A calculation on the pre-deformed equivalent model is possible if the model was previously created in the RF-IMP add-on module. The add-on module generates imperfections on the basis of eigenvalues from RF-STABILITY, RF-DYNAM, or of deformations from an RFEM load case that are scaled to a maximum ordinate.

The equivalent model is stored separately without changing the actual geometrical data. The coordinates of FE nodes are only aligned with the equivalent model once load combinations are calculated.

You can use a different equivalent model for each load combination. Select the relevant case in the Case of module RF-IMP list.
7.3.1.4 **Deactivate**

This dialog tab is only displayed if the Deactivate check box is selected in the Calculation Parameters tab (see Figure 7.21).

![Figure 7.25 Deactivate tab](image)

This tab allows you to ignore specific objects of the model in the calculation. Thus, the effect of temporary members (erection columns) or supports can be analyzed.

After selecting a check box, the input field where the objects’ numbers can be specified is enabled. The objects can also be selected graphically in the model using [Select].
7.3.2 Result Combinations

For basic information about superpositioning load cases in result combinations, see Chapter 5.6.

In the Existing Result Combinations dialog section, you can find a list of all created or generated result combinations. You can edit the Calculation Parameters of the selected entry in the dialog section to the right.

Options

The Quadratic Combination is deactivated by default. Thus, internal forces are superimposed additively:

\[ B = A_1 + A_2 + \ldots + A_n \]

**Equation 7.3**

The default setting is suitable for most application cases. However, a square addition of internal forces is relevant for dynamic analyses when combining load cases due to centrifugal forces, for example. In this case, the Pythagorean sum is created as follows:

\[ B = \sqrt{A_1^2 + A_2^2 + \ldots + A_n^2} \]

**Equation 7.4**

When the square addition is activated, you can use the Positive/Negative options to decide, which extreme values of the load cases are considered in the superposition and if you want to Preserve signs. In this way, the extreme values of the modal internal forces and deformations as well as the results belonging to the governing component can be determined with the correct signs.
7.3.3 Global Calculation Parameters

The Global Calculation Parameters dialog tab manages the settings that are generally applied to all load cases and load combinations. To open the corresponding dialog box, select **Calculate → Calculation Parameters** in the menu or use the corresponding toolbar button.

### Settings

#### Maximum number of iterations

When using the second-order or large deformation analysis as well as objects that are nonlinearly effective, you have to calculate iteratively. The value of the text box defines the highest possible number of calculation runs. The specification has nothing to do with the iterative method set for the system of equations described in the Options dialog section.

When the calculation reaches the maximum number of iterations without achieving an equilibrium, RFEM displays a corresponding message. The results can then be displayed regardless.

**Warning No. 10154**

The calculation did not converge in load case LC1, but the results could be applicable. To achieve more precise results, increase the number of iterations or perform:

Do you want to display the results anyway?

[Yes] [No]
Number of load increments

Specifications of this text box only take effect for calculations according to the second-order or large deformation analysis. Finding an equilibrium is often difficult when large deformations are considered. Instabilities can be avoided by applying the load in several steps.

For example, if two load increments are specified, half of the load is applied in the first step. Iterations are carried out until the equilibrium is found. Then, in the second step, the complete load is applied to the already deformed system and iterations are run again until the state of equilibrium is reached.

Please keep in mind that load increments have an unfavorable effect on the computing time. A value of 1 (no gradual load increment) is therefore preset in the text box.

Moreover, you can define how many load increments you want to apply for each load case and combination separately (see Chapter 7.3.1.1). The global specifications are then ignored.

If the Number of load increments check box is cleared, RFEM automatically determines the required number of load increments. A heuristic method is used to efficiently solve nonlinear tasks. In the text box below, you can define the Maximum number for incrementally increasing loading in order to keep the division into load increments at a tolerable level.

Number of divisions of members for result diagrams

This text box affects the graphical result diagram of members that have no other, distinct FE mesh division (due to an FE mesh refinement or a connected surface, for example). If a division of 10 is set, RFEM divides the length of the longest member in the system by 10. With this system-related division length, RFEM determines the graphical result distributions on the division points for each member.

In the FE Mesh Settings dialog box, there is another division option for straight members that are not integrated in surfaces (see Figure 7.10). With this option, you can create FE nodes on all free members whose results are used for the graphical result diagrams.

Number of divisions of members for special types of members (cable, etc.)

In contrast to the previous division option, a real division of the member is defined by internal intermediate nodes. This specification affects cables, foundation members (contact stresses), tapered members (interpolation of cross-section values), and members with plastic properties (yielding zones), if they have not yet been divided otherwise by FE nodes: This division is irrelevant if a member is placed on a boundary line of a surface or if the definition line has an FE mesh refinement.

Number of divisions of members for determination of max/min values

This value specifies the internal division that the maximum and minimum internal forces of members are determined with. Thus, the division (default setting: 10) represents the basis for the extreme values shown in the results tables and graphic. The division is also used for calculating member internal forces of load combinations.
Subdivisions of FE mesh for graphical results

This controls the accuracy of graphical distributions within the finite elements. The following example compares the results with the divisions 0 and 3.

![Graphical result diagram m-x with division 0 (left) and 3 (right)](image)

Figure 7.29

Percentage of iterations of Newton-Raphson method in combination with Picard

The approach according to Picard acts on the assumption of secant stiffenings, while the method of Newton-Raphson assumes tangent stiffenings (see Chapter 7.3.1). When the calculation option Newton-Raphson combined with Picard is selected, secant stiffenings are used in the first iterations before tangent stiffenings are applied for the remaining iterations.

In the text box, you can define the percentage of the first iterations with secant stiffenings. Specify the value in relation to the total number of iterations.

Options

Activate shear stiffness of members (cross-sectional areas $A_y$, $A_z$)

Considering shear stiffnesses leads to an increase of deformations due to shear forces. The shear deformation is hardly relevant for rolled and welded cross-sections. For solid and timber cross-sections, however, it is recommended to consider the shear stiffnesses for the deformation analysis.

Activate member divisions for large deformation or post-critical analysis

Beams can be divided by intermediate nodes for the calculation according to the large deformation analysis to calculate such members with a higher accuracy. The number of divisions is taken from the text box for cable and foundation members.

Modify stiffness (material, cross-sections, members, load cases and combinations)

Use this check box to globally define whether the adjustment factors of the stiffnesses for materials (see Chapter 4.3), cross-sections (Chapter 4.13), and members (Chapter 4.17) are considered in the calculation of load cases and load combinations. In the member and cross-section dialog boxes, factors of 1.00 are respectively preset. Thus, the check mark in the check box usually does not result in reductions or increases of the stiffnesses.

Consider extra options

If Extra Options have been defined for the calculation parameters of load cases and combinations (see Chapter 7.3.1.3), it is possible to globally activate or deactivate them with this check box.
Check critical forces of members

Exceeding the critical load often leads to an instability message as early as in the first iteration. Use this check box to control if the critical load is checked for trusses, compression members, and buckling members. The defined effective lengths of members will be taken into account.

Method for system of equations

Both options control the method used for solving the equation system: Direct or Iterative. To prevent misunderstandings: When solving the equation system directly, an iterative calculation is performed as well if there are nonlinearities or if data is calculated according to the second-order or large deformation analysis. Direct and Iterative refer to the data management during the calculation.

Which solver method leads to results more quickly depends on the complexity of the model as well as the size of the available main memory (RAM):

- For small and medium-sized systems, the Direct solver method is more effective.
- For large and complex systems, the Iterative method leads to results more quickly.

Once the matrices for the direct method can no longer be stored in the main memory, Windows starts to swap parts of the data to the hard disk, which slows down the calculation. Hard disk activities increase and the processor load is reduced, which is visible in the Windows Task Manager. By using the iterative ICG (Incomplete Conjugate Gradient) calculation method, you can avoid this storage problem.

It is necessary to ensure that the swap file is large enough or the file size is assigned automatically by Windows. When a swap file is too small, program crashes may occur.

Use the menu item Options ➔ Program Options or the toolbar button shown on the left to open the Program Options dialog box. In the Help Assistant dialog tab, you can define the number of 2D and 3D elements that must be exceeded for RFEM to show a warning before the calculation with the direct method.
Plate bending theory

Surfaces can be calculated according to the bending theories of Mindlin or Kirchhoff. The calculation according to Mindlin includes shear force deformations; in the calculation according to Kirchhoff, they are not considered. The Mindlin calculation option is therefore suitable for relatively thick plates and shells used in solid construction, while the Kirchhoff option is recommended for surfaces that are relatively thin such as metal sheets in steel construction.

Solver version

The direct method for solving the system of equations (see above) is based on an analysis core using the extended RAM memory capacities of 64-bit operating systems. This makes it possible to efficiently calculate all load cases and load combinations at once even for big structural systems, provided that no object nonlinearities become effective. The RAM memory must be large enough to cover the stiffness matrix and all loading.

Precision and Tolerance

Only rarely is it necessary to adjust the preset convergence and tolerance parameters. Select the Change standard settings or Penalty stiffness associated with zero-energy modes check boxes to enable the respective text boxes.

Precision of convergence criteria of nonlinear calculation

If nonlinear effects are involved or if the calculation is carried out according to the second-order or large deformation analysis, you can influence the calculation by means of convergence criteria.

The change of axial forces in the two last iterations is compared member by member. As soon as this change reaches a specific fractional amount of the maximum axial force, the calculation stops. During the iteration process, however, it is possible for axial forces to oscillate between two values instead of converging. A sensitivity can be defined with the value entered in this text box in order to neglect this oscillation effect.

The accuracy also affects the convergence criterion for deformation changes in calculations according to the large deformation analysis, where geometric nonlinearities are considered.

The default value is 1.00. The minimum factor is 0.01, the maximum value 100.00. The higher the factor, the less sensitive the break-off limit.

Tolerance for detection of instability

There are different approaches according to which the stability behavior of a model can be analyzed. However, none of them is able to detect singular stiffness matrices with absolute reliability.

RFEM uses two procedures to determine the instability: On the one hand, elements on the principal diagonal of the stiffness matrix are always compared with the same number in the iterations; on the other hand, each element of the principal diagonal is analyzed in relation to the adjacent number. The tolerance can be adjusted in the text box. The smaller the value is, the less sensitively the analysis is performed.

Relative setting of time step for Dynamic Relaxation

The time parameter controls the calculation as per the method of dynamic relaxation (see Chapter 7.3.1.1). The smaller the value, the smaller the time step and the more accurate the results.

Robustness of iterative calculation

In case of convergence problems with the Newton-Raphson method, you can increase the robustness to prevent the solution from being "skipped". It may be necessary to increase the maximum number of iterations.
Settings for cables and membranes

With the button, a dialog box opens where you can activate an initial prestress for cables and membranes. Moreover, it is possible to consider the effect of membranes for compressive forces. In doing so, you can often improve the robustness of the calculation and the convergence behavior.

Penalty stiffness associated with zero-energy modes

The FEM calculation uses a reduced Gaussian integration to suppress the stiffening effects of shear and spatial strain, for example when creating the stiffness matrix. However, spurious zero-energy modes are also associated with this reduced integration because the deformations do not cause stresses in the system.

For four-sided 2D elements, two types of zero-energy modes are possible, which describe the shape of an hourglass ("hourglass mode") or uniform rotation ("equal rotations mode"). For triangular elements, only a uniform rotation occurs.

To solve the problem, the potential energy of the finite element is provided with a little additional elastic energy ("penalty energy"), which counteracts these rotations. The detailed description of this approach including equations is given in [4].

For certain situations, however, it is possible that the basic value of the penalty stiffness is insufficient and the deformations of the model are too large due to the non-physical forms of energy described above. In this case, the penalty stiffness can be adjusted separately for shell elements and solid elements. Scaling factors between 0.01 (basic value) and 100 (maximum value) are possible.

If the check box is cleared, the default value 0.01 is used, with the exception of the following two cases:

- For a nonlinear material model for solids, the default factor of 1.0 is taken into account for solid elements.
- To determine the gas solids, RF-GLASS applies the default values 0.1 for linear or 1.0 for physically nonlinear 3D elements.

Nonlinearities

If non-linearly acting elements are used in the model, you can deactivate the effect of the following elements for the calculation:

- Failing supports/foundations (Chapter 4.7, Chapter 4.8, Chapter 4.9)
- Failing members (Chapter 4.17)
- Member hinges (Chapter 4.14)
- Member nonlinearities (Chapter 4.20)
- Contact solids (Chapter 4.5)
- Material nonlinearities (Chapter 4.3)
- Thermal-elastic properties (Chapter 4.3)
The nonlinear effects should only be suppressed for testing purposes in order to find the cause of an instability, for example. The options in this dialog section help you to find errors: Incorrectly defined failure criteria are sometimes responsible for calculation break-offs.

**Reactivation of Failing Members**

Settings in this dialog section concern member elements that may fail (e.g. tension members, compression members, or foundation members). These options allow you to solve instability problems caused by failing members: A model is stiffened by ties, for example. Because of post shortenings due to vertical loads, the ties receive small compressive forces in the first calculation run. They are removed from the system. In the second calculation run, the model is unstable without these ties.

**Check deformation of failing members and reactivate where appropriate**

If this check box is selected, RFEM analyzes the nodal displacements in each iteration. If, for example, the member ends of a failed tie move away from each other, the member is reactivated.

In some cases, reactivating members may be problematic: A member is removed after the first iteration, reactivated after the second one, removed again after the third iteration, etc. The calculation would run this loop until it reaches the maximum number of iterations, without converging. This effect can be avoided by defining a Maximum number of reactivations, which specifies how often a member element is permitted to be reactivated before it is definitively removed from the stiffness matrix.

**Exceptional handling**

After selecting the check box, two methods for the handling of failing members are available for selection. They can be combined with the reactivation option described above.

- **Failing members to be removed individually during successive iterations**
  
  After the first iteration, RFEM does not, for example, remove all tension members with a compression force at once, but only the tie with the greatest compressive force. In the second iteration, only one member is then missing in the stiffness matrix. Subsequently, the tie with the greatest compressive force is removed again. Because of redistributing effects, a better convergence behavior can usually be achieved for the system in this way.

  This calculation option requires more time because the program must go through a larger number of iterations. Furthermore, you have to make sure that a sufficient number of possible iterations is set in the Settings dialog section above.

- **Assign reduced stiffness to failing members**
  
  The failed members are not removed from the stiffness matrix, but are instead assigned a very small stiffness. Specify it in the Reduction factor of stiffness text box: A factor of 1000 signifies a reduction of the stiffness to 1/1000.

  For this calculation option, please keep in mind that RFEM displays small internal forces on members, which can technically not be absorbed by the member due to its definition.

**Pipe Internal Pressure**

The check box is important for the Pipe internal pressure member load. The so-called Bourdon effect describes the effort of a bent pipe to straighten under the influence of pressure. The perimeter stresses and axial stresses from internal pressure load lead to a longitudinal strain of the pipe when considering the material stiffness and transversal strain.

An example for calculating pipe internal pressure is described in the following technical article:
### 7.3.4 Calculation Diagrams

In the last tab of the dialog box, you can set user-defined options for diagrams that are displayed during the calculation (see Figure 7.38). These graphics and values are also available after the calculation. With them, it is possible to check the convergence diagram or the deformation of a node (e.g. supports with nonlinear properties).

The **Existing Diagrams** list provides an overview of the calculation diagrams \(CD\) defined in the current model. Use the button to create another calculation diagram with a description.

The **Vertical Axis** represents the x-axis, the **Horizontal Axis** the y-axis of the calculation diagram. You can select the respective **Result type** from the lists. The deformsations can be related to a deformation \(u\) or a rotation \(\phi\) in the **Value** list.

For the deformations of a node or FE-node, you can select the number of the relevant object from the list or in the work window by using .

During the calculation, a diagram that shows the development of deformations is displayed (see Figure 7.38). This graphic as well as the values displayed in it are also available in the **Calculation Diagrams** tab after the calculation (see figure above).

Use the button for an enlarged display of the diagram in a new window.
Starting the Calculation

There are several ways to start the calculation. It is recommended to perform a short plausibility check of input data beforehand (see Chapter 7.1.1). 

Calculate All

To start the corresponding function, use the menu item

**Calculate → Calculate All**

or the corresponding toolbar button.

This command starts the calculation of all load cases, load combinations, and result combinations, as well as all add-on modules where input data is available.

The [Calculate All] function should be used with care:

- Some load cases cannot occur on their own. Wind loads, for example, always act together with self-weight. For structures with failing supports for tension, instabilities may occur during the batch calculation of all single load cases.
- If many load combinations and module design cases are available, RFEM may need a lot of computing time.

Calculating selected load cases

To open the dialog box for selecting the load cases relevant for calculation, use the menu option

**Calculate → Calculate All.**
In the Not Calculated dialog section on the left, RFEM lists all load cases, load combinations, result combinations, and analysis cases of add-on modules for which no results exist. Use the button to transfer the selected entries into the Selected for Calculation list. You can also double-click the items. To transfer the entire list to the right, use the button.

If result combinations or add-on module cases that require results from load cases are selected, the relevant load cases are automatically included in the calculation.

The list can be sorted according to certain criteria with the filter options shown on the left.

The button opens the Calculation Parameters dialog box (see Chapter 7.3) where you can check and adjust settings for the calculation.

The Result Tables tab of the To Calculate dialog box controls, which tables are available after calculation.

Additional filter options are available for some results tables. They are presented in Chapter 8 together with the respective output tables (see Figure 8.14, for example).

**Calculating current load case**

It is possible to directly start the calculation of an individual load case: Select the load case, load combination, or result combination in the toolbar list, then click the [Show Results] button.
The calculation can be started after a message has been displayed that says that no results have been found.

**Calculating selected results**

The Calculate toolbar menu provides additional options for selecting results you want to calculate:

- RFEM results only
- Modules results only
- All results of all open models
- RFEM results only of all open models
- Modules results only of all open models

The calculation starts immediately after calling the corresponding function.

**Calculation process**

The calculation process is shown in the **FE-Calculation** window. In a diagram of the convergence process, you can observe the shapes of the maximum displacements in addition to the passed calculation steps.

The green or red vertical bars on the right in the window visualize the convergence behavior during the calculation: Each load increment takes up a part of the column; for example, 4/5 in the figure above is the fourth of five load increments. When the bar is green, deformations are in a tolerable zone, whereas a red bar symbolizes oversized displacements or rotations (≥ 0.1 rad).
8 Results

Generally, it is to be noted that any FE analysis is an approximation. Results should be interpreted and checked for plausibility with engineering expertise.

When data has been calculated, the Results tab (see Chapter 3.4.3) for controlling the graphical results display additionally appears in the navigator. The results are listed numerically in separate tables (see Chapter 3.4.4).

Colored relation scales in tables

The result columns of tables are sometimes highlighted in red or blue (see Figure 8.3). These colored bars represent result values graphically. They are scaled to the extreme values of the internal forces or deformations of all objects. Negative values are symbolized by red bars, positive ones by blue bars. Thus, the table also allows for a visual result evaluation.

To switch the colored bars on and off, use the menu item

Table → View → Colored Relation Scales

or the corresponding button in the table toolbar shown on the left.

Table filter

The displayed tables depend on the selections set in the Result Tables dialog tab of the To Calculate dialog box (see Chapter 7.4).

Results - Summary

Table 4.0 Results - Summary provides a summary of the results, sorted by load cases and combinations.

![Figure 8.1 Table 4.0 Results - Summary](image-url)
This overview shows the check sums of loadings and support forces. The deviations in each direction should be less than 1%. If this is not the case, there are numerical problems due to considerable differences in stiffness. It is also possible that the model has insufficient stability, or that the calculation has reached the maximum number of iterations without converging. The overview also provides information about the resulting support reactions that are effective in the model’s centroid in an idealized way.

This summary also shows the maximum displacements and rotations related to the global axes X, Y, and Z, as well as the largest total displacement. Due to the check of deformations, the results’ reliability can be evaluated.

The summary that is listed by load cases is completed by the used calculation parameters. The Number of iterations required to obtain the results is of particular interest here.

The table ends with an overall summary of selected parameters of the analysis core as well as globally valid calculation specifications (see Figure 7.27).

## 8.1 Nodes - Support Forces

With the entries under Support Reactions in the Results navigator, you can control, which components are graphically displayed in the work window. They can be related to the local axes of rotated supports or to the global axis system XYZ. Table 4.1 shows the support forces and moments in numerical form.

If the structure is a 2D model, RFEM only displays the table columns of support forces and moments that are relevant for a planar structural system.

To display the support reactions of a particular load case, select the load case from the list in the main toolbar or the toolbar of the table.
Support Forces $P_X / P_Y / P_Z$

The support forces are listed in three table columns where they are sorted by nodes. Usually, the forces refer to the axes $X$, $Y$, and $Z$ of the global coordinate system. To display the forces related to the local support axes $X'$, $Y'$, and $Z'$ (rotated supports) in the graphic as well as in the table, go to the Results navigator and use **Support Reactions → Nodal Supports → Local**.

Nodes with support rotations are marked by an asterisk (*) as shown in Figure 8.3. Forces are output in relation to the selected axis system. In the last table column, the support’s rotation angle is indicated.

The table shows the forces that are introduced into the support. Thus, with regard to signs, the table does not show the reaction forces on the part of the support. The signs result from the direction of the global axes. If the global axis $Z$ is directed downwards, the load case self-weight, for example, results in a positive support force $P_Z$ and a wind load against the global axis $X$ results in a negative support force $P_X$. Thus, the support forces shown in the table represent the foundation loads.

Conversely, the green vectors displayed in the graphic show the reaction forces on the part of the supports. The components of the support reactions are visualized by the size and direction of the vectors.

You can display the signs of support reactions in the work window. Go to Results in the Display navigator and select the corresponding check box.

![Figure 8.4](display.png)

The signs in the graphic refer to the global axis system $XYZ$ or the rotated local axis system $X'Y'Z'$. It is advisable to only display these signs for the introduced forces, as they may otherwise lead to misinterpretations.

Support Moments $M_X / M_Y / M_Z$

The support moments are listed in three table columns where they are sorted by nodes. Usually, the moments refer to the axes $X$, $Y$, and $Z$ of the global coordinate system. Use the Results navigator to display the moments related to the local support axes $X'$, $Y'$, and $Z'$ in the graphic as well as in the table.
The table shows the moments that are introduced into the support. As for the support forces, the table does not show the reactions on the part of the support in regards to signs. The signs result from the direction of the global axes. Thus, the support moments in the table represent the foundation loads.

In the work window, however, reaction moments on the part of the supports are shown.

Signs for support moments can be displayed in the graphic as well (see Figure 8.4). A positive support moment acts clockwise about the corresponding positive global axis. Similar to the vectors for support forces, vectors are already signed, and indications of value have to be considered independently: The signs indicate the directions of the moments in relation to the global axes.

In the graphic, support moments can be represented as a vector or arc. To change the display type, use the menu option Options → Display Properties → Edit.

On the left, select the Results → Support Reactions → Nodal Moments Category, then select the Arc display option on the right.

**Rotated nodal supports**

In the last table column, the rotation angles of rotated nodal supports are indicated (see Figure 8.3). The corresponding nodes are marked by an asterisk (*).

**Check sums**

For load cases and load combinations, RFEM displays check sums of loads and support reactions at the end of the table. Differences will occur between $\sum$ Forces and $\sum$ Loads if the model additionally has line supports and members or surfaces with elastic foundations. Therefore, the $\sum$ Forces available in Tables 4.3, 4.7, and 4.21 must also be considered for the total summary.

**Importing support forces as load**

Nodal support forces and moments of another RFEM model can be applied as loads in the current model. Thus, loads can be transferred from floor to floor to analyze 2D floor slabs. This function is described in Chapter 8.3.

Imported nodal support forces are applied as free concentrated loads.
Filtering support forces of result combinations

For result combinations, the default setting of the extreme values shown in the results table can be adjusted by using the menu item

Table → View → Result Filter

or the corresponding button in the table toolbar shown on the left.

![Table Filter dialog box (section)](image)

The check boxes in the Table Filter dialog box control the type and extent of the numerical output.

Resultants of support reactions

The resultants of support reactions for load cases and load combinations are shown in Table 4.0 Results - Summary for each global direction (see Figure 8.1). Use the Results navigator to also visualize the resultant forces on the model.

![Results navigator: Support Reactions → Resultant](image)

In addition to the total resultant $P$, you can display the individual Components that are effective in the model’s centroid in an idealized way. Thus, you can check the position and size of the resulting support forces at a glance.
8.2 Nodes - Deformations

To control the graphical display of nodal displacements and nodal rotations, select the Global Deformations check box in the Results navigator. Table 4.2 shows the deformations of nodes in numerical form.

![Figure 8.8 Results navigator: Global Deformations](image)

![Figure 8.9 Table 4.2 Nodes - Deformations](image)

The displacements and rotations are listed by nodes.

**Displacements / Rotations**

The deformations have the following meanings:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>u</td>
<td>Total displacement</td>
</tr>
<tr>
<td>uₓ</td>
<td>Displacement in direction of the global axis X</td>
</tr>
<tr>
<td>uᵧ</td>
<td>Displacement in direction of the global axis Y</td>
</tr>
<tr>
<td>u₂</td>
<td>Displacement in direction of the global axis Z</td>
</tr>
<tr>
<td>φₓ</td>
<td>Rotation about the global axis X</td>
</tr>
</tbody>
</table>
8.3 Lines - Support Forces

The entries under Support Reactions in the Results navigator allow you to control, which components are displayed graphically in the work window. They can be related to the local axes of rotated supports or to the global axis system XYZ. Table 4.3 shows the support forces and moments in numerical form.

If the structure is a 2D model, RFEM only displays the table columns of support forces and moments that are relevant for a planar structural system.

To display the support reactions of a particular load case, select the load case from the list in the main toolbar or the toolbar of the table.
Location \( x \)

The support forces are listed by lines. The \( x \)-locations shown in the table column represent the spacings of FE nodes along the line. They are related to the start node of the line. The surface grid is not relevant for line support forces.

Support Forces \( p_x / p_y / p_z \)

The support forces are listed in three table columns where they are sorted by lines. The forces can be related to the global axes \( X, Y, \) and \( Z \) or the local axes \( X', Y', \) and \( Z' \) of the line supports. The axis reference in the table is controlled by settings in the Results navigator (see figure on the left).

The table shows the forces that are introduced into the support. Thus, with regard to signs, the table does not show the reaction forces on the part of the support. If support forces refer to the global coordinate system, the signs result from the directions of the global axes. If the global axis \( Z \) is directed downwards, the load case self-weight, for example, results in a positive support force \( p_z \) and a wind load against the global axis \( X \) results in a negative support force \( p_x \). Thus, the support forces shown in the table represent foundation loads.

If the local support forces \( p_{x'}, p_{y'}, \) and \( p_{z'} \) are displayed, the forces refer to the axes of the line supports \( X', Y', \) and \( Z' \). Thus, the signs in the table for the introduced forces result from the directions of the local support axes. Use the Display navigator or the shortcut menu of line supports to display these axes.

Support Moments \( m_x / m_y / m_z \)

The support moments are listed in three table columns where they are sorted by lines. The moments are either related to the global axis system \( XYZ \) or the local axis system \( X'Y'Z' \) of the line support. If you have set a local reference, the support moments are labeled \( m_{x'}; m_{y'}; \) and \( m_{z'} \).

The table shows the moments that are introduced into the support. As for support forces, the table does not show the reactions on the part of the support in regards to signs.

In the work window, however, reaction moments are shown on the part of the support. In addition to the vector display, an arc display can be set. To change the type of display, go to the menu and select **Options → Display Properties → Edit** (see Figure 8.5).
Check sums

For load cases and load combinations, RFEM displays check sums of loads and support reactions at the end of the table. They are always related to the global axis system. Differences will occur between \( \Sigma \text{ Forces} \) and \( \Sigma \text{ Loads} \) if the model additionally has nodal supports and members/surfaces with elastic foundations. The \( \Sigma \) Forces in these tables must therefore also be considered for the total summary.

Result diagrams

The result diagrams of line supports can be specifically evaluated in a new window: Right-click the (selected) line support(s) and then select the Result Diagrams option in the shortcut menu (see Figure 8.12 in the left margin).

For more detailed information about the Result Diagram window, see Chapter 9.5.

In the work window, additional information is available for each line support:

- \( \Sigma \) : Sum as resultant force
- \( \Phi \) : Mean value
- \( x \) : Distance of line's midpoint from line start
- \( e \) : Eccentricity of resultant force related to the line's midpoint
- \( M \) : Moment due to eccentricity of resultant force

To display this information, select Results \( \rightarrow \) Support Reactions \( \rightarrow \) Info in the Display navigator.

Importing support forces as loads

The Z components of nodal and line support forces from another RFEM model can be applied as loads to the current model. This allows you to transfer loads from floor to floor to analyze 2D floor slabs, for example.

The support forces are imported into the current load case. Hence, it might prove to be advantageous to first create a load case for the new loads.

To open the import dialog box, go to the menu and select Tools \( \rightarrow \) Import Support Reactions as Load.

![Figure 8.13 Import Support Reactions As Load dialog box](image)
First, specify the relevant model in the Import from dialog section. The button shown on the left helps you to select the right model. Then, RFEM imports the calculated load cases, load combinations, and result combinations you have to make the next decision for. When a RC is set, you also have to define whether you want to import the maximum or the minimum support forces.

If you do not want to import All support forces, you can specify the numbers of the relevant nodes, lines, and surfaces or select them graphically in the original model with the button.

In the Apply as Load in Current Model on dialog section, enter the numbers of the surfaces for which you want to create the loads or select them graphically using .

If the original and target surfaces lie exactly on top of each other, no entry is required in the Offset dialog section. Otherwise, you can use the text boxes to define the global offsets $\Delta x$ and $\Delta y$ for the import. They refer to the global axes.

In the Line Supports dialog section, you can choose whether the support forces are imported as free line loads with a uniform (averaged) or a polygonal (actual) load distribution.

**Filtering support forces of result combinations**

For result combinations, it is possible to adjust the default setting for the extreme values shown in the results table by using the menu option

Table → View → Result Filter

or the corresponding button in the table toolbar shown on the left.

The check boxes in the Table Filter dialog box control the type and extent of the numerical output.
8.4 Members - Local Deformations

To control the graphical display of member displacements and member rotations, select the Members check box in the Results navigator. When asymmetrical cross-sections are used, you can select if results refer to the principal axes $u$ and $v$ (see graphic above) or to the standard input axes $y$ and $z$. Table 4.4 shows the members’ local deformations in numerical form.

![Results navigator: Members → Local Deformations](image)

![Table 4.4 Members - Local Deformations](image)

To display the deformations of a particular load case, select the load case from the list in the main toolbar or the toolbar of the table.

**Node No.**

The numbers of the start and end node are displayed for each member in the first two tables rows so that you can read the nodal values. The subsequent rows respectively provide information about the deformation maximum or minimum shown in table columns D to I.

**Location x**

The table lists the deformations of each member at the following locations:

- Start and end node
- Division points according to defined member division (see Chapter 4.16)
- Extreme values (Max/Min) of displacements and rotations
To adjust the default setting of the displayed x-locations, go to the menu and select

**Table → View → Result Filter**

or use the corresponding button in the table toolbar shown on the left.

![Table Filter dialog box (section)](image)

The check boxes in the *Table Filter* dialog box control the type and extent of the numerical output.

### Displacements / Rotations

The member deformations have the following meanings:

<table>
<thead>
<tr>
<th>u</th>
<th>Absolute total displacement (not for result combinations)</th>
</tr>
</thead>
<tbody>
<tr>
<td>u_x</td>
<td>Displacement of member in direction of its longitudinal axis</td>
</tr>
<tr>
<td>u_y/u_u</td>
<td>Displacement of member in direction of local axis y or u</td>
</tr>
<tr>
<td>u_z/v_u</td>
<td>Displacement of member in direction of local axis z or v</td>
</tr>
<tr>
<td>φ_x</td>
<td>Rotation of member about its longitudinal axis</td>
</tr>
<tr>
<td>φ_y/φ_u</td>
<td>Rotation of member about local axis y or u</td>
</tr>
<tr>
<td>φ_z/φ_v</td>
<td>Rotation of member about local axis z or v</td>
</tr>
</tbody>
</table>

To check the position of the local member axes, select **Model → Members** in the Display navigator and activate Member Axis Systems x,y,z (see Figure 8.23). You can also use the member shortcut menu shown on the left.

The local member axis system has an impact on the signs of deformations as well: A positive displacement follows the direction of the positive local axis, a positive rotation acts clockwise about the positive member axis.
Cross-Section

The final table column provides information about the cross-sections used in members or the corresponding load cases (for result combinations).

In the work window, deformations of members can be represented with a two- or multi-color display as well as in the rendering mode (see Chapter 9.3).

Member deformations can also be visualized as an animation of the deformation process (see Chapter 9.10).

Members - Global Deformations

To control the graphical display of member displacements and member rotations related to the global axes X, Y, and Z, select the Global Deformations check box in the Results navigator. Table 4.5 shows the global deformations of members in numerical form.

The Node No. and Location x table columns correspond to the columns of the previous results table 4.4 Members - Local Deformations.
Displacements / Rotations

The member deformations have the following meanings:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>(</td>
<td>u</td>
</tr>
<tr>
<td>( u_X )</td>
<td>Displacement of member in direction of global axis X</td>
</tr>
<tr>
<td>( u_Y )</td>
<td>Displacement of member in direction of global axis Y</td>
</tr>
<tr>
<td>( u_Z )</td>
<td>Displacement of member in direction of global axis Z</td>
</tr>
<tr>
<td>( \phi_X )</td>
<td>Rotation of member about global axis X</td>
</tr>
<tr>
<td>( \phi_Y )</td>
<td>Rotation of member about global axis Y</td>
</tr>
<tr>
<td>( \phi_Z )</td>
<td>Rotation of member about global axis Z</td>
</tr>
</tbody>
</table>

Table 8.3  Global member deformations

Members - Internal Forces

To control the graphical display of member internal forces, select the Members check box in the Results navigator. Table 4.6 shows the internal forces and moments in numerical form.

If the structure is a 2D model, RFEM only displays the table columns of internal forces that are relevant for a planar structural system.
To display the internal forces of a particular load case, select the load case from the list in the main toolbar or the toolbar of the tables.

**Location x**

The table lists the internal forces of each member at the following locations:

- Start and end node
- x-locations according to defined member division (see Chapter 4.16)
- Extreme values (Max/Min) of internal forces

To adjust the default setting of the x-locations shown in the results table, use the menu option **Table → View → Result Filter** or the corresponding button in the table toolbar shown on the left.

The check boxes in the **Table Filter** dialog box control the type and extent of the numerical output (see Chapter 11.5.5).

The diagram graphic for internal forces is based on the result values available in the FE mesh nodes or in the member divisions defined in the **Global Calculation Parameters** dialog tab of the Calculation Parameters dialog box (see Chapter 7.3.3).
Forces / Moments

The member internal forces have the following meanings:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>N</td>
<td>Axial force in member</td>
</tr>
<tr>
<td>V_y/V_u</td>
<td>Shear force in direction of local member axis y or u</td>
</tr>
<tr>
<td>V_z/V_v</td>
<td>Shear force in direction of local member axis z or v</td>
</tr>
<tr>
<td>M_T</td>
<td>Torsional moment</td>
</tr>
<tr>
<td>M_y/M_u</td>
<td>Bending moment about axis y or u</td>
</tr>
<tr>
<td>M_z/M_v</td>
<td>Bending moment about axis z or v</td>
</tr>
</tbody>
</table>

The local member axes y and z or u and v are the principal axes of the cross-section. Axis y or u represents the "strong" axis, axis z or v the "weak" axis (see Chapter 4.17). When asymmetrical cross-sections are used, you can select if internal forces refer to the principal axes u and v (see graphic above) or to the standard input axes y and z. To set the results display, use the Results navigator as shown on the left. This display setting affects both the graphical results output and the output of results in the tables.

When a nonlinear analysis is performed, internal forces can also be output in relation to the deformed member axis systems. The reference of the internal forces is set in the Options dialog section of the Calculation Parameters dialog box (see Chapter 7.3.1).

To check the member position, use the 3D rendering or the Display navigator where you go to the Model → Members entry and then activate the Member Axis Systems x, y, z.

The display of member axes can also be activated in the member shortcut menu shown on the left.
The local member axis system affects the signs of internal forces.

![Positive definition of internal forces](image)

The bending moment $M_y$ is positive if tensile stresses occur on the positive member side (in direction of the z-axis). $M_z$ is positive if compressive stresses occur on the positive member side (in direction of the y-axis). The sign definition for torsional moments, axial forces, and shear forces follows the usual conventions: These internal forces are positive if they act in a positive direction on the positive side of the section.

**Extreme values**

If the table display of extreme values is activated (see Figure 8.22), RFEM shows the maximum positive (Max) and the minimum negative (Min) internal forces for each member. The extreme values are highlighted in bold; the values in the remaining columns of the respective table row represent the internal forces related to the extreme value (also see Chapter 11.5.5).

**Cross-Section / Corresponding Load Cases**

The final table column provides information about the cross-sections used in the members.

**Result combinations**

When you look at the results of result combinations, this column is generally titled Corresponding Load Cases (see Figure 8.21). The table shows the numbers of the load cases or load combinations that were used to determine the maximum or minimum internal forces of the respective table row. Load cases classified as Permanent always appear in this table column; Variable load cases are only displayed if their internal forces have an unfavorable effect on the result (see Chapter 5.6).

At the same time, the table is extended by a third column C. It allows you to read the maximum positive (Max) and the minimum negative (Min) values at the end of the internal force list of a member.

The amount of data in the result combination tables can be reduced by using specific filter functions available in the Table Filter dialog box (see Figure 8.22). To open the dialog box, use the menu entry

**Table → View → Result Filter**

or the corresponding button in the table toolbar shown on the left.
8.7 Members - Contact Forces

When there are members with elastic foundations in the model (see Chapter 4.19), the contact forces and moments are displayed numerically in Table 4.7. To control the graphical display of results, select the Members check box in the Results navigator.

Node No.

In the first two table rows, the numbers of the start and end node are displayed for each foundation member. The remaining rows provide information about the types of extreme values available for contact forces and moments.

To adjust the default settings for the output of extreme values, use the menu option

**Table → View → Result Filter**

or the corresponding button in the table toolbar.

Location x

The table lists the contact internal forces of each member at the following locations:

- Start and end node
- Division points according to defined member division (see Chapter 4.16)
- Extreme values (Max/Min) of contact forces and moments
Contact Forces $p_x / p_y / p_z$

Contact forces that are effective in direction of the local member axes $x$, $y$, and $z$ are shown in relation to a standard length. When asymmetrical cross-sections are used, you can select if contact forces refer to the principal axes $u$ and $v$ (see cross-section graphic) or to the standard input axes $y$ and $z$. To set the results display, use the Results navigator.

To check the position of the local axes, select Model $\rightarrow$ Members in the Display navigator and activate the Member Axis Systems $x \ y \ z$ (see Figure 8.23). The signs correspond to the usual provisions explained in Chapter 8.6 where the internal forces of members are described.

If you want to determine soil contact pressures on the basis of the table values, you additionally have to divide the results by the respective cross-section widths.

Moments $m_x$

The contact moments about the longitudinal member axis $x$ are also output in relation to a standard length. The moments $m_x$ are influenced by the rotational spring constant $C_{\phi}$.

Cross-Section / Corresponding Load Cases

The final table column provides information about the cross-sections used in members or, in case of result combinations, about the load cases and load combinations that were used to determine the maximum and minimum contact forces in the respective table row.

Check sums

For load cases and load combinations, RFEM displays the check sums of loads and support reactions at the end of the table. Differences will occur between $\sum$ Forces and $\sum$ Loads if the model additionally has nodal and line supports, as well as surfaces with elastic foundations. Therefore, the $\sum$ Forces available in Tables 4.1, 4.3, and 4.21 must also be considered for the total summary.
8.8 Members - Strains

The member strains display local deformations in the form of strains and shears. According to Hooke's law, they result from the stresses in the members.

In Table 4.8, the strains of the members are displayed numerically. To control the graphical display of results, select the Members check box in the Results navigator.

Node No.

The numbers of the start and end nodes are displayed for each member.
Location x

The table lists the member strains that occur at the start and end nodes, as well as at the division points according to the specified member division (see Chapter 4.16).

Strains

The strain tensor for the spatial strain state is described in Chapter 8.35. The matrix is simplified for the one-dimensional member element as follows:

\[
\begin{bmatrix}
  e_{xx} & e_{xy} & e_{xz} \\
  e_{yx} & 0 & 0 \\
  e_{zx} & 0 & 0 \\
\end{bmatrix}
\]

Equation 8.1

The shears are determined according to the following equations:

\[
e_{xy} = 2 \cdot \gamma_{xy}
\]

Equation 8.2

\[
e_{xz} = 2 \cdot \gamma_{xz}
\]

Equation 8.3

<table>
<thead>
<tr>
<th>(e_x)</th>
<th>Strain in direction of the member axis (x)</th>
</tr>
</thead>
<tbody>
<tr>
<td>( x = \frac{\partial u}{\partial x} )</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>(\gamma_{xy})</th>
<th>Shear strain</th>
</tr>
</thead>
<tbody>
<tr>
<td>( xy = \frac{\partial u}{\partial y} + \frac{\partial v}{\partial x} )</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>(\gamma_{xz})</th>
<th>Shear strain</th>
</tr>
</thead>
<tbody>
<tr>
<td>( xz = \frac{\partial w}{\partial x} + \frac{\partial u}{\partial z} )</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>(\kappa_x)</th>
<th>Bending about the local member axis (x)</th>
</tr>
</thead>
<tbody>
<tr>
<td>(\kappa_y)</td>
<td>Bending about the local member axis (y)</td>
</tr>
<tr>
<td>(\kappa_z)</td>
<td>Bending about the local member axis (z)</td>
</tr>
</tbody>
</table>

Table 8.5  Member strains
8.9 Members - Coefficients for Buckling

When you calculate member models subjected to pressure according to the second-order analysis, the member coefficient $\varepsilon$ is important (see Chapter 7.3.1). Each member has its own member coefficient that is determined from the compressive force, member length, and member stiffness.

If necessary, members with member coefficients higher than 1 have to be analyzed according to the second-order analysis. Standards of some countries such as the USA also have rules where member coefficients must be limited.

Table 4.9 shows the member coefficients that are governing for buckling. There is no graphical output option.

<table>
<thead>
<tr>
<th>Member No.</th>
<th>Member Type</th>
<th>Material</th>
<th>Cross-Section</th>
<th>Length $L$ [m]</th>
<th>Axial Force $N$ [kN]</th>
<th>$\varepsilon_y$</th>
<th>$\varepsilon_z$</th>
<th>$\varepsilon_f$</th>
<th>$\varepsilon_0$</th>
<th>$\varepsilon_1$</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Beam</td>
<td>2</td>
<td>HEB 400</td>
<td>8.0</td>
<td>6.24</td>
<td>0.28</td>
<td>0.32</td>
<td>0.261</td>
<td>0.261</td>
<td>-</td>
</tr>
<tr>
<td>2</td>
<td>Beam</td>
<td>2</td>
<td>HEB 400</td>
<td>8.0</td>
<td>6.24</td>
<td>0.28</td>
<td>0.32</td>
<td>0.261</td>
<td>0.261</td>
<td>-</td>
</tr>
<tr>
<td>3</td>
<td>Beam</td>
<td>2</td>
<td>HEB 400</td>
<td>8.0</td>
<td>6.24</td>
<td>0.28</td>
<td>0.32</td>
<td>0.261</td>
<td>0.261</td>
<td>-</td>
</tr>
<tr>
<td>4</td>
<td>Beam</td>
<td>2</td>
<td>HEB 400</td>
<td>8.0</td>
<td>6.24</td>
<td>0.28</td>
<td>0.32</td>
<td>0.261</td>
<td>0.261</td>
<td>-</td>
</tr>
<tr>
<td>5</td>
<td>Beam</td>
<td>2</td>
<td>HEB 400</td>
<td>8.0</td>
<td>6.24</td>
<td>0.28</td>
<td>0.32</td>
<td>0.261</td>
<td>0.261</td>
<td>-</td>
</tr>
<tr>
<td>6</td>
<td>Beam</td>
<td>2</td>
<td>HEB 400</td>
<td>8.0</td>
<td>6.24</td>
<td>0.28</td>
<td>0.32</td>
<td>0.261</td>
<td>0.261</td>
<td>-</td>
</tr>
<tr>
<td>7</td>
<td>Beam</td>
<td>2</td>
<td>HEB 400</td>
<td>8.0</td>
<td>6.24</td>
<td>0.28</td>
<td>0.32</td>
<td>0.261</td>
<td>0.261</td>
<td>-</td>
</tr>
<tr>
<td>8</td>
<td>Beam</td>
<td>2</td>
<td>HEB 400</td>
<td>8.0</td>
<td>6.24</td>
<td>0.28</td>
<td>0.32</td>
<td>0.261</td>
<td>0.261</td>
<td>-</td>
</tr>
<tr>
<td>9</td>
<td>Beam</td>
<td>2</td>
<td>HEB 400</td>
<td>8.0</td>
<td>6.24</td>
<td>0.28</td>
<td>0.32</td>
<td>0.261</td>
<td>0.261</td>
<td>-</td>
</tr>
<tr>
<td>10</td>
<td>Beam</td>
<td>2</td>
<td>HEB 400</td>
<td>8.0</td>
<td>6.24</td>
<td>0.28</td>
<td>0.32</td>
<td>0.261</td>
<td>0.261</td>
<td>-</td>
</tr>
<tr>
<td>11</td>
<td>Beam</td>
<td>2</td>
<td>HEB 400</td>
<td>8.0</td>
<td>6.24</td>
<td>0.28</td>
<td>0.32</td>
<td>0.261</td>
<td>0.261</td>
<td>-</td>
</tr>
</tbody>
</table>

The member coefficients are listed by member numbers.

**Member Type**

The member types are indicated for informational purposes (see Chapter 4.17). RFEM only determines member coefficients for members that are able to absorb compressive forces.

**Material**

Characteristics of the material affect the member stiffness.

**Cross-Section**

The cross-section’s moments of inertia are required to determine the member stiffnesses.

**Length L**

The member lengths are indicated in table column D.

**Axial Force N**

The column lists the axial forces used for determining the member coefficient. These are the axial forces available in the member center ($x = L/2$).

Member coefficients are only determined for members that have compression forces in at least one portion of the member (truss girder) or along the entire member (compression member, buckling member, etc.).

**Member Coefficients $\varepsilon_y / \varepsilon_z$**

The member coefficient $\varepsilon$ depends on the member length $L$, compressive force $N$, and stiffness $E \cdot I$.

$$\varepsilon = L \cdot \sqrt{\frac{N}{E \cdot I}}$$

Equation 8.4
Table columns F and G show the member coefficients that refer to the local member axis system \(y\) or \(z\). When asymmetrical cross-sections such as angles are used, two additional columns appear where member coefficients are also shown in relation to the principal axes \(u\) and \(v\).

## 8.10 Member Slendernesses

Table 4.10 displays the slenderness ratios of members. They are significant for the evaluation of the buckling behavior of members subjected to pressure. There is no graphical output option.

![Figure 8.30 Table 4.10 Member Slendernesses](image)

The member slendernesses are listed by member numbers.

### Cross-Section

The cross-section's radii of gyration are required to determine the slendernesses.

### Length L

The member lengths are indicated in table column B.

### Effective Length Factors \(k_{cr,y} / k_{cr,x}\)

The effective length factors describe the ratio of buckling length and member length.

Effective length factor:

\[
k_{cr} = \frac{L_{cr}}{L}
\]

**Equation 8.5**

The buckling length \(s_{K}\) refers to the buckling behavior perpendicular to the 'strong' member axis \(y\) or the 'weak' member axis \(z\). If no buckling lengths have been defined manually (see Chapter 4.17), the Euler buckling mode 2 is assumed: In this case, the buckling length is equal to the member length. More accurate analyses can be performed with the RF-STABILITY add-on module or in Dlubal's design modules such as RF-STEEL EC3.
Slendernesses $\lambda_y / \lambda_z$

The slenderness ratio $\lambda$ represents a purely geometric value. It is determined from the effective length factor $k_{cr}$, the member length $L$, and the radius of gyration $i$.

$$\lambda = \frac{k_{cr} L}{i}$$

Equation 8.6

Table columns E and F show the slendernesses that refer to the local member axis system $y$ or $z$. When asymmetrical cross-sections such as angles are used, two additional columns appear where slendernesses are also shown in relation to the principal axes $u$ and $v$.

8.11 Sets of Members - Internal Forces

Table 4.11 shows the internal forces sorted by sets of members (see Chapter 4.21).

The table's structure is similar to the one of Table 4.6 Members — Internal Forces, described in Chapter 8.6. Here the results are sorted by continuous members or member groups. The descriptions of member sets remain fixed in the top row of the table so that it is easier to keep track of results data when scrolling.

The table includes the member-by-member results of all members contained in the set of members. The results list of a set of members ends with the color-highlighted table rows: They show the total extremes $\text{MAX}$ and $\text{MIN}$ of each internal force type in the member set. The extreme values are highlighted in bold text; the values in the remaining table columns of the respective row represent the internal forces related to the extreme value.

The amount of data in the table can be reduced with specific filter functions available in the Table Filter dialog box (see Chapter 11.5.5). To open the dialog box, use the menu option

Table → View → Result Filter

or the corresponding button in the table toolbar shown on the left.
Table 4.12 shows the internal forces sorted by cross-sections.

The table’s structure is similar to the one of Table 4.6 Members — Internal Forces, described in Chapter 8.6. Here the results are sorted by cross-sections. The descriptions of cross-sections remain fixed in the top row of the table so that it is easier to keep track of results data when scrolling.

The table includes the member-by-member results of all members that use the relevant cross-section. The listing for a cross-section ends with the color-highlighted table rows: They show the total extremes \( \text{MAX} \) and \( \text{MIN} \) of each internal force type in the cross-section. The extreme values are highlighted in bold text; the values in the remaining columns of the respective row represent the internal forces related to the extreme value.

The amount of data in the table can be reduced with specific filter functions available in the Table Filter dialog box (see Chapter 11.5.5).
8.13 **Surfaces - Local Deformations**

To control the graphical display of local surface deformations, select the Surfaces check box in the Results navigator. Table 4.13 shows the surfaces' local deformations in numerical form.

For 2D structures, RFEM only shows the relevant table columns of deformations.

![Figure 8.33 Results navigator: Surfaces \(\rightarrow\) Local Deformations](image)

![Figure 8.34 Table 4.13 Surfaces - Local Deformations](image)

The table shows the displacements and rotations sorted by surfaces. The results are listed in reference to the grid points of each surface.
Grid Point

The numbers of the grid points are listed by surface. They represent the characteristics of each surface. Number and arrangement of the grid points can be adjusted in the Grid tab of the Edit Surface dialog box.

In this dialog tab, you can define the Grid Type, Grid Parameters, or, if necessary, the Grid Origin and Direction of Grid Axis 1. The default setting is a Cartesian surface grid with uniform Grid distances of 0.5 m for the respective grid points in both directions.

The grid allows for a results output in equidistant, adjustable result points independent of the FE mesh. For small surfaces, the grid’s standard mesh size of 0.5 m may lead to a small number of grid points (or even just one result grid point in the grid origin). Then, count and distances of the grid points should be adjusted to the surface size in order to generate more grid points.

When the surface grid is modified, a new calculation of results is not necessary because the grid values are interpolated from the result values of the FE nodes.

The results output in the table is based on the surface results grid. In the work window, both the values of FE nodes and grid points can be displayed. To set the results display, use the Results navigator.
RFEM numbers the grid points automatically. To display the numbers of grid points in the results graphics, select the Numbering check box in the Results navigator as shown in Figure 8.36.

**Grid Point Coordinates**

Table columns B to D show the coordinates of grid points in the global coordinate system XYZ. When you click into a table row, the corresponding grid point is indicated by an arrow in the work window.

**Displacements / Rotations**

The deformations have the following meanings:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Absolute total displacement (not for result combinations)</td>
</tr>
<tr>
<td>$u_x$</td>
<td>Displacement of surface in direction of local axis x</td>
</tr>
<tr>
<td>$u_y$</td>
<td>Displacement of surface in direction of local axis y</td>
</tr>
<tr>
<td>$u_z$</td>
<td>Displacement of surface in direction of local axis z</td>
</tr>
<tr>
<td>$\phi_x$</td>
<td>Rotation of surface about local axis x</td>
</tr>
<tr>
<td>$\phi_y$</td>
<td>Rotation of surface about local axis y</td>
</tr>
<tr>
<td>$\phi_z$</td>
<td>Rotation of surface about local axis z</td>
</tr>
</tbody>
</table>

To display the local surface axes, use the shortcut menu shown on the left or the Display navigator where you select **Model** → **Surfaces** → **Surface Axis Systems xyz**.

When you analyze curved surfaces, the surface axes refer to the axes of the finite elements [see Figure 8.41].
8.14 Surfaces - Global Deformations

To control the graphical display of surface displacements and rotations related to the global axes X, Y, and Z, select the Global Deformations check box in the Results navigator. Table 4.14 shows the global deformations of surfaces in numerical form.

![Fig 8.37 Results navigator: Global Deformations](image1)

![Fig 8.38 Table 4.14 Surfaces - Global Deformations](image2)

The Grid Point and Grid Point Coordinates table columns correspond to those of the previous results table 4.13 Surfaces - Local Deformations.

### Displacements / Rotations

The surface deformations have the following meanings:

<table>
<thead>
<tr>
<th>u</th>
<th>Absolute total displacement (not for result combinations)</th>
</tr>
</thead>
<tbody>
<tr>
<td>ux</td>
<td>Displacement of surface in direction of global axis X</td>
</tr>
<tr>
<td>uy</td>
<td>Displacement of surface in direction of global axis Y</td>
</tr>
<tr>
<td>uz</td>
<td>Displacement of surface in direction of global axis Z</td>
</tr>
</tbody>
</table>
8.15 Surfaces - Basic Internal Forces

To control the graphical display of the basic internal forces, select **Surfaces** \(\rightarrow\) **Basic Internal Forces** in the Results navigator. Table 4.15 shows the basic internal forces of surfaces in numerical form.

*Table 8.7* Global surface deformations

| \(\varphi_X\) | Rotation of surface about global axis \(X\) |
| \(\varphi_Y\) | Rotation of surface about global axis \(Y\) |
| \(\varphi_Z\) | Rotation of surface about global axis \(Z\) |

*Figure 8.39* Results navigator: Surfaces \(\rightarrow\) Basic Internal Forces

*Figure 8.40* Table 4.15 Surfaces - Basic Internal Forces
The table shows the basic internal forces sorted by surfaces. The results are listed in reference to the grid points of each surface.

**Grid Point**

The numbers of the grid points are listed by surface. For more information about grid points, see Chapter 8.13.

**Grid Point Coordinates**

Table columns B to D show the coordinates of grid points in the global coordinate system XYZ. When you click into a table row, the corresponding grid point is indicated by an arrow in the work window.

**Moments / Shear Forces / Axial Forces**

In contrast to member internal forces, internal forces in surfaces are symbolized by small letters. The integral definition of the bending moments \( m_x \) and \( m_y \) shows that moments are related to the directions of the surface axes where the corresponding normal stresses are created. To display the surface axes, use the surface shortcut menu (see Figure 4.122).

When curved surfaces are analyzed, internal forces refer to the local axes of the individual finite elements. The axes can be displayed by selecting the corresponding check box in the Display navigator:

![Display navigator: FE Axis Systems x,y,z](image)

There is a fundamental difference between understanding surface internal forces and member internal forces: A member moment \( M_y \) "rotates" about the local member axis \( y \), whereas a surface moment \( m_y \) acts in the direction of the local surface axis \( y \), i.e. about the \( x \)-axis of this surface.
The following figure illustrates the definition of basic internal forces in surfaces:

![Surface internal forces and surface stresses](image)

Moments and shear stresses perpendicular to the surface run parabolically across the surface thickness.

The algebraic signs help you to see on which side of the surface the internal force is available. However, the signs also depend on the orientation of the global axis Z: If the global Z-axis is directed **downwards** (standard), positive internal forces generate tension stresses on the positive side of the surface (i.e. in direction of the positive surface axis z). They are visualized by blue bars in the table. Negative internal forces result in compression stresses on the positive side of the surface. They are represented by red bars in the table.

If the global Z-axis is directed **upwards**, the algebraic signs of the bending moments and shear forces are inverted.

**When the Z-axis is directed downwards**, basic internal forces are determined as follows:

<table>
<thead>
<tr>
<th>Force</th>
<th>Expression</th>
</tr>
</thead>
</table>
| \( m_x \)      | Bending moment that creates stresses in direction of the local axis x  
\[
m_x = \int_{-d/2}^{d/2} z \, dz
\] |
| \( m_y \)      | Bending moment that creates stresses in direction of the local axis y  
\[
m_y = \int_{-d/2}^{d/2} z \, dz
\] |
| \( m_{xy} \)    | Torsional moment  
\[
m_{xy} = m_{yx} = \int_{-d/2}^{d/2} x y \, dz
\] |
| \( v_x \)      | Shear force \( v_x \)  
\[
v_x = \int_{-d/2}^{d/2} x z \, dz
\] |
<table>
<thead>
<tr>
<th>$v_y$</th>
<th>Shear force $v_y$</th>
</tr>
</thead>
<tbody>
<tr>
<td>$v_y = \int_{-a/2}^{a/2} y_x dz$</td>
<td></td>
</tr>
<tr>
<td>$n_x$</td>
<td>Axial force in direction of the local axis $x$</td>
</tr>
<tr>
<td>$n_x = \int_{-a/2}^{a/2} x , dz$</td>
<td></td>
</tr>
<tr>
<td>$n_y$</td>
<td>Axial force in direction of the local axis $y$</td>
</tr>
<tr>
<td>$n_y = \int_{-a/2}^{a/2} y , dz$</td>
<td></td>
</tr>
<tr>
<td>$n_{xy}$</td>
<td>Shear flow</td>
</tr>
<tr>
<td>$n_{xy} = \int_{-a/2}^{a/2} y_x , dz$</td>
<td></td>
</tr>
</tbody>
</table>

| Table 8.8 | Basic internal forces |
8.16 Surfaces - Principal Internal Forces

To control the graphical display of the principal internal forces, select **Surfaces → Principal Internal Forces** in the Results navigator. Table 4.16 shows the principal internal forces of surfaces in numerical form.

![Results navigator: Surfaces → Principal Internal Forces](image1)

![Table 4.16 Surfaces - Principal Internal Forces](image2)

The table shows the principal internal forces sorted by surfaces. The results are listed in reference to the grid points of each surface.

The **Grid Point** and **Grid Point Coordinates** table columns correspond to those of the previous results table 4.15 **Surfaces - Basic Internal Forces**.
Moments / Shear Forces / Axial Forces

The Basic Internal Forces described in the previous chapter refer to the more or less freely defined coordinate system xyz of a surface. Conversely, Principal Internal Forces represent the extreme values of the internal forces in a surface element. For this purpose, the basic internal forces are transformed in the directions of both principal axes. The principal axes 1 (maximum value) and 2 (minimum value) are arranged orthogonally.

The principal internal forces are determined from the basic internal forces:

<table>
<thead>
<tr>
<th>( m_1 )</th>
<th>Bending moment in direction of principal axis 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \frac{1}{2}(m_x + m_y + \sqrt{(m_x - m_y)^2 + 4m_{xy}^2}) )</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>( m_2 )</th>
<th>Bending moment in direction of principal axis 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \frac{1}{2}(m_x + m_y - \sqrt{(m_x - m_y)^2 + 4m_{xy}^2}) )</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>( \alpha_b )</th>
<th>Angle between local axis x (or y) and principal axis 1 (or 2)</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \frac{1}{2} \left[ \arctan \left( \frac{2m_{xy}}{m_x - m_y} \right) \right] )</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>( m_{\tau,\text{max},b} )</th>
<th>Maximum torsional moment</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \sqrt{(m_x - m_y)^2 + 4m_{xy}^2} )</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>( v_{\text{max},b} )</th>
<th>Maximum resulting shear force from bending components</th>
</tr>
</thead>
<tbody>
<tr>
<td>( v_{\text{max},b} = \sqrt{v_x^2 + v_y^2} )</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>( \beta_b )</th>
<th>Angle between principal shear force ( v_{\text{max},b} ) and local axis x</th>
</tr>
</thead>
<tbody>
<tr>
<td>( = \arctan \frac{v_y}{v_x} )</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>( n_1 )</th>
<th>Axial force in direction of principal axis 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \frac{1}{2}(n_x + n_y + \sqrt{(n_x - n_y)^2 + 4n_{xy}^2}) )</td>
<td></td>
</tr>
</tbody>
</table>
### Table 8.9 Principal Internal Forces

<table>
<thead>
<tr>
<th>( n_2 )</th>
<th>Axial force in direction of principal axis 2</th>
</tr>
</thead>
</table>
| \[
\frac{1}{2}(n_x + n_y) - \sqrt{(n_x - n_y)^2 + 4n_{xy}^2}
\] | |

<table>
<thead>
<tr>
<th>( \alpha_{\text{m}} )</th>
<th>Angle between axis x and principal axis 1 (for axial force ( n_1 ))</th>
</tr>
</thead>
</table>
| \[
\frac{1}{2} \left[ \arctan \left( \frac{2n_{xy}}{n_x - n_y} \right) \right]
\] | |

<table>
<thead>
<tr>
<th>( V_{\text{max,m}} )</th>
<th>Maximum shear force from membrane components</th>
</tr>
</thead>
</table>
| \[
\sqrt{(n_x - n_y)^2 + 4n_{xy}^2} / 2
\] | |

The principal axes directions \( \alpha_b \) (for bending moments), \( \beta_b \) (for shear forces), and \( \alpha_{\text{m}} \) (for axial forces) can be displayed as trajectories in the work window.

Displaying the angle \( \alpha_{\text{m}} \), for example, also shows the size of the respective principal moments because the trajectories are scaled to the values of the moments \( m_1 \) and \( m_2 \).
8.17 Surfaces - Design Internal Forces

To control the graphical display of the design internal forces, select **Surfaces → Design Internal Forces** in the Results navigator. Table 4.17 shows the design internal forces of surfaces in numerical form.

![Figure 8.46](image)

**Figure 8.46** Results navigator: Surfaces → Design Internal Forces

![Table 4.17](image)

**Figure 8.47** Table 4.17 Surfaces - Design Internal Forces

The table shows the design internal forces sorted by surfaces. The results are listed in reference to the grid points of each surface.

**Grid Point**

The numbers of the grid points are listed by surface. For more information about grid points, see Chapter 8.13.
Grid Point Coordinates

Table columns B to D show the coordinates of grid points in the global coordinate system XYZ.

Moments / Axial Forces

The design moments and axial forces shown in this table are based on the approach described in DIN V ENV 1992-1-1, Appendix 2, A 2.8 and A 2.9. Thus, RFEM provides users without access to the design module RF-CONCRETE Surfaces with a tool required for the manual reinforced concrete design. As the RF-CONCRETE Surfaces add-on module uses the method by Baumann, the design internal forces from RFEM are not applied in this add-on module.

The design moments and axial forces of Table 4.17 must not be combined! As explained in DIN V ENV 1992-1-1, Annex 2.8, the moments exclusively refer to plate reinforcements; the axial forces are based on the design of wall elements described in Annex 2.9.

The design internal forces have the following meanings:

<table>
<thead>
<tr>
<th>$m_{x,D+}$</th>
<th>Design moment in the direction of the local axis $x$ on the positive side of the surface (i.e. side in direction of positive surface axis $z$)</th>
</tr>
</thead>
</table>
| $m_x + |m_{xy}|$ | for $m_x \leq m_y$ and $m_x \geq -|m_{xy}|$
| $m_x > m_y$ and $m_x \geq -|m_{xy}|$
| $0$ for $m_x \leq m_y$ and $m_x < -|m_{xy}|$
| $m_x + \frac{m_{xy}^2}{m_y}$ | for $m_x > m_y$ and $m_y < -|m_{xy}|$

<table>
<thead>
<tr>
<th>$m_{y,D+}$</th>
<th>Design moment in the direction of the local axis $y$ on the positive side of the surface (i.e. side in direction of positive surface axis $z$)</th>
</tr>
</thead>
</table>
| $m_y + |m_{xy}|$ | for $m_x \leq m_y$ and $m_x \geq -|m_{xy}|$
| $m_x > m_y$ and $m_y \geq -|m_{xy}|$
| $m_y + \frac{m_{xy}^2}{m_x}$ | for $m_x > m_y$ and $m_x < -|m_{xy}|$
| $0$ for $m_x > m_y$ and $m_x < -|m_{xy}|$ |
### $m_{c,D+}$
Design moment for concrete stress design on the positive side of the surface

$$-2|m_{xy}|$$

- for $m_x \leq m_y$ and $m_x \geq -|m_{xy}|$
- for $m_x > m_y$ and $m_y \geq -|m_{xy}|$

$$m_x = \frac{m^2_y}{|m_x|}$$

- for $m_x \leq m_y$ and $m_x < -|m_{xy}|$

$$m_y = \frac{m^2_x}{|m_y|}$$

- for $m_x > m_y$ and $m_x < -|m_{xy}|$

### $m_{x,D-}$
Design moment in the direction of the axis $x$ on the negative side of the surface

$$-m_x + |m_{xy}|$$

- for $m_x \leq m_y$ and $m_y \leq |m_{xy}|$
- for $m_x > m_y$ and $m_x \leq |m_{xy}|$

$$-m_x + \frac{m^2_y}{|m_x|}$$

- for $m_x < m_y$ and $m_y > |m_{xy}|$

0 for $m_x > m_y$ and $m_x > |m_{xy}|$

### $m_{y,D-}$
Design moment in the direction of the axis $y$ on the negative side of the surface

$$-m_y + |m_{xy}|$$

- for $m_x \leq m_y$ and $m_y \leq |m_{xy}|$
- for $m_x > m_y$ and $m_y \leq |m_{xy}|$

0 for $m_x \leq m_y$ and $m_y > |m_{xy}|$

$$-m_y + \frac{m^2_x}{|m_y|}$$

- for $m_x > m_y$ and $m_x > |m_{xy}|$
$m_{c,D^-}$ Design moment for concrete stress design on the negative side of the surface

$$-2 \cdot | m_{xy} |$$

for $m_x \leq m_y$ and $m_y \leq | m_{xy} |$

for $m_x > m_y$ and $m_x \leq | m_{xy} |$

$$- m_y - \frac{m_{xy}^2}{m_y}$$

for $m_x \leq m_y$ and $m_y > | m_{xy} |$

$$- m_x - \frac{m_{xy}^2}{m_x}$$

for $m_x > m_y$ and $m_x > | m_{xy} |$

$n_{x,D}$ Design force in direction of the local axis $x$

$$n_x + | n_{xy} |$$

for $n_x \leq n_y$ and $n_x \geq - | n_{xy} |$

for $n_x > n_y$ and $n_y \geq - | n_{xy} |$

0 for $n_x \leq n_y$ and $n_x < - | n_{xy} |$

$$n_x + \frac{n_{xy}^2}{n_y}$$

for $n_x > n_y$ and $n_y < - | n_{xy} |$

$n_{y,D}$ Design force in direction of the local axis $y$

$$n_y + | n_{xy} |$$

for $n_x \leq n_y$ and $n_x \geq - | n_{xy} |$

for $n_x > n_y$ and $n_y \geq - | n_{xy} |$

$$n_y + \frac{n_{xy}^2}{n_x}$$

for $n_x \leq n_y$ and $n_x < - | n_{xy} |$

0 for $n_x > n_y$ and $n_y < - | n_{xy} |$
<table>
<thead>
<tr>
<th>n_{c,D}</th>
<th>Design force for concrete stress design</th>
</tr>
</thead>
<tbody>
<tr>
<td>$-2 \left</td>
<td>n_{xy} \right</td>
</tr>
<tr>
<td>$-\left</td>
<td>n_x \right</td>
</tr>
<tr>
<td>-</td>
<td>for $n_x \leq n_y$ and $n_x &lt; -\left</td>
</tr>
<tr>
<td>$-\left</td>
<td>n_y \right</td>
</tr>
</tbody>
</table>

**Table 8.10** Design internal forces
### 8.18 Surfaces - Basic Stresses

To control the graphical display of the basic stresses, select **Surfaces → Stresses** in the Results navigator. Table 4.18 shows the basic stresses of surfaces in numerical form.

![Figure 8.48 Results navigator: Surfaces → Stresses](image)

![Figure 8.49 Table 4.18 Surfaces - Basic Stresses](image)
The table shows the basic stresses sorted by surfaces. The results are listed in reference to the grid points of each surface.

**Grid Point**

The numbers of the grid points are listed by surface. For more information about grid points, see Chapter 8.13.

**Grid Point Coordinates**

Table columns B to D show the coordinates of grid points in the global coordinate system XYZ.

**Basic stresses**

The stresses are related to the directions of the local surface axes. When you analyze curved surfaces, they refer to the local axes of the individual finite elements (see Figure 8.41).

The basic stresses are shown in Figure 8.42 and have the following meanings:

<table>
<thead>
<tr>
<th>Stress Type</th>
<th>Expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \sigma_{x^+} )</td>
<td>Stress in the direction of the local axis x on the positive side of the surface (i.e. side in direction of positive surface axis ( z ))&lt;br&gt; [ \sigma_{x^+} = \frac{n_x}{d} + \frac{6 m_x}{d^2} ]&lt;br&gt;where ( d ): thickness of surface</td>
</tr>
<tr>
<td>( \sigma_{y^+} )</td>
<td>Stress in the direction of the local axis y on the positive side of the surface (i.e. side in direction of positive surface axis ( z ))&lt;br&gt; [ \sigma_{y^+} = \frac{n_y}{d} + \frac{6 m_y}{d^2} ]</td>
</tr>
<tr>
<td>( \sigma_{x^-} )</td>
<td>Stress in the direction of the axis x on the negative side of the surface&lt;br&gt; [ \sigma_{x^-} = \frac{n_x}{d} - \frac{6 m_x}{d^2} ]</td>
</tr>
<tr>
<td>( \sigma_{y^-} )</td>
<td>Stress in the direction of the axis y on the negative side of the surface&lt;br&gt; [ \sigma_{y^-} = \frac{n_y}{d} - \frac{6 m_y}{d^2} ]</td>
</tr>
<tr>
<td>( \tau_{xy^+} )</td>
<td>Torsional stress on the positive side of the surface&lt;br&gt; [ \tau_{xy^+} = \frac{n_{xy}}{d} + \frac{6 m_{xy}}{d^2} ]</td>
</tr>
</tbody>
</table>
\[ \tau_{xy} = \frac{n_{xy}}{d} = \frac{6 m_{xy}}{d^2} \]

- **Torsional stress on the negative side of the surface**

\[ \tau_{xz} \]

- **Shear stress orthogonal to the surface in the direction of the axis x**
  \[ \frac{3 v_x}{2 d} \]
  where \( d \): thickness of surface

\[ \tau_{yz} \]

- **Shear stress orthogonal to the surface in the direction of the axis y**
  \[ \frac{3 v_y}{2 d} \]

**Table 8.11** - Basic stresses

**Surfaces - Principal Stresses**

To control the graphical display of principal stresses, select **Surfaces → Stresses** in the **Results** navigator (see Figure 8.48). Table 4.19 shows the principal stresses of surfaces in numerical form.

The table shows the principal stresses sorted by surfaces. The results are listed in reference to the grid points of each surface.

The **Grid Point** and **Grid Point Coordinates** table columns correspond to those of the previous results table 4.18 **Surfaces - Basic Stresses**.
Principal stresses

The basic stresses described in Chapter 8.18 refer to the coordinate system \(xyz\) of the surface. However, the principal stresses represent the extreme values of the stresses in a surface element. The principal axes 1 (maximum value) and 2 (minimum value) are arranged orthogonally.

It is possible to display the principal axis orientations \(\alpha\) as trajectories in the work window (see Figure 8.45).

The principal stresses are determined from the basic stresses:

\[
\sigma_{1,+} = \frac{1}{2}(x_+ + y_+ + \sqrt{(x_+ - y_+)^2 + 4y_{xy}})
\]

\[
\sigma_{2,+} = \frac{1}{2}(x_+ + y_+ - \sqrt{(x_+ - y_+)^2 + 4y_{xy}})
\]

\[
\alpha_+ = \frac{1}{2}\arctan2\left(\frac{2y_{xy}}{x_+ - y_+}\right) \in (-90^\circ, 90^\circ]
\]

\[
\sigma_{1,-} = \frac{1}{2}(x_- + y_- + \sqrt{(x_- - y_-)^2 + 4y_{xy}})
\]

\[
\sigma_{2,-} = \frac{1}{2}(x_- + y_- - \sqrt{(x_- - y_-)^2 + 4y_{xy}})
\]

\[
\alpha_- = \frac{1}{2}\arctan2\left(\frac{2y_{xy}}{x_- - y_-}\right) \in (-90^\circ, 90^\circ]
\]
**8.20**

Surfaces - Other Stresses

To control the graphical display of stress components due to bending moments and membrane forces, select Surfaces → Stresses in the Results navigator (see Figure 8.48). Table 4.20 shows these stresses in numerical form.

The table shows the other stresses sorted by surfaces. The results are listed in reference to the grid points of each surface.

---

Temple 8.12

**Principal Stresses**

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
<th>Equation</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\sigma_{1,m}$</td>
<td>Membrane stress in the direction of principal axis 1</td>
<td>$\sigma_{1,m} = \frac{1}{2} \left( x_{,m} + y_{,m} + \sqrt{(x_{,m} - y_{,m})^2 + 4 \sigma_{xy,m}^2} \right)$</td>
</tr>
<tr>
<td>$\sigma_{2,m}$</td>
<td>Membrane stress in the direction of principal axis 2</td>
<td>$\sigma_{2,m} = \frac{1}{2} \left( x_{,m} + y_{,m} - \sqrt{(x_{,m} - y_{,m})^2 + 4 \sigma_{xy,m}^2} \right)$</td>
</tr>
<tr>
<td>$\alpha_m$</td>
<td>Angle between local axis x and principal axis 1 for the membrane stresses</td>
<td>$\alpha_m = \frac{1}{2} \text{atan2} \left( \frac{2 \cdot \sigma_{xy,m}}{x_{,m} - y_{,m}} \right) \in (-90^\circ, 90^\circ]$</td>
</tr>
<tr>
<td>$\tau_{\max}$</td>
<td>Maximum shear stress perpendicular to surface</td>
<td>$\tau_{\max} = \sqrt{\tau_{xz}^2 + \tau_{yz}^2}$</td>
</tr>
</tbody>
</table>
Grid Point
The numbers of the grid points are listed by surfaces. For more information about grid points, see Chapter 8.13.

Grid Point Coordinates
Table columns B to D show the coordinates of grid points in the global coordinate system XYZ.

Stresses from Moments / Axial Forces
The stresses are related to the directions of the local surface axes. When you analyze curved surfaces, they refer to the axes of the finite elements (see Figure 8.41).

The stresses have the following meanings:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
<th>Formula</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\sigma_{x,b}$</td>
<td>Stress due to bending moment $m_x$</td>
<td>$\sigma_{x,b} = \frac{6 m_x}{d^2}$</td>
<td>where $d$: thickness of surface</td>
</tr>
<tr>
<td>$\sigma_{y,b}$</td>
<td>Stress due to bending moment $m_y$</td>
<td>$\sigma_{y,b} = \frac{6 m_y}{d^2}$</td>
<td></td>
</tr>
<tr>
<td>$\tau_{xy,b}$</td>
<td>Stress due to torsional moment $m_{xy}$</td>
<td>$\tau_{xy,b} = \frac{6 m_{xy}}{d^2}$</td>
<td></td>
</tr>
<tr>
<td>$\sigma_{x,m}$</td>
<td>Membrane stress due to axial force $n_x$</td>
<td>$\sigma_{x,m} = \frac{n_x}{d}$</td>
<td></td>
</tr>
<tr>
<td>$\sigma_{y,m}$</td>
<td>Membrane stress due to axial force $n_y$</td>
<td>$\sigma_{y,m} = \frac{n_y}{d}$</td>
<td></td>
</tr>
<tr>
<td>$\tau_{xy,m}$</td>
<td>Membrane stress due to shear flow $n_{xy}$</td>
<td>$\tau_{xy,m} = \frac{n_{xy}}{d}$</td>
<td></td>
</tr>
</tbody>
</table>

Table 8.13: Other stresses
8.21 Surfaces - Contact Stresses

If the model has surface supports (see Chapter 4.9), Table 4.21 shows the contact stresses ("soil contact pressures") of surfaces in numerical form. To control the graphical display of results, select Surfaces → Contact Stresses in the Results navigator.

For 2D slabs, only the results column $\sigma_z$ is displayed.

The table shows the contact stresses sorted by surfaces. The results are listed in reference to the grid points of each surface.

**Grid Point**

The numbers of the grid points are listed by surface. For more information about grid points, see Chapter 8.13.

**Grid Point Coordinates**

Table columns B to D show the coordinates of grid points in the global coordinate system XYZ. When you click into a table row, the corresponding grid point is indicated in the work window by an arrow, provided that the synchronization of selection is activated (see Chapter 11.5.4).
Contact Stresses

The stresses are related to the directions of the local surface axes. When you analyze curved surfaces, they refer to the axes of the finite elements (see Figure 8.41). The contact stresses have the following meanings:

<table>
<thead>
<tr>
<th>Stresses</th>
<th>Equation</th>
</tr>
</thead>
<tbody>
<tr>
<td>[\sigma_z]</td>
<td>Contact stress (&quot;soil pressure&quot;) in direction of surface axis [z]</td>
</tr>
<tr>
<td>[\tau_{yz}]</td>
<td>Shear stress from surface support</td>
</tr>
<tr>
<td>[\tau_{xz}]</td>
<td>Shear stress from surface support</td>
</tr>
</tbody>
</table>

\[\sigma_z = \frac{F_z}{A}\]

\[\tau_{yz} = \frac{F_y}{A}\]

\[\tau_{xz} = \frac{F_x}{A}\]

where

- \[F_z\]: Contact force in the FE node in direction \[z\]
- \[F_y\]: Contact force in the FE node in direction \[y\]
- \[F_x\]: Contact force in the FE node in direction \[x\]
- \[A\]: Application area for FE node

In the table, positive contact stresses are visualized by blue bars. Negative stresses are correspondingly characterized by red bars.

The table shows the stresses as forces per surface that is passed into the support. Thus, with regard to signs, the table does not show reactions on the part of the foundation. If the local surface axis \[z\] is orientated downwards, a load in the direction of the \[z\]-axis results in a positive stress \[\sigma_z\], for example. Thus, the signs result from the direction of the surface axis \[z\] (see Figure 4.76).

The orientation of the local surface axis \[z\] can be changed quickly for 3D models:

Right-click the surface to open the surface shortcut menu (see left figure above) and select the Reverse Local Axis System option. Please note, however, that a potential failure criterion changes the direction of action.
8.22 **Surfaces - Equivalent Stresses - von Mises**

To control the graphical display of equivalent stresses of surfaces, select **Surfaces → Stresses** in the Results navigator. Table 4.22 shows the equivalent stresses determined according to von Mises in numerical form.

![Figure 8.54](image)

**Figure 8.54** Equivalent stresses in Results navigator: Surfaces → Stresses → $\sigma_{eqv,Mises}$

![Figure 8.55](image)

**Figure 8.55** Table 4.22 Surfaces - Equivalent Stresses - von Mises

The table shows the equivalent stresses sorted by surfaces. The results are listed in reference to the grid points of each surface.
Grid Point

The numbers of the grid points are listed by surface. For more information about grid points, see Chapter 8.13.

Grid Point Coordinates

Table columns B to D show the coordinates of grid points in the global coordinate system XYZ.

Equivalent Stresses

In the Results navigator, four equivalent stress hypotheses for the plane stress condition are available for selection. The approach by von Mises is also called "shape modification hypothesis". It assumes that material fails when the shape modifying energy exceeds a certain limit. This energy is the type of energy that causes a distortion or deformation of the object.

This approach represents the most well-known and most frequently used equivalent stress hypothesis. It is suitable for all materials that are not brittle. Therefore, it is widely used in steel building construction. The hypothesis is unsuitable for hydrostatic stress conditions with equal principal stresses in all directions, as the equivalent stress is zero in such a case.

The equivalent stresses according to von Mises for the plane state of stress have the following meanings:

<table>
<thead>
<tr>
<th>( \sigma_{eqv,max} )</th>
<th>Maximum equivalent stress on the positive or negative side of the surface</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \sigma_{eqv,+} )</td>
<td>Equivalent stress on the positive side of the surface (i.e. side in direction of positive surface axis ( z ))</td>
</tr>
<tr>
<td>( eqv,+ = \sqrt{\frac{2}{x,+} + \frac{2}{y,+} - x,+ + y,+ + 3\frac{2}{xy,+}} )</td>
<td></td>
</tr>
<tr>
<td>( \sigma_{eqv,-} )</td>
<td>Equivalent stress on the negative side of the surface</td>
</tr>
<tr>
<td>( eqv,- = \sqrt{\frac{2}{x,-} + \frac{2}{y,-} - x,- - y,- + 3\frac{2}{xy,-}} )</td>
<td></td>
</tr>
<tr>
<td>( \sigma_{eqv,m} )</td>
<td>Membrane equivalent stress</td>
</tr>
<tr>
<td>( eqv,m = \sqrt{\frac{2}{x,m} + \frac{2}{y,m} - x,m - y,m + 3\frac{2}{xy,m}} )</td>
<td></td>
</tr>
</tbody>
</table>

Table 8.15 - Equivalent stresses according to von Mises
Surfaces - Equivalent Stresses - Tresca

To control the graphical display of equivalent stresses of surfaces, select **Surfaces → Stresses** in the Results navigator (see Figure 8.54). Table 4.23 shows the surfaces’ equivalent stresses according to Tresca in numerical form.

![Figure 8.56](Image)

Table 4.23 Surfaces - Equivalent Stresses - Tresca

The Grid Point and Grid Point Coordinates table columns correspond to those of the previous results table 4.22 Surfaces - Equivalent Stresses - von Mises.

The approach by Tresca is also known as the "maximum shear stress theory". It is assumed that failure is caused by the maximum shear stress. As this hypothesis is especially applicable for brittle materials, it is frequently used in mechanical engineering.

The equivalent stresses according to Tresca are determined as follows:

<table>
<thead>
<tr>
<th>( \sigma_{eqv,\text{max}} )</th>
<th>Maximum equivalent stress on the positive or negative side of the surface</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \sigma_{eqv,+} )</td>
<td>Equivalent stress on the positive side of the surface</td>
</tr>
<tr>
<td>( \sigma_{eqv,+} = \max (\sigma_{1} + \sigma_{2} + 2\sigma_{xy}) ) or ( \sigma_{eqv,-} = \max (\sigma_{1} - \sigma_{2} - 2\sigma_{xy}) )</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>( \sigma_{eqv,-} )</th>
<th>Equivalent stress on the negative side of the surface</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \sigma_{eqv,-} = \max (\sigma_{1} - \sigma_{2} - 2\sigma_{xy}) ) or ( \sigma_{eqv,+} = \max (\sigma_{1} + \sigma_{2} + 2\sigma_{xy}) )</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>( \sigma_{eqv,m} )</th>
<th>Membrane equivalent stress</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \sigma_{eqv,m} = \max (\sigma_{1} - \sigma_{2} + 2\sigma_{xy}) ) or ( \sigma_{eqv,m} = \max (\sigma_{1} + \sigma_{2} - 2\sigma_{xy}) )</td>
<td></td>
</tr>
</tbody>
</table>

Table 8.16 Equivalent stresses according to Tresca
Surfaces - Equivalent Stresses - Rankine

To control the graphical display of equivalent stresses of surfaces, select **Surfaces → Stresses** in the Results navigator (see Figure 8.54). Table 4.24 shows the surfaces' equivalent stresses determined according to Rankine in numerical form.

The **Grid Point and Grid Point Coordinates** table columns correspond to those of results table 4.22 **Surfaces - Equivalent Stresses - von Mises**.

The equivalent stress hypothesis by Rankine is also known as the "maximum principal stress criterion". It is assumed that the maximum principal stress leads to failure.

The equivalent stresses according to Rankine are determined as follows:

<table>
<thead>
<tr>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\sigma_{v,\text{max}}$</td>
<td>Maximum equivalent stress on the positive or negative side of the surface</td>
</tr>
<tr>
<td>$\sigma_{v,+}$</td>
<td>Maximum absolute value of the equivalent stress on the positive side of the surface</td>
</tr>
<tr>
<td>$\sigma_{v,+} = \frac{1}{2} \left</td>
<td>x_+ + y_+ \right</td>
</tr>
<tr>
<td>$\sigma_{v,-}$</td>
<td>Maximum absolute value of the equivalent stress on the negative side of the surface</td>
</tr>
<tr>
<td>$\sigma_{v,-} = \frac{1}{2} \left</td>
<td>x_- + y_- \right</td>
</tr>
<tr>
<td>$\sigma_{v,m}$</td>
<td>Maximum absolute value of the membrane equivalent stress</td>
</tr>
<tr>
<td>$\sigma_{v,m} = \frac{1}{2} \left</td>
<td>x_m + y_m \right</td>
</tr>
</tbody>
</table>

Table 8.17 - Equivalent stresses according to Rankine
To control the graphical display of equivalent stresses of surfaces, select **Surfaces → Stresses** in the Results navigator (see Figure 8.54). Table 4.25 shows the surfaces’ equivalent stresses according to Bach in numerical form.

The Grid Point and Grid Point Coordinates table columns correspond to those of results table 4.22 **Surfaces - Equivalent Stresses - von Mises**.

The equivalent stress hypothesis by Bach is also called "principal strain criterion". It is assumed that the failure occurs in the direction of the greatest strain. The approach is similar to the stress determination according to Rankine described in Chapter 8.24. Here, the principal strain is used instead of the principal stress.

The equivalent stresses according to Bach are determined as follows:

| \( \sigma_{v,\text{max}} \) | Maximum equivalent stress on the positive or negative side of the surface |
| \( \sigma_{v,+} \) | Maximum absolute value of the equivalent stress on the positive side of the surface |
| \( \nu = \max \left\{ \frac{1}{2} \left( x_{+,+} + y_{+,+} \right) + \frac{1}{2} \sqrt{(x_{+,+} - y_{+,+})^2 + 4 y_{+,+} x_{+,+}} \right\} \) |

where \( \nu \): Poisson’s ratio (see Chapter 4.3)

| \( \sigma_{v,-} \) | Maximum absolute value of the equivalent stress on the negative side of the surface |
| \( \nu = \max \left\{ \frac{1}{2} \left( x_{-,+} + y_{-,+} \right) + \frac{1}{2} \sqrt{(x_{-,+} - y_{-,+})^2 + 4 y_{-,+} x_{-,+}} \right\} \) |

| \( \sigma_{v,m} \) | Maximum absolute value of the membrane equivalent stress |
| \( \nu = \max \left\{ \frac{1}{2} \left( x_{,+m} + y_{,+m} \right) + \frac{1}{2} \sqrt{(x_{,+m} - y_{,+m})^2 + 4 y_{,+m} x_{,+m}} \right\} \) |
8.26 Surfaces - Basic Strains

To control the graphical display of surface strains, select **Surfaces → Strains** in the **Results navigator**. Table 4.26 shows the basic strains of surfaces in numerical form.

The table shows the strains sorted by surfaces. The results are listed in reference to the grid points of each surface.

**Grid Point**

The numbers of the grid points are listed by surface. For more information about grid points, see Chapter 8.13.
## Grid Point Coordinates

Table columns B to D show the coordinates of grid points in the global coordinate system XYZ.

## Basic Strains

The strains are related to the directions of the local surface axes. When you analyze curved surfaces, they refer to the axes of the finite elements (see Figure 8.41). The basic strains have the following meanings:

<table>
<thead>
<tr>
<th>( \varepsilon_{x,+} )</th>
<th>Strain in the direction of the local axis x on the positive side of the surface (i.e. side in direction of positive surface axis z)</th>
</tr>
</thead>
<tbody>
<tr>
<td>( x_+ = \frac{\partial u}{\partial x} + \frac{d}{2} \frac{\partial^2 x}{\partial y^2} )</td>
<td>where ( d ) is the thickness of the surface</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>( \varepsilon_{y,+} )</th>
<th>Strain in the direction of the local axis y on the positive side of the surface (i.e. side in direction of positive surface axis z)</th>
</tr>
</thead>
<tbody>
<tr>
<td>( y_+ = \frac{\partial v}{\partial y} + \frac{d}{2} \left( \frac{\partial^2 x}{\partial y \partial x} - \frac{\partial^2 y}{\partial x \partial y} \right) )</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>( \gamma_{xy,+} )</th>
<th>Related rotation on the positive side of the surface</th>
</tr>
</thead>
<tbody>
<tr>
<td>( xy_+ = \frac{\partial u}{\partial y} + \frac{\partial v}{\partial x} + \frac{d}{2} \left( \frac{\partial^2 x}{\partial y \partial x} - \frac{\partial^2 y}{\partial x \partial y} \right) )</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>( \varepsilon_{x,-} )</th>
<th>Strain in the direction of the axis x on the negative side of the surface</th>
</tr>
</thead>
<tbody>
<tr>
<td>( x_- = \frac{\partial u}{\partial x} - \frac{d}{2} \frac{\partial^2 x}{\partial y^2} )</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>( \varepsilon_{y,-} )</th>
<th>Strain in the direction of the axis y on the negative side of the surface</th>
</tr>
</thead>
<tbody>
<tr>
<td>( y_- = \frac{\partial v}{\partial y} - \frac{d}{2} \left( \frac{\partial^2 y}{\partial x \partial y} - \frac{\partial^2 x}{\partial y \partial x} \right) )</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>( \gamma_{xy,-} )</th>
<th>Related rotation on the negative side of the surface</th>
</tr>
</thead>
<tbody>
<tr>
<td>( xy_- = \frac{\partial u}{\partial y} + \frac{\partial v}{\partial x} - \frac{d}{2} \left( \frac{\partial^2 x}{\partial y \partial x} - \frac{\partial^2 y}{\partial x \partial y} \right) )</td>
<td></td>
</tr>
</tbody>
</table>

| Table 8.19 | Basic strains |
8.27 Surfaces - Principal Strains

To control the graphical display of strains, select Surfaces → Strains in the Results navigator (see Figure 8.59). Table 4.27 shows the principal strains of surfaces in numerical form.

![Figure 8.61 Table 4.27 Surfaces - Principal Strains](image)

The table shows the principal strains sorted by surfaces. The results are listed in reference to the grid points of each surface.

The Grid Point and Grid Point Coordinates table columns correspond to those of the previous results table 4.26 Surfaces - Basic Strains.

**Principal Strains**

The basic strains described in Chapter 8.26 refer to the surfaces’ coordinate system xyz. The principal strains, however, represent the extreme values of the strains in a surface element. The principal axes 1 (maximum value) and 2 (minimum value) are arranged orthogonally.

It is possible to display the principal axis orientations as trajectories in the work window (see Figure 8.45 for principal internal forces).

The principal strains have the following meanings:

<table>
<thead>
<tr>
<th>ε₁⁺</th>
<th>Strain in the direction of the principal axis 1 on the positive side of the surface (i.e. side in direction of positive surface axis z)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1⁺</td>
<td>( \varepsilon_{1,1} = \frac{1}{2} \left( x_{1,1} + 1 + \sqrt{\left( x_{1,1} + 1 - \sqrt{x_{1,1}^2 - y_{1,1}^2 + 2x_{1,1}y_{1,1}} \right) \varepsilon_{1,1}} \right) )</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>ε₂⁺</th>
<th>Strain in the direction of the principal axis 2 on the positive side of the surface (i.e. side in direction of positive surface axis z)</th>
</tr>
</thead>
<tbody>
<tr>
<td>2⁺</td>
<td>( \varepsilon_{2,1} = \frac{1}{2} \left( x_{2,1} + 1 + \sqrt{\left( x_{2,1} + 1 - \sqrt{x_{2,1}^2 - y_{2,1}^2 + 2x_{2,1}y_{2,1}} \right) \varepsilon_{1,1}} \right) )</td>
</tr>
<tr>
<td>Symbol</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>$\alpha_+$</td>
<td>Angle between local axis $x$ (or $y$) and principal axis 1 (or 2) for the strains on the positive side of the surface</td>
</tr>
<tr>
<td>$\varepsilon_{1,+}$</td>
<td>Strain in the direction of the principal axis 1 on the positive side of the surface</td>
</tr>
<tr>
<td>$\varepsilon_{2,+}$</td>
<td>Strain in the direction of the principal axis 2 on the positive side of the surface</td>
</tr>
<tr>
<td>$\alpha_-$</td>
<td>Angle between local axis $x$ (or $y$) and principal axis 1 (or 2) for the stresses on the negative side of the surface</td>
</tr>
<tr>
<td>$\varepsilon_{1,-}$</td>
<td>Strain in the direction of the principal axis 1 on the negative side of the surface</td>
</tr>
<tr>
<td>$\varepsilon_{2,-}$</td>
<td>Strain in the direction of the principal axis 2 on the negative side of the surface</td>
</tr>
</tbody>
</table>

\[
\alpha_+ = \frac{1}{2} \left( \arctan \left( \frac{x_{y+}}{x_+ - y_+} \right) \right)
\]

\[
\varepsilon_{1,+} = \frac{1}{2} \left( x_+ + y_+ \sqrt{\left( x_+ - y_+ \right)^2 + \frac{2}{xy_+}} \right)
\]

\[
\varepsilon_{2,+} = \frac{1}{2} \left( x_+ + y_+ \sqrt{\left( x_+ - y_+ \right)^2 + \frac{2}{xy_+}} \right)
\]

\[
\alpha_- = \frac{1}{2} \left( \arctan \left( \frac{x_{y-}}{x_- - y_-} \right) \right)
\]

\[
\varepsilon_{1,-} = \frac{1}{2} \left( x_- + y_- \sqrt{\left( x_- - y_- \right)^2 + \frac{2}{xy_-}} \right)
\]

\[
\varepsilon_{2,-} = \frac{1}{2} \left( x_- + y_- \sqrt{\left( x_- - y_- \right)^2 + \frac{2}{xy_-}} \right)
\]
Surfaces - Maximum Strains

The extreme values of strains are available under Surfaces → Strains in the Results navigator (see Figure 8.59). Table 4.28 shows these strains in numerical form.

The table shows the extreme values of strains sorted by surfaces. The results are listed in reference to the grid points of each surface.

The Grid Point and Grid Point Coordinates table columns correspond to those of results table 4.26 Surfaces - Basic Strains.

Maximum Strains

These values represent the extreme values of the strains determined by the equations shown in Table 8.20.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\varepsilon_{\text{max}}^{+}$</td>
<td>Maximum value of the strain on the positive side of the surface (i.e. side in direction of positive surface axis $z$)</td>
</tr>
<tr>
<td>$\varepsilon_{\text{min}}^{+}$</td>
<td>Minimum value of the strain on the positive side of the surface</td>
</tr>
<tr>
<td>$</td>
<td>\varepsilon_{\text{max}}^{+}</td>
</tr>
<tr>
<td>$\varepsilon_{\text{max}}^{-}$</td>
<td>Maximum value of the strain on the negative side of the surface</td>
</tr>
<tr>
<td>$\varepsilon_{\text{min}}^{-}$</td>
<td>Minimum value of the strain on the negative side of the surface</td>
</tr>
<tr>
<td>$</td>
<td>\varepsilon_{\text{max}}^{-}</td>
</tr>
<tr>
<td>$\varepsilon_{\text{max}}$</td>
<td>Maximum value of the strain on the positive or negative side of the surface (columns E and H)</td>
</tr>
<tr>
<td>$\varepsilon_{\text{min}}$</td>
<td>Minimum value of the strain on the positive or negative side of the surface (columns F and I)</td>
</tr>
<tr>
<td>$</td>
<td>\varepsilon_{\text{max}}</td>
</tr>
</tbody>
</table>
To control the graphical display of surface strains available with the equivalent stress hypothesis according to von Mises, select **Surfaces → Strains** in the Results navigator. Table 4.29 shows these strains in numerical form.

The table shows the equivalent strains sorted by surfaces. The results are listed in reference to the grid points of each surface.

**Grid Point**

The numbers of the grid points are listed by surface. For more information about grid points, see Chapter 8.13.®
Grid Point Coordinates

Table columns B to D show the coordinates of grid points in the global coordinate system XYZ.

Strains according to von Mises

The approaches for the planar condition of strain described in Chapters 8.22 to 8.25 are available for selection in the Results navigator. The approach by von Mises is also called "shape modification hypothesis". It assumes that the material fails when the shape modifying energy exceeds a certain limit. This energy is the type of energy that causes a distortion or deformation of the object (see Chapter 8.22).

The strains according to von Mises for the plane condition of strain have the following meanings:

<table>
<thead>
<tr>
<th>Formula</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\varepsilon_{+,\text{Mises}}$</td>
<td>Equivalent strain on the positive side of the surface (i.e. side in direction of positive surface axis $z$)</td>
</tr>
<tr>
<td>$\varepsilon_{-,\text{Mises}}$</td>
<td>Equivalent strain on the negative side of the surface</td>
</tr>
<tr>
<td>$\varepsilon_{\text{Mises}}$</td>
<td>Maximum equivalent strain on the positive or negative side of the surface (columns E and F)</td>
</tr>
</tbody>
</table>

\[
\varepsilon_{+,\text{Mises}} = \sqrt{\left(\frac{x_+}{1} - y_+\right)^2 + \left(\frac{x_+}{1} - y_+\right)^2 + \left(\frac{x_+}{1} - y_+\right)^2 + \frac{3}{2} x_+}
\]

\[
\varepsilon_{-,\text{Mises}} = \sqrt{\left(\frac{x_-}{1} - y_-\right)^2 + \left(\frac{x_-}{1} - y_-\right)^2 + \left(\frac{x_-}{1} - y_-\right)^2 + \frac{3}{2} x_-}
\]

\[
\varepsilon_{\text{Mises}} = \max(\varepsilon_{+,\text{Mises}}, \varepsilon_{-,\text{Mises}})
\]
8.30 Surfaces - Strains - Tresca

To control the graphical display of surface strains available with the equivalent stress hypothesis according to Tresca, select **Surfaces** → **Strains** in the Results navigator (see Figure 8.63). Table 4.30 shows these strains in numerical form.

![Figure 8.63 Table 4.30 Surfaces - Strains - Tresca](image)

The **Grid Point** and **Grid Point Coordinates** table columns correspond to those of the previous results table 4.29 **Surfaces - Strains - von Mises**.

In the approach according to Tresca, it is assumed that failure is caused by the maximum shear stress (see Chapter 8.23).

The strains according to Tresca are determined as follows:

<table>
<thead>
<tr>
<th>( \varepsilon_{Tresca} )</th>
<th>Equivalent strain on the positive side of the surface ( \text{(i.e. side in direction of positive surface axis } z \text{)} )</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \varepsilon_{+,Tresca} )</td>
<td>( \varepsilon_{+,Tresca} = \sqrt{x_+ - y_+^2 + \frac{2}{x_+} + 1} )</td>
</tr>
</tbody>
</table>

At the same time, the equivalent strain according to Rankine is analyzed (see the following Chapter 8.31). If a larger strain is reached with this hypothesis, this value is shown in table column E.

<table>
<thead>
<tr>
<th>( \varepsilon_{-,Tresca} )</th>
<th>Equivalent strain on the negative side of the surface</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \varepsilon_{-,Tresca} = \sqrt{x_- - y_-^2 + \frac{2}{x_-} + 1} )</td>
<td></td>
</tr>
</tbody>
</table>

If the hypothesis by Rankine results in a larger equivalent strain, this value is shown in column F.

<table>
<thead>
<tr>
<th>( \varepsilon_{Tresca} )</th>
<th>Maximum equivalent strain on the positive or negative side of the surface ( \text{(columns E and F)} )</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \varepsilon_{Tresca} )</td>
<td></td>
</tr>
</tbody>
</table>

![Table 8.23 Strains according to Tresca](image)
Surfaces - Strains - Rankine

To control the graphical display of surface strains available with the equivalent stress hypothesis according to Rankine, select **Surfaces → Strains** in the Results navigator (see Figure 8.63). Table 4.31 shows these strains in numerical form.

![Table 4.31 Surfaces - Strains - Rankine](image)

The Grid Point and Grid Point Coordinates table columns correspond to those of results table 4.29 Surfaces - Strains - von Mises.

In the approach according to Rankine, it is assumed that failure is caused by the maximum principal stress (see Chapter 8.24).

The strains according to Rankine are determined as follows:

- **$\varepsilon_{+, \text{Rankine}}$**
  
  Equivalent strain on the positive side of the surface (i.e. side in direction of positive surface axis $z$)

  $$
  \varepsilon_+ = \frac{1}{2} \left( \frac{1}{1 - \nu_+} + \sqrt{\left( \frac{x_+ - y_+}{1 - \nu_+} \right)^2 + \frac{2}{1 + \nu_+}} \right)
  $$

- **$\varepsilon_{-, \text{Rankine}}$**
  
  Equivalent strain on the negative side of the surface

  $$
  \varepsilon_- = \frac{1}{2} \left( \frac{1}{1 - \nu_-} + \sqrt{\left( \frac{x_- - y_-}{1 - \nu_-} \right)^2 + \frac{2}{1 + \nu_-}} \right)
  $$

- **$\varepsilon_{\text{Rankine}}$**
  
  Maximum equivalent strain on the positive or negative side of the surface (columns E and F)

![Table 8.24 Strains according to Rankine](image)
8.32 Surfaces - Strains - Bach

To control the graphical display of surface strains available with the equivalent stress hypothesis according to Bach, select **Surfaces → Strains** in the Results navigator (see Figure 8.63). Table 4.32 shows these strains in numerical form.

![Image](image-url)

Figure 8.67 Table 4.32 Surfaces - Strains - Bach

The Grid Point and Grid Point Coordinates table columns correspond to those of results table 4.29 Surfaces - Strains - von Mises.

In the approach according to Bach, it is assumed that failure occurs in the direction of the maximum strain (see Chapter 8.25).

The strains according to Bach are determined as follows:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\varepsilon_{+,\text{Bach}}$</td>
<td>Maximum absolute value of the principal strain $\varepsilon_1$ or $\varepsilon_2$ on the positive side of the surface (see Chapter 8.27).</td>
</tr>
<tr>
<td>$\varepsilon_{-,\text{Bach}}$</td>
<td>Maximum absolute value of the principal strain $\varepsilon_1$, or $\varepsilon_2$, on the negative side of the surface (i.e., side in opposite direction of positive surface axis z)</td>
</tr>
<tr>
<td>$\varepsilon_{\text{Bach}}$</td>
<td>Maximum equivalent strain on the positive or negative side of the surface (columns E and F)</td>
</tr>
</tbody>
</table>

Table 8.25 Strains according to Bach
8.33 Solids - Deformations

To control the graphical display of solid deformations, select the Global Deformations check box in the Results navigator (see Figure 8.37). Table 4.33 shows the deformations for the boundary surfaces of solids in numerical form.

Figure 8.68 Table 4.33 Solids - Deformations

The table shows the displacements and rotations for the grid points of the individual boundary surfaces. The deformations inside the solid are not shown.

Grid Point

The numbers of the grid points (see Chapter 8.13) are listed by surface.

Grid Point Coordinates

Table columns C to E show the coordinates of grid points in the global coordinate system XYZ.

Displacements / Rotations

The deformations have the following meanings:

| \( |u| \) | Absolute total displacement (not for result combinations) |
| --- | --- |
| \( u_x \) | Displacement of the solid in the direction of the global axis X |
| \( u_y \) | Displacement of the solid in the direction of the global axis Y |
| \( u_z \) | Displacement of the solid in the direction of the global axis Z |
| \( \varphi_x \) | Rotation of the solid about the global axis X |
| \( \varphi_y \) | Rotation of the solid about the global axis Y |
| \( \varphi_z \) | Rotation of the solid about the global axis Z |

Table 8.26 Solid deformations
8.34 **Solids - Stresses**

To control the graphical display of solid stresses, select the Solids check box in the Results navigator. Table 4.34 shows the stresses of solids in numerical form.

The results in the table refer to the grid points of the boundary surfaces, which means that the table does not list any stresses available inside the solid. However, stresses within the solid can be represented graphically on the interior FE mesh points: In the Results navigator, select the **Values on Surfaces → Settings → On FE mesh points** option. To display the values specifically, use a clipping plane (see Chapter 9.9.2).

![Figure 8.69 Results navigator: Solids → Stresses](image)

The table shows the solid stresses sorted by surfaces. The results are listed in reference to the grid points of each surface.

**Grid Point**

The numbers of the grid points are listed by surface. For more information about grid points, see Chapter 8.13.
Grid Point Coordinates

Table columns C to E show the coordinates of grid points in the global coordinate system XYZ.

Basic Stresses / Shear Stresses / Principal Stresses

Unlike surface stresses, solid stresses cannot be described by simple equations. The Basic Stresses $\sigma_x$, $\sigma_y$, and $\sigma_z$ as well as the Shear Stresses $\tau_{xy}$, $\tau_{yz}$, and $\tau_{xz}$ are directly determined by the analysis core.

If a cube with the edge lengths $d_x$, $d_y$, and $d_z$ is cut from a 3D object with multiaxial loading, the stresses in each cubic surface can be split into normal and shear stresses. If neither the spatial force nor stress differences on parallel surfaces are considered, the stress condition in the cube’s local coordinate system can be described by nine stress components.

Figure 8.71  Solid element with stress components

The matrix of the stress tensor is the following:

$$S = \begin{bmatrix} x & xy & xz \\ yx & y & yz \\ zx & zy & z \end{bmatrix}$$

Equation 8.7

The Principal Stresses $\sigma_1$, $\sigma_2$, and $\sigma_3$ result from the eigenvalues of the tensor according to the following formula:

Principal stresses:

$$\det(S - E) = 0$$

Equation 8.8

where

$E$ : 3x3 unit matrix

The maximum Shear Stress $\tau_{\text{max}}$ is determined according to Mohr’s circle:

Maximum shear stress:

$$\tau_{\text{max}} = \frac{1}{2} (\sigma_1 - \sigma_3)$$

Equation 8.9
The trajectories of the principal stresses can be displayed graphically by selecting the $\sigma_{123}$ navigator entry.

### Equivalent stresses

The equivalent stress $\sigma_v$ according to von Mises can be expressed by the following homologous equations:

**Equivalent stress from principal stresses according to von Mises:**

$$
\sigma_v = \sqrt{\frac{1}{2} \left((1 - \frac{\sigma_1}{\sigma_2})^2 + (1 - \frac{\sigma_1}{\sigma_3})^2 + (1 - \frac{\sigma_2}{\sigma_3})^2\right)}
$$

*Equation 8.10*

**Equivalent stress from basic stresses according to von Mises:**

$$
\sigma_v = \sqrt{\frac{2}{x^2 + y^2 + z^2} \left(x^2 - y^2 - xz + \frac{2}{x^2} + \frac{2}{y^2} + \frac{2}{z^2}\right)}
$$

*Equation 8.11*

For determining the Equivalent Stress $\sigma_v$ according to Tresca, RFEM analyzes the differences from the principal stresses in order to determine the maximum value with them.

**Determination of the equivalent stress according to Tresca:**

$$
\sigma_v = \max\left| \frac{\sigma_1 - \sigma_2}{\sigma_1} \right|, \left| \frac{\sigma_2 - \sigma_3}{\sigma_2} \right|, \left| \frac{\sigma_3 - \sigma_1}{\sigma_3} \right|
$$

*Equation 8.12*

The Equivalent Stress $\sigma_v$ according to Rankine is determined from the maximum absolute values of the principal stresses.

**Determination of the equivalent stress according to Rankine:**

$$
\sigma_v = \max\left| \frac{\sigma_1}{\sigma_1}, \frac{\sigma_2}{\sigma_2}, \frac{\sigma_3}{\sigma_3} \right|
$$

*Equation 8.13*

For determining the Equivalent Stress $\sigma_v$ according to Bach, RFEM analyzes the principal stress differences while taking Poisson's ratio $\nu$ into account in order to determine the maximum value with them.

**Determination of the equivalent stress according to Bach:**

$$
\sigma_v = \max\left| \frac{\sigma_1 - \left(\frac{\nu}{1-\nu}\right)\sigma_2}{\sigma_1}, \frac{\sigma_2 - \left(\frac{\nu}{1-\nu}\right)\sigma_3}{\sigma_2}, \frac{\sigma_3 - \left(\frac{\nu}{1-\nu}\right)\sigma_1}{\sigma_3} \right|
$$

*Equation 8.14*
8.35 Solids - Strains

The general definition of the tensor for the spatial strain state is as follows:

\[
e = \begin{bmatrix}
  e_{xx} & e_{xy} & e_{xz} \\
  e_{yx} & e_{yy} & e_{yz} \\
  e_{zx} & e_{zy} & e_{zz}
\end{bmatrix}
\]

Equation 8.15

The individual elements of the tensor are defined as follows:

\[e_{ij} = \frac{1}{2} \left( \frac{\partial u_i}{\partial x_j} + \frac{\partial u_j}{\partial x_i} \right)\]

Equation 8.16

To control the graphical display of solid strains, select **Solids → Strains** in the Results navigator. Table 4.35 shows these strains in numerical form.

Figure 8.72: Results navigator: Solids → Strains

Figure 8.73: Table 4.35 Solids - Strains
The table shows the strains sorted by surfaces. The results are listed in reference to the grid points of each surface that encloses the solid.

The Grid Point and Grid Point Coordinates table columns correspond to those of the previous results table 4.34 Solids · Stresses.

**Solids - Strains**

The strains are directly determined from the eigenvalues of the strain matrix by the analysis core. When the model is analyzed according to the linear static or second-order analysis, a linear calculation is performed; for a calculation according to the large deformation analysis, strains are determined with a logarithmic approach.

The equivalent strains are determined according to the four stress hypotheses as follows:

<table>
<thead>
<tr>
<th>Hypothesis</th>
<th>Equation</th>
</tr>
</thead>
</table>
| **\( \varepsilon_{\text{Mises}} \)** | \[
\varepsilon_{\text{Mises}} = \frac{1}{1 + \sqrt{\frac{2}{x} \frac{2}{y} \frac{2}{z} - \frac{x}{y} \frac{y}{z} - \frac{y}{z} \frac{z}{x} + \frac{3}{4} \left( \frac{2}{xy} + \frac{2}{yz} + \frac{2}{xz} \right)}}
\] |
| **\( \varepsilon_{\text{Tresca}} \)** | Maximum of the eigenvalue differences according to the matrix \( R \) (see Equation 8.17) |
| | \[
\varepsilon_{\text{Tresca}} = \max \left( \left| R_1 - R_2 \right|, \left| R_2 - R_3 \right|, \left| R_3 - R_1 \right| \right)
\] |
| **\( \varepsilon_{\text{Rankine}} \)** | Maximum of the eigenvalues according to the matrix \( R \) |
| | \[
\varepsilon_{\text{Rankine}} = \max \left( \left| R_1 \right|, \left| R_2 \right|, \left| R_3 \right| \right)
\] |
| **\( \varepsilon_{\text{Bach}} \)** | Maximum of the eigenvalue differences by considering Poisson’s ratio \( \nu \) according to the matrix \( R \) |
| | \[
\varepsilon_{\text{Bach}} = \max \left[ \left| R_1 - (R_2 + R_3) \right|, \left| R_2 - (R_3 + R_1) \right|, \left| R_3 - (R_1 + R_2) \right| \right]
\] |

**Table 8.27** Equivalent strains

\[
R = \frac{1}{1 + \sqrt{\frac{(1 - \frac{x}{y}) + \frac{xy}{2}}{1 - 2} + \frac{xy}{2} + \frac{xy}{2} + \frac{(1 - \frac{x}{z}) + \frac{xz}{2}}{1 - 2} + \frac{xz}{2} + \frac{yz}{2} + \frac{yz}{2}}}
\]

**Equation 8.17**
8.36 Solids - Gas Pressure

To control the graphical display of the gas pressure, select **Solids → Stresses → Pressure P** in the Results navigator. Table 4.36 shows the gas pressure of solids in numerical form.

![Results navigator: Solids → Stresses → Pressure P](image)

![Table 4.36 Solids - Gas Pressure](image)

The table shows the distribution of pressure sorted by surfaces. The results are listed in reference to the grid points of each surface that encloses the solid.

The **Grid Point** and **Grid Point Coordinates** table columns correspond to those of results table 4.34 Solids - Stresses.

**Pressure p**

The gas pressure is a specific type of stress for solids of the type "gas" (see Chapter 4.5). It is determined with the functions of state for volume \( V \) and temperature \( T \) according to the following condition:

State equation for gases:

\[
p \cdot \frac{V}{T} = \text{const}
\]

**Equation 8.18**

with \( T \) in [K] relative to absolute zero
9 Results Evaluation

9.1 Available Results

Select

Results → Available Results

in the menu to open a dialog box with an overview of all calculated load cases and combinations.

![Available Results dialog box](image)

The list allows you to check, which load cases, load combinations, and result combinations have been calculated. The Calculation Errors table column lists reasons for problems that may have occurred during the calculation process and can be viewed in detail by clicking the button.

To display a particular result in the graphic, select it in the dialog box and click the button. You can also double-click the entry. Results that are not required can be deleted with the button.

It is also possible to select load cases, load combinations, or result combinations in the load case list of the main toolbar or the toolbar of the results tables. Results graphic and table display are updated automatically if the synchronization of selection is active (see Chapter 11.5.4).
9.2 **Results Selection**

You can use the Results navigator to control the display of deformations, internal forces, stresses, strains and/or support reactions, as well as sections and smooth ranges, where applicable.

![Results navigator](image)

You can also select results by using the Results toolbar.

![Buttons in the Results toolbar](image)

To switch the display of the results graphic on or off, use the [Results on/off] toolbar button; to display the result values, use the [Show Result Values] button to the right of it.

For results of a result combination (RC), the navigator additionally provides the Result Combinations entry.

![Results navigator for a result combination](image)
There are three options to graphically display the results of deformations, internal forces, and support forces of result combinations: Max and Min-values can be displayed separately. To display both envelopes from the extreme values on the model, select Max and Min-values.

9.3 Results Display

The way results are presented is set in the Display navigator.

In the Results navigator, you can specify, which results are displayed. The Display navigator specifies, how they are displayed.
The internal forces of members are displayed Two-Colored by default. Positive internal forces are represented by light blue lines, negative internal forces by red lines. Member deformations are shown as single-colored Lines by default.

The graphical result diagram is controlled by the Number of divisions of members for Result diagrams text box in the Global Calculation Parameters dialog tab of the Calculation Parameters dialog box (see Figure 7.27). If a division of 10 is set, RFEM divides the length of the longest member in the system by 10. With this system-related division length, RFEM determines the graphical result distributions on the division points for each member.

If the member internal forces are displayed in colors using the With Diagram/Without Diagram display options, colors for the graphical results are assigned according to the scale shown in the control panel. You can find hints for adjusting the value and color scales in Chapter 3.4.6.

The internal forces can also be displayed as Cross-Sections: A photorealistic display of members appears, showing color-coordinated diagrams of internal forces on the rendered members.

Analogously, you can display the deformation of Cross-Sections (3D rendering of deformation) or Cross-Sections Colored (rendering of deformation with color gradation).
9.3.2 Surface and Solid Results

The results of surfaces and solids are displayed as Isobands by default. The color assignment is managed in the control panel (see Chapter 3.4.6).

The Display navigator provides various display options for surface and solid results by selecting Results $\rightarrow$ Type of Display.

The results of surfaces and solids can be displayed as Isobands or Isolines. Isolines often prove to be useful for output by a monochrome printer.

The Without graphic representation option allows for an output of pure result values: Isobands or isolines are hidden so that only the result values on the grid or FE mesh points are displayed. This setting is also suitable for printing.

The Differences display option is only available for stresses. With this setting, you can see the stress changes in the finite elements, which makes it possible to draw conclusions regarding the quality of the FE mesh: If there are significant differences in adjacent FE elements, you should entertain the idea of an FE mesh refinement on these locations.

You can select the Solid FE Nodes option to evaluate the stresses inside a solid, provided that the FE mesh is fine enough. The color assignment of FE nodes follows the scale of the control panel. If you additionally activate the Values in the FE mesh points in the Results navigator, you can directly see the solid stresses displayed on the model.

You can control the scaling of deformations and internal forces with settings in the Display Factors control panel tab (middle). The Filter tab (right) is used for a specific selection of members, surfaces, or solids whose results you want displayed (see Figure 9.51). Both panel tabs are described in Chapter 3.4.6.
Criteria for nonlinear material properties

If a material model with nonlinear effects was selected (see Chapter 4.3), you can graphically check, which areas are affected by reduced stiffnesses when reaching the yield strength, for example. This option is only available if the RF-MAT NL add-on module is licensed.

The Is nonlinear results display option shows the portion of Gauss points that were nonlinearly analyzed at least once during the analysis. With the Design Ratio, you can find out, which plastic hinges arise at a beam, for example.

Load distribution

By selecting the check boxes under the Distribution of load navigator entry, you can display the forces and moments received by the FE Nodes or FE Elements from the entered loads. The forces of the finite elements can be displayed in relation to the global axis system XYZ or the local surface axes xyz.

The mesh loads allow you to check the entered loads. For free concentrated loads, for example, you can check whether the load acts on all surfaces specified in the On Surfaces list (see Figure 6.33).
9.4 **Value Display**

The display of values is managed in the Results navigator (see Chapter 3.4.3).

### 9.4.1 Result Values

The Values navigator category controls the result values displayed in the work window.

**Values of results graphic**

The first option (m-1 in the figure above) is aligned with the result type that is displayed in the work window. If this selection field is active, RFEM displays the result values of the current deformation graphic, stress graphic, or graphic of internal forces.

**Value groups**

With the Groups option, it is possible to show two result values for each location for surface results. Four groups are preset. The following figure shows the first group with the principal moments $m_1$ and $m_2$. The arranged grid values are rotated about the angle $\alpha_b$.
It is also possible to create user-defined groups of values: Right-click the Groups navigator item to open the shortcut menu shown on the left. Select New Values Group to open the following dialog box:

![New Values Group dialog box](image)

First, define the Group Name that later appears as an item in the navigator. In the Values in Group dialog section, you can select the result types from the 1st Value, 2nd Value, and 3rd Value lists. The rotation of the values is specified in the fields below Rotated by $\alpha$.

**Specific result values**

You can use the Specific selection field to determine the result values (deformations, internal forces, stresses, strains) you want displayed, irrespective of the result type active in the work window. Thus, you can, for example, simultaneously provide the deformations of a surface graphically and display the values of the principal internal forces $m_1$ and $m_2$ as shown on the left.
9.4.2 Settings

The display options available under the Settings navigator entry control the design locations of the result values and their representation.

Figure 9.13 Results navigator: Values on Surfaces ➔ Settings

**Extreme Values**

If the Extreme Values option is selected, only the minimum or maximum result values are displayed, depending on the setting.

**Grid points / FE mesh points**

In addition, result values can be displayed either On grid and user-defined points or On FE mesh points. Use the latter option with caution, because importing all FE result values takes time for larger models.

**Symbols / Numbering / Transparent**

The final three check boxes listed under Settings control the type and extent of the labeling:

- The Symbols of the set result type (u, mx, σz, etc.) are also output.
- The Numbering of Grid points or FE-Mesh nodes (G1, M1, etc.) are output as well.
- The values can be displayed with the Transparent option - without frame and background.
To adjust the colors and fonts of the result values, use the menu option

**Options → Display Properties → Edit.**

In the general Display Properties dialog box, specify the settings in the category

**Results → Result Values → Result Values on Surfaces.**
User-Defined Result Values

Grid values

The grid points represent a property of the respective surface. Number and arrangement of grid points can therefore be adjusted in the Grid tab of the Edit Surface dialog box. The results output in tables is based on the result grid for surfaces. In the graphic, both the values of FE nodes as well as of grid points can be displayed.

For more information about grid points, see Chapter 8.13.

Graphic values

In the work window, you can set result values on any location of the model. If the results display is active, you can access this feature by selecting the menu entry

Results --> Set Result Values Manually

or using the corresponding toolbar button.

When you move the mouse over a surface, result values appear for the current position of the mouse pointer. The result values can then be placed on the relevant locations per mouse click.

A manually placed value can be deleted easily: Select the value by mouse click, then press the [Del] key on your keyboard. For a multiple selection, keep the [Ctrl] key pressed or draw a window across the values that you want to select.

To access the shortcut menu of result values, right-click one of the values. The menu contains specific display and filter functions for the graphical evaluation.
With the Result Values Filter shortcut menu function (see figure above), you can define precise specifications for the result values you want displayed. To open the corresponding dialog box, select

**Results → Display Options**

in the menu. The following dialog box for entering filter criteria appears.

![Value Display Filter dialog box](image)

In the Show Values According to Magnitude list, you can define limits for the result values in the table columns from and to. Values that are outside this range are not shown in the graphic.

**Search Criteria for Local Extreme Values**

To control the output of graphical extreme values for surfaces, select the menu item

**Results → Display Options → Search Criteria for Local Extreme Values**

or use the shortcut menu of the Results navigator entry Of All Local Extreme Values.

![Search Criteria for Local Extreme Values dialog box](image)

In the first text box, specify when a result value is considered to be a local peak. The difference between global maximum and global minimum of all active surfaces is multiplied by the specified percentage value. The lower this threshold is, the more local extreme values are displayed.

In the second text box, you can define how many finite elements generated around a point you want to apply for the analysis of extreme values. The higher this number is, the more local extreme values are displayed.
There is a special output function available for member and surface results. To open the corresponding dialog box, select the menu option

Tools → Info About Object

or use the corresponding toolbar button.

An Info window appears. If you move the pointer over a surface, a member, or a solid, this window provides information about the object data (material, thickness, cross-section, etc.) as well as the deformation values, internal forces, or stresses on the current pointer position.

For evaluating surface results, we recommend using the Solid Transparent Display Model.
9.5 Result Diagrams

The result diagram makes it possible to see the result distribution of objects in detail:

- Section
- Member
- Set of members
- Line
- Line support

Select the object(s) in the work window (multiple selection by holding down the [Ctrl] key). Then, select the menu option

**Results → Result Diagrams for Selected Sections/Members/Sets of Members/Lines/Line Supports**

or use the shortcut menu of the corresponding object. For members and sets of members, the toolbar button shown on the left is also available.

A new window opens, showing the result diagrams of the selected object.

The **Results** navigator on the left manages the deformations, internal forces, stresses, strains, or support forces that appear in the result diagram. Use the list in the toolbar to select a particular load case, load combination, or result combination.

In the result diagrams for members, the numbers of the selected members are listed in the upper left corner of the window. You can also enter member numbers into the **Member No.** text box manually. That way you can extend, reduce, or completely reorganize the selection.

When you move the mouse along the line or member selected in the result diagram, you can see the "moving" result values for the current x-location. The location x is related to the line or member start and is indicated in the upper right corner of the window. It is also possible to manually enter a specific location x into the text box. The **Fixed** check box pins the pointer to the indicated location.

In the right window section, the result values are listed numerically. These values represent the results for the edge nodes as well as for the locations of the extreme values and the division points. The latter correspond to the FE mesh nodes or member divisions according to specifications set in the **Global Calculation Parameters** tab of the **Calculation Parameters** dialog box (see **Figure 7.27**). When lines separate two surfaces from each other, the window shows the surface results of both sides.
You can save the user-defined settings in the navigator for deformations or internal forces as default settings. There is a corresponding option in the navigator shortcut menu. This function is described in the following article:

The buttons in the User operations toolbar, in particular the smoothing options for support forces, lines, or sections, help you to evaluate results for civil engineering purposes.

![Floating User operations toolbar]

The buttons have the following meanings:

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Prints result diagrams]</td>
<td>Prints result diagrams</td>
</tr>
<tr>
<td>![Removes all displayed result diagrams]</td>
<td>Removes all displayed result diagrams</td>
</tr>
<tr>
<td>![Maximizes result diagrams]</td>
<td>Maximizes result diagrams</td>
</tr>
<tr>
<td>![Minimizes result diagrams]</td>
<td>Minimizes result diagrams</td>
</tr>
<tr>
<td>![Opens the control parameters shown in Figure 9.22]</td>
<td>Opens the control parameters shown in Figure 9.22</td>
</tr>
<tr>
<td>![Saves smoothed result diagrams]</td>
<td>Saves smoothed result diagrams</td>
</tr>
<tr>
<td>![Opens the Export Table dialog box (see Figure 11.126)]</td>
<td>Opens the Export Table dialog box (see Figure 11.126)</td>
</tr>
<tr>
<td>![Displays member results with or without rib components]</td>
<td>Displays member results with or without rib components</td>
</tr>
<tr>
<td>![Switches result diagram over column area on and off]</td>
<td>Switches result diagram over column area on and off</td>
</tr>
<tr>
<td>![Reverses direction x of member]</td>
<td>Reverses direction x of member</td>
</tr>
<tr>
<td>![Switches ordinates with maximum values on and off]</td>
<td>Switches ordinates with maximum values on and off</td>
</tr>
<tr>
<td>![Switches display of average values on and off]</td>
<td>Switches display of average values on and off</td>
</tr>
<tr>
<td>![Opens dialog box for defining smooth ranges (Figure 9.36)]</td>
<td>Opens dialog box for defining smooth ranges (Figure 9.36)</td>
</tr>
<tr>
<td>![Switches display of smooth ranges on and off]</td>
<td>Switches display of smooth ranges on and off</td>
</tr>
</tbody>
</table>

Table 9.1 Buttons of User operations toolbar
Use the [Result Diagram Settings] button to open a dialog box that provides several options for adjusting the Result Diagram window.

![Result Diagram Settings dialog box](image)

**Sections**

You can create user-defined sections in RFEM by defining a plane that slices through the model. They allow for a detailed evaluation of results that are available on the plane lines that intersect surfaces and solids. The sections are managed as independent objects in the tabs of the project navigator.

To generate a new section, use the menu option

**Insert → Section**

or the corresponding shortcut menu in the Data navigator.

![Data navigator: Sections shortcut menu](image)

A dialog box opens where you can define the section parameters.
### 9.6.1 Section Through Surface

**New Section dialog box for surface**

In addition to the No. of the section, you have to enter the Section Name that ensures a reliable assignment when evaluating results. All sections are stored in the Data navigator under Sections where they can be adjusted retroactively. Entering the number and name is unnecessary if the Save section check box is cleared in the Options dialog section.

If you create a Section Through a Surface, the surface-specific parameters and the corresponding graphics are displayed in the Section Type and Projection Direction dialog sections.

The Section Type can be created as a Plane that slices the model. As an alternative, you can cut along any line in the model. The line number can be entered manually or determined in the work window using .

The Edge Points of Section must be specified with the global coordinates XYZ of both points A and B. You can also select them graphically with . To be able to select free points (i.e., no nodes) in the work window, you may have to adjust the current work plane.

Starting from points A and B, two straight lines are “drawn” in the projection direction. If the lines intersect a surface contained in the On surfaces No. list, the result diagram is displayed along the connecting line of both intersection points. If several surfaces are cut by the projection plane, result diagrams are displayed for each of these surfaces.

In addition to the global Projection Directions in X, Y, and Z, it is possible to define a vector. With , you can select two points in the work window to define the vector.

The Show Result Diagram in Plane dialog section defines, in which surface plane the section is displayed. The setting only affects the work window (see Figure 9.27) but not the Result Diagram dialog box (Figure 9.25).

The On surfaces dialog section lists the numbers of surfaces on which the cutting lines are displayed. This option is useful if the section plane intersects with several surfaces. You can also select the relevant surfaces graphically by using the button.

The three check boxes in the Options dialog section allow you to control whether the result diagrams are displayed as a dialog box after clicking [OK] (Figure 9.25) and if you want to Save the section.
When you select the Show values on isolines check box, isolines are labeled automatically in the work window.

If the dialog input is complete, select [OK]. Usually, the following Result Diagram dialog box appears:

![Result Diagram in Section dialog box](image)

When you move the mouse along the section in the diagram, you can see the "moving" result values for the current x-location. The location x is related to the section start A and indicated in the upper right corner of the window. It is also possible to manually enter a specific location x into the text box. The Fixed check box pins the pointer to the indicated location.

Use the list in the toolbar to switch between the individual sections.

The buttons of the Result Diagram dialog box are described in Table 9.1.

With the button shown on the left, you can switch the sections on and off in the work window. You can also use the Results navigator, which allows you to additionally select specific sections among the saved ones.

The Display navigator provides global setting options for displaying sections.

![Display navigator for displaying sections](image)
The following figure shows a section through a plane and a curved surface that are both cut by the section plane. For this graphic display, the Result Diagrams Filled option was selected in the Display navigator.

**Figure 9.27** Section display of axial forces n-2 on RFEM model

### 9.6.2 Section Through Solid

Similar to a section through surfaces, enter a No. and Section Name if you want to Save the section (see Options dialog section).
When you create a Section Through a Solid, the solid-specific parameters and the corresponding graphics are displayed in the Section Type and Display Result Diagrams dialog sections.

When the section cuts through a solid, you can generate a section line that runs through the object. Then, as with surfaces, results are displayed in the Result Diagram dialog box (see Figure 9.25). Alternatively, results can be displayed On boundary surfaces of solid, which is intersected by the plane in the work window. The On sectional area of solid in graphics option directly shows the results in the section plane.

As for surfaces, the Edge Points of Section must be manually entered or selected graphically.

Starting from points A and B, two straight lines are "drawn" in the direction of the Vector. If the lines intersect a solid contained in the On solids No. list, results are displayed along the connecting line of both intersection points or as a section plane between the straight lines. If several solids are cut by the projection plane, result diagrams are displayed for each of these solids.

The Vector defines the projection direction of the section. With you can select two points in the work window to define the vector.

### 9.7 Smoothing Results

The FE analysis determines the results for each FE mesh node. Usually, a continuous distribution of the internal force or deformation is preferable for the graphic. For this purpose, it is necessary to smooth the results, for example via interpolation.

The following smoothing options are available for surfaces and solids:

- Constant on elements
- Non continuous
- Continuous within surfaces or solids
- Continuous total
- Continuously by groups

In addition, it is possible to define smooth ranges for result diagrams (see Figure 9.36).
9.7.1 Work Window

The Display navigator controls the results smoothing that influences the work window.

![Display navigator screenshot](image)

**Figure 9.29** Display navigator: Results ➜ Surfaces or Solids ➜ Distribution of Internal Forces/Stresses

**Example**

The following example illustrates the effects of the different smoothing options.

A steel plate with the dimensions 3 m \( \times \) 3 m and a thickness of 3 cm is supported on two lines with pinned supports facing each other. The plate is not modeled with one complete surface, but with two surfaces with the same properties lying side by side. The local z-axes of both surfaces are oriented in opposite directions.

![Steel plate modeled with two surfaces](image)

**Figure 9.30** Steel plate — modeled with two surfaces

The FE length is 1 m. This element size cannot provide precise results; it is only used to demonstrate the result displays of the different smoothing modes.

The steel surface is stressed only by its self-weight.
Distribution of internal forces Constant on Elements

The values of the FE nodes are averaged and the result is displayed in the middle of the elements. The distribution in each finite element is constant. This type of results display is recommended for plastic material models (see Chapter 4.3).

Distribution of internal forces Non Continuous

The display shows the FE node values that result from the displacements and rotations of each single element. Several values are therefore displayed for each FE node. A dotted line on the node value indicates the element to which the value belongs.

For the graphic display, a plane is defined by the corner values of every element. As the results of adjacent elements are not taken into account, there is a discontinuous distribution.
Distribution of internal forces Continuous within Surfaces

Figure 9.33  Distribution of internal forces Continuous within Surfaces, values On FE mesh points

The values on the FE nodes are averaged. The averaging stops on the surface boundary, which may result in discontinuities between adjacent surfaces. This is quite correct in our example. At the boundary line, two FE node values are displayed.

This smoothing option is preset because it provides the best results in most cases.

Distribution of internal forces Continuous Total

Figure 9.34  Distribution of internal forces Continuous Total, values On FE mesh points

The average values are determined by considering the FE values beyond the surface boundaries. This leads to a continuous distribution between adjoining surfaces, which is not correct for our example.
The following requirements must be met for the Continuous Total display option:

- The orientation of the surface axis systems is congruent.
- Only two surfaces concur.
- The surfaces lie in one plane.
- No line release is defined on the boundary line.

If one of these conditions is not met, incorrect result distributions are displayed.

**Distribution of internal forces Continuously by Groups**

It is also possible to smooth results by groups. RFEM provides Generated groups with similar material properties.

You can create user-defined groups of surfaces or solids by using the navigator shortcut menu (right-click User Groups).

Then, a dialog box opens where you can define the objects that you want to examine as a group.
In the Result Diagram dialog box (see Chapter 9.5), you can create smooth ranges to prepare results for civil engineering purposes. To use this function, click the diagram toolbar button shown on the left. The following dialog box opens.

Define the Smooth Ranges in the table columns on the left; entries for Start, End, and Length are interactive. Each range can be separately set to Active. The Use for Results dialog section allows you to control, for which deformations and internal forces you want to apply a smoothing.

The smoothing can be defined as Constant (as shown in the figure above) or as Linear for all smooth ranges.
9.7.3 Average Region

It is possible to define a region in the model where the graphical results are not displayed with the actual distributions, but as an average value. This average region allows for an evaluation of the averaged surface internal forces and stresses. Regions are managed as independent objects in the tabs of the Project Navigator.

To create an average region, select the menu item

**Results → New Average Region**

or use the corresponding shortcut menu in the Data navigator.

A dialog box opens where you can specify the parameters of the region.
In addition to the No., you have to enter the Description of the region, making the selection easier when you evaluate results. The regions are stored under Average Regions in the Data navigator where they can also be adjusted retroactively.

The On Surfaces No. dialog section lists the numbers of the surfaces for which you want to average results. This option is useful if the region’s projection intersects with several surfaces. You can also select relevant surfaces graphically using the button.

In the Center dialog section, specify the center point C of the region. The coordinates can be entered manually or selected graphically in the work window using the button. The Dimensions describe the shape of the region by means of parameters relevant for your settings.

The Projection in Direction dialog section describes the reference of the defined region to the surfaces. Generally, the projection is set perpendicular to the selected surfaces, but global projection directions in X, Y, and Z are also possible, as well as entering any projection vectors. With the button, you can select two points in the work window to define the vector.

The Angular Rotation dialog section provides an option to rotate the average region. The Form of the region can be defined as a rectangle, circle, or ellipse. The respective parameters are shown in the dialog graphic to the right.

In the Directions and forces for Averaging dialog section, you can specify the local axes that the Grouped averaging should refer to for the internal forces. Alternatively, it is possible to use the Individual averaging to only consider selected surface axes and internal forces.

It is also possible to Set result values over the entire region to zero. In this way, you can disable the result values in a selected zone of the model.

In the Results navigator, you can individually display and hide average regions.
9.8 Multiple Windows View

On the screen, several windows with different deformations or internal forces can be displayed at the same time. To open the corresponding dialog box, use the menu item

**Results → Arrange Result Windows**

or the toolbar button shown on the left.

A dialog box with a navigator tree opens where you can select the result types to be displayed in the individual windows.

![Show Results in Multiple Windows dialog box](image)

The multiple windows display can also be used for the printout (see Chapter 10.2.1).
9.9 Filtering Results

Various filter functions are available, which are especially useful for evaluating and documenting results in case of complex models.

9.9.1 Views

User-defined views (angles of view, zoom settings, etc.) make the results evaluation easier. By using "visibilities", you can divide the model into user-defined and generated partial views that fulfill certain criteria. It is thus possible, for example, to only activate the surfaces of a plane or members with a particular cross-section for the display. Of course, you can use these options both for the evaluation of results and for the input of model or load data.

You can access the different functions in an independent navigator (Chapter 9.9.1.1) and by using list buttons or menu functions (Chapter 9.9.1.2).

9.9.1.1 Views navigator

The Views tab of the project navigator allows you to create user-defined views of the model, which you can use for input and evaluation. The tab also manages the user-defined or automatically created visibilities.

![Figure 9.40 Views tab of the navigator](image-url)
User-defined views

In contrast to object-oriented Visibilities (see below), User-defined views allow you to save and import specific viewing angles, zoomed views, and settings in the Display navigator.

The current view is saved as a display setting—regardless of the filter specifications effective in the Visibilities list: RFEM always uses the current visibilities settings for the object representation of a User-defined view. A User-defined view manages the viewing angle, the zoom factor, and the specifications set in the Display navigator.

Use the View buttons to quickly set the following standard angles of view:

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="View against axis X" /></td>
<td>View against axis X</td>
</tr>
<tr>
<td><img src="image" alt="View against axis Y" /></td>
<td>View against axis Y</td>
</tr>
<tr>
<td><img src="image" alt="View against axis Z" /></td>
<td>View against axis Z</td>
</tr>
<tr>
<td><img src="image" alt="View in direction of or against axis U of work plane" /></td>
<td>View in direction of or against axis U of work plane (see Chapter 11.3.1)</td>
</tr>
<tr>
<td><img src="image" alt="View in direction of or against axis V of work plane" /></td>
<td>View in direction of or against axis V of work plane</td>
</tr>
<tr>
<td><img src="image" alt="View in direction of or against axis W of work plane" /></td>
<td>View in direction of or against axis W of work plane</td>
</tr>
</tbody>
</table>

Table 9.2 View buttons

The buttons below the views list have the following functions:

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Create a new User-defined view from the current view" /></td>
<td>Creates a new User-defined view from the current view (see Figure 9.41)</td>
</tr>
<tr>
<td><img src="image" alt="Redefines the active User-defined view via the current view" /></td>
<td>Redefines the active User-defined view via the current view</td>
</tr>
<tr>
<td><img src="image" alt="Restores the active User-defined view after modifications" /></td>
<td>Restores the active User-defined view after modifications</td>
</tr>
<tr>
<td><img src="image" alt="Deletes the entry selected in the User-defined views list" /></td>
<td>Deletes the entry selected in the User-defined views list</td>
</tr>
<tr>
<td><img src="image" alt="Deletes all User-defined views" /></td>
<td>Deletes all User-defined views</td>
</tr>
</tbody>
</table>

Table 9.3 Buttons in the User-defined views navigator section

Creating user-defined views

The current view can be saved by using the [Create New User-Defined View] button. A dialog box appears where you have to enter the Name of the new display setting.

![New User-Defined View dialog box](image)
**Visibilities**

With the so-called "visibilities", it is possible to display partial views of the model or groups of objects (e.g. surfaces in one plane or columns of a particular floor).

**Visibility buttons**

The buttons above the Visibilities list (see Figure 9.40) allow you to select the displayed objects according to particular criteria. The buttons have the following functions:

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Display" /></td>
<td>Displays the objects selected in the work window in partial view.</td>
</tr>
<tr>
<td><img src="image" alt="Hide" /></td>
<td>Hides the objects selected in the work window.</td>
</tr>
<tr>
<td><img src="image" alt="Create" /></td>
<td>Creates a visibility by drawing a window (see Chapter 9.9.1.2).</td>
</tr>
<tr>
<td><img src="image" alt="New" /></td>
<td>Defines a new visibility by using object numbers (see Chapter 9.9.1.2).</td>
</tr>
<tr>
<td><img src="image" alt="Rest" /></td>
<td>Restores the previous visibility.</td>
</tr>
<tr>
<td><img src="image" alt="Reverse" /></td>
<td>Reverses the current display (new visibility: hidden objects).</td>
</tr>
<tr>
<td><img src="image" alt="Exit" /></td>
<td>Exits visibility mode. All objects are displayed again.</td>
</tr>
</tbody>
</table>

*Table 9.4* Buttons above Visibilities list

The Visibilities list contains user-defined and generated visibilities.

**User-defined visibilities**

You can create a visibility with the graphical or numerical selection of objects (see Chapter 9.12).

Use the [Create New User-Defined Visibility] button (below the Visibilities list) to save the current partial view. The New User-Defined Visibility dialog box opens where you can define a name and the Group (see Figure 9.45).

The buttons below the Visibilities list are explained in Table 9.5.

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="New User-Defined Visibility" /></td>
<td>The New User-Defined Visibility dialog box appears (see Figure 9.45).</td>
</tr>
<tr>
<td><img src="image" alt="Add" /></td>
<td>Adds the objects selected in the work window to the group marked in the list above.</td>
</tr>
<tr>
<td><img src="image" alt="Remove" /></td>
<td>Removes the objects selected in the work window from the group marked in the list above.</td>
</tr>
<tr>
<td><img src="image" alt="Reassign" /></td>
<td>Reassigns the selected objects to the group marked above.</td>
</tr>
<tr>
<td><img src="image" alt="Reverse" /></td>
<td>Reverses the current display (new visibility: hidden objects).</td>
</tr>
<tr>
<td><img src="image" alt="Show All" /></td>
<td>Shows all objects activated in the Visibilities list.</td>
</tr>
</tbody>
</table>
Only shows objects available in each active Visibilities entry.

Table 9.5 Buttons below Visibilities list

The Add new objects into visibility check box allows you to control, how new nodes, lines, members, etc. should be treated when working in a user-defined visibility. If this option is selected, you can specify the relevant group in the list below.

A color symbol is automatically assigned to each user-defined visibility. In the Display navigator, these colors can also be used for the graphical display of objects (see Chapter 11.1.9). With this, you can quickly detect the customized visibilities in the model. To control the display of groups, use the Views navigator.

**Generated visibilities**

RFEM automatically generates visibilities for surfaces, lines, members, etc. according to specific criteria.

These generated visibility types help you to get a quick overview of the model, since you can use the list to specifically filter objects. In this way, you can easily check both input and results in RFEM.

In addition to the multiple selection of generated views (default), the list allows you to create an intersection. Use the navigator buttons shown on the left to set the intersection; you can find them below the list. The functions are described in Table 9.5.

The User-defined / generated check box above the list allows you to control if the filter function is effective for the work window: All objects are displayed again after removing the check mark.
### 9.9.1.2 Visibility buttons and menu

To access the different visibility functions, use the menu option

*View → Visibility*

or the corresponding list button in the toolbar.

#### Visibility by Window

Partial views can be created graphically by drawing a window with the mouse.

If you draw the window from left to right, the partial view only contains objects that are completely within this window. When opening the window from right to left, the partial view also includes objects that are cut by the window.

#### Visibility by Numbering

Enter the numbers of Nodes, Lines, Surfaces, Solids, or Members that are relevant for the partial view in a dialog box.

#### Cancel Visibility Mode

Use this function to restore the view of all objects.
Create User-Defined Visibility

Before you access this function, select the objects that you want to save as a Visibility in the work window (see Chapter 11.2.1 and Chapter 11.2.2). The menu function **Edit → Select → Special** is useful for this.

Only the objects that are selected in the work window are integrated into a Visibility. Therefore, when you use the [Visibility by Hiding Selected Objects] function, you have to select the displayed objects once more by drawing a window.

After a click on the [New] button, the following dialog box appears.

![New User-Defined Visibility dialog box](image)

Define the Name and Group. If you want to use several visibility groups, click the [New] button to create another group.

![New Group for Visibilities dialog box](image)

Click [OK] to save the group of objects as a new visibility.

The user-defined visibilities are managed in the Views navigator where they can be switched on and off individually (see Figure 9.40).

Changing objects into visibilities

Objects can be retroactively integrated into existing visibilities: Exit the visibility mode by clicking the button shown on the left or using the menu item **View → Visibility → Cancel Visibility Mode**. Now, select the objects that you want to add.

In the Views navigator, click the relevant entry in the User-defined list. RFEM enables the button, which allows you to integrate the selected objects into the user-defined visibility.

Analogously, you can use the button to remove selected objects from a user-defined visibility.

Click the button to overwrite the objects available in the marked visibility of the Views navigator with the selection in the work window. With this, existing visibilities can be redefined but the name is kept.
Transparency for hidden objects

When you use visibilities, it is possible to display hidden objects with minor intensity in the background. The degree of visibility is set individually in the Graphics tab of the Program Options dialog box (see Figure 9.52). The display of background objects can be turned on and off in the Display navigator.

9.9.2 Clipping Plane

This feature allows you to define any section plane that cuts through the model. The zone in front of (or behind) the plane is consequently hidden in the display. With this, it is possible, for example, to look at the results in an intersection or in a solid.

RFEM places the clipping plane through the center of the geometric total dimensions. Thus, the plane is related to the model geometry. In the work window, the clipping plane is enclosed by a frame. It is not possible to save a clipping plane.

To open the corresponding dialog box, use the menu option Insert → Clipping Plane.

The following dialog box appears:
You can arrange the Plane to be parallel to one of the planes spanned by the axes of the global coordinate system XYZ. It is possible to place the plane into the current work plane as well. You can also select three points in the work window by clicking the button.

The value entered into the Offset text box results in a parallel displacement of the plane in the direction of the positive or negative axis that is perpendicular to the plane. Both directions are indicated by gray arrows in the work window. The offset can be entered directly or set with the two spin buttons . The Step text box controls the interval of spacings by which the plane is moved every time you click a spin button.

In the Options dialog section, you can change the active side of the clipping plane. Moreover, you can switch the result diagrams on the clipping borders on and off.

You can rotate the clipping plane with a Rotation by the angles \( \alpha \) (about the last named axis of the plane) and \( \beta \) (about the first named axis). The graphic is interactive with the input.

When the Clipping Plane dialog box is open, you can use all functions to change the view in the work window, but there is no printout option. You can exit the function with the [Close] button.

The following example shows a clipping plane that runs through a node of a pipe connection.

![Figure 9.49: Clipping plane cutting through a pipe connection](image-url)
9.9.3 Filter Functions

The grouping options described in Chapter 9.9.1 refer to the objects of the model. Additionally, you can use internal forces, deformations, and stresses as filter criteria.

Filtering results

Results are filtered by means of the control panel. If it is not displayed, use the menu option View → Control Panel or the corresponding button in the Results toolbar.

The control panel is described in Chapter 3.4.6.

The filter settings for results are defined in the Color Scale tab that is shown for the isoband and isoline results of surfaces and solids (see Figure 3.16). As this tab is not available for the two-colored display of member internal forces, you have to switch to the With/Without Diagram or Cross-Sections display options in the Display navigator (see figure on the left).

In the panel, you can configure, for example, that member moments are only displayed if they exceed a certain value or that base internal forces of surfaces are only displayed within the range of ± 30 kNm using a fine gradation (see Figure 3.18).

The following example represents a floor slab. RFEM only displays contact stresses between −120 kN/m² and −260 kN/m² on the model.

As the model also provides multi-colored member results, the Surfaces selection field is set active in the control panel. The color scale is modified in such a way that one color range covers exactly −20 kN/m². No results for surface elements with elastic foundations whose contact stresses are beyond the defined range of values are shown.
Filtering objects

In the Filter tab of the control panel, you can enter the numbers of selected members, surfaces, or solids to display their result diagrams in a filtered display. This function is described in Chapter 3.4.6.

In contrast to the visibility function, the model is displayed completely in the graphic.

The following figure shows the bending moments available in the floor surfaces of a building. The walls are shown in the model but are displayed without internal forces.

The filter settings of the panel also affect the objects in the results tables: When you restrict the results display in the panel to two members, for example, Table 4.6 Members - Internal Forces only lists the results of those two members.

Animation of Deformations

Normally, deformations of objects are displayed in their final state.

However, it is also possible to show the deformation process as an animation. To open the corresponding dialog box, use the menu option

Results → Animation

or the corresponding toolbar button. To close the animated view, click the button again. You can also use the [Esc] key.

To define detailed settings for the animation process, use the menu entry

Options → Program Options

in the Graphics dialog tab.
The animation of deformations can be saved as a video file. Arrange the animated graphic appropriately on the screen and then use the menu option

**Tools → Create Video File.**

You may see a message about the OpenGL settings before the corresponding dialog box appears where you can define different settings for creating the video file.

Click the [Browse] button to specify the name of the video file in a separate dialog box.

The red [Record] button starts the recording and the blue [Stop] button stops it.
10 Printout

10.1 Printout Report

Normally, input data and results of RFEM are not sent directly to the printer. Instead, a so-called printout report is generated first to which you can add graphics, explanations, scans, and other elements. In the printout report, you have to define the data that is relevant for the printout.

It is possible to create several printout reports for the model. When your structure is complex, it is recommended to split the data into several small reports instead of creating one large report. For example, you can create a report for the input data, another one for the support forces, and one for the surface results. In this way, you can reduce waiting periods.

It is also possible to create different printout reports in an RFEM model. Depending on the required data, the test engineer and the design engineer may want different printout reports.

A printout report can only be opened if a default printer is installed. The preview in the printout report uses the printer driver.

10.1.1 Creating or Opening Printout Reports

To create a new printout report, use the menu option

File → Open Printout Report,

the toolbar button shown on the left, or the shortcut menu in the Data navigator.

The following dialog box appears.

![New Printout Report dialog box](image)
The No. of the report is preset but can be changed. In the Description text box, you can enter a name for the report, which facilitates the selection in the lists later. This description does not show up in the printout.

You can select a specific report template from the list in the Printout Report Template dialog section (see Chapter 10.1.7).

The buttons in the dialog box have the following functions:

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Template icon]</td>
<td>A new report template is created.</td>
</tr>
<tr>
<td>![List icon]</td>
<td>The selection of the report can be changed (see Chapter 10.1.3).</td>
</tr>
</tbody>
</table>

Table 10.1 Buttons in New Printout Report dialog box

If a printout report is already available and you select **File → Open Printout Report** in the menu, the Printout Report Manager appears.

You can select the relevant report from the list.

The buttons in the dialog box have the following functions:

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Add icon]</td>
<td>Creates a new printout report.</td>
</tr>
<tr>
<td>![Delete icon]</td>
<td>Deletes selected printout report.</td>
</tr>
</tbody>
</table>

Table 10.2 Buttons in the Printout Report Manager dialog box
10.1.2 Working in the Printout Report

When the printout report is open, the report navigator is displayed on the left and the page view with the preview of the printout on the right.

In the navigator, the individual chapters of the report can be arranged in any way by using the drag-and-drop function. The following should be noted: If you move a chapter to a Symbol (the folder on the left in the figure), it is inserted after this chapter. However, if you move the chapter to a Title (Text), it is added as a subchapter.

If you move multiple chapters, we recommend switching off the [Immediate Refresh].

Shortcut menu

The shortcut menu (see Figure 10.4) provides functions for adjusting the printout. As is common for Windows applications, a multiple selection is possible by using the [Ctrl] and [⇧] keys.

Remove from Printout Report

The selected chapter is deleted. If you want to reinsert it, use the selection (go to the menu and select Edit → Selection).

Start with New Page

The selected chapter starts on a new page. It is marked by a red pin in the navigator (such as the chapter Results - Summary in Figure 10.4).
Selection

You have access to the global selection that is described on the following pages. The selected chapter is preset.

Properties

Some general properties of the selected chapter can be modified.

![Properties dialog box](image)

In the dialog box, you can change the Title of the chapter and enter an Additional Explanation, which appears in the left margin of the report. The additional text can be displayed and hidden, like the info pictures of the chapter (e.g. drawings of cross-sections or loading).

Navigation in the printout report

To look at a particular section in the printout report, click the corresponding chapter in the navigator.

The Edit menu provides further navigation functions. You can also use the corresponding buttons in the report toolbar to access these functions.

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Previous Page" /></td>
<td>Go to previous page in the page preview</td>
</tr>
<tr>
<td><img src="image" alt="Next Page" /></td>
<td>Go to next page</td>
</tr>
<tr>
<td><img src="image" alt="First Page" /></td>
<td>Go to first page in the page preview</td>
</tr>
<tr>
<td><img src="image" alt="Last Page" /></td>
<td>Go to last page</td>
</tr>
<tr>
<td><img src="image" alt="Page Number" /></td>
<td>Specify the number of a particular page in a dialog box</td>
</tr>
<tr>
<td><img src="image" alt="Zoom In" /></td>
<td>Zoom in</td>
</tr>
<tr>
<td><img src="image" alt="Zoom Out" /></td>
<td>Zoom out</td>
</tr>
</tbody>
</table>
10.1.3 Defining the Content of Printout Reports

In the global selection, you can select the chapters that you want displayed in the printout report. To open the corresponding dialog box, use the menu entry Edit → Selection, the toolbar button shown on the left, or the shortcut menu of the Printout Report.

The following dialog box appears.
The list in the Program / Modules dialog section contains all add-on modules where input data is available. When a program is selected in the list, you can choose the chapters to be printed in the tabs to the right.

The Global Selection tab manages the main chapters of the report. If you clear a check box, the corresponding detail register disappears.

The three check boxes in the Display dialog section (bottom left) allow you to control if a Cover sheet, a table of Contents, and small Info pictures are displayed in the report margin.

### 10.1.3.1 Selecting model data

![Printout Report Selection dialog box, Model Data tab](image)

The check boxes in the Display column allow you to control, which chapters appear in the printout report.

There are subchapters for some tables. If you click into table field 1.13 Cross-sections, for example, you can open another dialog box with the button. There you can define the sections for which cross-section details are included. To define the type and extent of details, use the button.
The printout report is based on the input tables described in Chapter 4. The check boxes in the third column, All, allow you to control if all rows of the selected table are included in the printout. When a check box is cleared, you can specify the numbers of selected objects (table rows) in the Number Selection column.

It is also recommended to use the button at the end of the text box because it allows you to select nodes, members, sets of members, etc. graphically in the work window. For the remaining objects, a list with table rows appears.
### 10.1.3.2 Selecting load cases and combinations

This dialog tab allows you to control the information about load cases and combinations that appears in the printout report. Use the button at the end of a text box to open a dialog box where you can select specific subtables.

In the All column, you can use the button to select specific table entries (load cases, actions, combination expressions, etc.) for the printout (see previous Chapter 10.1.3.1).
10.1.3.3 Selecting load data

Tables are selected as described in Chapter 10.1.3.1. Specific selection options are available in this tab. In the Load Cases to Display - Tables dialog section, you can determine whether the input data of all or only some selected load cases are included in the printout. When the Selected selection field is activated, you can use the button to open a new dialog box where you can select the load cases.
Selecting the normally comprehensive results data is done in two dialog tabs: The LC/CO Results tab manages the selection for load cases and load combinations, the RC Results tab controls the printout for the results of result combinations.

Results data can be prepared like load data (see Chapter 10.1.3.3): Use the Selected selection field to restrict the printout data to results of specific load cases or combinations.

In the Tables to Display dialog section, you can select the tables and table rows as described in Chapter 10.1.3.1. The Number Selection column allows you to specify particular objects or to select objects graphically at the end of the table row with the button.

In the Table column, some table rows have three dots at the end of the line. The dots indicate the button that you can activate by clicking into the table row. Use this button to access more selection criteria, such as for member internal forces.
The printout report lists the results of each member on the following locations:

- Start and end node
- Division points according to specified member division (see Chapter 4.16)
- Extreme values (Max/Min) of results (see Chapter 8.6)

The selection is connected with the table filter settings (see Figure 11.122).

You can considerably reduce the printout extent by restricting output data to results that are indispensable for your documentation.

If several load cases or COs for which you want to document different results data are available (e.g. internal forces of CO1, support forces of CO2), you first have to do the global selection. After having created the printout report, you can remove the unimportant results by deleting the navigator items. To avoid the selection being overwritten by the global settings again, the Replace individual settings check box is additionally displayed when opening the Printout Report Selection once more (see example in the Knowledge Base).

### 10.1.3.5 Selecting data of add-on modules

The printing data of all add-on modules is also managed in the RFEM printout report. You can combine it with the RFEM data into a single report or organize it in separate printout reports. For complex structural systems with a high number of design cases, it is recommended to split data into several printout reports.

In addition to RFEM, the list in the Program / Modules dialog section contains all add-on modules where entries have been made. When you select a module in the list, you can choose the chapters for printing in the tabs to the right.
The Global Selection dialog tab manages the main chapters of the add-on module data. When you clear a check box, the respective detail tab disappears as well.

The Display all cases option in the Cases to Display dialog section is selected by default. If you only want to include specific design cases in the printout report, clear the check box. Now you can move the cases that you do not need from the Cases to Display list to the Existing cases list.

The selection in the detail tabs of the input and results data is analogous to the selection described in the chapters 10.1.3.1 and 10.1.3.4.

### 10.1.4 Adjusting Printout Report Headers

During the program installation, a printout report header is created from the customer data. To change the data for the printout report, use the menu option

**Settings → Header**

or the toolbar button in the printout report shown on the left.

The following dialog box appears.
**Header Default**

If several report headers are available, you can select the appropriate header in the list.

You can also use the button to access different report headers. Additionally, you can create, modify, or delete headers in the library.

![Header Library dialog box](image)

**Figure 10.19** Header Library dialog box

The buttons in the Header Library have the following meanings:

<table>
<thead>
<tr>
<th>Button</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Create" /></td>
<td>Creates a new header. You can enter the specifications in another dialog box that is similar to the Printout Report Header dialog box <a href="image">see Figure 10.18</a>.</td>
</tr>
<tr>
<td><img src="image" alt="Edit" /></td>
<td>Allows you to edit the properties of the selected printout report header.</td>
</tr>
<tr>
<td><img src="image" alt="Delete" /></td>
<td>Deletes the header selected in the list.</td>
</tr>
</tbody>
</table>

**Table 10.4** Buttons in Header Library dialog box

The headers are stored in the `DlubalProtocolConfigNew.cfg` file in the general master data folder `C:\ProgramData\Dlubal\Global\General Data`. The file is not overwritten during an update; a backup file may still be useful.

**Display**

The settings in this dialog section determine, which elements of the page layout or header are shown.

The *Info row below header* option activates or deactivates the display of project and model data, with or without date [see below]. The project description is taken from the project's general data filed in the project manager [see Chapter 12.1.1](image); the model description is taken from the base data of the model [see Chapter 12.2](image). The default specifications for the printout can be adjusted in the Change Project Name/Description and Change Model Name/Description dialog sections [see below].

The **Footer** can be switched on and off, just like the **Black circles** in the points of intersection of the boundary line with the header and footer line.

**Date**

RFEM provides automatic default settings and a **User-defined** specification option for displaying the date in the printout report header.
Page and Sheet Numbering

If the Page and Sheet have the same initial numbers and both check boxes are selected, there is no difference in numbering (see figure on the left).

Use the button for more detailed settings of the numbering.

Use this dialog box to decide if a Prefix is applied to the page numbering. The prefix can be an abbreviation that is specified chapter by chapter, labeling all model data in the numbering with a prefixed "MO", for example. In addition, you can decide if the End number is included, for example "Page: MO3/25".

Use the Automatically increasing check boxes to define a continuous numbering. You can also specify the First number for the page and sheet numbering. The Result table column dynamically shows the result of all specifications.

Company Address

This section of the Printout Report Header dialog box contains information from the customer data that can be adjusted. A separate text box is provided for each row of the report header. You can use the button to change the font and font size. The Alignment of rows can also be defined separately.

The left area of the header is reserved for the company logo. The graphic must be in *.jpg, *.png, *.gif, or *.bmp format; use the button to import it.

To save the modified settings, click the button at the bottom of the dialog box. The Header Template Name dialog box opens where you have to enter a description. The new report header then appears as the Header Default.
Change Project Name/Model Name/Description

In both dialog sections, the project and model name including user-defined descriptions are preset. To modify the presettings, select the check boxes in front of the relevant name. The text boxes then become accessible for new entries that appear later in the printout.

10.1.5 Inserting RFEM Graphics

Every picture displayed in the work window can be integrated into the printout report. It is also possible to include result diagrams of sections, members, and line supports, as well as the cross-section details in the report by using the button in the respective dialog boxes.

To print the currently displayed graphic, use the menu entry

File → Print Graphic

or the toolbar button shown on the left.

The following dialog box appears.
**Graphic Picture**

Select the To a printout report option in this dialog section. If several printout reports are available, you can select the number of the relevant report in the list to the right.

**Options**

**Lock graphic picture**

Dynamic graphics are generated by default: When the model or the results are modified, the graphics in the printout report are updated automatically. If performance problems occur in the report because of the graphics, you can stop the dynamic adjustment by selecting the Lock graphic picture (without update) check box.

In the printout report, a graphic can be unlocked again: Right-click the graphic item in the report navigator to open its shortcut menu (see Figure 10.4). Select Properties to once more access the Graphic Printout dialog box of the picture. You can also mark the graphic in the report navigator and select Edit → Chapter Properties in the menu.

The lock buttons in the toolbar of the printout report provide another way to classify graphics as static or dynamic (see Figure 10.4). The buttons have the following functions.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="icon1" alt="Icon" /></td>
<td>All graphics are updated.</td>
</tr>
<tr>
<td><img src="icon2" alt="Icon" /></td>
<td>All graphics are unlocked and can therefore be updated dynamically.</td>
</tr>
<tr>
<td><img src="icon3" alt="Icon" /></td>
<td>All graphics are locked and therefore fixed in place in the printout report.</td>
</tr>
</tbody>
</table>

**Show printout report on [OK]**

When closing the dialog box with [OK], the printout report normally opens so that you can check the print results. This may be annoying when you want to transfer several graphics in a row to the printout report, for example. After clearing the check box, it is possible to print pictures without waiting periods when creating the printout report.

The remaining functions and tabs of the dialog box are explained in Chapter 10.2.

**Changing a graphic in the printout report**

![Figure 10.23](image) Graphic shortcut menu in the printout report

- **Figure 10.23**: Graphic shortcut menu in the printout report
Use the shortcut menu of the printout report to change a graphic retroactively.

Among other things, the Properties control the size, frame, and color of the picture. Use the Edit button to edit the view (angle of view, object and value display, etc.) in the RFEM work window.

### 10.1.6 Inserting Graphics and Texts

External graphics and texts can also be integrated into the printout report of RFEM.

#### Graphics

To insert an image that is not an RFEM graphic, you first need to open the graphic file in an image editor (e.g. MS Paint) and then copy it to the clipboard using [Ctrl]+[C].

To insert the graphic from the clipboard into the printout report, use the menu option

**Insert → Image from Clipboard.**

Before it is inserted, you have to enter a chapter name for the new graphic.

![Insert image from the Clipboard dialog box](image)

The graphic appears as a separate chapter in the printout report.

#### Texts

You can also add short, user-defined notes to the printout report. To use this function, select the printout report menu entry

**Insert → Text Block.**

![Import Text dialog box](image)

Enter the Title and the Text. After clicking [OK], the chapter is inserted at the end of the printout report. Then you can use the drag-and-drop function to move it to the desired place in the printout report.

In the selection mode (see Table 10.3), you can retroactively modify the text with a double-click. Alternatively, right-click the heading in the navigator and then select Properties in the shortcut menu.
Text and RTF files

Text files in ASCII format and formatted RTF files including embedded graphics can be integrated into the printout report. Hence, you can save recurring texts in files to use them in the report.

This function also allows you to integrate analysis data from other design programs into the printout report, provided that the results are available in ASCII or RTF format.

To insert text and RTF files, select the printout report menu item

**Insert → Text File.**

First, the Windows dialog box Open appears where you can select the file. After clicking the [Open] button, the chapter is added to the end of the printout report. Then you can use the drag-and-drop function to move the chapter to the desired place in the printout report.

In the selection mode (see Table 10.3), you can retroactively modify the text with a double-click. The **Import Text** dialog box appears for user-defined adjustments.

![Import Text dialog box](image)
10.1.7 Printout Report Template

The selection described in Chapter 10.1.3 is relatively time-consuming. It is possible to save such a selection including graphics as a template that you can use for other models. Creating printout reports becomes more efficient with these templates.

An existing printout report can also be saved as a template.

Creating new templates

New templates are defined by using the two printout report menus:

Settings → Printout Report Template → New

New

First, the selection dialog box described in Chapter 10.1.3 opens.

Use the tabs to select the chapters that you want to print. When the selection is complete, click [OK] and enter a Description of the new report template.

![New Printout Report Template dialog box](image)

New from Current Printout Report

The selection of the currently shown printout report is used for the new template. You have to enter the Description of the new report template in the dialog box (see Figure 10.29).

Applying templates

When a printout report is already open, you can apply the selected contents of a template to the current report. To open the corresponding dialog box, use the menu option

Settings → Printout Report Template → Select.

A dialog box opens where you can select the template from the list of the Available Printout Report Templates.

![Printout Report Template dialog box](image)
More information about the buttons in this dialog box can be found in Table 10.6.

After confirming the dialog box and the subsequent security query, the current selection is overwritten by the template.

When you create a new printout report, you can select a template from the Printout Report Template list to apply specific settings to the new report.

Managing templates

All templates are managed in the Printout Report Template dialog box. To open this dialog box, use the menu option

\[\text{Settings} \rightarrow \text{Printout Report Template} \rightarrow \text{Select.}\]

The dialog box shown in Figure 10.30 appears. The functions of the buttons are only enabled for user-defined templates.

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Change Name Button]</td>
<td>Allows you to change the name of the selected template.</td>
</tr>
<tr>
<td>![Delete Button]</td>
<td>Deletes the selected template.</td>
</tr>
</tbody>
</table>

Table 10.6

The printout report templates are stored in the \texttt{RfemProtocolConfig.cfg} file that can be found in the master data folder for RFEM 5 \texttt{C:\ProgramData\Dlubal\RFEM 5.xx\General Data}. The file is not overwritten during an update. By copying the file, the report templates can be transferred to another computer.
10.1.8 Adjusting Layouts

The layout of a printout report can be adjusted regarding its fonts and font colors, as well as its margin settings and table design.

To open the dialog box where you can edit the page layout, select the menu item

Settings → Page

or use the toolbar button in the printout report shown on the left.

The default fonts for table contents and table headers are relatively small. However, you should be careful when changing the default Arial font sizes: Larger fonts do not always fit in the columns and entries are truncated.

The layout settings also apply to the printout reports of the RFEM add-on modules.
10.1.9 Creating Cover Sheets

The printout report can be provided with a cover sheet. To open the dialog box where you can enter the cover sheet data, use the menu option

**Settings → Cover**

or the toolbar button in the printout report shown on the left.

When the input is complete, click [OK] to create the cover in the report.

![Cover Sheet dialog box](image)

![Cover sheet in the printout report](image)
The contents of the cover sheet can be modified again with a double-click in the selection mode (see Table 10.3). Alternatively, right-click the cover sheet in the report navigator and select Properties in the shortcut menu.

### 10.1.10 Printing a Printout Report

To start the printing process, select the printout report menu entry

```
File — Print
```

or use the corresponding button in the printout report toolbar.

![Printout Report button](image)

The standard Windows printer dialog box opens where you can specify the printer and the pages that you want to print.

![Print dialog box](image)

If you do not use the default printer, the page break and therefore the page numbers on the paper might be different from the print preview in RFEM.

If you select the Print to File option, you can create a print file in the PRN format that can be sent to the printer with the `copy` command.
10.1.11 Exporting a Printout Report

The printout report can be exported to different file formats or directly to VCmaster.

**RTF export**

All common word processing programs support the RTF file format. To export the printout report including graphics as an RTF document, use the menu option

**File → Export to RTF.**

The Save As Windows dialog box opens.

![Save As dialog box](Figure 10.37)

Enter the storage location and the file name. If you select the Export selected blocks only check box, only the chapter(s) that have previously been selected in the navigator are exported instead of the entire report.

**PDF export**

The integrated PDF printer allows you to output report data as a PDF file. To open the corresponding dialog box, use the menu item

**File → Export to PDF.**

The Save As Windows dialog box opens (see Figure 10.37) where you have to enter the storage location and the file name. In the Description dialog section below, you can enter notes for the PDF file.

Moreover, the PDF file is created with bookmarks that make navigating the digital document easier.

**VCmaster export**

VCmaster from the Veit Christoph company (formerly BauText) is a word processing program with specific extras for structural calculations.

To start the direct export to VCmaster, use the [Export to VCmaster] button in the report’s toolbar.

For a successful export, VCmaster should already be running in the background.
10.1.12 Language Settings

The language in the printout report is independent of the language set for the RFEM user interface. Thus, you can create a German or Italian printout report when you are working with the English program version.

Changing the language for a printout

To change the language used in the printout report, select the menu entry

Settings → Language.

A dialog box opens where you can select the desired language from the list.

![Languages dialog box](image)

Adding available languages

The expressions used in the printout report are stored as strings. Thus, adding new languages is relatively easy.

First, open the Languages dialog box with the menu option

Settings → Language.

In the lower part of the dialog box, there are some buttons for managing the languages.

Creating new languages

In the dialog box, specify the Name of the new language and select a Language group from the list so that the character set is interpreted correctly.

![Create New Language dialog box](image)
After clicking [OK], the new language is available in the list of Existing Languages.

![Languages dialog box](image)

**Figure 10.40** Languages dialog box, Edit Selected Language button

You can use the button to enter the strings of the new language.

![Edit Printout Report Texts dialog box](image)

**Figure 10.41** Edit Printout Report Texts dialog box

Only user-defined languages can be edited.
Copying languages

This function is similar to the creation of a new language. The difference is that you do not create an "empty" language column (see Figure 10.41, Basque column) since the terms of the selected language are preset.

Renaming or deleting languages

Use the remaining buttons of the Languages dialog box to rename or delete a language. The two functions cannot be accessed for the default languages, only for user-defined languages.


10.2 Direct Graphic Printout

Each graphic of the work window can be printed immediately without embedding it in the printout report beforehand (see Chapter 10.1.5). Result diagrams of sections, members, sets of members, lines, and line supports, as well as cross-section details can also be sent directly to the printer by using the [Print] button provided in the respective windows.

To directly print the currently displayed graphic, use the menu option

File → Print Graphic

or the corresponding toolbar button.

A dialog box with several tabs appears, which are described in the following chapters.

10.2.1 General

![Graphic Printout dialog box, General tab](image)
Graphic Picture

There are four options for graphical output: You can send the image

- directly to a printer
- to a printout report (see Chapter 10.1.5)
- to the clipboard
- to a 3D PDF

The Directly to a printer option results in a direct printout. It is possible to adjust the report header by using the button that opens the Printout Report Header dialog box (see Chapter 10.1.4).

When printing to a Printout report, the graphic is added to the printout report PR, which can be selected from the list. If no printout report is available, the New Printout Report dialog box is displayed after confirming the dialog box where you can specify the description and content of the printout report (see Figure 10.2).

The Clipboard provides the graphic for other programs. Then you can import the graphic anywhere you want by selecting Edit → Insert on the menu.

If the graphic is to be filed as a 3D PDF, the button also allows you to adjust the report header. The button opens the 3D PDF Print Page Setup dialog box where the specifications for the print format can be defined. You can find further information about 3D PDFs on the Adobe support website.

Window To Print

This dialog section is used for defining the printout settings of multiple windows views. Select Current only to print the graphic of the active window (e.g. the right window in Figure 10.46).

Please note that you can only print the graphics of a single model when printing several graphic windows (see Chapter 9.8). A cross-model printout is not possible.
By activating the option to print More windows, the button becomes available. Clicking it opens a dialog box with control options for the print arrangement of graphics.

![Window Arrangement dialog box](image)

Figure 10.47 Window Arrangement dialog box

Select **As on Current Screen** to arrange the windows on the printout sheet according to the proportions displayed on the screen. With that, the overall picture on the page is usually wider than it is high — as it is presented on the screen. Select **Page Filling** to use the entire sheet size for the display of the windows.

With the **Mass print** option, you can transfer default graphics to the printout report. After selecting this option and clicking , a new dialog box appears where you can define the parameters (see Chapter 10.2.6).

**Graphic Scale**

The dialog section in the upper right corner of the Graphic Printout dialog box ([Figure 10.45](image)) manages the image scale of the graphic on the sheet.

If you want to use the same scale as displayed on the monitor, select **As screen view**. This allows you to print zoomed areas or special views.

The **Window filling** option prints the overall graphic on the sheet. The currently set angle of view is used to display the whole model in the specified graphic image size (see next dialog section).

With the **To scale** option, the graphic is printed with the scale that is selected in the list or entered manually into the text box. Again, the current angle of view is used. A perspective view is not suitable for the scale printout.
**Graphic Picture Size**

Settings in this dialog section define the size of the graphic on the sheet.

If the Use whole page width check box is selected, the left margin next to the vertical separation line is also used for the graphic, as shown in the figure below.

If you do not want to use the complete size of the graphic in vertical direction, the Height of the graphic area can be defined as a percentage of the page.

The rotation angle in the Rotation text box rotates the graphic for the printout.

**Options**

This section is described in Chapter 10.1.5. When printing result diagrams, you can use the Show results for selected x-location in result diagram check box to control if values that appear on the position of the vertical line are printed (see Figure 9.20).

**Header of Graphic Picture**

When you open the Graphic Printout dialog box, a title is preset for the graphic. It can be modified in this text box.
10.2.2 Options

![Graphic Printout dialog box, Options tab](image)

**Script / Symbols**

In most cases, it is not necessary to change the default settings in these two dialog sections. For printing with plotters using large formats, however, you have to adjust the factors (see Chapter 10.2.7).

The size of the font and the graphic symbols (nodes, supports, lines, etc.) depends on the printer driver. If the printed results are not satisfactory, scaling factors can be defined separately for Script and Symbols.

**Frame**

The graphic can be printed with or without a frame around the graphic.

Furthermore, there is an option to add a title box to the printout. Click the button to open the following dialog box where layout and contents of the title box can be defined. The lower part of the dialog box shows a preview.
Print Quality

In most cases, it is not necessary to change the default settings in this dialog section [Figure 10.49]. Select Standard to print the graphic as a bitmap file in a size of at most 1000 x 1000 pixels. The maximum size of up to 5000 x 5000 pixels together with a 32-bit color depth results in an amount of data of about 100 MB. As this may cause problems for some printer drivers, use such a high resolution with caution.

Color

When you direct the printing to a monochrome printer, you can print Texts and lines in black instead of gray scales to improve readability. Please note that some elements such as isobands and support symbols are not affected by this setting and therefore appear colored in the printout.

The conversion of colored result diagrams to gray scales is always done by the printer driver. Corresponding adjustment options do not exist in RFEM.
10.2.3 Color Scale

The tab is available when results are shown in a multicolored display (see Chapter 9.3).

**Position**

The color scale of the control panel is usually printed as well. If you do not want to print it, select the No color scale check box.

When the panel lies in the graphic picture, the color scale overlaps a part of the picture. It is possible to specify the position of the panel: You can either define it in one of the four corners or as a User-defined arrangement.

The Out of graphic picture option cuts off a strip of the graphic window and uses it only for the color scale. You can define the Scale width in the lower part of the dialog box.

**Size**

The size of the color scale can be defined in absolute dimensions or relative to the picture size.

**Multicolor Scales**

If members and surface results are displayed together in the work window, it is possible to define the color scale relevant for the screen in the control panel (see Figure 9.50). On the sheet, however, two color scales are displayed in this case. Their arrangement can be specified in this dialog section.

**Options**

The color-value assignment in the work window can be user-defined (see Chapter 3.4.6).

You can determine whether the default color scale that refers to the extreme values [Max/Min] or the user-defined color scale is used for the printout. For the latter, no dynamic update is available.
10.2.4 **Factors**

You can adjust the Display Factors for the different result types in this dialog tab. This way, you can scale the results in the printout irrespective of the current work window. This is mainly useful for the final preparation of the documentation.

10.2.5 **Border and Stretch Factors**

With the settings in this tab, you can adjust the Graphic Borders of the printed graphic. You can also use the Compress or Stretch Model option.

The functions are described in Chapter 11.3.11.
10.2.6 Mass Print

The Mass Print dialog box appears if you click the button to the right of the Mass print option in the General dialog tab (see Figure 10.45). In the three tabs of this dialog box, you can specify, which default graphics of the model, the loads, and the results are automatically integrated into the printout report.

Figure 10.54 Mass Print dialog box, Model tab

Seven standard views are available for selection. Furthermore, you can activate a spatial Perspective for the model display.

Figure 10.55 Mass Print dialog box, Loads tab

In the Generate Graphics of and Load Cases / Combinations dialog sections, you can specify if automatic load graphics are created and which load cases are relevant. Use the button to define Selected load cases in the Load Cases / Load Combinations dialog box (see Figure 10.57).
The Views dialog section allows you to control, which angles of view are used for the default graphics.

![Figure 10.56 Mass Print dialog box, Results tab](image)

In the list of the Results, you can select the relevant deformations and internal forces in the tree structure by selecting the check boxes.

The Generate Graphics of and Load Cases / Combinations dialog sections allow you to control whether the graphics are created with or without load displays and which load cases are relevant for the printing. With the button, you can define Selected load cases in a separate dialog box.

![Figure 10.57 Load Cases / Load Combinations dialog box](image)

The graphics' angle of view is defined in the Views dialog section.

It is recommended to check the specified Number of graphics, in particular for the results: A small mistake during the selection may lead to a multitude of automatic graphics that significantly slow down the creation of the report.
10.2.7 Notes for Plotting

Please note the following to achieve optimal results on the plotter.

Settings in the operating system

Basically, RFEM uses the print system of Windows. Unlike some other CAD software programs, RFEM uses no special drivers to control the plotter. The plotter must therefore be installed as a normal printer under Windows first.

Internal tests have shown that the drivers included in the Windows installation are unstable and defective. Therefore, we recommend using the original drivers or the latest drivers available on the website of the plotter producer.

When plotting, huge amounts of data are processed. It is necessary to ensure that sufficient space is available on the system partition of your computer.

Do not set the plotter as the default printer in the system. In fact, only select the plotter when printing. The reason: The printout report uses the standard printer driver for the print preview. With the tested plotter drivers, crashes occurred in the printout report.

Many plotter drivers provide an option to prepare the graphic either in the plotter or the computer. Generally, preparing graphics in the plotter is faster because it has a specialized processor. Your work on the computer is also unaffected in this case. The problem, however, is that the plotter often provides only a small random access memory. If the memory is insufficient for receiving the picture, parts are lost. When plotting RFEM graphics, you can see the loss in the form of missing descriptions or fills, missing lines, etc. In such a case, the plotter will normally display a corresponding message.

In case of doubt, prepare the data in your computer. However, the default setting is usually the preparation in the plotter. In this case, adjust the printer properties accordingly.
Settings in RFEM

![Graphic Printout dialog box, General tab](image1)

It is recommended to set the graphic size **To scale** in the General tab of the Graphic Printout dialog box, since the output on an A0 plan is almost always true to scale. Then, select the scale from the list or enter it directly into the text box.

Generally, it is recommended to use the complete sheet area for the plotter output. For this, select the **Use whole page width** check box in the Graphic Picture Size and Rotation dialog section.

![Graphic Printout dialog box, Options tab](image2)

In the Options tab, you can influence the output quality. You will most likely need several test plot printings to find the optimal settings. Unfortunately, it is not possible to give generalized recommendations because the settings' effect depends on the printer driver. The guide values shown in the figure above refer to a HP DesignJet 650C plotter with driver version 4.62 under Windows XP.
If crashes occur during the plotting process, we recommend installing the latest printer driver as described above and selecting it for the preparation of the graphic in computer. Afterwards, if crashes still occur when plotting, you should gradually reduce the resolution in the Print Quality dialog section.

The Script dialog section controls the scaling of the font size for numberings, dimensions, and result values. For the A0 plot on a HP DesignJet 650C, good results have been achieved with the factor 2 and the Constant setting.

The Symbols dialog section affects not only the size of support symbols, nodes, etc., but also the line widths. If lines are too rough, you should reduce the factor. For the A0 plot on the HP DesignJet 650C, good results have been achieved with the factor 0.2 and the Proportional setting.

The factors for symbols and font globally affect all fonts and symbols. To specifically influence the appearance of particular objects, use the settings in the Display Properties dialog box (see Figure 11.3). It is recommended to save adjustments for the plotter as a new display configuration for the printout report. For more information, see Chapter 11.1.2.

After clicking [OK], the Print dialog box of the operating system appears. Select the plotter from the list of printers. Click [Printer Properties] to open another dialog box where you can set the page size and alignment.

Figure 10.61 Plotter Properties dialog box for setting the page format.
Program Functions

In the following you will find descriptions of functions for graphical and table input, such as CAD tools for designing or generating model and load objects, edit options, operations in spreadsheets, or parameterized input.

11.1 General Functions

This chapter describes program functions for the general use of RFEM and tools that are provided in many dialog boxes.

11.1.1 Language Settings

The language that was selected for the installation is preset. Materials and cross-section tables in the libraries have also been set up by country-specific arrangements.

To change the graphical user interface of RFEM, select the menu entry Options → Program Options or use the corresponding toolbar button.

In the Program dialog tab, you can select another Program Language in the list.

The changed language settings take effect after restarting the program.

When you change the language, please note the following:

- Some characters are only displayed correctly if the corresponding fonts are available in the operating system.
- The new language also affects the arrangement of materials and cross-section tables in the libraries.
11.1.2 Display Properties

The display properties determine how a graphical object is displayed on the screen and in the printout. The Display navigator allows you to control if an object is displayed (see Chapter 3.4.3).

Adjusting the display

To open the dialog box for adjusting the graphical display, use the menu item

Options → Display Properties → Edit

or the configuration manager (see Chapter 3.4.10).

It is also possible to directly access the display properties of each graphical object (model, load, or result symbol): Right-click the object to open its shortcut menu. Select Display Properties to directly adjust the object’s display parameters in the Display Properties dialog box (see Figure 11.3).

Figure 11.2 Shortcut menu of nodal support

Figure 11.3 Display Properties dialog box for Nodal Supports category

The settings for the display on the Screen and for the Printout Report are managed in two dialog tabs. Thus, it is possible to define adjustments separately for the monitor graphic (e.g. size of support symbols with black background) and for the printout.

Use the Identical Settings for screen and printout report check box to synchronize the display properties for the screen and printout report: If it is selected, the subsequently defined settings are
also carried out in the other dialog tab (Screen or Printout Report) of the current category. Already defined settings cannot be transferred retroactively with this function.

The Category navigator lists the graphical objects in a directory tree. To change the display properties of an object, select the relevant entry. Then, adjust the object-specific display parameters in the dialog section to the right: color, line display, size in work window, type and arrangement of numbering, font, size of load vector, etc.

RFEM additionally provides [Details] buttons for some parameters (see Figure 11.4).

![Figure 11.4 - Size dialog box for Line Forces](image)

The buttons are used to open a new dialog box where you can, for example, scale the distance or size of the object to the dimensions of the total structure.

The buttons below the parameters have the following functions:

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Font settings" /></td>
<td>Opens the Font dialog box for changing the type, size, and color of the font</td>
</tr>
<tr>
<td><img src="image" alt="Axes display" /></td>
<td>Opens the display parameters of axes for the current object</td>
</tr>
<tr>
<td><img src="image" alt="Object base data" /></td>
<td>Returns you to the base data of the object</td>
</tr>
<tr>
<td><img src="image" alt="Relative positions" /></td>
<td>Opens the Relative Positions dialog box (Figure 11.5) for arranging descriptions</td>
</tr>
<tr>
<td><img src="image" alt="Default settings" /></td>
<td>Restores the default settings</td>
</tr>
</tbody>
</table>

Table 11.1 - Buttons in Display Properties dialog box

For objects that are relevant for lines and members, you can arrange the description or symbol with user-defined settings. A dialog box opens where you can define the information's position by means of a relative distance from the line or member start (see Figure 11.5).
Saving a display configuration

The Display Properties dialog box allows you to adjust the display configuration to the given requirements. It is thus possible, for example, to create different settings for the screen with a colored background and for the plotter with specific settings.

However, the modifications cannot be saved in the Display Properties dialog box. The Configuration Manager described in Chapter 3.4.10 is responsible for managing display configurations.

Therefore, use the following procedure when you want to create a new display profile based on your modifications:

- Confirm the modifications in the Display Properties dialog box with [OK].
- Open the Configuration Manager (see Chapter 3.4.10).
- Create a [New] configuration.
- Enter a description in the New Configuration dialog box and confirm with [OK].
11.1.3 Units and Decimal Places

The units and decimal places for RFEM and all add-on modules are managed in one dialog box. The settings can be modified as required for modeling or evaluation. All numerical values are converted or adjusted.

Changing units and decimal Places

Many dialog boxes provide the button shown on the left, which you can use to access the dialog box for changing units and decimal places (see Figure 11.4 for Display Properties dialog box).

To open the Units and Decimal Places dialog box, you can also use the menu option Edit → Units and Decimal Places.

Figure 11.6 Units and Decimal Places dialog box

First, select the module whose units or decimal places you want to adjust in the Program / Module dialog section. The right side of the dialog box changes depending on the selection.

Four dialog tabs are provided for RFEM so that you can specify settings separately for the Model, Loads, and Results data, as well as the Dimensions. For some add-on modules, the right part of the dialog box is also divided into several tabs. The units and decimal places are summarized in groups.

If the dialog box was opened from another dialog box (e.g. New Member), the relevant units and decimal places are marked with a red triangle on the right as shown in the figure above.
Saving and importing units as user profiles

The settings in the Units and Decimal Places dialog box can be saved and reused in other models. This way, creating specific unit profiles for models consisting of steel and reinforced concrete, for example, is possible.

The button shown on the left opens a dialog box where you have to enter the Name of the new units user profile.

To use this profile as the default setting for new models, select the Save profile as default check box.

A user profile can be imported with the button shown on the left. A dialog box opens where several profiles are available for selection. A metric and an imperial (Anglo-american) unit profile are preset as default settings.
11.1.4 Comments

This chapter describes the comment fields in the dialog boxes and tables (see Figure 4.12, for example). The comments that you can insert graphically are described in Chapter 11.3.6.

Using comments

You can enter any text into the comment fields. With the [Import Comment] button shown on the left, you can also use predefined text modules that are managed across models.

A dialog box appears showing a list of stored text modules.

The List of Default Comments contains all comments that are suitable for the category. Click the [Import] button to insert the selected comment into the comment field of the dialog box. If the comment field already contains text, it is overwritten. Then you can further edit the comment in the comment field.

Use the button shown on the left to add the selected comment to an existing comment field text.

Creating and managing comments

In the Import Comment dialog box (Figure 11.9), you can create new text modules with the button shown on the left. Alternatively, you can use the Comments tab in the Program Options dialog box where all comments are managed. To open the dialog box, use the menu option

Options → Program Options

or the toolbar button shown on the left.
The Category dialog section allows you to control, which group (i.e., input table or input dialog box) you want to assign the comment text to.

The Comments for Default dialog section provides four buttons that have the following functions.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Create Comment" /></td>
<td>Creates a new comment within the marked Category. Enter the text in the list.</td>
</tr>
<tr>
<td><img src="image" alt="Delete Comment" /></td>
<td>Deletes the comment that is selected in the list.</td>
</tr>
<tr>
<td><img src="image" alt="Move Up" /></td>
<td>Moves the selected comment upwards.</td>
</tr>
<tr>
<td><img src="image" alt="Move Down" /></td>
<td>Moves the selected comment downwards.</td>
</tr>
</tbody>
</table>

When the special selection is used (see Chapter 11.2.2), you can filter data by user-defined comments.
11.1.5 Measuring Function

In order to check entered data, distances and angles can be measured. To access this function, use the menu option

Tools → Measure.

The following measure functions are available for selection:

- Distance between two nodes
- Angle between three nodes
- Angle between two members
- Angle between two surfaces
- Angle between member and surface
- Angle between two lines
- Angle between member and line
- Angle between surface and line

Click the objects for measurement one after the other in the work window. Distance and, if applicable, Deformation of the nodes are subsequently shown in a dialog box.
11.1.6 Search Function

Selection via table

To find an object in the graphic, you can also use the tables: Click into the desired table row to highlight the relevant object in the work window. Use this method for simpler models to quickly and easily detect objects in the graphic.

The graphical selection by means of the table only works if the synchronization of the selection is active (see Chapter 11.5.4). 

Search via object number

In RFEM, you can search for specific objects, which is especially recommended for larger structures. To access the search function, use the menu entry

```
Edit → Find via Number.
```

The following dialog box appears.

![Find Object with Number dialog box](image)

In the Object dialog section, use the list to specify what type of object to search for: node, line, surface, solid, member, or even finite element. Enter the No. of the object directly into the text box or use the list to select it.

After clicking [OK], a big arrow indicates the object you searched for in the work window. The arrow is still displayed when you adjust the area around the object by zooming or rotating the model. The arrow disappears with a click into the workspace.
11.1.7 Viewpoint and View Angle

RFEM provides the standard views [in X-Direction], [in Reverse Y-Direction], [in Z-Direction], as well as the [Isometric View], selectable with the buttons shown on the left. Additional buttons for user-defined coordinate systems and angles of view are available in the list button of the toolbar and in the Views navigator [see Chapter 9.9.1.1].

If these views including the rotating option (button while holding down [Ctrl] key) do not result in the desired display, you can use the extended options of the Edit Viewpoint dialog box.

To open the dialog box, use the menu item

**View → Viewpoint.**

![Edit Viewpoint dialog box](image)

Clicking and moving the mouse in the preview windows on the right allows you to set the viewpoint and view angle. In addition, you can adjust the factor of the Perspective.
11.1.8 Determining the Centroid

The overall centroid of the model is automatically displayed when the FE mesh is successfully generated and the corresponding option in the Display navigator under the General entry is selected. Color and size can be adjusted in the Display Properties dialog box under the Colors → Other → Center of Gravity category (see Chapter 11.1.2).

It is also possible to determine the centroid of specific objects: Select the relevant members, surfaces, and solids, for example via multiple selection or by opening a selection window (see Chapter 11.2). You can activate the shortcut menu shown on the left by right-clicking one of the objects. The Centroid and Info menu entry opens a dialog box with information about the selected objects.

![Figure 11.15 Centroid and Info About Selected Objects dialog box](image)

The dialog box provides the Centroid Coordinates in relation to the origin of the global axis system XYZ. In the work window, the centroid is indicated by an arrow. You can also use the Create new node in centroid option to create a node at this location.

In addition to the global Envelope Size of the selected objects, the following Additional Info is displayed:

- Area of all surfaces
- Length of all members
- Surface area of visible surfaces of all objects
- Volume of material
- Mass of material
11.1.9 Rendering

The model’s display in the work window can be controlled by the user. Use the list button in the toolbar shown on the left to quickly switch between the Wireframe and Solid display types, and the Solid Transparent Display Model.

Detailed settings for the individual objects can be specified in the Display navigator under Rendering.

![Display navigator with options for Rendering model and load objects](image)

The Solid Model display can be individually adjusted for members, surfaces, and solids. There are also control options for displaying supports and loads.

Textures

If Textures are activated, RFEM shows the surface textures in the rendered model. To access detailed settings for the textures, use the menu option

**Options → Display Properties → Edit.**

The Display Properties dialog box opens where you can select the **Objects by Color → Material** category. The materials with the assigned colors and textures are then listed on the right. Double-click the field of a table row to open the **Edit Material Color and Texture** dialog box.
You can use this dialog box to adjust the Color and Texture of the selected material. For this, RFEM provides a [color palette] and a comprehensive [library] with textures.

**Color control**

The Display navigator item **Colors in Graphics According to** contains several selection fields. The active field controls the assignment of colors for the objects in the rendering. By default, RFEM uses the material colors defined for the individual construction materials (see Chapter 4.3). With the remaining options, it is possible to graphically check cross-sections and types of members, surfaces, solids, etc. by means of the assigned colors.

The **+/- z Surface Side** option is used for checking the position of the surface sides. It is important for defining foundations with failure or for the reinforcement layout. The top side of a surface is displayed in red, the bottom side in blue color (default).
11.1.10 Lighting

Brightness and light effects of the rendered model can be adjusted individually. To manage the lighting in the Display navigator, go to

Rendering → Lighting.

Six different light sources are available for selection: Light 1 to 4 light the model from its side, light 5 and 6 from below or above. Each Light can be switched on and off individually.

Select the Display light positions check box to display the light sources in the work window. Active lights are displayed in gold, inactive lights are shown in gray.

It is also possible to apply light effects to the Results. The check box is inactive by default, because lighting often has an unfavorable effect on the visibility of surface and solid results.
11.2 Selection

With the selection functions, you can specify objects for subsequent editing. Objects are nodes, lines, surfaces, solids, members, supports, FE mesh refinements, etc. But it is also possible to graphically select loads and guide objects (dimension lines, comments).

To select (or find) an object in the work window, you can also use the tables. Click into a table row to highlight the corresponding object in the graphic. However, this type of selection only works if the synchronization of the selection is active (see Chapter 11.5.4).

Another option for selecting objects is using the Data navigator: Right-click the relevant navigator entry and click the Select option in the shortcut menu.

11.2.1 Selecting Objects Graphically

Selection with mouse

Every object can be selected in the work window with a mouse click. It is then highlighted in another color in the graphic. Only the last clicked object remains selected, provided that the New Selection default setting is not changed.

If you want to select several objects by clicking them, hold down the [Ctrl] key while clicking. By switching to the Add to Selection setting with the toolbar button shown on the left or by using the Edit menu item, you can individually click objects to select them one by one.

The so-called preselection allows you to locate relevant objects before clicking. If selecting objects proves to be difficult for complex structural systems, you can exclude non-required model objects from the graphical preselection in the Display navigator category Preselection.

Selection with window

Use the window selection to mark a lot of objects in a single step: Simply hold down the left mouse button and draw a window across the relevant objects. If you draw the window from left to right, all objects that are completely within the window are selected. If you draw the window from right to left, you also select the objects that are only partly within the window.

Lines or nodes that lie in surfaces can be selected without unintentionally displacing the surfaces: Hold down the [Alt] key while you draw the window over the objects inside the surface.
Selection with rhomboid

In the isometric view, it is sometimes difficult to select an object with a rectangular window. In such a case, it is recommended to use the Selection via Rhomboid function, which you can access with the menu entry

**Edit → Select → Rhomboid**

or with the corresponding toolbar button.

![Selection via Rhomboid button](image1)

![Selection with rhomboid](image2)

**Selection with ellipse/circular ring**

The possibility to select objects via an ellipse or annulus are alternatives to the rhomboid selection, which can be used for circular surfaces, for example. To access the corresponding functions, select the menu item

**Edit → Select → Ellipse or Circular Ring**

or use the corresponding toolbar buttons.

![Selection via Ellipse or Circular Ring buttons](image3)

The elliptical or annular selection zone can be defined by clicking the center point and both radii.

**Selection with section line**

You can select objects by means of a line that runs anywhere through the model. To access this function, use the menu option

**Edit → Select → Section Line.**

The section line can not only be defined as a simple line but also as a polygonal chain in the work window. Click the relevant points one after the other to define the line. These points are independent of the work plane: The selection includes all objects that are cut by the intersection line displayed in the current view.
After setting the endpoint of the section line, click it once again (alternative: double-click the last point). Make sure to place this point into an empty area of the work window.

![Figure 11.24](image)

**Selection in plane**

Objects that lie in one plane (e.g. roof surfaces) can be easily selected with the In Plane selection function. To open the corresponding dialog box, use the menu option

**Edit → Select → In Plane.**

A dialog box appears with detailed settings for selecting the objects and the plane.

![Figure 11.25](image)

After clicking [OK], you can graphically define the selection plane: Click 3 Nodes or draw a Polygonal chain freely or with the help of nodes in the work plane.

**Selecting free nodes**

Nodes that are not used for defining lines or surfaces can be selected with the menu entry

**Edit → Select → Free Nodes.**

The easiest way to delete selected free nodes is to use the [Del] key.

**Selecting related objects**

When you select a surface with a click, for example, the related nodes and lines are not included in the selection. To select the components of objects, use the menu option

**Edit → Select → Related Objects.**

Use this function to, for example, quickly integrate the supports of members or surfaces into the selection and save them as related objects in a Visibility (see Chapter 9.9.1.2 ）。
### 11.2.2 Selecting Objects by Criteria

This feature allows you to select objects according to specific criteria. Moreover, objects can be added to or removed from an existing selection.

To open the dialog box for the special selection, select the menu entry

**Edit → Select → Special**

or use the toolbar button shown on the left.

The Category column on the left lists the objects defined in the model. The right part of the dialog box depends on the selected object. You can determine a selection criterion and specify detailed settings in this scrollable dialog section.

**Example**

With the settings shown in Figure 11.26, all surfaces that are modeled *Parallel to surface 1* (floor slab) are selected. You can also use the button to define the template surface graphically.

![Special Selection dialog box](image1)

![Selection of parallel surfaces](image2)
11.3 Work Window

Special CAD functions such as work planes, snap options, guidelines, and user-defined coordinate systems help you to model graphical objects in the work window.

11.3.1 Work Planes

A spatially defined model can only be displayed in two dimensions on the screen. Defining objects graphically is therefore a problem, because which plane they are created in when clicking into the graphic window must be organized. The work plane determines, which coordinate is always “fixed”.

The axes of coordinates of the current work plane are displayed as two green, orthogonal lines. The intersection point of these two lines is called the “origin of the work plane”.

Normally, a work plane is parallel to one of the global planes XY, YZ, or XZ that are spanned by two axes of the global coordinate system. It is also possible to specify the work plane directly as a plane with any inclination or to define it by means of line, member, and surface axes.

To open the Work Plane dialog box with the parameters of the work plane, select the menu entry

Tools → Work Plane, Grid/Snap, Object Snap, Guidelines

or use the toolbar button shown on the left.

The dialog box shown in Figure 11.34 appears.
Parallel to global plane XY / YZ / XZ

The work plane can be aligned to be parallel to one of the following global planes:

<table>
<thead>
<tr>
<th>Plane</th>
<th>Selection in Work Plane dialog box</th>
<th>Selection in Toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td>XY</td>
<td><img src="image" alt="Selection in Work Plane dialog box for XY" /></td>
<td><img src="image" alt="Selection in Toolbar for XY" /></td>
</tr>
<tr>
<td>YZ</td>
<td><img src="image" alt="Selection in Work Plane dialog box for YZ" /></td>
<td><img src="image" alt="Selection in Toolbar for YZ" /></td>
</tr>
<tr>
<td>XZ</td>
<td><img src="image" alt="Selection in Work Plane dialog box for XZ" /></td>
<td><img src="image" alt="Selection in Toolbar for XZ" /></td>
</tr>
</tbody>
</table>

Table 11.3  Selection of work plane

To find more options for defining work planes, use the menu item

**Tools → Select Work Plane**

or the corresponding toolbar buttons.

3 Points Plane

In the work window, you can select three points that define a new work plane with the axis system UVW. The points must not be defined on a straight line.

Plane with line in X / Y / Z

The work plane is defined by one of the global axes and a line that you determine graphically in the work window. The zero point of the new work plane is placed into the start node of the line and the axis U is aligned parallel to the selected global axis. With this, you can quickly shift the work plane into a roof area, for example.
Plane with member axis xy / xz

The planes of the member axes xy ("weak" axis) or xz ("strong" axis) are used for defining the work plane (see Chapter 4.17). The relevant member must be defined graphically in the work window. The zero point of the new work plane is placed into the start node of the member.

![Work plane in roof inclination of member axis xz](image)

**Figure 11.30** Work plane in roof inclination of member axis xz

Plane with surface axis xy

The work plane is defined by the xy-axes of a surface that you determine graphically in the work window (see Chapter 4.4). The axes of the new work plane are called UVW (see Figure 11.30).

Offset of work plane

You can use this function to shift the work plane perpendicular to the current plane. Specify the distance in the Offset Workplane dialog box.

![Offset Workplane dialog box](image)

**Figure 11.31** Offset Workplane dialog box

The offset remains active until the function is canceled in the menu.

Origin of the work plane

The Work Plane dialog box (Figure 11.34) manages the zero point (origin) of the work plane. Use the dialog to select a node in the work window or to define a new node. It is also possible to enter the coordinates of any point directly.

![Work Plane dialog box, Origin of Work Plane dialog section](image)

**Figure 11.32** Work Plane dialog box, Origin of Work Plane dialog section
The zero point of the work plane can also be defined graphically by selecting the menu item

**Tools → Select Work Plane → Define Origin**

or using the corresponding toolbar button.

![Set Origin of Grid/Work Plane button](image)

### 11.3.2 Grid

Grid points help with the graphical input in the work plane. When nodes are defined graphically, the pointer snaps to the grid points.

The properties of the grid points are also managed in the **Work Plane and Grid/Snap** dialog box. To open the dialog box, select the menu entry

**Tools → Work Plane, Grid/Snap, Object Snap, Guidelines**

or use the toolbar button shown on the left (see Figure 11.29).

![Work Plane and Grid/Snap dialog box](image)

The setting options relevant for the grid are available in the **Grid/Snap** dialog tab.

**Show**

To display the grid in the work window, select the **Grid** check box. The snap function can be turned on and off independently of the grid by means of the **Snap** check box. Thus, the snap function on the grid points can be effective while the grid is invisible.

To quickly switch both functions on and off, use the **[GRID]** and **[SNAP]** buttons in the status bar.
**Type**

The grid points can be arranged in the Cartesian or the polar coordinate system. Depending on the selection, the content of the following dialog sections changes.

Alternatively, you can select the coordinate system with the [CARTES], [POLAR], or [ORTHO] buttons in the status bar.

**Number of Grid Points**

When a Cartesian grid is set, you can define the number of grid points for both axis directions separately.

When a polar grid is set, you have to specify the number of concentric grid circles.

If the Dynamically according to size of model option is selected, the grid is automatically adjusted to the dimensions of the model. Thus, a sufficient number of grid points is always available around the model. However, the required grid points are recalculated after each input, which may slow down the speed for creating the graphic when you work on complex models.

**Grid Point Spacing**

When you use a Cartesian grid, you can define the spacing of grid points separately for the directions 1 and 2.

For a polar grid, you have to specify the radial spacing $R$ for the grid circles. The angle $\alpha$ controls the spacing of grid points on the circles.

Optionally, the cartesian and the polar grid can be rotated by the rotation angle $\beta$.

If needed, the number of pixels controlling the Snap distance can be adjusted.
11.3.3 Object Snap

The object snap facilitates the CAD-like modeling when defining lines. In addition to the nodes, several snap points can be activated along the lines.

The settings for the object snap are defined in the Work Plane dialog box. To open it, select the menu option

**Tools → Work Plane, Grid/Snap, Object Snap, Guidelines**

or use the toolbar button shown on the left (see Figure 11.29).

![Work Plane and Grid/Snap dialog box](image)

The **Object Snap** dialog tab manages the different snap functions.

The **[OSNAP]** button must be active in the status bar if you want to use the functions of the object snap.

**Nodes**

![Snapping to a node](image)

When defining a new line, existing nodes are snapped to. Snap points are symbolized by squares.
**Perpendicular**

When drawing a line, the pointer snaps to the perpendicular point when you are near it. The snap point is characterized by a perpendicular symbol.

**Tangent**

This function creates the tangent on a circular arc. When drawing a line, the pointer snaps to the tangent point when you are near it. The snap point is characterized by a tangent symbol.

**Centers and focuses**

When you move the pointer near the center (middle) of a line, it snaps to it. The center symbol appears on the snap point.
**Intersections**

The pointer snaps to the intersection point of two crossing lines that have no common node. The snap point is indicated by the intersection symbol shown on the left.

**Parallel**

Use this function to place parallel lines: Define the start node of the new line and then move the pointer over a template line. If you now move the pointer near a possible end node of the new line so that it is parallel to the template, the parallel symbol shown on the left appears on both lines.
Partition points

In the **Object Snap** dialog tab of the **Work Plane** dialog box, you can enter a number of \( n \) line divisions. When you move the pointer along a line, it snaps to the partition points. On the pointer, the partition is displayed as a fraction.

Distance

In the **Object Snap** dialog tab of the **Work Plane** dialog box, you can enter a distance \( d \) for dividing a line. When you move the pointer over a line, it snaps at the defined distance from the line start and end. The distance symbol appears on the pointer.
**Guidelines**

When you move the pointer near the intersection point of two guide lines (see Chapter 11.3.7), it snaps to it. The intersection symbol appears on the snap point.

**Background layers**

Use this snap function to place nodes at intersection points of background layers (see Chapter 11.3.7). The intersection symbol appears on the snap point.

**Line grid**

Use this snap function to place objects into the intersection points of a line grid (see Chapter 11.3.8).
11.3.4 Coordinate Systems

User-defined coordinate systems make entering inclined parts of a model easier. They have nothing to do with the axis systems of lines, surfaces, or members. Alternatively, you can define work planes graphically by means of points, line axes, member axes, or surface axes (see Chapter 11.3.1).

To open the Coordinate System dialog box, select the menu item

**Tools → Coordinate System**

or use the toolbar button shown on the left.

You can also use the button in the Work Plane and Grid/Snap dialog box (see Figure 11.34) to create a user-defined coordinate system.

The Standard coordinate system related to the global axes XYZ and the origin is preset.

**Creating a new coordinate system**

Click the button shown in Figure 11.48 to open the following dialog box. You can find the same button in the Work Plane and Grid/Snap dialog box (see Figure 11.34).
Figure 11.49 Define New Coordinate System dialog box

Enter a Name for the new coordinate system. Then, define the axis system with the help of three parameters in the UVW Coordinate System Related to XYZ CS dialog section:

- **Origin** (zero point of new coordinate system)
- **Point on positive U-axis** (first axis)
- **Point in positive UW-plane** (rotation of plane about axis U)

For this purpose, specify three points that you can enter directly or select graphically. The points must not lie on a straight line.

You can use the buttons shown on the left to select the three [Nodes] or [Points] one after the other in the work window (please observe the sequence when defining points 0 to 2). With the left button, you can only select Nodes; with the right button, you can select any Points. The difference becomes especially significant when a node that represents a definition point of the coordinate system is changed. The coordinate system is then adjusted automatically. In case of arbitrary points, the system of coordinates is fixed.

If a user-defined work plane is defined with the help of three points (see Chapter 11.3.1), RFEM automatically creates a new coordinate system with the name Generated.

**Editing or deleting coordinate systems**

Only user-defined coordinate systems can be edited or deleted. For this purpose, there are two available buttons in the Coordinate System dialog box.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Modify" /></td>
<td>Modifies selected coordinate system.</td>
</tr>
<tr>
<td><img src="image" alt="Delete" /></td>
<td>Deletes selected coordinate system.</td>
</tr>
</tbody>
</table>

Table 11.4 Buttons in the Coordinate System dialog box
**Example**

In a frame joint, a new coordinate system is defined for the diagonal that lies in the plane of the roof. The Origin is set in corner node 6. End node 4 of the diagonal member is selected as a Point on positive U-Axis and base node 5 of the column as a Point in positive UW-Plane.

![User-defined coordinate system UVW in a frame joint](image)

The grid then refers to the work planes UV, VW, and UW where you can define new objects (see Chapter 11.3.1).
11.3.5 Dimensions

It is possible to add user-defined dimension lines to the model.

To apply dimensioning functions, select the menu entry

**Insert → Dimensions**

or use the corresponding toolbar buttons.

**Figure 11.51** New Dimension buttons

The following dimension options can be selected:

<table>
<thead>
<tr>
<th>Dimension</th>
<th>Dimensioned Objects</th>
</tr>
</thead>
<tbody>
<tr>
<td>Linear</td>
<td>Lengths between two or several nodes</td>
</tr>
<tr>
<td>Arc length</td>
<td>Length between the nodes of an arc</td>
</tr>
<tr>
<td>Angular</td>
<td>Angle between three nodes or two lines</td>
</tr>
<tr>
<td>Radial</td>
<td>Circle and arc diameters or radii</td>
</tr>
<tr>
<td>Slope</td>
<td>Inclination angle between a line and a plane</td>
</tr>
<tr>
<td>Height</td>
<td>Height level of a node</td>
</tr>
</tbody>
</table>

**Table 11.5** Dimensioning functions

The **New Dimension** dialog box opens. The appearance of the dialog box depends on your selection.

**Figure 11.52** New Linear Dimension dialog box
Use the selection pointer and click the objects that represent the dimensioning’s reference points one by one. In the Reference dialog section, you can select the real length or the projection in one of the global axis directions.

The Plane dialog section controls where the dimension line is applied. This setting refers to the axes of the global coordinate system XYZ or the line axes. If you change the plane and move the pointer in the graphic, you can see the effect of both selection fields.

Use the four check boxes in the Options dialog section to define the information that appears on the values. When you select Symbol, you can enter a dimensioning symbol or select it from the list. Select Hide value to switch off the measured value so that only the symbol appears.

The Offset determines the distance of the dimension line from the first selected node. The distance can also be defined graphically by using the mouse pointer. To definitively place the dimension line, click into the work window or use the [Set Dimension] button.

To define a chain dimensioning with equal offset, click the individual nodes one by one and then specify the offset.

To set the display of dimension lines, use the Display navigator or the general shortcut menu (right-click into an object-free area of the work window).

When the model geometry is modified, the dimensions are adjusted automatically.

Double-click a dimension to open the Edit Dimension dialog box where you can retroactively adjust the offset. However, if you want to relate the dimension line to other nodes or lines, delete the dimension first, then redefine it.
### 11.3.6 Comments

There are two types of comments:

- Comments in dialog boxes and tables (see Chapter 11.1.4)
- Comments in the work window

This chapter describes how comments are set graphically.

You can place comments in relation to nodes and centers of lines and members, or you can place them anywhere in the current work plane or in a global plane.

To access the function for placing comments, select the menu entry **Insert → Comments** or use the corresponding toolbar button.

![New Comment button](image)

The New Comment dialog box opens.

![New Comment dialog box](image)

Enter the comment text into the **Text** dialog section. The appearance of comments regarding colors and fonts can be adjusted in the **Options** dialog section. Optionally, the comment can be framed by a rectangle or circle.

The **Rotation** of the comment allows you to user-define the comment text arrangement.

If the check box in the **Offset** dialog section is selected, the comment is arranged at a certain distance from the selected object. You can also define the distance graphically: First, click the object after entering the comment text. Then, use the pointer to locate the appropriate position where you enter the comment text with another mouse click. RFEM displays the current work plane so that you can place the comment correctly. If necessary, you can change the work plane before placing the comment.
To set the display of comments, use the Display navigator or the general shortcut menu (right-click into an object-free area of the work window, see Figure 11.56).

Figure 11.56 Display navigator [Guide Objects → Comments] and general shortcut menu

When the model geometry is modified, comments are adjusted automatically.

Comment texts including offset can be edited retroactively: Double-click the comment in the work window or its entry in the Data navigator.

You can move comments by using the drag-and-drop function (to copy them, hold down the [Ctrl] key). Please note the following: When you "grab" the arrow of the comment at its head, you can move the entire comment. When you "grab" its text instead, the arrowhead continues to point to the object; the position of the comment text in the work plane can now be adjusted.
11.3.7 Guidelines

Guidelines represent a grid of axes and rows underneath the graphical workspace. The intersection points of guidelines are also snap points for the graphical input, provided that the snap function for Guidelines-Intersections is active in the object snap (see Chapter 11.3.3).

Guidelines do not need to be parallel to the axes of the global coordinate system XYZ. Angles can be specified freely; you can even define a polar arrangement of guidelines. Spacings among guidelines may also be arbitrary.

![Diagram of guidelines](image)

Creating guidelines

Dialog input

To open the dialog box for creating a new guideline, select the menu entry

**Insert → Guidelines → Dialog Box**

or use the shortcut menu in the Data navigator.
The following dialog box appears.

![New Guideline dialog box](image)

The No. of the guideline is automatically allocated by the program but can be adjusted, if necessary.

The Type dialog section allows you to control how the guideline is created (see Table 11.6).

<table>
<thead>
<tr>
<th>Type</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>II to X / Y / Z (parallel to axis X, Y, or Z)</td>
<td>The guideline is created parallel to one of the global axes. Specify the distances $x_1 / y_1 / z_1$ of the respective global axes in the Parameters dialog section.</td>
</tr>
<tr>
<td>Bias by 2 points</td>
<td>In the Parameters dialog section, enter the coordinates of two points in the current work plane that define the guideline.</td>
</tr>
<tr>
<td>Bias by angle and point</td>
<td>In the Parameters dialog section, enter the coordinates of a point and a rotation angle to define the guideline. The guideline is created in the current work plane.</td>
</tr>
<tr>
<td>Polar</td>
<td>In the Parameters dialog section, specify the center point and the radius for the circular guideline.</td>
</tr>
</tbody>
</table>

Enter the parameters into the text boxes or determine them graphically in the work window by using or .

When the Description check box is selected, you can enter a description for the guideline into the text box or select it from the list.

**Graphical input**

To define a guideline graphically,

- select **Insert → Guidelines → Graphically** in the menu,
- use the [New Guideline Graphically] button shown on the left,
- or use the parallel shift of an axis of the work plane with the mouse (only possible if guidelines are not locked — see below).
The **New Guideline** dialog box is described above.

**Editing and deleting guidelines**

To open the dialog box for editing guidelines, double-click a guideline in the graphic or its entry in the **Data navigator**.

If the guideline cannot be selected in the graphic, it is locked (see below). Guidelines can be unlocked quickly: Right-click in an empty space of the work window and deactivate the **Lock Guidelines** option in the shortcut menu.

You can also edit guidelines by selecting **Tools** → **Work Plane, Grid/Snap, Object Snap, Guidelines** in the menu or using the corresponding toolbar button. A dialog box opens where you can use the **Guidelines** tab not only to activate the snap but also for editing, deleting, or hiding and displaying guidelines, as well as creating new ones.

Guidelines can be deleted both in the work window and the **Data navigator**: Right-click the guideline and select the **Delete Guideline** function in the shortcut menu.
Locking guidelines

When guidelines are locked, they cannot be selected, edited, or moved. That way, they do not impair the graphical input of objects. Nevertheless, the snap function on the intersection points remains active.

To lock or unlock all guidelines,
- right-click a guideline and select Lock Guidelines in the shortcut menu,
- select Edit → Guidelines → Lock in the menu,
- or right-click Guidelines in the navigator and select Lock Guidelines in the shortcut menu.

Copying and moving guidelines

Guidelines are graphical objects for which many of the common editing functions can be used.

To move or copy a guideline, select the guideline first. Then you can apply the function described in Chapter 11.4.1. Please note that guidelines can only be copied in the plane of the original guideline.

Displaying guidelines

The Display navigator controls the graphical display of guidelines in detail.
11.3.8 Line Grids

User-defined line grids help you to model structures consisting of surfaces, girder grillages, or grids. The intersection points of the grid provide definition points for surfaces, lines, and members.

It is possible to use several line grids in one model.

Creating line grids

To open the dialog box for creating a new line grid, use the menu item

Insert → Line Grid

or the shortcut menu in the Data navigator.

The Line Grid dialog box appears where you can define the new grid.
The Global Position of Insert Point defines the origin of the line grid. The coordinates can be entered or selected in the work window with 

The Type dialog section below the dialog graphic provides the following options for defining the grid system before entering more data:

- Cartesian
- Spherical
- Inclined (grid can be rotated for each axis by any rotation angles $\gamma$)
- Cylindrical

The small graphic to the right is interactive with the type specification.

In the Line Grid in X-/Y-/Z-Direction dialog sections, enter the distances $d$ and the Number of spans for each direction. The respective Name is preset but can be adjusted. It is also possible to enter the Coordinates of the distances or to adjust them retroactively.

The Positive and Negative options respectively determine, in which direction of the global axis the line grid is created.

In the Rotation dialog section, you can rotate the line grid about an axis: First, select the Sequence that determines the order of the local grid axes $X'$, $Y'$, and $Z'$. Then, enter the angle of rotation about the global axes $X$, $Y$, and $Z$ in the text boxes under Rotated about. You can also use the buttons to define the support rotation graphically.

A large part of the dialog box is covered by a graphic window where the input is immediately displayed graphically. The buttons below the window are familiar from RFEM; they control the display of the dimensioning, numbering, axes, and view. It is also possible to use the mouse control options in this window (see Chapter 3.4.9).

Each line grid can be saved as a template and reused later. The buttons shown on the left are used to [Save] and [Load] the grid data.

After closing the dialog box, you can set objects at the grid nodes. Please make sure that the object snap is active for this (see Chapter 11.3.3).
11.3.9 Visual Objects

Visual objects are 3D objects used in architectural design programs to realistically display model designs, for example (e.g. people, cars, trees, textures, etc.). You can also integrate 3D objects into the RFEM model to illustrate the model’s proportions.

Importing visual objects

To open the dialog box for importing a visual object, select the menu entry

Insert → Visual Objects

or use the shortcut menu in the Data navigator.

The New Visual Object dialog box opens where you can specify the Description and File Name.

The visual object must be available in the .3ds format. Use the [Browse] button to select the file in the Open dialog box from Windows.

Define the Position of the object in the model by entering the coordinates or in the work window by using . The reference point of the 3D object is indicated by the selection color in the graphic to the right.
In addition, it is possible to define a Rotation of the object or to Scale the object.

Click [OK] to insert the object into the model.

The edit dialog box of a visual object can be accessed by double-clicking the object in the graphic or in the Data navigator.

### 11.3.10 Background Layers

A DXF file can be imported as a background layer and used for the graphical input of objects. In contrast to the DXF import (see Chapter 12.5.2) where the complete model is converted into nodes and lines and loaded, background layers represent a sort of transparent sheet for specific modeling.

It is possible to use several background layers in a model.

**Creating background layers**

To open the dialog box for creating a new background layer, use the menu option

*Insert → Background Layer*

or the shortcut menu in the Data navigator.

The Open dialog box from Windows appears. Enter the directory and the name of the DXF file.
Click the [Open] button to access the Background Layer dialog box.

The No. of the layer is automatically allocated by the program. In the Background Layer Description dialog section, you can enter any name, making later assignment easier.

Use the button to access more settings for the DXF import. This dialog box is depicted and explained in Figure 12.50.

After clicking [OK], RFEM imports the layer, which appears gray in the background of the work window. In this line model, you can now define nodes, lines, and members.
Make sure that the object snap for background layers is activated so that you can arrange objects on
the points available in the layer. To activate the object snap for DXF points, use the [DXF] button in the
middle of the status bar. Alternatively, select Tools → Work Plane, Grid/Snap, Object Snap,
Guidelines in the menu or use the corresponding toolbar button.

In the Background Layers dialog tab of the Work Plane and Grid/Snap dialog box, you can not only
activate the snap but also create new layers, as well as edit, hide, or display them.

![Work Plane and Grid/Snap dialog box, Background Layers tab](image)

**Editing or deleting background layers**

To open the edit dialog box, double-click the background layer or the relevant entry in the Data
navigator (see Figure 11.67). You can also use the Background Layers dialog tab available in the
dialog box for work plane settings (see Figure 11.71): After selecting the layer in the list, you can
[Edit] it.

You can also delete a background layer with the Data navigator.

To move, rotate, or mirror a background layer, select it first. Then you can apply the function described
in Chapter 11.4.1.

**Displaying background layers**

The Display navigator controls the display of background layers in detail.

![Background layer settings in the Display navigator](image)
11.3.11 Margins and Stretch Factors

In most cases, it is not necessary to change the full screen arrangement or the scaling of the model in the work window. If you have to adjust the global display parameters regardless, use the menu option 

Options → Display Margins and Stretch Factors

to open a dialog box that manages the default settings.

The Graphic Margins dialog section allows you to control the minimum distances that are maintained on the four sides of the work window’s margins when the model is displayed. The values are percentages in relation to the total height or width of the work window. They have an impact when using the buttons of the Select View menu (see figure on the left) or the Show Whole Model function [F8] for the window-filling graphical display.

To display the model in a distorted view, you can define factors not equal to 1 for the global directions in the Compress or Stretch Model dialog section. However, customizing settings in this way may only be required in exceptional cases. They only affect the display of the model, not the actual geometry: To scale the model, use the Edit → Scale function (see Chapter 11.4.5 @).

11.4 Editing Objects

You can use the graphical editing functions to modify objects that you selected in the graphic beforehand. The selected objects can be

- moved,
- copied,
- rotated,
- mirrored,
- projected,
- scaled,
- extruded,
- sheared.

No selection is needed for the CAD functions described in Chapter 11.3 @. The functions help you to model new objects.

This chapter also describes how to divide lines, place comments, or change the numbering.
11.4.1 **Move and Copy**

To move or copy selected objects, use the menu entry

**Edit → Move/Copy,**

the shortcut menu of the object, or the corresponding toolbar button.

The following dialog box appears.

![Move and Copy - Copy dialog box](image)

If the **Number of copies** is set to 0, the selected objects are moved. Otherwise, the entered number of copies is generated.

The **Reference to Coordinate System** dialog section allows you to control whether the objects are moved or copied in the global coordinate system XYZ or in a user-defined coordinate system UVW (see Chapter 11.3.4). The user-defined coordinate system can be selected in the list or created with the button.

The **Displacement Vector** must be specified by means of the distances \(d_x\), \(d_y\), and \(d_z\), or \(d_u\), \(d_v\), and \(d_w\) for a user-defined coordinate system. The vector can also be determined in the work window with \(\Delta\) by clicking two grid points or nodes.

If copies are created, you can influence the numbering of the new nodes, members, lines, surfaces, and solids in the **Numbering Increment for** dialog section.

Click the **button** to open another dialog box with useful copying options. This dialog box is also used for other functions such as mirroring, rotating, etc.
Detail Settings

You can create new Lines and Members between the selected nodes and their copies. In addition, it is possible to generate Surfaces and Solids between the selected lines or surfaces and their copies (see Figure 11.77).

When a Template member, Template surface, or Template solid is selected in the list or graphically with , its properties are used for the connecting objects.
Duplicity

Double members may be created when copying. Use the check box to control if overlapping members are allowed, or merged into one member.

Local Coordinate Systems

This section allows you to adjust the local line and member coordinate systems to the new position when rotating and mirroring. This function also adjusts eccentric connections that are defined in the direction of the global axes X, Y, and Z.

The automatic adjustment of local axes is usually important when mirroring objects. The feature is also useful when rotating a vertical member, since its y-axis is oriented parallel to the global Y-axis (see Chapter 4.17).  

Load Cases

If the Copy including loading check box is selected, the loads that act on the selected objects are transferred to the copies. The loads of all load cases are copied, not just the loads of the current load case.

The Adjust nodal loads when rotating or mirroring check box allows you to control the direction of the copies of globally defined nodal loads. If you have selected the check box, RFEM converts the loads to the new position as local concentrated loads (make sure that the loads are also selected). The global load direction is kept otherwise.

Auto Connect

The check box allows you to control if the copies of the lines and members are automatically connected to the existing lines and members. If this function is activated, a node is created at the point of intersection.
11.4.2 Rotate

To rotate selected objects about an axis, use the menu option

**Edit → Rotate,**

the shortcut menu of the object, or the corresponding toolbar button.

![Rotate button](image1.png)

The following dialog box appears.

![Rotate dialog box](image2.png)

If the **Number of copies** is set to 0, the selected objects are rotated. Otherwise, the entered number of copies is generated.

Enter the rotation angle in the **Rotation** dialog section. The angle is related to a coordinate system that is clockwise-oriented.

The **Axis of Rotation** can be defined in two ways:

- The rotation axis runs parallel to an axis of the global axis system XYZ.
  - In this case, activate the first option and select the relevant axis from the list. Then, in the **Definition of the Axis of Rotation** dialog section, specify a point through which the rotation axis runs.

- The rotation axis is defined anywhere in the work plane.
  - In this case, activate the second option. Then, in the **Definition of the Axis of Rotation** dialog section, specify two points that define the rotation axis.

If copies are created, you can influence the numbering of the new objects in the **Numbering Increment** dialog section.

Use the button to open another dialog box with useful options that are described in Chapter 11.4.1. The parameters in this dialog box allow you to control if the connecting lines that are created when copying are generated as straight lines or arcs.
11.4.3 **Mirror**

To mirror selected objects on a plane, use the menu item 

*Edit → Mirror,*

the shortcut menu of the object, or the corresponding toolbar button.

The following dialog box appears.

To keep the original object, select the **Create copy** check box.

The **Mirroring Plane** can be defined in two ways:

- The mirroring plane runs parallel to a plane that is defined by the axes of the global axis system XYZ. In this case, activate the first option and select the relevant plane from the list. Then, in the **Mirroring Plane** dialog section, enter a point that lies in this plane.

- The mirroring plane lies anywhere in the work plane. In this case, activate the second option. Then, in the **Mirroring Plane** dialog section, enter three points that define the plane.

If a copy is created, you can influence the numbering of the new objects in the **Numbering Increment** for dialog section.

Use the **button** to open another dialog box with useful options that are described in Chapter 11.4.1.
11.4.4 Project

Use this function to project selected objects onto a plane. With this, you can adjust the inclination angle of horizontal beams or rafter members, for example.

**Example**

A member is projected in the direction X onto the YZ-plane.

To open the dialog box for entering the projection parameters, select the menu entry **Edit → Project** or use the shortcut menu of the selected objects.
To keep the original object, select the Create copy check box.

In the Projection Direction dialog section, you can decide whether the objects are projected in the direction of a global axis (X, Y, or Z) or perpendicular to a target plane.

The Target Plane can be defined in the following three ways:

- The target plane runs parallel to a plane that is spanned by the axes of the global axis system XYZ. In this case, activate the first option and select the relevant plane from the list. Then, in the Point Coordinates of Target Plane dialog section, enter a point that lies in this plane.

- The target plane runs parallel to a plane that is defined by the axes of the global axis system XYZ, but is rotated around one of the axes. In this case, activate the second option. Select the relevant plane in the list and specify the axis and angle of rotation. Then, in the Point Coordinates of Target Plane dialog section, enter a point that lies in that plane.

- The target plane is defined freely in the work plane. In this case, activate the third option. Then, in the Point Coordinates of Target Plane dialog section, define the plane by entering three points.

If a copy is created, you can influence the numbering of the new objects in the Numbering Increment for dialog section.

Use the button to open another dialog box with useful options that are described in Chapter 11.4.1.

### 11.4.5 Scale

Use this function to scale selected objects in relation to a point.

**Example**

Starting from the origin, a quadrangle surface is stretched equally in all three directions by the factor 2.

To open the dialog box for entering the scale parameters, select the menu item

Edit → Scale

or use the shortcut menu of the selected objects (see figure in the margin to the left of Figure 11.83).
If the Number of copies is set to 0, the selected objects are scaled. Otherwise, the entered number of copies is generated.

The Scale by dialog section manages the scaling factor $k$ (see graphic in the dialog box).

There are three available ways to define the Direction of Scaling:

<table>
<thead>
<tr>
<th>Equally in X,Y,Z</th>
<th>All object coordinates (X, Y, and Z) are scaled in relation to the starting point defined in the Coordinates dialog section.</th>
</tr>
</thead>
<tbody>
<tr>
<td>In direction: X / Y / Z</td>
<td>You have to define one of the global axes. Only the object’s coordinates of the selected global axis are scaled in relation to the starting point defined in the Coordinates dialog section.</td>
</tr>
<tr>
<td>In direction, defined by two points</td>
<td>In the Coordinates dialog section, specify a vector by entering two points. Objects are scaled in the vector’s direction.</td>
</tr>
</tbody>
</table>

If a copy is created, you can influence the numbering of the new objects in the Numbering Increment for dialog section.

Use the button to open another dialog box with useful options that are described in Chapter 11.4.1.
It is also possible to scale background layers. To open the corresponding dialog box, select the menu entry

**Edit → Background Layers → Stretch**

or use the shortcut menu of background layers in the Data navigator.

In the Select Background layer dialog box, specify the relevant layer first. Then you can define the stretch factor in the Stretch Background Layer dialog box [see Figure 11.87 below].

![Figure 11.87](stretch_background_layer.png)

**Figure 11.87  Stretch Background Layer dialog box**

### 11.4.6 Shear

This feature rotates objects about an axis and only adjusts the coordinates of a single direction. You can use the shear function to move horizontal members into the inclination plane of a roof, for example. The member lengths are adjusted and the horizontal components of the coordinates remain unchanged.

Before you use the function, select the members and the related nodes.

To open the dialog box for entering the shearing parameters, select the menu item

**Edit → Shear**

or use the shortcut menu of the selected objects.

![Figure 11.88](shear_dialog.png)

**Figure 11.88  3D Shearing dialog box**
In the Slope dialog section, enter the rotation angle in \[^\circ\] or \[%\].

The parameters for Shearing can be defined in two ways:

- The rotation axis runs parallel to a plane that is spanned by the axes of the global axis system XYZ. In this case, activate the About axis option and select the relevant axis of rotation from the list. Then, in the In direction list, select the global axis that is relevant for adjusting the node coordinates. Finally, in the Starting Plane dialog section, enter the point of rotation.

- The rotation axis lies anywhere in the work plane. In this case, activate the second option. Then, in the Starting Plane dialog section, define both points of the rotation axis and another point for determining the plane. You can also select the points graphically.

### 11.4.7 Dividing Lines and Members

Lines and members can be divided quickly: Right-click the object and select Divide Line or Divide Member in the shortcut menu.

The shortcut menu provides three division options.
Graphically

The Divide Line dialog box opens. When you move the pointer along the line, it snaps to it at the distances specified in the Step dialog section. Click to define the division point. The Reference of the division spacings can be set in absolute distances or relative to the total length.

It is also possible to directly enter the Division Spacing. Before entering the spacing, specify the line that you want to divide and the number of the new line in the Line No. and New No. text boxes. If you want to relate the division spacing to the line end, you can change the line orientation with the Reverse orientation check box.

n Intermediate Nodes

Use this function to evenly divide the line into several line parts. In the Number of dialog section, you can define the number of Intermediate nodes for the line division.

The line is either divided into "real" lines via new intermediate nodes, or the line is retained while RFEM places nodes on the line in equal spacings. Usually, the real division is preferred. However, if you want to change the course of a B-Spline line when dividing the line, the second option is the better choice.

In the Numbering Starts with dialog section, you can influence the numbering of the new nodes, lines, and members.
Distance

You can use this function to generate a division node on a specific location of the line.

The line is either divided into "real" lines via a new intermediate node or retained while RFEM places a new node on the line.

The Distance Relative to dialog section controls the relation of the division distance: The distance can be related to the real line length (normal case) or to a projection.

The Distance Between New Node and start or end node of the line is to be specified as an absolute value or relative to the total length. The four text boxes are interactive.

For entering the distance, it is important to know the line or member orientation. The orientations and axis systems of lines and members can be switched on and off in the shortcut menu or the Display navigator [see Figure 4.26 @ and Figure 4.169 @].

The Numbering Starts with dialog section controls the numbering of new objects.
11 \textbf{Program Functions}

11.4.8 \textbf{Connecting Lines and Members}

This function connects lines and members that cross each other but do not have a common node.

![Figure 11.93](image) Original on the left (intersecting, unconnected lines) and result on the right (connected lines)

To access the corresponding function, select the menu entry \textbf{Tools $\rightarrow$ Connect Lines/Members}

or use the toolbar button shown on the left.

![Figure 11.94](image) Connect Lines or Members button

Go into the work window and draw a window across the zone where you want to connect the lines or members. It is not necessary to catch the objects completely.

You can use this function to determine the intersection point of a line and a surface, for example.

![Figure 11.95](image) Creating an intersection point between a line and surface: Original (left) and copy with result (right)

This function can also be used for setting new lines or members graphically (see Figure 11.96). However, connection nodes are only created when lines/members are connected to other lines/members, that is when they end at the corresponding object. When you define crossing diagonals, no intersection node is generated.

In the \textit{New Line} or \textit{New Member} dialog box, you can use the button to determine if lines or members are automatically connected when they are generated.
11.4.9 Merging Lines and Members

Lines or members that are connected with each other can be combined into a single line or member. This function is only available in the shortcut menu of nodes, which can be accessed by right-clicking the division node.

While the [Del] key simply deletes the selected node and consequently the joined lines, members, and surfaces, the shortcut menu offers extended options to Delete Nodes, but only for nodes where exactly two lines or members are connected.

If the lines or members do not lie on a straight line, RFEM creates a new line or member between the edge nodes when merging.
11.4.10 Extending Lines and Members

You can use this feature to adjust the length of a line (or a member) or to extend the line until it reaches another line.

To access the extend function, use the line shortcut menu (see Figure 11.89) or the member shortcut menu shown on the left.

The Extend Line or Extend Member dialog box opens.

The Extend Method dialog section provides three options:

- **Extend to L** changes the total length of the line or member to a dimension that you specify in the text box.
- **Extend by Δ** extends one or both member sides by a specified value, or shortens the side(s) if the value in the text box is negative.
- **To next member or line** extends the object to the nearest line that forms an intersection with the straight line of the line or member. When the Divide target member or line check box is selected, the objects are connected automatically.

Specify the direction of extension in the dialog section below: The On both ends option results in an extension at both ends of the member. With it, you can either relate the total length L to the line/member center, or extend the line on both sides either by the value Δ or until the next two lines are reached. Alternatively, you can use the On member start i or On member end j options to adjust the length of the member on only one end.

The display of line or member orientations can be set in the Display navigator (see Figure 4.26).
11.4.11 Joining Members

Unlike when connecting members (see Chapter 11.4.8), this function does not require a common point of intersection. Thus, free members at a certain distance to a member can be joined to the nodes of this member. However, if you want to connect the member by extending it, use the Extend Member function (see Chapter 11.4.10).

To access the corresponding function, use the menu option

**Tools → Join Members.**

The following dialog box appears.

![Join Members dialog box](image)

In the **Settings** dialog section, enter the number of the member whose nodes you want to join the free members to, or select it graphically with ![select option](image). The text box below specifies the distance, that is, the circumference where RFEM looks for free member ends. If the **Also select other connected members** check box is selected, RFEM also includes members that are connected with an already selected member in the member list of the text box above.

The **How to Connect Free Member Ends** dialog section allows you control how the free member ends are connected to the selected members: You can either move them to the nodes of the selected members or connect them with eccentric connections.
**11.4.12 Inserting Nodes**

You can use this function to create a new node between any two nodes. That way, you do not need to define a line and divide it by an intermediate node (see Chapter 11.4.7). To access the corresponding function, select the menu entry

> Insert → Model Data → Nodes → Node Between Two Points

or use the [New Node] list button in the toolbar.

Select the two points (nodes, grid points, any points) one after the other in the work window. Then the following dialog box appears.

![Node Between Two Points dialog box](image)

The Distance from Point can be defined in absolute or relative values. The work window displays modifications immediately. To create the new node, click [OK].
11.4.13 Inserting Members

This function allows you to define a section that has different cross-section properties on an existing member. The original member is divided by two intermediate nodes. To access the corresponding function, use the menu option

Insert → Model Data → Members → Graphically → Inserted Member.

After selecting the relevant member in the work window, the following dialog box appears.

![New Inserted Member dialog box](image)

Define both division points with mouse clicks in the work window. A cross on the pointer position indicates the current division point on the member. The distances shown when moving the pointer along the member are managed with the Step text box.

The x-locations of the start and end nodes are displayed in the text boxes of the Inserted Member dialog section where they can be modified, if necessary. The Length of the intermediate member appears below.

The Reference dialog section allows you to control whether the division spacings are related to the absolute lengths or to the relative distances from the member start.

The Cross-section can either be accepted or newly assigned from the list of already defined cross-sections. With the buttons shown on the left, you can create a [New] cross-section or select a cross-section from the [Library].

The Numbering Starts with dialog section controls the numbering of new objects.
11.4.14 Assigning Member Properties Graphically

You can use this feature to graphically transfer the definition criteria of members for cross-sections, releases, and eccentricities to already created members.

To access the corresponding function, use the menu option

Insert → Model Data → Members → Assign Member Properties to Members Graphically

or

Edit → Model Data → Members → Assign Member Properties to Members Graphically.

The following dialog box appears.

Select the Cross-Section from the list or use the buttons shown on the left to select the cross-section from the [Library] or to create a [New] one. If necessary, you can define the Member End Release in the list, but it is also possible to create a [New] release type (see Chapter 4.14).

You can relate the Member Eccentricity to the local member axis system x,y,z or the global coordinate system X,Y,Z. If needed, define the eccentricity in the corresponding text boxes (see Chapter 4.15).

The Status dialog section allows you to control if a member eccentricity is newly assigned (Set) or removed (Delete). Select Keep original to only change the cross-section and the member end release, but no existing eccentricity.

After clicking [OK], the members are graphically divided at one-third division points (see Figure 4.143). Now you can click the member sides to which you want to apply the selected properties (a release, for example). Click a member in its center to assign the release or the eccentricity to both member ends.
11.4.15 **Rounding Corners**

Corners and edges in the model may result in singularity effects. To open the dialog box for realistically modeling corners using fillet radii, use the menu option

**Tools → Create Round or Angled Corner.**

It is not necessary to select both lines beforehand. The following dialog box appears.

![Create Round or Angled Corner dialog box](image)

In the **Corner Type** dialog section, specify if the corner zone should be made round or angled. Depending on the selection, you have to enter the fillet radius \( r \) or a reduction by the lengths \( l_1 \) and \( l_2 \) in the **Parameters** dialog section.

Then, select both lines by mouse-click in the work window without closing the dialog box. The line numbers are shown in the **Create Between Lines No.** dialog section.

When the **Cut lines** check box is selected, RFEM deletes the extensions of the original lines that overlap in the corner zone after creating the arc or the new line. The **Delete corner** option also removes the node in the corner.
11.4.16 Splitting Surfaces

During the modeling process, it may be necessary to split a surface into surface components.

A plane surface has to be defined by four lines. It must not contain any reentrant corner. The lines cannot be intersecting lines, trajectory curves, or similar objects.

To divide a surface, right-click it and select Split Surface in the shortcut menu. This function is not only available for plane surfaces but also for quadrangle and rotated surfaces, pipes, etc.

A preview appears in the Split Surface dialog box, suggesting a division that illustrates the preset parameters. When you change the Number of divisions for both boundary line pairs A and C, as well as B and D, the graphic immediately shows the new sub-surfaces.

A Relative distance can be defined for each division line, which also enables irregular splitting patterns.

In the graphic window, you can use the common mouse functions such as zooming or rotating to change the view (see Chapter 3.4.9).
11.4.17 Applying Tangents to Circles

You can easily create a tangent on an arc or a circle by using the object snap (see Chapter 11.3.3 [5]). A special feature allows you to find the tangent(s) to two circles or circular arcs as well. To access this function, use the menu option Tools —> Tangent to Two Circles/Arcs.

The following dialog box appears.

![Tangent to Circles or Arcs dialog box](image)

First, click both circle lines or arc lines one after the other in the work window. RFEM drafts the possible tangents as gray lines. Now click the relevant line. RFEM divides the circular or arc lines by nodes and creates the tangent as a new line.

By selecting the Trim arcs check box, you can automatically remove overlapping line sections that result from the division (see figure above).
11.4.18 Changing the Numbering

A regular, structured numbering proves to be useful both for the modeling and evaluation. However, graphical input and subsequent modifications may rearrange the numbering.

There are three options for adjusting the sequence of the numbering retroactively. To access the corresponding functions, select the menu entry

\[\text{Tools} \rightarrow \text{Renumber}.\]

Loads are no problem when changing the numbering because the assigned loading is automatically transferred to the new numbers of the objects.

Singly

In the Object to Renumber dialog section, you can specify whether nodes, lines, members, or other model objects selected from the list are renumbered. Specify the start number of the new numbering and the increment in the Renumbering section.

After closing the dialog box with the [Close] button, you can click the relevant objects one by one in the work window. Please note that RFEM can only allocate free numbers that are not yet assigned.

Automatically

First, select the nodes, lines, members, surfaces, or solids (see Chapter 11.2.1) whose numbering you want to adjust. Then, open the following dialog box.
Specify the Priority of the global directions X, Y, and Z for the new numbering in the dialog box. In addition, you have to decide if the ascending numbering is applied in Direction of the respective positive or negative axis.

In the example above, the nodes (as well as lines and members) with the smallest X-coordinates receive new numbers first. The nodes are renumbered in the positive direction X. If two nodes have identical X-coordinates, the second priority decides, which node receives the lower number: This is the node with the smaller Y-coordinate. Should the Y-coordinates also be identical, the third priority is decisive.

The Objects to Renumber dialog section controls, which nodes, lines, members, surfaces, or solids are renumbered and which start numbers and increments are used for the renumbering. Numbers that are already allocated may not be assigned again. However, RFEM allows the use of allocated numbers if they become available due to the renumbering.

**Shift**

First, select the objects whose numbering you want to adjust. Then, open the following dialog box by selecting Tools → Renumber in the menu.

In the Selected Objects dialog section, define the objects that you want to renumber: In addition to nodes, lines, and members, you can select other objects of the model in a list (see figure on the left). In the Increment column, you can specify, by which value the numbers of the selected objects are to be increased. Use negative increments to reduce the numbering. Make sure that no resulting numbers are smaller than 1.

In the Load Cases and Combinations dialog section, you can adjust the numbering of load cases, load and result combinations. Specify the numbers of the load cases and combinations as a list in the No. from and No. to columns. The Increment column controls, by which value the numbers of the load objects are respectively increased.

After clicking [OK], the numbers are shifted. Note that only free, unassigned numbers can be allocated to the various model and load objects.
11.5 Table Functions

11.5.1 Editing Functions

The editing functions are tools that make the data input in tables easier (see Chapter 3.4.4). In contrast to the selection functions described in the following Chapter 11.5.2, it is not necessary to select cells beforehand. The editing functions only affect the cell in which the pointer is placed.

To turn the tables on and off, select the menu entry

Table → Display

or use the toolbar button shown on the left.

Accessing the editing functions

To enable the editing functions for the table, place the pointer in a table cell. To access the editing functions, use the menu option

Table → Edit.

Some editing functions are available in the toolbar of the table.

You can also use the shortcut menu in the table to access the functions.
<table>
<thead>
<tr>
<th>Function</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut [Ctrl+X]</td>
<td>Removes the content of the cell and saves it in the clipboard.</td>
</tr>
<tr>
<td>Copy [Ctrl+C]</td>
<td>Copies the cell content to the clipboard.</td>
</tr>
<tr>
<td>Paste [Ctrl+V]</td>
<td>Inserts the content of the clipboard into the cell. If the content of</td>
</tr>
<tr>
<td></td>
<td>the clipboard is larger than a cell, the cells of subsequent table</td>
</tr>
<tr>
<td></td>
<td>columns and rows are overwritten. A warning is displayed before.</td>
</tr>
<tr>
<td>Copy Row [Ctrl+2]</td>
<td>Overwrites the next row with the content of the current row.</td>
</tr>
<tr>
<td>Empty Row [Ctrl+Y]</td>
<td>Deletes the content of the row without deleting the row itself.</td>
</tr>
<tr>
<td>Insert Row [Ctrl+I]</td>
<td>Inserts a new, empty row. The subsequent rows are moved downwards.</td>
</tr>
<tr>
<td>Delete Row [Ctrl+R]</td>
<td>Deletes the current row. The subsequent rows are moved upwards.</td>
</tr>
<tr>
<td>Find [Ctrl+F]</td>
<td>Searches for a specific number or string within the table.</td>
</tr>
<tr>
<td>Replace [Ctrl+H]</td>
<td>Searches for a number or string within the table and replaces it with</td>
</tr>
<tr>
<td></td>
<td>a different entry.</td>
</tr>
<tr>
<td>Empty table</td>
<td>Deletes the content of the current table completely and without a</td>
</tr>
<tr>
<td></td>
<td>warning message.</td>
</tr>
<tr>
<td>Empty all tables</td>
<td>Deletes the contents of all tables.</td>
</tr>
<tr>
<td>Select [F7]</td>
<td>Opens a list for selection in a cell.</td>
</tr>
<tr>
<td>Update graphics</td>
<td>Applies the modifications in the table to the graphic.</td>
</tr>
<tr>
<td>Edit in dialog box</td>
<td>Opens a dialog box where the data of the current row can be entered.</td>
</tr>
</tbody>
</table>
11.5.2 Selection Functions

The selection functions are tools that facilitate the data input in tables. In contrast to the editing functions described in Chapter 11.5.1, you have to mark several connected cells as a Selection first.

![Table with coordinates](image)

It is not important whether the cells are empty or not. A selection function collectively modifies the contents of selected cells.

**Accessing the selection functions**

First, mark a selection as a block of contiguous cells in the table. This is done by moving the mouse while keeping the left mouse button pressed down. A click on a table header (A, B, C ...) selects the whole table column, a click on a row number selects the whole row.

To access the selection functions, use the menu option **Table → Selection**.

Some selection functions are available in the toolbar of the table.

![Table toolbar with selection icons](image)

Alternatively, you can use the shortcut menu in the table to access the functions.
## Functions and commands

<table>
<thead>
<tr>
<th>Function</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Deselect</td>
<td>Cancels the selection of the row or column.</td>
</tr>
<tr>
<td>Cut</td>
<td>Removes the content of the selected cells and saves it in the clipboard.</td>
</tr>
<tr>
<td>Copy</td>
<td>Copies the content of the selection to the clipboard.</td>
</tr>
<tr>
<td>Paste</td>
<td>Inserts the content of the clipboard into the table. The command is only available if the clipboard contains suitable data (e.g. from Excel).</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes all of the contents of the selected cells.</td>
</tr>
<tr>
<td>Add</td>
<td>Adds/subtracts a value to/from cells that contain numerical values.</td>
</tr>
<tr>
<td>Multiply</td>
<td>Multiplies cells that contain numerical values by a specified factor.</td>
</tr>
<tr>
<td>Divide</td>
<td>Divides cells that contain numerical values by a divisor.</td>
</tr>
<tr>
<td>Set</td>
<td>Assigns the value of the topmost selected cell to all cells of the selection.</td>
</tr>
<tr>
<td>Generate</td>
<td>Used for cells with numerical values to generate the cells between the first and last selected cell via interpolation of both reference values (see example below).</td>
</tr>
<tr>
<td>Save</td>
<td>Saves the selection as a file.</td>
</tr>
<tr>
<td>Import</td>
<td>Imports a selection that was saved as a file.</td>
</tr>
</tbody>
</table>

Table 11.9: Selection functions
Example: Generating cell values

You can use this function to quickly fill empty cells. The intermediate values are determined by a linear interpolation from the start value of the top cell (6.000) and the end value of the bottom cell (30.000).

After the Generate function has been used, the cells in between are filled with the interpolated values.

11.5.3 View Functions

The table display can be adjusted by means of various view functions.

Accessing the view functions

To access the view functions, select the menu entry

Table ➔ View or

Table ➔ Optimize Load Data.

Some view functions can also be accessed in the toolbar of the table.
## Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Only filled rows</td>
<td>Hides all empty table rows.</td>
</tr>
<tr>
<td>Only marked rows</td>
<td>Only shows the marked rows.</td>
</tr>
<tr>
<td>Selected objects only</td>
<td>Only shows the objects selected in the graphic.</td>
</tr>
<tr>
<td>Select related objects</td>
<td>In addition to loads, the associated model objects (members, nodes, sets of members) are selected in the graphic. The function is only available in the loads tables 3.</td>
</tr>
<tr>
<td>Compress data</td>
<td>Combines objects with the same loads into a single table row in the loads tables.</td>
</tr>
<tr>
<td>Decompress data</td>
<td>Lists the loads individually for each object.</td>
</tr>
<tr>
<td>Result filter</td>
<td>The table output can be restricted to particular result types (see Chapter 11.5.5 @).</td>
</tr>
<tr>
<td>Info about cross-section</td>
<td>Shows the characteristic values of the current cross-section.</td>
</tr>
<tr>
<td>Result diagrams</td>
<td>Displays the results of the selected member graphically in a new window (see Chapter 9.5 @).</td>
</tr>
<tr>
<td>Colored relation scales</td>
<td>Switches the display of the red and blue bars in the table on and off.</td>
</tr>
<tr>
<td>Title bar</td>
<td>Switches the title bar on and off.</td>
</tr>
<tr>
<td>Selection in Toolbar</td>
<td>Switches the toolbar on and off.</td>
</tr>
<tr>
<td>Column bar</td>
<td>Switches the column headings (A, B, C, ...) on and off.</td>
</tr>
<tr>
<td>Status bar</td>
<td>Switches the status bar of the table on and off.</td>
</tr>
<tr>
<td>Highlight table row</td>
<td>The table row where the pointer is placed is highlighted with colors or is not marked.</td>
</tr>
</tbody>
</table>

*Table 11.10 View functions*
Example: Only filled rows

A table contains empty rows that affect its clarity.

![Figure 11.117 Table with empty rows](image1)

Use the *Only Filled Rows* button in the table toolbar to hide all empty table rows.

![Figure 11.118 Table without empty rows](image2)
11.5.4 Table Settings

The font and color settings used in the tables can be individually adjusted. It is also possible to synchronize the selection in the graphic with the one in the table.

Accessing the table settings

To access the settings, use the menu option

Table → Settings.

To activate and deactivate the synchronization of the selection, you can also use the table toolbar buttons.

<table>
<thead>
<tr>
<th>Function</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Colors</td>
<td>Opens the Colors dialog box (see Figure 11.120). Colors of individual table objects can be adjusted separately.</td>
</tr>
<tr>
<td>Fonts</td>
<td>Opens the Font dialog box (see Figure 11.120). Font, style, and font size can be modified globally for all table objects.</td>
</tr>
<tr>
<td>Select current object in the graphic</td>
<td>The object of the table row where the pointer is placed is also selected in the work window (default setting).</td>
</tr>
<tr>
<td>Show selected object in tables</td>
<td>The objects selected in the work window are also highlighted with colors in the table (default setting).</td>
</tr>
</tbody>
</table>

Table 11.11 Table settings
11.5.5 Filter Functions

Various filter functions allow you to specifically evaluate internal forces, contact forces, and deformations in the member results tables. There are also filter options for nodal and line support forces of result combinations (see Chapter 8.1 and Chapter 8.3).

Accessing the filter functions

To access the result filters, select the menu item

**Table → View → Result Filter**

or use the button in the table toolbar shown on the left.

The following dialog box appears.

Select the relevant results table in the **Tables to Display** dialog section. Use the dialog tab on the right to determine, which values are shown numerically.

For internal forces of members, you can separately define for **Load Cases / Load Combinations** and **Result Combinations** whether the values of the **Start of members** and **End of members** (nodal values), the **Internal points** (x-locations of the user-defined member division, see Chapter 4.16), as well as the **Extreme** values of the members are shown in the table. The type of internal force for extreme values is determined with the six check boxes.

Two result values appear on each location for result combinations — the minimum and maximum internal forces with the corresponding internal forces.
You can use the buttons shown on the left to transfer the filter criteria from one dialog section to the other.

**Example**

A member division with two intermediate points has been defined for member 11 that has a length of 6.700 m. The filter settings for result combinations shown in Figure 11.122 result in the following results table 4.6 Members - Internal Forces.

![Figure 11.123](image)

Table column H shows the maximum and minimum bending moments $M_y$ in bold on the nodes, division points, and locations of the absolute extreme values. The latter appear with a capitalized initial letter as $\text{Max } M_y$ and $\text{Min } M_y$ at the end of the list (see marked cells in figure above). The values in the remaining columns are the corresponding internal forces of the respective maximum and minimum values.

### 11.5.6 Importing and Exporting Tables

A table from MS Excel can be imported directly into the current RFEM input table. The programs involved must be opened. Conversely, it is also possible to completely or partially export the current RFEM table to MS Excel.

**Accessing the import and export function**

To use the import or export function, click the [Export/Import Table] button in the table toolbar.

![Figure 11.124](image)

Use this button to open the Import table and Export table dialog boxes (see figures below).
Import table

The MS Excel workbook must be opened before starting the import. If headers exist in the spreadsheets, activate the Including table header check box. In doing so, the headers are ignored during the import and only the lists are transferred to the RFEM tables.

The spreadsheet software MS Excel is the only available Application.

The Transfer Parameters dialog section specifies whether the active workbook or only the active worksheet is imported. When importing a complete workbook, the order and structure of the worksheets must completely match the RFEM tables.

In the Formulas and Parameters dialog section, you can decide if formulas stored in Excel are also imported when exchanging data.

Click [OK] to start the import.

If you only want to import specific parts of the worksheet, the copy function is recommended: Select the relevant area in the Excel table and copy it to the clipboard with [Ctrl]+[C]. Then, place the pointer into the corresponding cell of the RFEM table and insert the content of the clipboard with [Ctrl]+[V].
Export table

To export RFEM tables, MS Excel does not need to be opened beforehand.

The available Application is the spreadsheet software MS Excel. It is also possible to create a file in the general spreadsheet format CSV (see Chapter 4.13).

In the Table Parameters dialog section, specify if the headers are exported as well. If the check box is selected, the result in Excel looks like in the figure below:

![Excel table with exported headers](image)

If the check box is not selected, only the table content is transferred to Excel.

With the Only marked cells option, you can export selected table contents (see Chapter 11.5.2).

Use the Only selected objects check box to export data or results of selected row numbers. The selection is facilitated by the synchronization of the selection between graphic and table (see Chapter 11.5.4).

The Only filled rows option controls, how empty rows are treated for the export.

In the Transfer Parameters dialog section, you can specify the target tables that data will be written into. When the first check box is clear, RFEM creates a new workbook. With the Export table to active worksheet option, it is possible to use the current worksheet of the spreadsheet program. If the Rewrite existing worksheet check box is selected, RFEM searches for a table in the workbook with the same name as in RFEM and then overwrites it.

In the Formulas and Parameters dialog section, you can decide if and how the formulas saved in RFEM should be exported.

To start the export of the current RFEM table, click [OK].

To transfer several tables at once to Excel, it is recommended to use the File → Export menu function (see Chapter 12.5.2). Then you can select the relevant tables in a dialog box.
11.6 Parametrized Input

11.6.1 Concept

The parametrized input of model and load data makes use of certain variables (e.g. length, width, traffic load, etc.), which are called "parameters" and are stored in a parameter list.

The parameters can be used in formulas to determine a numerical value. The formulas are edited in the Formula Editor. If a parameter is modified in the parameters list, the results of all formulas using this parameter are adjusted.

The parametrized input is useful for projects where many changes can be expected. The formulas of the geometry and load input are stored in the model data. The parametrized input is also quite suitable for editing recurring models that are similar in design: Simply open a template file and adjust the parameters.

A technical article describes how a surface load can be applied with parameterization: https://www.dlubal.com/en-US/support-and-learning/support/knowledge-base/000922

11.6.2 Parameter List

The parameter list manages all parameters required for modeling.

Accessing the parameter list

To access the parameter list, click the [Edit Parameters] button:

- in the toolbar of an input table
- in the Formula Editor
Description

The Edit Parameters dialog box appears.

![Edit Parameters dialog box](image)

Each table row manages a Parameter. In column A, enter a name that must consist of ASCII signs and contain no spaces. The name is used to refer to the parameter in the formulas. Each parameter name can only be assigned once.

In table column B, define the Unit Type to determine if the parameter represents a length, load, density, etc. The unit types are predefined. To access the selection list available in this column, use the shortcut button or [F7].

In column C, specify the numerical Value of the parameter.

Specify the Unit in table column D. To access the selection list of available units in this column, use the shortcut button or [F7].

In column E, you can enter a Formula to determine the value of the parameter for table column C. In addition to common mathematical operations, If statements and Max/Min functions are available. With the $-reference, you can refer to a specific table (for example, $1.1(A1)$ uses the value of cell A1 from table 1.1).

Examples

\[
\text{if}(A < B; 10; B)
\]

If parameter A is smaller than parameter B, the value 10 is applied. Otherwise, parameter B is used.

\[
\text{max}(A; B)
\]

The larger value among parameters A and B is used.

\[
\text{min}(\text{max}(A; B); C)
\]

The larger value of parameters A and B is determined, which is then compared to the value of parameter C. The smallest value is finally applied.
Use the button in table column E to access a List of operators and functions.

In table column F, you can define a Range of Values to control the values of column C.

Column G is reserved for entering any Comment.

**Input functions**

The parameters can be entered cell by cell.

For efficient input, several tools are available, which you can access by right-clicking a cell. The editing functions (empty or insert row, replace, etc.) are described in Chapter 11.5.1.

When several cells are marked as a selection, the following shortcut menu appears.
You can find a description of the menu functions in Chapter 11.5.1 and 11.5.2.

**Buttons**

In addition to the default buttons, the following functions are available in the parameter list.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Save" /></td>
<td>Saves the parameter list in a file.</td>
</tr>
<tr>
<td><img src="image" alt="Load" /></td>
<td>Loads a saved parameter list.</td>
</tr>
<tr>
<td><img src="image" alt="Export" /></td>
<td>Exports the parameter list to MS Excel.</td>
</tr>
<tr>
<td><img src="image" alt="Import" /></td>
<td>Imports the data from the opened Excel table.</td>
</tr>
<tr>
<td><img src="image" alt="Calculator" /></td>
<td>Opens the calculator and imports its result.</td>
</tr>
<tr>
<td><img src="image" alt="Delete" /></td>
<td>Deletes the entire content of the parameter list.</td>
</tr>
<tr>
<td><img src="image" alt="Cross-section" /></td>
<td>Shows the cross-section details of the cross-sections used in the model.</td>
</tr>
</tbody>
</table>

*Table 11.12 Buttons in the Edit Parameters dialog box*
11.6.3 Formula Editor

The formula editor manages the equations of the parametrized input.

Accessing the formula editor

To open the Formula Editor,

- use the button in the table toolbar shown on the left

![Figure 11.133](image)

- click the yellow or red corner of a table cell (the red corner indicates an error in the formula)

![Figure 11.134](image)

- use the function buttons next to the text boxes in the dialog boxes (see Figure 11.139)

![Figure 11.135](image)

It is also possible to import formulas saved in Excel and to export formulas from RFEM to Excel. For more information about the data exchange with Excel, see Chapter 12.5.2.

Description

![Figure 11.136](image)
In the Formula text box, any formula can be entered manually. When you use the calculator, its results are transferred automatically.

The formula may consist of constant numerical values, parameters, or functions. The result of the equation appears in the field below. Use the button at the end of the Formula line to select an entry from the list of previously entered formulas.

Click the button to apply the formula to the table cell or text box of the dialog box. Delete the formula line with the button. In case of incorrect entries, formulas are displayed in red in the Formula text box.

Contents of other cells can be used in formulas by means of references.

A reference is introduced by an exclamation point; the reference cell is set in brackets. As shown in the figure above, the content of cell D3 is three times the value of cell D2.

With a prefixed equal sign, you can also enter formulas directly into table cells (e.g. \(-2.5*\pi\)). If values are used (e.g. \(-22.1+A*H\)), they are integrated into the formula in SI units with \([m]\) or \([N]\).

The following functions are available in the calculator of the formula editor:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>(\sin)</td>
<td>Sine</td>
</tr>
<tr>
<td>(\cos)</td>
<td>Cosine</td>
</tr>
<tr>
<td>(\tan)</td>
<td>Tangent</td>
</tr>
<tr>
<td>(\cot)</td>
<td>Cotangent</td>
</tr>
<tr>
<td>(\sqrt{\cdot})</td>
<td>Square root</td>
</tr>
<tr>
<td>(^{\cdot\cdot})</td>
<td>Power</td>
</tr>
<tr>
<td>(\ln)</td>
<td>Natural logarithm</td>
</tr>
<tr>
<td>(\log)</td>
<td>Logarithm to the base 10</td>
</tr>
<tr>
<td>(\abs{\cdot})</td>
<td>Absolute value</td>
</tr>
</tbody>
</table>
The List of Parameters dialog section in the Formula Editor lists all parameters with the current values. To transfer a particular parameter to the Formula line, double-click the entry or select it and use the [Retain] button.

Click the [Edit Parameters] button (see Chapter 11.6.2) to open the parameter list where you can modify or complete the parameters.

**Buttons**

The buttons available in the formula editor have the following functions.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>✔️</td>
<td>Applies formula to table cell or dialog field</td>
</tr>
<tr>
<td>✗</td>
<td>Deletes formula input</td>
</tr>
<tr>
<td>📊</td>
<td>Saves content of formula editor as file</td>
</tr>
<tr>
<td>📂</td>
<td>Loads a saved file</td>
</tr>
<tr>
<td>📝</td>
<td>Displays or hides calculator and parameter list</td>
</tr>
</tbody>
</table>

**Table 11.14** Buttons in Edit Formulas dialog box
### 11.6.4 Formulas in Tables and Dialog Boxes

The equations stored in the formula editor can be used both in the table cells and in the text boxes of dialog boxes. Since tables and dialog boxes are interactive, you can access the formulas in both input modes.

#### Formulas in tables

When cells are marked by a yellow or red flag (triangle) in the upper left corner, a formula has been linked (see Figure 11.134). Click the flag to open the formula editor.

To link a "normal" cell with a formula, place the pointer in this cell and open the formula editor by using the button shown on the left.

A red flag means that there is an error in the formula. This corresponds to the red formula line in the formula editor. The formula should be corrected.

#### Formulas in dialog boxes

The parametrized input has been developed primarily for the application in tables. However, it is also possible to use formulas in dialog boxes.

A function button to the right of the text boxes in dialog boxes indicates that they can be linked with formulas.

If the text box has already been linked with a formula, it is marked by a yellow flag (or red flag in case of incorrect input) like a cell.

Click the function button to open the shortcut menu shown in Figure 11.135. You can access the formula editor in this menu.
11.7 Model Generators

A variety of tools help you to create models or parts of structural systems. In addition to copy and extrude functions, RFEM provides special dialog boxes for generating member and surface models.

11.7.1 Copies and Extrusions

11.7.1.1 Parallel offset of lines and members

It is easy to copy selected lines or members graphically: Move the objects to the desired place in the workspace while holding down the [Ctrl] key. This function follows the general standards for Windows applications.

If you want to create parallel lines or members, you can enter specific settings in a dialog box. To access the corresponding function, select the menu entry

Tools ➔ Set Parallel Line or
Tools ➔ Set Parallel Member

or use the shortcut menu of the line or member (see Figure 11.149).

![Figure 11.140](New Parallel Line with Offset dialog box)

The selected line appears in the List of Lines. If necessary, more lines can be added by clicking them in the work window. Please note that all lines of the list must lie in one plane.

In the Offset Distance dialog section, you can specify the copy’s distance to the original.

When several lines are copied by parallel offset, there are several ways to adjust the copied lines or members in the Outer Corners dialog section. The figure above shows the copied lines (without axes) extended to the common point of intersection. Moreover, both ends are connected to the original lines with the selected Close ends check box.

The Offset Direction dialog section allows you to control, onto which side the lines are copied. The directions +y and —y are directly displayed in the work window. They are specifically used for this dialog box and do not depend on the currently set work plane. Thus, they do not necessarily reflect the line axes. The Rotation about x text box allows you to copy objects out of the plane.
Extruding lines and members

By extruding lines and members, you can quickly create surfaces, grids, or grillages. But if you want to generate an irregular grid using extended specifications, it is recommended to use the Generate Grid dialog box (see Chapter 11.7.2).

Access the function by selecting the line and member entries in the menu

**Tools → Extrude.**

You can also use the shortcut menu of the relevant line or member.

**Extrude Line/Member into Surface**

The selected line appears in the *List of Lines*. If necessary, more lines can be added by clicking them in the work window. Please note that all lines of the list must lie in one plane.

Enter the material, depth, and thickness of the new surface as the *Surface Parameters*. If an *Offset* is defined, the surface is created at a lateral distance that relates to the direction of the extrusion. In this case, specify the *Side*. The modified parameters are shown immediately in the graphic of the work window.

When several lines are extruded, there are different ways to adjust the copied lines in the *Outer Corners* dialog section. The figure above shows the lines (without axes) extruded with an offset and connected with an arc.

In the *Extrude in Direction* dialog section, specify the global or local direction of the extrusion. The direction is displayed in the graphic. It is specifically used for this dialog box and does not depend on the currently set work plane.
Extrude Member into Grid

The selected member appears in the List of Members. If necessary, other members can be added by clicking them in the work window. All members of the list must lie in one plane.

In the Parameters of Perpendicular Members dialog section, enter the cross-section of the vertical members and the depth as the total height of the grid. Optionally, specify an eccentricity in order to connect the members via an eccentric connection (see Chapter 4.15).

The Number of Member Divisions dialog section controls the division into a uniform grid consisting of parallel and vertical members. Furthermore, you have the Option to do it without the generation of external vertical members.

In the Extrude in Direction dialog section, define the global or local direction where grid members are to be created. The direction is displayed in the graphic. It is specifically used for this dialog box and does not depend on the currently set work plane. The Rotation about x text box allows you to copy objects out of the plane.
11.7.1.3 Extruding surfaces

By extruding planar surfaces, you can quickly create spatial geometric objects.

Access this function by selecting the surface entries in the menu

**Tools → Extrude.**

You can also use the shortcut menu of the relevant surface.

![Surface shortcut menu](Figure 11.143)

The following three options control, which objects are created through the parallel shift of the surface in the work space:

- **Solid**: A 3D solid is created (see Chapter 4.5).
- **Casing**: Only surfaces that encase the spatial object are generated.
- **Members**: Members are created on the connection lines between the nodes and their copies. Optionally, the basic surface is copied as well.

Depending on your choice, a dialog box appears where you have to define the parameters. The Depth $d$ can be entered directly or determined graphically with the mouse.

![Extrude Solid dialog box](Figure 11.144)
11.7.1.4 Generating solids

The previous chapter describes how existing surfaces can be used to create solids or casings. If you want to generate a completely new solid, however, RFEM provides special functions for creating 3D objects: First, create the surfaces (rectangle with roundings, semi-circle, etc.). In a second step, extrude the surfaces in relation to a point or a plane.

Extruding a surface in relation to a parallel plane

To access the corresponding function, use the menu option

**Insert → Model Data → Solids → Graphically → Extrude Tapered**

or the corresponding list button in the menu bar.

The menu contains a multitude of planar surface shapes that can be defined graphically and then extruded parallel to the surface plane.

The functional principle is similar to the graphical input of surfaces (see Chapter 4.4): First, define the material and stiffness in a dialog box. Then you can create the surfaces in the work window by clicking the definition points.
Once the base area is defined, specify the parameters for creating the solid in the Extrude dialog box.

The **Height** \( h \) can be entered directly in the dialog box or determined graphically with the mouse. The projection direction is always orthogonal to the plane of the base area.

By entering a value in the Tapering dialog section, you can create a parallel cover or base area with inclined sides. The angle \( \beta \) describes the inclination towards the projection direction.

In addition, the **Material** of the new solid must be specified.
Extruding a surface in relation to a point

To access the corresponding function, use the menu option

**Insert → Model Data → Solids → Graphically → Extrude to Point.**

The menu contains a large number of planar surface shapes that can be defined graphically and then extruded in relation to a point.

The functional principle is similar to the extrusion of the object in reference to a parallel plane (see above): First, define the base area graphically. Then you can enter the extrusion’s projection point in the Extrude dialog box or define it graphically.

![Extrude Semi Circle to Point dialog box with result](image-url)
11.7.1.5 Splitting members into surfaces

It is sometimes necessary to more thoroughly analyze particular zones of the framework model (e.g., evaluation on the supports or analysis of a frame joint as a surface model). It would be feasible but relatively time-consuming to manually enter a cross-section using surface elements. The Generate Surfaces from Members function facilitates the display of a 1D member element by means of 2D surface elements.

The function is only available if the model type is defined as 3D (see Figure 12.23).

To split the selected member, select the menu item

**Tools → Generate Surfaces from Members → Generate.**

This function is also available in the member shortcut menu, which is opened by right-clicking the member (see Figure 11.149).

![Member shortcut menu](image)

The data of the member is not lost: A dummy member is additionally created in the centroidal axis. The dummy contains all the member data but is not considered in the calculation.
To access more options regarding the Generate Surfaces from Members function, use the menu option

**Tools → Generate Surfaces from Members → Settings.**

The **Divide Member Arcs** dialog section allows you to control how many times a member that lies on a curved line is split. If a very rough polygonal chain is created with the **Automatically** presetting, you can reduce the division angle or division length.

The settings in the **Divide Cross-section Arcs** dialog section affect the splitting of curved surfaces, for example members of the cross-section type "Pipe". Again, the division can be refined by a user-defined division angle.

In the **Created Surfaces** dialog section, you can define an FE mesh refinement for the generated surfaces (see Chapter 4.23). In the course of the conversion, **Frontal Plates** can additionally be created at the member ends. Characteristics of generated surfaces can be retroactively adjusted by editing the surfaces [see Chapter 4.12].
11.7.2 Model Generators

To access the dialog boxes for creating model objects, use the menu entry

**Tools → Generate Model - Members** or
**Tools → Generate Model - Surfaces.**

On the following pages, the generators are individually described. However, you will not find a detailed description of the dialog boxes because the dialog graphics illustrate the parameters adequately.

Each dialog input can be saved as a template and reused later. The two buttons shown on the left are used to [Save] and [Load] the generator data.
### 11.7.2.1 Members

**Continuous beam**

![Generate Continuous Beam dialog box](image)

RFEM creates a continuous beam with supports, irregular spans, and a uniform cross-section. Optionally, load cases and result combinations are created as well.

**2D frame**

![Generate 2D Frame dialog box](image)

Before you enter geometrical data and cross-section properties, select the Frame Type. The columns of the planar frame receive equal support conditions.
**Tapered 2D frame**

![Generate Tapered 2D Frame dialog box](image)

The planar frame must be defined by its Geometry and Cross-Sections. You can create tapers, craneway consoles, and eccentric connections. Loads can be generated as well. The buttons provide access to the generator parameters. The Frame location is important for the load determination.

![Settings - Wind Loads dialog box](image)
In the list, specify the **Type** of truss and the arrangement of the **Diagonals**. Then you can define the **Parameters**, **Cross-Sections** and **Member Types**.

### Grid

Use this generator to create models that have a uniform grid (e.g., gratings). They do not need to be designed with right angles as in the dialog graphic above. Any kind of spatial quadrangle model with four corner points is possible. To generate a "real" girder grillage, it is recommended to set the **Type** of **Model** to **2D - in XY** in the model’s general data (see Chapter 12.2).  

To generate irregular grids, use the **button**.
### Column

In the Type dialog section, define if a center or corner column is generated. If you want to generate Loads, you have to specify their Effective Widths and Correction Factors.

For generating a gable column, the span $a$ is required for the influence range in the longitudinal direction of the hall. The factors $f_1$ and $f_2$ are used to scale the geometric widths $b_1$ and $b_2$ for the static model or to fulfill specific code requirements (e.g. load increment factors for individual designs).

#### Roof generators

The Roof menu item provides three roof generators, which you can use to generate planar roof systems including loads (see following figures).

The [Settings] buttons in the roof dialog boxes help you to determine wind and snow loads (see Figure 11.155).
Roof → Collar Roof

![Generate Collar Roof dialog box](image1)

Roof → Rafter Roof

![Generate Rafter Roof dialog box](image2)
Roof → Purlin Roof

To generate fish-bellied girders, which are mainly used in timber construction, the rectangular and ITS cross-section types (symmetric I-beams) are available for selection in the Cross-section type list.
3D frame

Use this generator to create regular frame models. The columns of the frame receive equal support conditions.

3D hall

Figure 11.163 Generate 3D frame dialog box

Figure 11.164 Generate 3D Hall dialog box
This extensive generator creates a complete hall, including loads. Four dialog tabs are provided: Geometry/Supports manages the system geometry; Partitioning/Bracing controls irregular grid spacings and the arrangement of bracings. In the remaining two tabs, the Cross-Sections and Loads are defined.

### 3D truss

![Generate 3D Truss dialog box](Figure 11.165)

You can use this generator to create a spatial load-bearing structure according to the Bernauer system.
3D cell

This generator creates a spatial cell with several fields. Use the button shown on the left to open another dialog box where you can define openings as well as the grid arrangement for irregular field spacings.
Stairway

In the list, select the Type of stairway, which determines the remaining parameters.

Spiral staircase

In the list, select the Type of stairway, which determines the remaining parameters.
Line

This function allows you to generate straight lines based on new or existing nodes. It is also possible to only create nodes that lie on an imaginary straight line.

Arc

First, define the Type of Arc: circle, parabola, hyperbola, or catenary. Points A and B represent the two edge nodes of the arc, point C determines its arrangement. The Arch Rise defines the sag. The length of a catenary is defined by the parameter L. The heights h1, h2, and h3 are interactive values.
The Parameter describes the constant $a$ in the following equation of the catenary curve:

$$y(x) = a \cosh\left(\frac{x - v_x}{a}\right) + v_y$$

**Equation 11.1**

where $v_x$ or $v_y$: displacements in $x$ or $y$

The larger the number of members is, the more precisely the arc is modeled as a polygonal chain.

**Circle**

The circle arc or full circle is defined by the *Radius* and *Angles*. The object is created around a center point that can be selected anywhere in one of the global planes.
**Sphere**

The larger the number of Planes and Meridians is, the rounder the shape of the sphere will be. Polygonal chains approximate the spherical form, with each member representing a segment.

**Bracings in cells**

Cells are defined by four corner nodes, enclosed by members on all sides and placed in a plane. In the generator dialog box, specify the Members of Bracing and the Cells for Bracing or use the button to select them in the work window by clicking the cell crosses.

Virtual lines allow you to close cells so that bracings can also be created between wall supports, for example.
11.7.2.2 Surfaces

Vaulted head according to DIN 28011 or DIN 28013

For creating a vaulted head, RFEM provides the standard variants Torispherical head and Semi ellipsoidal head. Once the reference point for placing the head is set in the General Data tab, you can define the material and the generator parameters for surface thickness, outer diameter, and border height in the Structure dialog tab. In the Loads dialog tab, it is possible to additionally specify overpressure as a surface load for the generation.

Barrel roof

You can define the parameters of the barrel roof in the Basis and Structure dialog tabs. In the Loads tab, enter the required data for creating the snow load cases.
Domed roof

You can specify the parameters of the domed roof in the Basis and Structure dialog tabs. In the Loads tab, enter the required data for the creation of snow load cases.

Surfaces from cells

Cells consist of at least three corner nodes. They are enclosed by lines or members on all sides and lie in one plane. To fill cells with surfaces, define the Material and Thickness of the surface first. Then, graphically select the cells with the cell crosses in the work window.
Load Generators

The load generators facilitate the input of member and area loads: On the one hand, it is possible to convert area loads (e.g. snow, wind) into member and surface loads; on the other hand, you can convert free line loads and coating loads (e.g. ice) into member loads.

To open the dialog boxes for generating member and area loads, use the menu option

Tools → Generate Loads.

11.8.1 General Features

Settings for load generation

Many dialog boxes provide the button (see Figure 11.184) for opening the Settings for Load Generation dialog box, used to control the tolerance for the integration of nodes into the load plane and to correct the generated loads.

![Figure 11.178 Settings for Load Generation via Plane dialog box](image)

These settings apply for all member load generators. The Tolerance determines the conditions under which members or nodes are considered as belonging to a plane or line. Specifications are possible by entering an angle or a distance. If nodes lie within these defined thresholds, RFEM recognizes the cells and generates the loads.

The Correction of Generated Loads dialog section allows for a comparison between the available area loads and the determined member loads. The check sums are displayed in the dialog boxes that appear after the load generation, before the final conversion into member loads (see Figure 11.188). In case of minor differences, you should make a correction of the distribution in accordance with the moment equilibrium.
The following applies:

\[ \int_{C_{cell}} (q_{member} + q_{correct}) \, dL = \int_{C_{cell}} q \, dC \quad \text{Equilibrium of forces} \]

\[ \int_{C_{cell}} (q_{member} + q_{correct}) r \, dL = \int_{C_{cell}} qr \, dC \quad \text{Equilibrium of moments} \]

where \( r = (x, y) \) \quad \text{Distance to centroid of cell}

When correcting generated loads in accordance with the moment equilibrium, the moment is formed from the area loads to the centroid and then compared with the moment from the member loads to the centroid. As a simplification, you may imagine the moment correction to be a recalculation of the support forces. This support force is then applied to the member as a line load. This correction option allows you to create trapezoidal member loads from variable area loads, for example.

The Usage of Non-loaded Members for Cell Generation dialog section primarily concerns members that lie in an inclined position within the model. In the course of the load generation, the total area to be loaded is determined first. Then RFEM examines, which members enclose cells. The cells are subsequently subtracted from the total area. When excluding a member from the loading (Remove Influence from members option, see below), RFEM relocates its load to the remaining members of the plane or cell.

The three options are illustrated with an example of a platform construction. We only want to apply traffic loads to the members that run in direction X. Like the Y-parallel members, the inclined member is excluded from the load application, but it does affect the creation of member loads depending on the setting.

![Figure 11.179 Platform construction with cells for load generation](image-url)
- **Do not use any member**

The load is applied uniformly to the edge members and the intermediate members. With this setting, all excluded members are ignored, that is, internally applied for load distribution. After calculating the cell area, the load is distributed to the allowed members of the cell.

- **Use all members**

All unloaded members are excluded for the load generation. There is still a problem with the load distribution because of the large, generated cell 2.
Use members parallel to boundary

With this, it is possible to exclude members that lie in an inclined position. If the limit angle between members $\phi_b$ is restricted to $40.55^\circ$ in the Settings dialog box (see Figure 11.178), the load is generated as expected.

![Figure 11.182 Result for Use members parallel to boundary](image)

Modifying generated loads retroactively

After confirming a generator dialog box, the generated loads are transferred to load table 3.15. The Generated Loads entry additionally appears in the Data navigator (see Figure 6.57). In the load shortcut menu and the Display navigator, you can set if the generated loads are displayed as a surface load symbol or Separately as member loads.

The generator parameters are not lost because the original dialog boxes remain accessible as input objects for changes. To open the initial dialog box once more, double-click one of the entries in the navigator or double-click a generated load in the work window. There you can adjust the parameters.

If you want to treat the generated loads as isolated load objects, you have to release the loads from the concept and split them into their components. This step can be accessed in the load shortcut menu that you open by right-clicking a generated load. The Disconnect Generated Load function (see Figure 11.183) allows you to create the individual loads.

![Figure 11.183 Shortcut menu of generated loads](image)

You can also use the shortcut menu of the generated loads in the Data navigator.
11.8.2 Member/Line Loads from Area Loads

11.8.2.1 Member loads from area loads via plane

**Area Load Direction**

Specify, whether the load acts perpendicular to the plane or globally related to the real or projected area. The dialog graphic in the bottom right illustrates the selected load direction.

**Member Load Direction**

The generated member loads can be set to be global or local loads (see Chapter 6.2). The difference is especially significant for nonlinear calculations.

**Area of Load Application**

There are two selection options. Select *Full closed plane* when there is a surface in the load plane between the members (e.g. wall or roof surface) that is not displayed in the RFEM model. In doing so, RFEM apportions the area load that acts on the entire plane to the members. However, if the construction consists only of members (e.g. lattice tower), select the *Empty, on members only* option. Then, only the effective or projected area that is provided by the member cross-sections as the "load application surface" is stressed. The load is applied in consideration of the member orientation.
Load Distribution Type

This section controls how the area load components are assigned to the members. Select Axes of angles for polygons that do not have a reflex angle. The intersection points of the bisecting lines are connected in such a way that application areas are created as shown in the figure on the left. In this way, it is possible to unambiguously distribute the area load to the members.

The angle axes method is not applicable for planes with reflex angles or for polygons. In such cases, set the load distribution type to Constant. In addition to the angle bisectors, RFEM also determines the centroid of the plane. If the intersection points of the bisecting lines lie in front of the centroid, triangular application areas are generated. If they lie behind the centroid, a line that is parallel to the member is drawn through the centroid, forming an application area with both angle bisectors.

Using this method results in areas not being considered or being applied twice. The missing or remaining amount is multiplied by a constant so that the sum of the area and member loads is equal.

The Combined option determines the application areas of triangles, quadrangles, and polygons according to the angle axes method, where possible. If the method cannot be used, RFEM automatically switches to the constant load distribution. The combined method is therefore set by default; RFEM automatically selects the appropriate method.

Area Load Distribution

The load can act on the area as a Uniform or Linearly variable load. You can also define area loads that act freely Varying in direction of a global axis (e.g. height-dependent wind load). The button opens a dialog box where you can define the load parameters depending on the height levels.

In the left table column, enter the global ordinates of the Level; on the right, assign the respective values of the Area Load. The graphic visualizes the current state of input.
When freely variable loads are set, you have to select the correction of the distribution according to the moment equilibrium in the Settings dialog box (see Figure 11.178). Otherwise, constant member loads are generated.

**Area Load Magnitude**

When the load acts uniformly on the area, enter the load value into the enabled text box. For linearly variable loads, specify three node numbers with the respective loads. You can also use the button to graphically select the nodes in the work window.

**Boundary of the Area Load Plane**

Select the corner nodes of the plane to define the Boundary of the Area Load Plane. Use the button and click the relevant nodes one after the other in the work window. In doing so, the plane is marked in the selection color. The fully entered plane appears cyan in color. At least three nodes are required for defining a plane. The area does not need to be enclosed by lines or members on all sides.

It is possible to define different planes that appear in the Corner nodes list.

If the dialog box is opened repeatedly, the last entered planes may be preset in the Corner nodes list. To avoid unintentionally assigning double loads to these planes, it is recommended to empty the entire list with the button.

**Remove Influence from members**

In the Remove Influence from dialog section, you can exclude members from the load application (e.g. purlins, bracings). The selection is carried out member by member or by entering a member template that is [Parallel] to the load-free members. It is recommended to use the graphical selection using.

Click the button to open the Settings for Load Generation dialog box (see Figure 11.178). In it, you can adjust the tolerance for the integration of nodes into the load plane or correct the generated loads.

The [Assign load correction factors] button allows you to scale the loads for specific members. With it, you can, for example, consider the effects of continuity of a roof sheathing on the edge rafters in order to generate reduced member loads. The following dialog box appears.

You can use the and buttons to select the members in the work window and scale them with a Factor.

Click [OK] to start the generation of member loads. An overview appears with information about the cells and loads.
If inadmissible cells are listed, RFEM was unable to unambiguously assign the loads. Use the button to highlight the invalid cell in the graphic. To show a list of reasons for invalid cells, click the button. Often, removed borders of the cell (i.e. edge members excluded from load application) or crossing members that are not connected are responsible for occurring problems when converting loads.

In the *Total Moment to Origin* dialog section, the determined member loads are compared with the applied area loads. If there are differences, you can use the button to open the initial dialog box once more. Specifications must be adjusted in the *Settings for Load Generation* dialog box (see Figure 11.178) that you can access by using the button.

The two buttons in the info window have the following functions:

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Button" /></td>
<td><strong>The Convert Area Loads to Member Loads</strong> dialog box where you can adjust the generation parameters opens again.</td>
</tr>
<tr>
<td><img src="image" alt="Button" /></td>
<td>The work window opens where you can change the view (view mode). To return to the <em>Info</em> window, use [Back] or [Esc].</td>
</tr>
</tbody>
</table>

| Table 11.15 | Buttons in info window for converted member loads |

Figure 11.188  Info About Conversion of Area Load to Member Loads dialog box
11.8.2.2 Member loads from area loads via cells

This dialog box is similar to the Convert Area Loads to Member Loads via Planes dialog box. When opening the dialog box, RFEM checks, which cells are available in the model and displays them as crossed in the work window. “Cells” are zones defined by three or more corner nodes, enclosed by members on all sides, and placed in one plane.

RFEM does not recognize any cells for wind loads on a hall wall with columns, for example, because the members between the footings are missing. In such a case, you can create Virtual lines with \( \hat{\text{V}} \) by clicking the start and end nodes. In this way, cells are closed artificially and recognized by the generator.

The Nodes of cell can be selected one by one with \( \hat{\text{V}} \) in the graphic. After the generation, an overview with information about cells and loads appears.

Click the \( \hat{\text{V}} \) button to open the Settings for Load Generation dialog box [see Figure 11.178 \( \hat{\text{V}} \)]. In it, you can adjust the tolerance for the integration of nodes in the load plane or correct the generated loads.
11.8.2.3 Line loads from area loads on openings

This dialog box resembles the Convert Area Loads to Member Loads via Planes dialog box. In the upper dialog sections, you can define the different load parameters.

In the text box of the Openings with Area Load dialog section, you can enter the numbers of openings or select them in the work window with [ ].

After clicking [OK], an overview with information about the generated loads appears. Then, click [OK] again to create the line loads on the edges of the opening(s).
11.8.3 Other Loads

11.8.3.1 Member loads from free line load

For pure member models such as girder grillages, you can use this dialog box to define free line loads and prorate them to members.

The correct load assignment requires specifications for the Line Load Direction and, where applicable, Member Load Direction. These dialog sections and the Remove Influence from section are described for the "Member Loads From Area Load via Plane" function.

The Line Load Magnitudes can be defined constantly or linearly. The Line Load Position can be graphically defined with \( A \) by clicking the start and end node. If the line load is perpendicular to the plane, additionally enter the help node \( C \).

Click the \( \) button to open the Settings for Load Generation dialog box (see Figure 11.178).
11.8.3.2 Member loads from coating load

**Convert Coating Load to Member Loads**

Members with Coating Load can be entered directly or determined graphically with \( S \). The coating is defined with the thickness and specific weight.

You can use the \( A \) button to check the coating areas \( A_S \) of the selected member cross-sections that are applied for determining the ice load. The areas are related to the center lines of the ice load as shown in the dialog graphic (Figure 11.192). Thus, loads are determined correctly even for small cross-sections with many edges.

11.8.3.3 Loads from accelerated movements

**Generate Loads from Movements**

The load is generated from the acceleration vector and the position vector. The program supports point and line accelerations as well as rotation accelerations and angular velocities. The position vectors can be specified graphically or by entering the coordinates. All inputs can be previewed in the dialog graphic.
This generator creates loads as a result of an acceleration or rotation that acts on specific objects of the model. The mass is determined from the self-weight.

In the Objects with Load dialog section, you can enter the numbers of relevant members, surfaces, or solids or select them graphically with 

You can define the Load Parameters either as an acceleration or rotation (angular velocity \( \omega \), angular acceleration \( \alpha \)). With the button, you can determine the acceleration from the velocities that are available on two points.

In the Definition of the vector of acceleration dialog section, specify if the vector is related to a global axis or defined by two points. The vector can also be defined graphically by using the buttons.

Click [OK] to create the loads for the current load case.

### 11.8.4 Snow Loads

#### 11.8.4.1 Flat/Monopitch roof

Flat and monopitch roofs are managed together in one dialog box. The shape coefficients for flat roofs or roofs with one-sided inclination are taken into account according to EN 1991-1-3 and DIN 1055-5.

First, define the standard and, if necessary, the National Annex in the Snow Load Parameters dialog section. This specification controls, which individual text boxes can be accessed.

Use the button to open a map where the snow load zone \( Z \) can be selected graphically. Based on your specifications, RFEM determines the characteristic value of the snow load \( s_k \) on the ground, taking account of the the altitude \( A \) (sea level).
Use the three check boxes in the Additional Snow Loads dialog section to control if other snow loads should be considered:

- Snow accumulations because of snow drift
- Snow overhang on the eave
- Snow loads on snow guards

Use the button to define the parameters of the snow overhang and snow guard.

If required, you can adjust the exposure coefficient \( C_e \) (EN 1991-1-3, Table 5.1) as well as the thermal coefficient \( C_t \) (EN 1991-1-3, Clause 5.2 (8)) in the Coefficients dialog section.

Define the Roof Geometry by means of the roof corner nodes A to D in accordance with the dialog graphic. You can also use the button to determine them graphically in the work window. The plane is marked in the selection color. At least three nodes are required to define a plane. The area does not need to be enclosed by lines or members on all sides.

The Position of Drifted Snow Load can be defined via the edge nodes of the roof area.

Specify the load case numbers for the load generation in the Load Case to Generate and Load Case for Drifted Snow Load dialog sections. Snow load cases can be created with the button. If surfaces are available in the model, you can specify whether member or surface loads are generated in the Create Load Type dialog section.

The Load Distribution Type and Remove Influence from dialog sections are described for the Member Loads From Area Load via Plane generator function.

Click the button to open the Settings for Load Generation dialog box (see Figure 11.178).

You can use the button to scale the loads for specific members. Specifications must be entered in a separate dialog box (see Figure 11.187).

After confirming the generator dialog box with [OK], RFEM displays the results of the load generation for all load cases in an overview. This way, the acting area loads can be compared with the converted loads. Before the loads are transferred to RFEM, you can click the button to access the initial dialog box where you can change the parameters of the loads.
11.8.4.2 Duopitch roof

First, define the standard and, if necessary, the national annex in the Snow Load Parameters dialog section. This setting controls, which text boxes can be accessed.

Specify the parameters as described in Chapter 11.8.4.1. The Roof Geometry of a duopitch roof is defined by the roof's corner nodes A to F in accordance with the dialog graphic. You can also use the button to graphically determine the nodes in the work window.

Specify the load case numbers for the load generation in the Load Cases to Generate and Load Cases for Drifted Snow Load dialog sections. Alternative load cases are created when additional snow loads (e.g., DIN 1055-5, Figure 4) or shape coefficients (e.g., EN 1991-1-3, Figure 5.3) are taken into account. The relevant snow load cases can be created with the button.
11.8.5 Wind Loads

11.8.5.1 Vertical walls

First, define the standard and, where applicable, the national annex in the Velocity Pressure dialog section. This setting controls, which text boxes can be accessed.

The wind zone and terrain category can be selected graphically in a map that you can open with the button. The structure height $h$ is not automatically transferred from the model; it must be specified. Based on your settings, RFEM determines the basic value of the fundamental wind velocity $v_{b,0}$.

Click the button to access more coefficients for determining the wind loads (see Figure 11.197).
The walls are determined by means of the Base Geometry (nodes I to L for base area, bottom) and the Roof Type and Geometry (nodes A to D or F for roof planes, top). In case of roof overhangs, specify the upper wall nodes, not the roof nodes. As shown in the dialog graphic, wind loads can be generated for building objects closed on all sides with a quadrilateral base area. When entering geometry, note that the start nodes I and A must lie on top of each other and that the "direction" must be consistent when determining the base and roof area. You can use the \( \text{and} \) buttons to graphically define the base and roof geometry.

In the Load Case to Generate dialog section, enter the load case number for the load generation. With the \( \text{button, you can create a wind load case.} \)

The wind direction is defined in the Set Wind on Side dialog section. The wind acts perpendicular to the specified line.

If surfaces are available in the model, you can use the options in the Create Load Type dialog section to decide whether member or surface loads will be generated.

The Load Distribution Type and Remove Influence from dialog sections are described for the Member Loads From Area Load via Plane \( \text{generator function.} \)

Click the \( \text{button to open the Settings for Load Generation dialog box (see Figure 11.178 \( \text{).} \)

After confirming the generator dialog box with [OK], RFEM displays the results of the load generation in an overview. Thus, the acting area loads can be compared with the converted loads. Before the loads are transferred to RFEM, you can click the \( \text{button to access the initial dialog box where you can change the parameters of the loads.} \)
RFEM considers a roof to be flat if the roof inclination $\alpha < 5^\circ$.

First, define the standard and, where applicable, the National Annex in the *Velocity Pressure* dialog section. This setting controls, which text boxes can be accessed.

Specify the parameters as described in Chapter 11.8.5.1. The *Eaves Type* dialog section is linked to the interactive dialog graphics that illustrate the individual settings.

As described in EN 1991-1-4, Table 7.2, for example, several load cases must be taken into account for a flat roof. In the *Load Cases to Generate* dialog section, specify the load case numbers for the load generation. The compression loads are created in load case $LC_{w^+}$, the suction loads in $LC_{w^-}$. The relevant load cases can be created with the button.

After confirming the generator dialog box with [OK], RFEM displays the results of the load generation for all load cases in an overview (see Figure 11.201). The dialog tabs represent an important control option because the external pressure coefficient $c_{pe,10}$ and the external pressure $w_e$ are displayed by zones for each load case.
11.8.5.3 Monopitch roof

First, define the standard and, where applicable, the National Annex in the Velocity Pressure dialog section. This setting controls which text boxes can be accessed.

Specify the parameters as described in Chapter 11.8.5.1. The Monopitch Roof Parameters are automatically determined from the roof geometry and the side where the wind blows.

As described in EN 1991-1-4, Table 7.3a, for example, several load cases must be taken into account for a monopitch roof. In the Load Cases to Generate dialog section, you can specify the load case numbers for the load generation. The compression loads are created in the load case LC \( w^+ \), the suction loads in \( LC \ w^- \). The relevant load cases can be created with the button.

You can use the button to scale the loads for specific members. This way, you can, for example, consider the effects of continuity of a roof sheathing on the edge rafters in order to generate reduced member loads. Specifications are entered in a separate dialog box (see Figure 11.187).
First, define the standard and, where applicable, the National Annex in the Velocity Pressure dialog section. This setting controls, which text boxes can be accessed.

Specify the parameters as described in Chapter 11.8.5.1. The Duopitch Roof Parameters are automatically determined from the roof geometry and the side where the wind blows.

As described in EN 1991-1-4, Table 7.4a, for example, several load cases must be taken into account for a duopitch roof. In the Load Cases to Generate dialog section, specify the load case numbers for the load generation. The compression loads are created in the load case $LC_{w^+}$, the suction loads in $LC_{w^-}$. The combinations (compression on one side of the roof and suction on other side) are defined as $LC_{w^-/+}$ and $LC_{w^+/+}$. The relevant load cases can be created with the button.

After confirming the generator dialog box with [OK], RFEM displays the results of the load generation for all load cases in an overview (see Figure 11.201). The dialog tabs represent an important control option because the external pressure coefficient $c_{pe, 10}$ and the external pressure $w_e$ are displayed by zones for each load case.
Before the loads are transferred to RFEM, you can click the button to access the initial dialog box where you can change the parameters of the loads.
11.8.5.5 Vertical walls with roof

First, define the standard and, where applicable, the National Annex in the Velocity Pressure dialog section. This specification controls, which text boxes can be accessed.

Specify the parameters as described in Chapter 11.8.5.1. As described in EN 1991-1-4, Table 7.4a, for example, several load cases must be taken into account for a duopitch roof. In the Load Cases to Generate dialog section, specify the load case numbers for the load generation. The compression loads are created in the load case LC \( w^+ \), the suction loads in LC \( w^- \). The combinations (compression on one side of the roof and suction on other side) are defined as LC \( w^-/+ \) and LC \( w^+/-. \) The relevant load cases can be created with the button.

Use the button to scale the loads for specific members. Specifications are entered in a separate dialog box (see Figure 11.187). After confirming the generator dialog box with [OK], RFEM displays the results of the load generation for all load cases in an overview (see Figure 11.201). The dialog tabs represent an important control option because the external pressure coefficient \( c_{pe,10} \) and the external pressure \( w_e \) are displayed by zones for each load case.
12 File Management

This chapter describes how data is organized with the Project Manager and how recurring model components are managed in blocks. In addition, the chapter describes the interfaces integrated in RFEM that can be used for exchanging data with other programs.

12.1 Project Manager

In structural analyses, a project is often subdivided into several positions. These positions are called "Models" in RFEM. The Project Manager helps you to organize the models of all Dlubal applications. You can also use it for managing RFEM models within the network (see Chapter 12.3).

The project manager can be left open in the background as a stand-alone application while working in RFEM.

To open the project manager, select File ➔ Project Manager in the menu or use the toolbar button shown on the left.

The project manager can also be accessed in the model's General Data dialog box.

When you open the project manager, the following multi-part window appears. It has its own menu and toolbar.
Project Navigator

A navigator that lists all projects in a tree structure is displayed on the left. The current project is marked in bold. To select a different project, double-click it or use the Current Project list in the toolbar. The table to the right of the navigator lists the models contained in the selected project.

Table of models

The models are arranged in several tabs, sorted by Dlubal applications. The RFEM tab lists all RFEM models contained in the selected project. The Model Name and Description are displayed, as well as significant model and file information including the name of the user who created and edited the model.

To adjust the displayed columns, select View → Manage Register Columns in the menu or use the corresponding button.

Details

This part of the window shows all information available for the model selected in the table.

Preview

The selected model is displayed in a preview. The size of the preview window can be adjusted by moving the upper edge of the window.

Thumbnails

The bottom area of the project manager provides a graphical overview of all models contained in the selected project. The thumbnail images are interactive with the table of the models.

Use the pins to minimize particular window parts. They are then docked as tabs in the footer.
12.1.1 Project Management

Creating new projects

To create a new project,

- select **Project → New** in the project manager menu or
- click the [New Project] button in the toolbar.

The following dialog box opens where you have to enter the **Name** of the new project and select the **Folder** where you want to save the structures. You can use the **button to set the directory. You can also add a short project **Description**. It is also shown in the header of the printout report but has no further relevance.

It is also possible to create sub-projects in the project manager by selecting a project in the **Place** project under list. The new project is then displayed as a sub-project in the navigator. If you do not want to use this setting, select the **Projects** list entry on the top of the list. The project then appears as the main entry in the navigator.

After clicking [OK], a new folder with the project name is created on the local or network drive.

Connecting existing folders

To integrate a folder that already contains several RFEM models as a project,

- select **Project → Connect Folder** in the project manager menu or
- use the [Connect Folder] button in the toolbar.
Which folder of the local or network drive the project is located in is irrelevant. It is included in the internal file management and left at its location — similar to the creation of a shortcut on the desktop. The information is saved in the ASCII file PRO.DLP in the Project Manager folder (see Chapter 12.1.4.3).

A dialog box opens that is similar to the dialog box shown in Figure 12.5. Enter the Name and Description of the project and, if necessary, use to set the directory of the relevant Folder.

If a project is specified in the Place project under list, the connecting folder must be contained in the directory of this project. The folder is then managed as a sub-project. If you want the folder to appear as an independent project in the project manager, however, select Projects at the top of the list.

With the Connect folder including all subfolders option, you can connect all folders contained in the selected folder with the management of the project manager at once.

**Disconnecting folders**

To disconnect a folder from the project management,

- use the Project  Disconnect menu option (select project beforehand),
- click the [Disconnect Project] button in the toolbar, or
- use the shortcut menu of the project in the navigator.

![Figure 12.7](shortcut_menu_of_a_project.png)

The project is only removed from the internal management. The folder on the hard disk and its contents remain.

**Deleting projects**

To delete a project,

- select Project  Delete in the project manager menu (select project beforehand),
- click the [Delete] button in the toolbar, or
- use the Delete entry in the project’s shortcut menu in the navigator (see Figure 12.8).

![Figure 12.8](delete_button.png)
The folder including its content is completely deleted from the hard disk.

If the folder also contains files from other programs, only the files of Dlubal applications are deleted and the folder itself remains.

To undo the deletion of projects, use the menu option

**Edit → Restore from Dlubal Recycle Bin.**

The Dlubal recycle bin is described in Chapter 12.1.4.2.

If files that are stored on a network drive are deleted, the deleted files are copied into the Dlubal recycle bin on the hard disk. This way, you can restore files that were deleted on network drives. If you do not want the files to be copied into the recycle bin, we recommend simply disconnecting the project (see above). Then you can manually delete the data from the network drive.

### Copying projects

To copy a project,

- select **Project → Copy** in the project manager menu (select project beforehand) or
- use the **Copy** entry in the project's shortcut menu in the navigator (see Figure 12.7).

![Copy Project dialog box](image)

Enter the Name, Description, and location of the new project in the project manager and define the Folder that is created by the copy function.

You can also copy the project with the Windows Explorer and then integrate it into the project manager as a connected folder (see Figure 12.6).
**Renaming projects / changing descriptions**

To change the description of a project retroactively,
- select **Project → Properties** in the project manager menu (select project beforehand) or
- use the **Properties** entry in the project’s shortcut menu in the navigator (see Figure 12.7).

In the Project Properties dialog box, you can change the Name and Description of the project. The Folder of the project is also displayed.

**Figure 12.10** Project Properties dialog box

**Importing project folders**

With this feature, you can restore the complete directory structure of the project manager without copying the **PRO.DLP** file (see Chapter 12.3) after changing your computer. All projects contained in a folder are included in the project management (which means that this folder must contain projects, not models). In this way, the projects do not need to be connected individually.

To open the dialog box for importing a project folder, use the project manager menu option **Project → Import Folder**.

**Figure 12.11** Import folder dialog box

In the **Place projects under** list, you can define how you want to integrate the project folders into the management. If you want the folders to appear as independent projects in the project manager, select the **Projects** list entry at the top of the list. Use the **...** button to set the directory for the **Folder** to be linked.

Select the **Connect folders including all subfolders** option to integrate all subfolders of the folders into the management of the project manager.
12.1.2 Model Management

Opening models

To open a model in the project manager,

- double-click the model name or its thumbnail image,
- select **Model → Open** in the project manager menu (select model beforehand), or
- use the shortcut menu of the model.

![Model shortcut menu](image)

Use the **Open With** option in the shortcut menu to select a Dlubal application that you want to open the model with.

You can open RSTAB files directly in RFEM.

Copying / moving models

To copy a model into another project,

- use the **Model → Copy** menu option (select model beforehand),
- use **Copy** in the model’s shortcut menu (see Figure 12.12), or
- use the drag-and-drop function by holding down the [Ctrl] key.
In the Copy Model dialog box, specify the target project as well as the Name and Description for the model’s copy.

To move a model, use the mouse to drag it into a different folder.

**Renaming models**

To rename a model,

- select **Model → Properties** in the project manager menu (select model beforehand) or
- use the **Properties** entry in the model’s shortcut menu (see Figure 12.12).

In the dialog box, you can change the Name and Description of the model. The File name and the model’s directory are also displayed.

If the model also contains results and printout reports, you can remove such Contained Data from the data set by using the buttons.
Deleting models

To delete a model,

- select Model —> Delete in the project manager menu (select model beforehand),
- click the [Delete] button in the toolbar, or
- use the Delete entry in the model's shortcut menu (see Figure 12.12).

It is also possible to specifically delete Results and/or Printout Reports of the model. The input data remains in these cases.

To undo the deletion of models, use the menu option

Edit —> Restore from Dlubal Recycle Bin.

The Dlubal recycle bin is described in Chapter 12.1.4.2.

Displaying the history

To check the history of a model,

- select Model —> History in the project manager menu (select model beforehand) or
- use History in the model's shortcut menu (see Figure 12.12).

A dialog box appears that provides information about the users who created, opened, or modified the model as well as the time when the individual actions were carried out.

The notes listed in the Comment column are based on the model's general data. Corresponding entries are managed in the History dialog tab. You can use comments to document the processing state (see Chapter 12.2.3).
**12.1.3 Data Backup**

**Archive**

You can back up selected models or even an entire project folder in a compressed archive file. The models or folders remain on the hard disk.

To start the archiving process,

- select **Archive Data → Make Archive** in the menu (select model or project beforehand) or
- use the shortcut menu of the project [see Figure 12.7](#) or model [see Figure 12.12](#).

![Archive dialog box](image.png)

The backup file can be generated with or without results and printout reports. Further options allow for the integration of subprojects and files that do not belong to any of the Dlubal applications.

When the **Name** and **Folder** of the archive file are defined, you can create a ZIP file by clicking **[OK]**.

**Extracting from archives**

To unpack an archive, select the project manager menu entry

- **Archive Data → Extract Project from Archive** or
- **Archive Data → Extract Models**.

The Windows dialog box **Open** appears where you can select the ZIP archive file. After clicking **[OK]**, the content is displayed in a dialog box.
In the Select Models to Extract dialog section, you can select the models that you want to restore. They can either be unpacked with the original project settings or as a new project. In the Place project under list, you can define the integration in the management structure of the project manager. You can also create a new directory with.

12.1.4 Settings

12.1.4.1 View

Displaying thumbnails and details

You can customize the area below the model table. There are two options for additional windows that can be activated independently of each other.

To set the display options, select the menu item

View → Pictures Preview of All Models or
View → Details of Current Models

or use the corresponding toolbar buttons:

- Shows thumbnail images of all models in the project
- Shows model details and preview of model

Table 12.1

Buttons for setting the view
Sorting models

The arrangement of models in the table can be adjusted: As is familiar from Windows applications, you can sort the list in ascending or descending order by clicking one of the various column titles. Alternatively, you can use the menu option

**View → Sort Models.**

Adjusting columns

To arrange the columns as required,

- select **View → Manage Register Columns** in the menu or
- use the [Manage Register Columns] button in the toolbar.

![Manage Register Columns dialog box](image)

First, specify the Register whose columns you want to adjust (e.g. RFEM). In the **Columns - Available** list, you can select the relevant entries and transfer them to the **Columns - To Display** list. Use the **<** buttons for the transfer, or double-click the items. Columns that you do not want displayed can be hidden with the **<** buttons.

The order of the columns in the model list can be changed by moving a selected entry up or down with the **<** and **>** buttons in the **Columns - To Display** list.

To optimize the column widths of the model list, select **View → Arrange Automatically** in the menu or use the corresponding toolbar button.
12.1.4.2 Recycle bin

To restore deleted projects and models, use the project manager menu option

*Edit → Restore from Dlubal Recycle Bin.*

A dialog box appears where all deleted models are listed by projects.

![Figure 12.19: Restore Models from Dlubal Recycle Bin dialog box](image)

Select the desired models per mouse click (you can select all models at once with the button). Click the button to reinsert the deleted models into the original project folders.

To delete the objects stored in the Dlubal recycle bin, use the menu item

*Edit → Empty Dlubal Recycle Bin.*

Before the final deletion, a security query is displayed.

The settings for the Dlubal recycle bin are available with the project manager menu entry

*Edit → Settings for Dlubal Recycle Bin.*

A dialog box appears where the specifications for storage location and memory size are managed.

![Figure 12.20: Settings for Dlubal Recycle Bin dialog box](image)
12.1.4.3 Directories

The directories of the project manager (and block manager) can be checked in the Program Options. To open this dialog box, select the project manager menu option Edit → Program Options.

In the Category, the settings for the project manager and block manager are managed separately. The folder and the file name are displayed in the text box below where they can be adjusted, if necessary. The projects are managed in the PRO.DLP file, which is stored in the folder C:\ProgramData\Dlubal\Global\Project Manager by default. The button helps you to set another directory path.

Since the project manager is network-compatible, you can organize the data management for the models contained in the project manager in a central place: Set the directory to the PRO.DLP file on the server (see Chapter 12.3).

The Options dialog section provides general settings for handling RFEM files: A message usually appears when opening a file in the Explorer, e-mail program, etc. if the related folder is not integrated into the management of the project manager. This message can be deactivated. You can also decide, which program version you want to use to create or open model files.
12.2 Creating New Models

To create a model, use

- **File → New** in the RFEM menu,
- the **[New Model]** toolbar button, or
- **Model → New With → RFEM 5** in the project manager menu.

The **New Model - General Data** dialog box opens. It consists of three tabs.

If you want to edit the model’s general data at a later point in time,

- select **Edit → Model Data → General Data** in the menu or
- use the shortcut menu of the model in the Data navigator.
12.2.1 General

The first dialog tab (see Figure 12.23) manages basic model parameters.

**Model Name / Description**

Enter a name into the Model Name text box. It is used as the model’s file name as well. You can enter a Description of the model. It appears in the printout report but has no further relevance, just like the project description.

**Project Name / Description**

In the Project Name list, you can select the project folder that the model will be created in. The current project is preset. If necessary, you can change this presetting in the project manager (see Chapter 12.1) that you can access with the dialog button to the right.

The Description and Folder of the selected project are displayed for informational purposes.

**Type of Model**

In the model’s general data, you have to specify if your structure is a spatial or planar model. For 2D models, the input effort is reduced due to the limited coordinates and degrees of freedom.

The 2D - XY type is suitable for planar plate structures such as slabs that are stressed perpendicular to the surface plane. The 2D - XZ and 2D - XY model types can be used for walls and shells, provided that loads only act in the direction of the surface plane. The use of type 2D - XZ is recommended for planar frame structures, as this option only considers moments about the strong member axes.

It is possible to change the type of model retroactively. Please note that this may lead to data loss when a 3D model is reduced to a wall, for example.

**Classification of Load Cases and Combinations**

Loading must be applied according to the sorted load cases. Load cases are, for example, self-weight, snow, or live load.

The individual standards specify rules for combining load cases. It is therefore important to assign the load cases to particular action categories (see Chapter 5.1). As a result, RFEM is able to automatically provide the load cases with correct partial safety factors and combination coefficients when creating load and result combinations.

**According to Standard**

The According to Standard list contains a variety of rules and standards that describe the principles for the ultimate limit state, the serviceability, and the resistance of structural systems. With the selection of the standard, the rules for creating load and result combinations in RFEM are defined. This specification is significant for the automatic creation of combinations (see Chapter 5.2 to Chapter 5.4).

When None is set, no combinations are created automatically. In this case, load cases must be superimposed manually (see Chapter 5.5.1 and Chapter 5.6.1).

Use the button to show or hide old standards in the list.
When changing the standard retroactively, you need to reclassify the load cases and adjust the combination. A corresponding warning appears.

![Figure 12.26] Warning when changing the standard

**National annex**

When the standard EN 1990 is selected, an additional drop-down list appears: Though combination rules are defined in the Eurocode standard, countries are allowed to specify partial safety factors and combination coefficients themselves.

The list provides a choice of National Annexes of different countries. When the CEN option is set, the factors recommended by the European Commission are applied.

Use the button to check and, for a user-defined standard, adjust the partial safety factors and combination coefficients of the current standard.

The factors are organized in several tabs of the Coefficients dialog box. The first tab manages the Partial Safety Coefficients $\gamma$ for the design situations “static equilibrium” and “ultimate limit state”.

![Figure 12.27] Coefficients dialog box, Partial Safety Coefficients tab

The Combination Coefficients dialog tab (see Figure 5.24) controls the factors $\psi$ and $\xi$. In the Consequences Class tab that is available for EN 1990, you can specify the reliability factor $K_F$. 
Create combinations automatically

If this check box is cleared, the options below cannot be accessed. In such a case, the required load and result combinations must be created manually (see Chapter 5.5.1 and Chapter 5.6.1). The specified standard causes the partial safety and combination factors to be assigned automatically.

As an alternative, you can Create combinations automatically. For this purpose, additional dialog tabs in the Edit Load Cases and Combinations dialog box, separate entries in the Data navigator, as well as Tables 2.2 to 2.4 are available. Generating combinations is described in Chapter 5.2 to Chapter 5.4.

You can find additional information about combinatorics in Chapter 5 as well as in the manual for the former add-on module RF-COMBI, available for download on our website.

During the automatic superpositioning, RFEM either creates Load combinations or Result combinations. The difference between both combination options is described in Chapters 5.5 and 5.6.

Positive Orientation of Global Axis Z

This dialog section controls the orientation of the global axis Z. In CAD programs, the Z-axis is usually directed upwards and in structural analysis programs downwards. This specification is irrelevant for the calculation.

If Z is directed Upward and the self-weight is defined with the factor 1.0 in the direction Z in the base data of the load case, the self-weight acts upwards. In this case, the self-weight factor needs to be changed to –1.0.

If the Z-axis is directed upwards, you can define settings for surfaces and members by clicking the button. The Orientation of Local z-Axis dialog box appears.

The local z-axis can be oriented Upward or Downward in order to appropriately assign elastic surface foundations or reinforcements of plates, for example. Then, answer the query (see Figure 12.29) that appears when you close the General Data dialog box with No.

It is possible to retroactively change the orientation of the Z-axis. You can also adjust the coordinates and global loads in such a way that the view of the model is retained. If the axis direction is modified, the following query appears:
Template

The model can be created according to a template that was saved in a different model by using

**File → Save As Template**

in the menu.

In general, the templates are stored in the Dlubal folder for template models called **Base**. They are also available in the project manager by selecting **Templates → Default** (see Figure 12.3 @).

After selecting the check box in the **New Model - General Data** dialog box, you can select the desired **template model** from the list.

Click the button shown on the left to open an overview with preview pictures that help you choose among the templates.
Comment

You can enter a text into the text box or select one from the list to add a short description to the general data. The comment also appears in the printout report.

The buttons in the General Data dialog box have the following functions.

<table>
<thead>
<tr>
<th>Button</th>
<th>Name</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>![ ]</td>
<td>Comment</td>
<td>→ Chapter 11.1.4</td>
</tr>
<tr>
<td>![ ]</td>
<td>Units and Decimal Places</td>
<td>→ Chapter 11.1.3</td>
</tr>
<tr>
<td>![ ]</td>
<td>MS Excel</td>
<td>Option for additional explanations in the form of an XLS file saved in the RFEM file</td>
</tr>
<tr>
<td>![ ]</td>
<td>MS Word</td>
<td>Option for additional explanations in the form of a DOC file saved in the RFEM file</td>
</tr>
</tbody>
</table>

Table 12.2: General Data dialog box, buttons
12.2.2 Options

The second tab of the New Model - General Data dialog box allows you to control if an RFEM add-on module is enabled and which basic value is set for the standard gravity.

![Image of New Model - General Data dialog box, Options tab]

**Activate**

You can use the check boxes to enable the add-on modules RF-FORM-FINDING (form-finding of membrane and cable structures), RF-CUTTING-PATTERN (determination of cutting patterns for membrane structures), and RF-PIPING (piping analysis). Specific dialog boxes and functions of RFEM for modeling membrane structures and piping systems are thus enabled.

To work with RF-FORM-FINDING, RF-CUTTING-PATTERN, and RF-PIPING, corresponding licenses are required.

The Use CQC Rule check box allows you to combine seismic load cases according to the CQC rule ("complete quadratic combination rule"). This allows for a complete quadratic modal combination of dynamic load cases. The parameters for the Rayleigh damping or Lehr's damping can be specified in the input fields below. The RF-DYNAM Pro manual provides more detailed explanations for the dynamic analysis.

The Enable CAD/BIM model check box must be selected when the data is to be aligned with a CAD or BIM model. Thus, importing, organizing, and transforming IFC, STEP, and IGES files, for example, is possible (RF-LINK add-on module required). This feature is presented in the following article: https://www.dlubal.com/en-US/support-and-learning/support/knowledge-base/001328

**Standard Gravity**

This dialog section manages the basic value of the gravitational acceleration $g$ that is significant, for example, for determining the self-weight and for dynamic analyses. If necessary, you can adjust the approximate value of 10.00 m/s$^2$. 
12.2.3 **History**

The History dialog tab of the General Data dialog box documents the processing.

The table shows at which point in time the model was Opened and Saved, and by which User.

In the topmost table row, you can enter a Comment that describes the state of model processing. The next time the model is saved, the comment is effective for the history. The comment appears not only in this tab but is also available in the project manager (see Figure 12.15). To delete the history, click the [X] button. That way, you can remove personal information from the file.
12.3 Network Management

When several users work on the same projects, model management can be organized via the project manager, provided that the models are stored in a folder that is accessible on the network.

First, connect the network folder to the internal project management. This is described in Chapter 12.1.1. This allows you to directly access the models of this folder in the project manager, which means that you can open or copy the models, check their history, provide them with write protection, etc.

If another user is already working on the model that you want to open, a warning appears. In this case, you can open the model as a copy.

![Query when opening a write-protected model](image)

An automatic data synchronization of modifications is not possible.

Information about the projects registered in the project manager is stored in the PRO.DLP file. It is an ASCII file that is stored in the directory C:\ProgramData\Dlubal\Global\Project Manager by default.

By copying the PRO.DLP file to another computer, you can avoid having to connect folders project by project. In addition, the file can be edited by an editor. This facilitates the import of all relevant project folders into the internal file management of the project manager, especially after new installations. As an alternative, you can use the Import Folder feature (see Chapter 12.1.1).

Before copying the PRO.DLP file, such as before uninstalling Dlubal applications, it is recommended to save the existing file.

The project manager is network-compatible as well. The file management can thus be organized in a central place so that all users are incorporated into one common project management. To define the network settings, select the project manager menu entry

**Edit → Program Options.**

A dialog box opens where you can define the storage location for the PRO.DLP file (see Figure 12.21).

The project manager runs on every local computer, but each is using the central server file PRO.DLP. In this way, all users can carry out modifications to the project structure at the same time. For writing access to the PRO.DLP file, the file is locked for a short time and is unlocked immediately afterwards.
12.4 Block Manager

The block manager manages model blocks across projects: Selected objects can be saved as blocks and reused in other structures. A multitude of typified elements is predefined in the block manager’s Catalog.

To open the block manager, select File → Block Manager in the menu or use the toolbar button shown on the left.

![Block Manager button in the toolbar](image)

When you open the block manager, a multi-part window appears. Like the project manager (see Chapter 12.1), it has its own menu and toolbar.

![Block manager](image)

**Navigator**

On the left, a navigator is displayed with the Catalog of all block categories. The current category is marked in bold. To select a different category, double-click it or use the Current Category list in the toolbar. The table to the right of the navigator lists the objects filed in the selected category. Several blocks for various member, surface, and solid models are available.

**Table of blocks**

The blocks of the selected category are listed one by one. The Block Name, the Description, and important object and file information are respectively shown.

To adjust the displayed columns, select View → Manage Register Columns in the menu or use the corresponding toolbar button (see Chapter 12.1.4.1).
Details
This window section shows detailed information about the selected block.

Preview
The selected block is displayed in a preview. The size of the preview window can be adjusted by moving the upper edge of the window.

Thumbnails
The bottom area of the block manager provides a graphical overview of the blocks contained in the selected category. The thumbnail images are interactive with the table above.
Use the pins to minimize specific window parts. They are then docked as tabs in the footer.

12.4.1 Creating a Block

To create a block from specific objects, first select the relevant objects in the current RFEM model. A multiple selection is possible by drawing a window with the mouse or by clicking several elements while holding down the [Ctrl] key.

To then create the new block, use the RFEM menu option

File → Save as Block.

The following dialog box appears.

Specify the Block Name and Category Name under which you want to save the block. The category can be selected in the list. You can use the Description to briefly describe the block.

The directory of the block is indicated in the Folder dialog field.

If loads are defined, they can be saved together with the block. In addition, you can use the settings in the Option dialog section to control if all loads or only specific load cases are relevant.

To create a new block category, use the [New Category] button shown on the left.
The procedure is similar to the creation of a new project in the project manager (see Chapter 12.1.1).

### 12.4.2 Importing a Block

To import a block into the current RFEM model, open the block manager (see Figure 12.35). Select the category in the catalog first. Then you can select the relevant block with a mouse-click in the RFEM tab.

To start the import,

- select **Block → Insert Block** in the menu or
- use the shortcut menu of the block.

You can also double-click the block in the table. The following dialog box appears.
Specify the Insert Point of Block (the "snap point") and the Global Position of Reference Point in the dialog box. The points can also be selected graphically in the block model or the RFEM model.

Geometric Parameters as well as Materials and Cross-Sections can be modified. A click into the corresponding text box enables buttons that you can use to select items from a list or to open libraries.

For user-defined blocks, it is even possible to import loads: The Active Load can be selected in the list.

Use the button to access specific import settings.
The Detail Settings dialog box allows you to control how objects are aligned with the existing model elements. You can also influence the Numbering.

Click the button in this dialog box (see Figure 12.41) to open another dialog box. In it, you can select the load cases, load combinations, and result combinations for the import.

12.4.3 Deleting a Block

To delete a block,

- select Block → Delete in the block manager menu (select block beforehand),
- click the [Delete] button in the toolbar, or
- use the shortcut menu of the block (see Figure 12.39).

After confirming a security query, the block is moved into the Dlubal recycle bin.
12.5 Interfaces

RFEM allows you to exchange data with other programs. Thus, you can utilize both the CAD templates of other applications and the results of structural calculations in construction or design software.

Exporting the printout report as an RTF file and to VCmaster is described in Chapter 10.1.11.

RFEM can also be controlled externally by means of a programmable interface based on COM technology (e.g. Visual Basic): With RF-COM, which can be acquired as an RFEM add-on module, you can use customized input macros and post-processing programs.

12.5.1 Direct Data Exchange

Dlubal applications

RFEM provides an interface to software programs developed by the Dlubal company. Input data of all previous RFEM versions can be imported without problems. Files of the framework program RSTAB can also be directly opened in RFEM and surface or solid elements can be added. Conversely, you can also open RFEM 5 files in RSTAB 8.

Tekla Structures / AutoCAD

RFEM has a direct connection to CAD programs from Tekla Structures and AutoCAD (but not for LT versions). With it, you can use the advantages of BIM (Building Information Modeling) with RFEM to exchange data models for digital planning purposes.

To start the direct data exchange, select the menu option

File ➔ Import or
File ➔ Export

or use the toolbar buttons shown on the left.

The dialog box shown in Figure 12.44 or Figure 12.45 opens where you can select the desired CAD program in the Direct Imports or Direct Exports dialog section.

The buttons in the Export/Import toolbar have the following functions:

- Direct import from Tekla Structures
- Direct export to Tekla Structures
- Direct import from AutoCAD
- Direct export to AutoCAD

Table 12.3 Buttons of Export/Import toolbar

Find more information on the interfaces with Tekla Structures and Autodesk Revit in the BIM Interfaces manual.
12.5.2 Formats for Data Exchange

If CAD programs or programs for structural analysis can create files of the types *.stp, *.dxf, *.fem, *.asf, *.dat, *.cfe, or *.ifc, the data can be used as a template for RFEM. Conversely, RFEM is also able to create files in formats suitable for other programs.

To open the dialog box for importing a file, use the menu option

File → Import.

Figure 12.44 Import dialog box

When the Import as background layer option is selected, RFEM only shows a line model that can be used to set nodes, lines, etc. (see Chapter 11.3.10).

To start the export of an RFEM file, use the menu option

File → Export.

Figure 12.45 Export dialog box
**Formats for Frameworks**

**DSTV format *.stp**

With the product interface of the DSTV (German Steel Construction Association), the transfer is not performed with framework files reduced to wireframe models; files contain all model and load data necessary for efficient processing. Many software developers, among them Dlubal Software, work on the development of this interface. It enables the exchange of data with programs such as Bentley ProStructure, Tekla Structures, Intergraph Frameworks, Advance Steel, CIS/2 CIMSteel, or cadwork.

The interface generally covers structural and CAD data. RFEM, however, supports only the structural format with specific "entities" that can be found in a description (German only, PDF download at [http://www.dlubal.com/de/download/pss_dstv.pdf](http://www.dlubal.com/de/download/pss_dstv.pdf)).

The interface transfers information of nodes, members, and cross-sections including member eccentricities and cross-section rotations. Furthermore, nodal supports, load cases, load combinations, and result combinations are transferred with nodal and member loads as well as imperfections. The results of the calculation can be stored in the exchange file as well.

More settings for the data exchange can be specified in the DSTV (.stp) dialog tab.

![Figure 12.46 Export dialog box, DSTV (.stp) tab](image)

**Formats for Spreadsheet**

**MS Excel format *.xlsx**

RFEM can import and generate tables as *.xls files. Exchanging data with MS Excel is described in Chapter 11.5.6. However, the described option is only available for the active RFEM table. The function described below covers all data of the model at once. Thus, user-defined, external generators for model and load data can be used.

To import an XLS file, open the file in MS Excel first. Then you can use the Microsoft Excel option in the RFEM import dialog box (see Figure 12.44) to open the following dialog box.

![Figure 12.47 Import from Microsoft Excel - Settings dialog box](image)
Select the Workbook and Worksheets that you want to import. Description, sequence, and structure of worksheets must match the data in RFEM exactly, so that imported data can be correctly written into the RFEM tables. If you are not entirely sure, you can create an XLS file from the current RFEM file for test purposes.

In the Options tab, you can specify if worksheets are imported with or without headers and how formulas are handled in the worksheets.

When exporting a file, it is not necessary to open MS Excel; the program starts automatically.

In the Export of Tables dialog section, select the tables that you want to export. When you activate the Only selected tables option, RFEM enables the corresponding button. Click the button to open another dialog box for specific settings.

In the Formulas and Parameters dialog section of the initial dialog box (Figure 12.48), you can specify whether stored formulas are also transferred between RFEM and Excel during the data exchange.
**CSV format *.csv**

The RFEM tables can also be exported into the CSV format. The procedure is similar to the export into the MS Excel format (see above).

### General Formats for CAD Programs

**ASCII format *.dxf**

The DXF format only transfers general information regarding the lines used in the model. RFEM is able to import a line model created in, for example, AutoCAD, as well as to create a DXF file from the current model. A layer is used for each cross-section. Nodal supports, loads, etc. cannot be transferred.

More settings for the data exchange can be defined in the ASCII Format DXF (*.dxf) dialog tab. It is recommended to check the parameters, especially before the import.

It is also recommended to check the length units of the DXF template. Optionally, you can enter an Offset to place the DXF model at a certain distance to the origin. Select the Import 3DFACE as surface option to automatically create 3D surfaces from the DXF template as surfaces in RFEM.

If you want to Import from a specific layer, use the button on the right to select the DXF file. The individual layers are then available for selection in the list.

In most CAD programs the Z-axis is directed upwards, but in RFEM it is normally directed downwards. If you now switch to the second dialog tab in the import dialog box, Detail Settings, and select Down in the list for the Z-axis, weight loads can be entered as positive values in RFEM.

The DXF export also includes values. However, only one value or one group of values is possible. If several values are specified, the first value is always exported and a corresponding message is displayed.

For the DXF export, it is also recommended to check the orientation of the Z-axis.
**IFC format *.ifc**

The Industry Foundation Classes (IFC) are a global standard to exchange data for model-based approaches in the construction industry and are developed by the IAI (International Alliance for Interoperability). The IFC are structured in domains (architecture, design, structural analysis, electrical engineering, etc.). Dlubal Software supports the domain for structural engineering, which allows for the transfer of structural data such as nodes, members, supports, load cases, and loads. The IFC are still under development.

You can find a description of the interface at [https://www.buildingsmart.org](https://www.buildingsmart.org).

When you export an RFEM model as an IFC model, an analytical model is created in the version IFC 2x Edition 3.

**Bentley format *.ism.dgn, *.dgn**

This interface allows you to exchange data with the CAD product MicroStation. You can both import model data and export RFEM files, thus using the possibilities of interoperability. Therefore, a connection to all Bentley applications such as ProSteel is given on the basis of ISM (Integrated Structural Modeling).

**SDNF format *.dat**

The SDNF format (Steel Detailing Neutral File) is used for the data exchange of geometrical data such as nodes, cross-sections, and members with the program Intergraph.

**Formats for Reinforcement CAD Programs**

**Glaser format *.geo, *.fem**

RFEM provides an interface with the program Glaser by Isb Cad. This interface handles the exchange of geometrical and reinforcement data.

If you want to export reinforcement results of the RF-CONCRETE Surfaces add-on module, make sure that surfaces are defined as plane and horizontal, i.e. created in the plane XY.

After clicking [OK], you can specify the reinforcement results that are relevant for the export in a new dialog box.

The reinforcements of the grid points or FE nodes are realized graphically in the Glaser program. As they are available as values, it is possible to use them in reinforcement drawings.
Strakon format *.cfe

The Strakon format *.cfe supports the exchange of geometrical data such as surfaces with the CAD program system STRAKON produced by the software developer Dicad.

In the Results tab of the Export dialog box, you can specify the surfaces whose reinforcements you want to export (see Figure 12.53).

Nemetschek format *.asf

Data can also be exchanged with Nemetschek's Allplan program.

For the export of reinforcement results of the RF-CONCRETE Surfaces add-on module, please note that while surfaces may be defined in any position, they must be plane. During the export, RFEM creates one ASF file per plane surface. For example: When the RFEM model has 12 surfaces, 12 files are created that can be merged into a 3D model in Allplan.

In the Results dialog tab of the Export dialog box, you can specify the surfaces whose reinforcements you want to export.

ESF format *.esf

This interface was developed for the program CADKON by AB STUDIO. It is possible to export plane surfaces with constant thicknesses including openings and material information. Furthermore, you can export the reinforcements of RFEM surfaces into the *.esf format (Engineering Structural Format).

You can use the DXF format for the data import; the ESF format is not supported.

Formats for Structural Analysis Programs

Ansys format *.ans

Use the interface with the FE program ANSYS to import files available in the *.ans format. This way, you can also use the data of this multifunctional program for analyses performed with RFEM.

Scia format *.xml

It is also possible to import model data from the structural analysis program Scia by Nemetschek to RFEM, provided that data is available in the *.xml format.

Dlubal Plate format *.000

Use this interface to import DOS files from the Dlubal program Plate. Set the directory of the INP folder including input data in the Open dialog box.
General Dlubal formats *.xml, *.ft5

To save RFEM files as XML files or templates, use the menu option **File → Save As**.

In the **Save As** Windows dialog box, use the list to set the desired file type in the **Save as type** dialog field.

![Save As dialog box](image)

The FT5 format saves the model as a template that can be reimported when you create a new file (see Figure 12.23). When you save the model as the RFX file type, tabular data is converted into an XML format; the remaining data is saved in binary form. Data is stored in a compressed file that can be opened like a ZIP archive file. With it, it is possible to create files for CAD programs.
12.5.3 RF-LINK Import *.step, *.iges, *.sat

With the RF-LINK add-on module (not contained in RFEM), it is possible to import data in the STEP, IGES, or ACIS formats. These file formats are mainly used in mechanical engineering. They allow for a transfer of the model geometry in the form of boundary lines and surfaces.

To import model files available in one of these formats, use the menu option

**File → Import.**

![Import dialog box](image)

In the *Extra Formats* dialog section, you can define the relevant file format:

- *Standard for the Exchange of Product Model Data* (*.stp, *.step)*
- *Initial Graphics Exchange Specification* (*.iges)*
- *Standard Acis Text Format* (*.sat)*

In the *Import (*.sat, *.step, *.iges)* dialog tab, you can specify more detailed settings.

![Import dialog box, Import (*.sat, *.step, *.iges) tab](image)

The export of RFEM files into the STEP, IGES, or SAT formats is currently not available.
13 Literature


