Frequently Asked Questions (FAQ)

Search FAQ

Show Filter Hide Filter





Customer Support 24/7

Knowledge Base

In addition to our technical support (e.g. via chat), you’ll find resources on our website that may help you with your design using Dlubal Software.

Newsletter

Receive information including news, useful tips, scheduled events, special offers, and vouchers on a regular basis.

  • Answer

    You can delete the selected load cases in the navigator as follows:

    1. Activate the "Data" tab in the Project Navigator.
    2. Select the load cases to be deleted under "Load Cases and Combinations" → "Load Cases."
    3. Right-click the selection and select "Delete."
  • Answer

    If you want to calculate stresses in SHAPE‑THIN, it is necessary to create at least one load case. You can create a new load case by using:

    • Menu "Insert" → "Loads" → "New Load Case"

    • Shortcut menu of the "Load Cases" entry in the navigator

    • Entry in Table "2.1 Load Cases"

    Furthermore, it is necessary to define internal forces. You can enter the internal forces by using:

    • Menu "Insert" → "Loads" → "3.1 Internal Forces" → "Dialog Box"

    • Entry in Table "3.1 Internal Forces"

    • Import of internal forces from RFEM or RSTAB in Table "3.1 Internal Forces"

    After the calculation, you can display the stresses graphically and in tables (Figure 01). This is also shown in the video.

    Figure 01 - Stress

  • Answer

    Many webinars and online videos explain the automatic load combination, for example, for Eurocode. An example of this can be found directly on YouTube here.

    However, due to time reasons, these webinars and videos often do not include any accidental combination, such as those necessary for a fire situation or earthquake.

    Such a combination can be generated just as easily and flexibly as the combination for the ultimate limit state (ULS) or the serviceability limit state (SLS).

    The generation of it is shown in the attached video.

    In summary, the following steps are necessary (the structure and load cases are already defined):

    1. Activating the automatic generation of combination in General Data (Figure 01)
    2. In the Combination Expressions tab, select the accidental combination with psi1 or psi2 as leading (Figure 02).
    3. Ideally, create the combinations with an enveloping result combination.
    4. Select the created result combination for design in the add-on module, for example RF-/TIMBER Pro, under the "Fire Resistance" tab.
  • Answer

    The load distribution of a line load is defined by the "Distribution" attribute. The "Distribution" attribute is of the "LoadDistributionType" type, and the list entries of the combo box are of the "String" type, so the type conversion is required. The "GetLoadDistributionType" function converts a list entry of the String type into a LoadDistributionType.

    '--------------------------------------------------------------------------------------------------
    Function GetLoadDistributionType(sType As String) As LoadDistributionType
    '--------------------------------------------------------------------------------------------------
        
        If sType = "Concentrated2x2QType" Then
          GetLoadDistributionType = Concentrated2x2QType
        ElseIf sType = "Concentrated2xQType" Then
          GetLoadDistributionType = Concentrated2xQType
        ElseIf sType = "ConcentratedNxQType" Then
          GetLoadDistributionType = ConcentratedNxQType
        ElseIf sType = "ConcentratedType" Then
          GetLoadDistributionType = ConcentratedType
        ElseIf sType = "ConcentratedUserDefinedType" Then
          GetLoadDistributionType = "ConcentratedUserDefinedType"
        ElseIf sType = "LinearType" Then
          GetLoadDistributionType = LinearType
        ElseIf sType = "LinearXType" Then
          GetLoadDistributionType = LinearXType
        ElseIf sType = "LinearYType" Then
          GetLoadDistributionType = LinearYType
        ElseIf sType = "LinearZType" Then
          GetLoadDistributionType = LinearZType
        ElseIf sType = "ParabolicType" Then
          GetLoadDistributionType = ParabolicType
        ElseIf sType = "RadialType" Then
          GetLoadDistributionType = RadialType
        ElseIf sType = "TaperedType" Then
          GetLoadDistributionType = TaperedType
        ElseIf sType = "TrapezoidalType" Then
          GetLoadDistributionType = TrapezoidalType
        ElseIf sType = "UniformType" Then
          GetLoadDistributionType = UniformType
        ElseIf sType = "VaryingType" Then
          GetLoadDistributionType = VaryingType
        End If

    End Function

    The "SetLineLoad" procedure creates a line load on Line 1. The load distribution is readout from the "LoadDistribution" combo box of the "LineLoad" Excel worksheet.

    '--------------------------------------------------------------------------------------------------
    Sub SetLineLoads()
    '--------------------------------------------------------------------------------------------------
    Dim model As RFEM5.model
    Dim load As RFEM5.ILoadCase
    Dim data(0) As RFEM5.LineLoad
        'Get interface for model
        Set model = GetObject(, "RFEM5.Model")
        
        'Block COM licence and program access
        model.GetApplication.LockLicense
        On Error GoTo e
       'Get interface for loads
        Set load = model.GetLoads.GetLoadCase(0, AtIndex)
        'Set parameters for lineload
        data(0).No = 1
        data(0).LineList = "1"
        data(0).Type = ForceType
        'Load Distribution from combo box
        data(0).Distribution = GetLoadDistributionType(Worksheets("LineLoad").DropDowns("LoadDistribution").List(Worksheets("LineLoad").DropDowns("LoadDistribution").ListIndex))
        data(0).Direction = LocalZType
        data(0).DistanceA = 11
        data(0).DistanceB = 22
        data(0).RelativeDistances = True
        data(0).Magnitude1 = 4000
        data(0).Magnitude2 = 5000
        data(0).Magnitude3 = 6000
        data(0).OverTotalLength = False
        data(0).Comment = "line load 1"
        'Transfer lineload
        load.PrepareModification
        load.SetLineLoads data
        load.FinishModification
        
    e:  If Err.Number <> 0 Then MsgBox Err.Description, , Err.Source
        Set load = Nothing
        'COM licence is unlocked, program access possible again
        model.GetApplication.UnlockLicense
        Set model = Nothing


    End Sub

    The source code can be found under Downloads.
  • Answer

    In RF‑/FOUNDATION&nbso;Pro, the load is always applied to the top edge of the foundation, regardless of the foundation type.
  • Answer

    You can combine several load cases into one load case by right-clicking the existing load case and using the "Add Load Cases..." option.

    Figure 01 - Right-Clicking Existing Load Case and Selecting "Add Load Cases"

    A dialog box appears where you can select the load case in which you want to add this load.

    This procedure can be used to combine loads from several load cases in one load case.

  • Answer

    In this regard, there are several options.

    On the one hand, you can decompose the eccentric load into the vertical component and the moment component, and model the loading by using line loads.

    Figure 02 - Loading as Line Load and Moment Component

    On the other hand, you can apply the line load eccentrically to the surface by means of an additional surface with the surface type - Stiffness "Rigid."

    Figure 03 - Loading as Line Load Using Rigid Surface

  • Answer

    Project Navigator - Results provides a special option to evaluate the results of the RWIND Simulation loads: Activate the results of "Distribution of load" and then select the "Wind load using RWIND Simulation" option.
  • Answer

    A load that was accidentally applied in the wrong load case can be copied from one load case to another by using the table with the area "3. Loads."

    In the table, select the type of load that you want to transfer from one load case to another. In the subsequent graphic, these are the "member loads," for example. Then, select and right-click the row describing this load. A shortcut menu appears where you can select "Copy." As an alternative, you can use the keyboard shortcut "Ctrl + C" directly after selecting the row.

    Figure 01 - Copying Loads from One Load Case to Another

    After copying the row to the clipboard, you can switch to the "Target load case" in the table area and paste the entry from the clipboard using "Ctrl + V."

    Note: This procedure is not possible for the generated loads.

  • Answer

    If load cases are superimposed manually, the "Edit Load Cases and Combinations" dialog box only provides three options. This is specified in the "General Data" dialog box.

    Figure 01 - Manual Combination

    If you select the "Create combinations automatically" check box, you obtain the additional options (actions, combination expressions, action combinations) as desired.

    Figure 03 - Automatic Combination

1 - 10 of 292

Contact us

Did you find your question?
If not, contact us via our free e-mail, chat, or forum support, or send us your question via the online form.

(267) 702-2815

info-us@dlubal.com

First Steps

First steps

We provide hints and tips to help you get started with the main programs RFEM and RSTAB.

Wind Simulation & Wind Load Generation

With the stand-alone program RWIND Simulation, wind flows around simple or complex structures can be simulated by means of a digital wind tunnel.

The generated wind loads acting on these objects can be imported to RFEM or RSTAB.

Your support is by far the best

“Thank you for the valuable information.

I would like to pay a compliment to your support team. I am always impressed how quickly and professionally the questions are answered. I have used a lot of software with a support contract in the field of structural analysis, but your support is by far the best. ”