常见问题和解答 (FAQ)

搜索 FAQ

专题报告

专题报告

在“专题报告”板块中您能发现许多实用的技术文章和提示技巧,方便您使用 Dlubal 软件。

新闻简报

您能定期收到关于公司新闻、实用技巧、预定活动、促销和优惠券的信息。

  • Which resources are available to perform the pushover analysis?

    FAQ 002258 ZH 附加模块 RF-DYNAM Pro RF-DYNAM Pro - Equivalent Loads RFEM

    回答

    In RFEM, it is possible to calculate a pushover curve (also called capacity curve). The pushover curve data can be exported to Excel. Important steps in order to evaluate this nonlinear curve are listed below:

    1. Comprehensive definition of nonlinear hinges
      1. Plastic hinges in accordance to FEMA 356: This is a nonlinear hinge (elastic‑plastic or rigid‑plastic) with default values for yielding points in the hinge diagram and acceptance criteria, both for steel members (Chapter 5 in FEMA 356). The yielding limits of the members are dependent on the cross‑sections and are set automatically. For moment hinges, the diagram parameters and acceptance criteria are interpolated for different type of cross‑sections. You can adjust all the values of a 'FEMA' hinge using your own user‑defined values. Figure 1 shows the Plastic Hinge dialog box.

        Plastic hinges in accordance to EN 1998‑3: This is a nonlinear hinge with a bilinear definition. The bilinear hinges include predefined values for the yielding points in the hinge diagram, acceptance criteria, and yielding limits of the cross‑sections. These values can also be adjusted manually.

        The plastic hinges are displayed with various colors when viewing the results of several load steps. The colors depend on the state of plasticity. This is very useful to identify exceeded acceptance criteria.

      2. Instead of using hinges, you can use the 'Plastic Hinge' type of member nonlinearity in RFEM. In the relevant dialog box, you can define perfectly plastic behavior and set the yielding limits manually. The main advantage of this option is that the location of the plastic hinge is found automatically during the iterative calculation. See Figure 2 for further explanation.

    2. Definition of load pattern for nonlinear analysis

      You can manually define loads in a specific load case, for example a uniform load pattern.

      To achieve load distribution in accordance to a mode shape of your structure you can use RF‑DYNAM Pro - Equivalent Loads. This add‑on module calculates eigenvalues, mode shapes and equivalent loads by using the multi‑modal response spectrum analysis. For each selected eigenvalue, the program automatically exports the equivalent loads into a load case in RFEM.


    3. Load increments in RFEM

      In the calculation parameters of load cases, you can define an incrementally increasing load. The results of each load step can then be analyzed. When using 'Plastic Hinges', you can easily evaluate the plasticity states due to the color marking of the hinges. It is important to scale the exported equivalent loads from RF‑DYNAM Pro to avoid load increments in too large steps. 

      Figure 3 shows a load case exported from RF‑DYNAM Pro and the recommended calculation parameters.


    4. Calculation diagrams for creating pushover curve

      These diagrams are available in the 'Global Calculation Parameters' dialog box. Here you can set the sum of support forces on the vertical axis and the deformation in a roof plane on the horizontal axis and thus obtain the required pushover curve. The data can easily be exported to Excel. The pushover curve is displayed in Figure 4.

      Figure 5 shows the color representation of the plastic hinges. The color scale can display the hinge diagram parameters or the acceptance criteria.

      The continuing pushover analysis (determination of the inelastic spectrum and performance point) can further be carried out in an external program (for example Excel).


  • 回答

    There can be different reasons for an unsuccessful calculation due to an instable. On the one hand, this can indicate a “real” instability due to an overloading of the system. On the other hand, the error message can result from inaccuracies in the model. Below you find a possible procedure for discovering the reason for this instability.

    First of all, you should check if there are errors in the model. For example, you can calculate the structure only with its self-weight in a load case according to the linear static analysis. If results are displayed afterwards, the structure is stable concerning the model. If this is not the case, the most common cases are the following (see Video 1):

    - Supports are missing or have been defined incorrectly
    - Members are twisted about their own axis (torsional releases are defined at both member ends)
    - Members are not connected with each other (Tools --> Model Check)
    - Nodes seem to be in the same place, at a closer look they deviate minimally from each other (common cause at CAD import, Tools --> Model Check)
    - Member end releases/line hinges cause a "chain of releases"
    - Stiffening of the structure is not sufficient
    - Failure of nonlinear structural elements (for example tension members)

    Figure 2 shows the latter point. You can see a hinged frame which is stiffened by tension members. Due to the column contractions as a result of the vertical loads the tension members receive minor compressive forces during the first calculation. They are removed from the structure (because only tension can be absorbed). During the second calculation, the model is then unstable without these tension members. There are several ways to solve this problem. You can assign a prestress (member load) to the tension members to "eliminate" the minor compressive forces, allocate a little stiffness to the members (see Figure 2) or have removed the members successively during the calculation (see Figure 2).

    The RF-STABILITY add-on module (RFEM) may be useful if you want to display graphically the reason for instability. Use the "Calculate eigenvector for unstable model ..." option (see Figure 3) to calculate supposedly unstable structures. On the basis of the structural data, an eigenvalue analysis is performed so that the instability of the structural component in question is displayed graphically.


    If load cases/load combinations can be calculated according to the linear static analysis and the calculation is only cancelled when performing the second-order analysis, it is mostly caused by a "critical load problem" (critical load factor less than 1.0). The critical load factor indicates the number by which the load must be multiplied so that the model under the associated load becomes unstable (buckling). It follows that a critical load factor less than 1.0 leads to an unstable structure. Only a positive critical load factor higher than 1.0 makes it possible that the loading due to specified axial forces multiplied by this factor results in buckling of the stable structure. To be able to determine the "weak point", we recommend the following procedure which requires the RSBUCK (RSTAB) and RF-STABILITY (RFEM) add-on module (see Video 2):

    First of all, the load of the concerned load combination should be reduced until the load combination becomes stable. The load factor in the calculation parameters of the load combination is a useful tool here (see Video 2). This also corresponds to manually determining the critical load factor if the RSBUCK and RF-STABILITY add-on module is not available. Based on this load combination, you can then calculate the buckling modes in the RSBUCK and RF-STABILITY add-on module and display the results graphically. By displaying the results, you can detect the "weak point" in the structure and then optimize it systematically.

    Attachments
    Video 1-en.wmv (16.60 MB)
    Video 2-en.wmv (18.98 MB)
  • 回答

    For one thing, there is a zip archive with examples and help files available for download on our product page of RF-COM, which can be found at:

    https://www.dlubal.com/en/products/rfem-and-rstab-add-on-modules/others/rf-com

    The archive can be found on the left in the box labeled "help files and example macros" by clicking "Download".

    In the newer versions of RFEM, there is also an SDK folder in the "Dlubal" folder. It is located under "C:\Users\Public\Documents\Dlubal" in the standard installation. It contains additional and newer help files.

  • 回答

    The administration interface can be accessed via http://localhost:1947. No further installation i srequired because this service is available after the installation of the dongle driver.

    All Sentinel dongles are displayed in the option Sentinel Keys. By clicking on one of these dongles you get to the address of the server.

    Our licenses are displayed with the vendor number 48521. If you select the option Sessions here, you can see who is using which license.
  • 回答

    The interface "Autodesk AutoCAD Structural Detailing" allows you to export the results of the RF‑CONCRETE Surfaces add-on module including the geometry directly to AutoCAD Structural Detailing. Since no RF‑CONCRETE Surfaces case has been created in your model, an error message appeared saying that no load case was found.

  • 回答

    The internal forces to be considered in design can be found in the "1.6 Reinforcement" window, "Reinforcement Layout" tab. Here you can select the internal forces, which should not be taken into account for the respective reinforcement group. Please note that this setting is valid for all members of the reinforcement group. You should use this function carefully.

  • 回答

    The beam is a rolled section with welded taper from sheets or an I-section. In order to use such a cross-section in RF-/FRAME-JOINT Pro, the web thickness of the welded component has to have at least the same value as the main cross-section web.

  • 回答

    Please note, that the object snap must be activated when inserting new linear dimensioning. Furthermore, you can activate the corresponding objects for snapping in the "Work Plane and Grid/Snap" dialog box, "Object Snap" tab.
  • 回答

    Open the program and click "Options" -> "Program Options" in the menu. You can change the language in the "Program" tab. Close the program and open it again to activate the selected language.

  • 回答

    For relatively common structures, you can select various generators by clicking menu: "Tools" -> "Generate Model - Members (Surfaces)". If you cannot find the required template there, you can look in the block manager. It can be opened by clicking menu: "File" -> "Block Manager" and has a similar structure as the project manager. The corresponding catalogue includes numerous parametrized structures, for example for silos or towers. It is also possible to parametrize already modeled structures and save them as a block.

1 - 10378

联系我们

联系 Dlubal

您找到想找的问题和解答了吗?
如果没有,请联系我们或者把您的问题通过网上表格递交给我们。

+49 9673 9203 0

(可要求接中文热线)

info@dlubal.com

初学者

Erste Schritte

我们在这里为初学者提供了重要的提示和建议,以便用户更加容易快速的掌握使用我们的基本软件 RFEM 和 RSTAB。

优秀的技术支持

“谢谢你们提供的实用信息。

我想向你们的技术支持团队表示感谢!给我印象深刻的是每次都快速、专业的解答我的问题。在建筑结构行业中,我使用了几个软件,包括服务合同,但是你们的技术支持是最好的。”