Cross-section modeling based on DXF files

Technical Article

This article was translated by Google Translator View original text

In SHAPE-THIN, you can import cross-section geometries that are available as outline or centroid layouts in DXF format and use them as a basis for modeling.

The following options are available for creating the cross-section:

  • Creating and editing elements automatically
  • Viewing lines of the DXF template as center lines of elements with assigned thicknesses
  • Creating a DXF template for further editing

Figure 01 - Dialog Box 'Insert DXF Template'

The automatic creation of elements is useful for simple cross-section geometries. SHAPE-THIN tries to create center lines for parallel lines and then to set the elements between the intersection points. Only elements that have the same functions as shown in the "Max. Thickness "does not exceed the defined maximum thickness.

If the cross-section geometry is available as a gravity line model, you can consider the lines of the DXF template as the center lines of the elements. The thickness defined in the "t" field is assigned to all elements equally.

For the above-mentioned options for creating the cross-section, the DXF file is additionally created as a background layer. Importing the DXF file as background layer is only possible with the option "Create DXF template for further editing."

You select the material from the material library and the Length unit of the DXF template by using the "Unit of length" drop-down. Optionally, it is possible to rotate the DXF template. Furthermore, you can enter the position of the offset point manually in the "y" and "z" fields or transfer it in the graphic by selecting the node or the gripping point. The DXF template can then be positioned in the work window of SHAPE-THIN with the mouse. Alternatively, you can specify the position of the DXF template in the "Y", "Z" fields.

The background layer can be shifted, mirrored, rotated, or stretched. To access these functions, select the menu "Edit" → "Background Layers" or use the shortcut menu in the Project Navigator - Data.

Furthermore, it is possible to import a background layer by clicking "New Background Layer". In contrast to the DXF import, where a new file is created, the background layer is inserted into the current file.

Figure 02 - Project Navigator - Data, Background Layer

It is possible to retroactively create elements based on the background layer. To do this, open the "Set Elements According to DXF Template" dialog box under "Edit" → "Define Elements with DXF Template."

Figure 03 - Dialog Box 'Set Elements According to DXF Template'

First, use the option "Set Center Lines" to create the center lines by clicking the opposite contour lines. If there is no intersection between the center lines, you can use the option "Extend Center Centers" to draw the lines. Click to enlarge the selected part of the line.

The "Set Elements" option creates elements on center lines that have an intersection point on both ends. Click the corresponding center lines.

For outline lines that are not parallel, you have to set the elements manually, because SHAPE-THIN can only create center lines and therefore also elements for parallel lines. The background layer serves as a modeling aid. For lines and nodes of the background layer, the object snap of nodes, intersection points, the center, and so on, is available.

Irregularities in the cross-section geometry can be represented by point elements. They can be added as a fillet, rectangle, circle, or triangle, or removed from member surfaces. You can insert point elements by using "Insert" → "Cross-Section Data" → "1.5 Point Elements", the table with the same name, or by using the corresponding button in the toolbar.

Figure 04 - Dialog Box 'Set Point Element'

For symmetric cross-sections, it is recommended to model only one part of the cross-section and to create the other parts by means of mirrors.

Cross-section modeling based on a DXF file is shown in the video.

Keywords

DXF background layer Modeling Aid Import

Downloads

Links

Contact us

Contact Dlubal Software

Do you have questions or need advice?
Contact our free e-mail, chat, or forum support or find various suggested solutions and useful tips on our FAQ page.

(267) 702-2815

info-us@dlubal.com

Contact us

Contact Dlubal Software

Did you find your question?
If not, contact us via our free e-mail, chat, or forum support, or send us your question via the online form.

(267) 702-2815

info-us@dlubal.com

Cross-Sections Thin-Walled
SHAPE-THIN 8.xx

Cross-Section Properties Software

Section properties, stress analysis, and plastic design of open and closed thin-walled cross-sections

Price of First License
1,120.00 USD