Frequently Asked Questions (FAQ)

Helpful Questions & Answers

  • Frequently Asked Questions (FAQs)

Search FAQ

Show Filter Hide Filter





Customer Support 24/7

In addition to personal support (e.g. via e-mail, chat), you can find help and information on our website.

Newsletter

Receive information including news, useful tips, scheduled events, special offers, and vouchers on a regular basis.

1 - 10 of 124

Sort by:

Items:

  • Answer

    By activating the Advanced lighting option in Program Options, you should solve the problem. As an alternative, try to adjust the lighting in the Display navigator under Rendering → Lighting. On some computers, all the lights may be off, so you can try turning them on gradually until it is ideal for you.
  • Answer

    The colors of the selection and preselection can be changed within the display properties:

    • Menu bar "Options" → "Display Properties" → "Edit"
      or shortcut menu (right-click on the work plane) → Display Properties
    • Colors → Other → Selection/Preselection, see the image
    Image 01 - Changing Colors of Selection/Preselection

  • Answer

    The ellipse is the inertia ellipse, which is used to display the radius of gyration. This can be deactivated or activated as shown in Image 01.

    Both additional lines are used to display the area bisection axes for y and z, but also for the principal axes u and v. These bisectors can also be deactivated in the Display navigator (see Image 01).

  • Answer

    The view can be switched in the navigator in the tab Display → Results → Members → Draw in XY‑Plane.
  • Answer

    Yes, it is possible to create visibilities via the COM interface (RF‑COM3 / RS‑COM6). In the following code, the elements are first selected for a visibility. This is done via Selections. First, activate them with "rfEnableSelections," then you can use "rfSelectObjects" to select the objects:

    Sub set_visibility()
        
    '   get interface from the opened model and lock the licence/program
    Dim iModel As RFEM3.IrfStructure3
    Set iModel = GetObject(, "RFEM3.Structure")
    iModel.rfGetApplication.rfLockLicence
        
    On Error GoTo e
        
    '   get interface for modeldata
    Dim iModData As RFEM3.IrfStructuralData4
    Set iModData = iModel.rfGetStructuralData

    '   get interface for view
    Dim iView As RFEM3.IrfView2
    Set iView = iModel.rfGetActiveView
    '   remove old views
    iView.rfDeletePartialView "test|view"
    iView.rfDeletePartialView "test|view2"
    iView.rfDeletePartialView "test|view_add"
    iView.rfDeletePartialView "test|view_rev"
    iView.rfDeletePartialView "test|view_diff"

    '   create first view
    iModData.rfSelectObjects STR_MEMBER, "3-4"
    iView.rfSetPartialView "test|view"
    'iView.rfSelectPartialView "test | view", PVM_SHOW, True, True

    '   create second view
    iModData.rfSelectObjects STR_SURFACE, "1"
    iModData.rfSelectObjects STR_MEMBER, "3"
    iView.rfSetPartialView "test|view2"
    '    iView.rfSelectPartialView "test|view2", PVM_SHOW, True, True

    '   create sum from view from 1 and 2
    iView.rfSelectPartialView "test|view", PVM_SELECT, True, True
    iView.rfSelectPartialView "test|view2", PVM_SELECT, False, True
    iView.rfSelectPartialView "", PVM_SHOW_SELECTION_ONLY, True, True
    iView.rfSetPartialView "test|view_add"


    '   create differential view 2 minus 1
    '       first created reversed view
    iView.rfSelectPartialView "test|view", PVM_SHOW, True, True
    iView.rfSelectPartialView "test|view2", PVM_SHOW, False, True
    iView.rfSelectPartialView "", PVM_SHOW_REVERSE, True, True
    iView.rfSelectPartialView "", PVM_SELECT, True, True
    iView.rfSetPartialView "test|view_rev"
    iView.rfSelectPartialView "", PVM_SHOW_REVERSE, True, True

    '       select view to substract and reverse view
    iView.rfSelectPartialView "test|view_rev", PVM_SELECT, True, True
    iView.rfSelectPartialView "test|view", PVM_SELECT, False, True
    iView.rfSelectPartialView "", PVM_SHOW_SELECTION_ONLY, True, True
    iView.rfSelectPartialView "", PVM_SHOW_REVERSE, True, True
    iView.rfSelectPartialView "", PVM_SELECT, True, True
    iView.rfSetPartialView "test|view_diff"
    iView.rfSelectPartialView "", PVM_SHOW_SELECTION_ONLY, True, True

    iView.rfSelectPartialView "", PVM_SHOW_REVERSE, True, True
    iView.rfCancelPartialView

        
    e:  If Err.Number <> 0 Then MsgBox Err.description, , Err.Source
        
    iModel.rfGetApplication.rfUnlockLicence
    Set iModel = Nothing

    End Sub

    You can use the "iView" interface and the "rfSetPartialView" command to create a visibility. The description is especially important here. The separator "|" ensures that the visibility with the "view" name is created in the "test" group.

    The rfSelectPartialView command is used to display a visibility. The first argument is the name of the visibility. For the second argument, you can select various commands. Depending on the command, a name of the visibility is required or not.

    The third argument asks whether everything shown so far should be deactivated or not. So if you also want to display two visibilities, you have to commit "False" at least when selecting the second visibility.

    The fourth argument controls whether everything that is hidden should be displayed in the background or not.

    Here is a list of important commands of the second argument:

    PVM_SELECT - selects the elements in the specified visibility

    PVM_SHOW - shows the specified visibility

    PVM_SHOW_SELECTION_ONLY - After selecting elements from the visibilities, they can be displayed alone now.

    PVM_SHOW_REVERSE - All elements shown so far go into the background and all elements from the background are displayed (the display is inverted).

  • Answer

    The font color of the numbering of guidelines can be changed in Display Properties:

    Right-click the workspace → Display Properties → Fonts → Other → Guidelines → "Font" button → Change Color, see the figure.

    Image 01 - Display Properties

  • Answer

    This adjustment of the arrow sizes of punching loads can be done in the display properties in the main program: Shortcut menu (right-click the workspace) → Display Properties → Loads → Nodal Loads → Nodal Forces, see the figure.

    Image 01 - Display Properties

  • Answer

    The effective length of a member can be adjusted manually in the "Effective Lengths" tab of the "Edit Member" dialog box (see Figure 01).

    Image 01 - Adjustment of Effective Length Factors

    Then, you can graphically display the members in color according to the effective length:
    Click the "Display" navigator → "Colors in Graphic According to" → "Effective Length Factor" (see Figure 02).

    Image 02 - Colors in Graphic According to Effective Length Factor

  • Answer

    The colors of user-defined visibilities for the screen can be set in the panel. To do this, double-click the entry in the panel that you want to modify, and open the "Color" dialog box where you can select the desired color (Figure 01). The settings in the panel only affect the screen and not the printout report.

    Figure 01 - Changing Colors for Screen in Panel

    The color of user-defined visibilities can also be set in the display properties. You can open the dialog box by using the menu "Options" → "Display Properties" → "Edit" or the shortcut menu. The color setting for user-defined visibilities can be set separately for the screen and the printout report in the "Objects by Color" → "User-defined Visibilities" category (Figure 02).

    Figure 02 - Changing Colors for Screen/Printout Report in Display Properties

    Under the link below, you find the explanation of how to make identical settings for the screen and the printout report.

    The video shows you how to change the color of the visibility "E‑05" for the screen in the panel. Then, it shows how to change the color of the visibility "E‑05" for the printout report.

  • Answer

    You can change the color of member hinges in the display properties under "Model Data" → "Hinges" → "Member Hinges," see Figure 01.

    Figure 01 - Display Properties for Member Hinges

1 - 10 of 124

Contact us

Contact Dlubal

Did you find your question?
If not, contact us via our free e-mail, chat, or forum support, or send us your question via the online form.

+49 9673 9203 0

info@dlubal.com

First steps

First steps

We provide information and tips to help you get started with the basic program RFEM and RSTAB.

Wind Simulation & Wind Load Generation

RWIND Simulation Manuals

With the stand -alone program RWIND Simulation, you can simulate wind flows around simple or complex structures by means of a digital wind tunnel.

The generated wind loads acting on these objects can be imported to RFEM or RSTAB.

Your support is by far the best

“Thank you very much for the useful information.

I would like to pay a compliment to your support team. I am always impressed how quickly and professionally the questions are answered. In the industry of structural analysis, I use several software including service contract, but your support is by far the best.”