Frequently Asked Questions (FAQ)

Search FAQ




Customer Support 24/7

Knowledge Base

In addition to our technical support (e.g. via chat), you’ll find resources on our website that may help you with your design using Dlubal Software.

Newsletter

Receive information including news, useful tips, scheduled events, special offers, and vouchers on a regular basis.

  • Answer

    To ensure that the cross-sections are recognized when directly importing girders and columns in REVIT, a corresponding family must be available for these components in the REVIT project.
    If this is not the case, you can import a suitable family into your project during the import process. The interface then independently recognizes all other cross-sections and creates the corresponding cross-sections within the family.


    Figure 01 does not show a 480/520 (mm) timber column. After importing the correct family type, this cross-section and all other cross-sections of the same type are recognized and the import process is successfully completed.


  • Answer

    There are two options for the export to Advanced Steel:

    • Export via the product interface

    Export the data to an stp format via the interface of the German Steel Engineering Association and import the file into the target program.

    You can find this interface in the "File" -> menu "Export" in the "Formats for Frameworks" box.

    • Export via the Advanced Steel interface

    Use the "Advanced Steel" interface to export the data to an smlx format and import it into the target program.

    You can also find this interface in the "General Formats for CAD Programs" dialog box in the "Export" dialog box.

  • Answer

    The student version also supports the interface to REVIT.
  • Answer

    • Bidirectional interface between RFEM / RSTAB and Revit Structure

      RFEM and RSTAB communicate via a direct interface to Revit Structure, enabling bidirectional data exchange. Structures modeled using RFEM and RSTAB can be easily transferred to Revit Structure at the touch of a button.

    • Direct RSTAB / RFEM interface to Autodesk AutoCAD

    • Direct RSTAB / RFEM interface to Thekla Structures

      With the direct integrated interface, Tekla Structures' analytical model of detailed systems can be easily transferred to RFEM / RSTAB.


    • Further exchange formats

      DXF, IFC, STP (eg. (from tower cranes, for example) for Intergraph, Advance Steel, SEMA, Cadwork, HSB-Cad, etc.), DSTV (e.g. (from tower cranes, for example) for Bocad and Frilo), FEM (Glaser) and CFE (Strakon), XLS (Microsoft EXCEL), CSV, ISM.DGN, DGN (Bentley ISM), DAT, SMLX (Advance Steel), ASF (Nemetschek Allplan), ESF
    A detailed overview of the interfaces and the BIM-oriented planning is available on our homepage in the section " Building Information Modeling (BIM) ".

    In addition, there are already numerous webinars on BIM , which can be viewed on our homepage as a video.
  • Answer

    Unfortunately, there are two different interfaces with the same file extension - the .stp interface of the German Steel Construction Association (Deutcher STahlbau-Verband, DSTV) on one hand, and the STEP interface (STandard for the Exchange of Product model data) on the other hand, which is defined in the ISO standard 10303.

    While the DSTV interface refers to the system axes of members, that is to the structural model, the STEP interface refers to the model geometry in the form of boundary lines, surfaces and simple solids. In the latter case, the models can be imported either as RFEM objects (nodes, lines, surfaces, solids) or as background layers so that the nodes can be set manually. The STEP interface does not usually transfers any system lines, but only the outer contours of structural components so it is necessary to manually create system planes afterwards. You can do this in RFEM and RSTAB, for example, by using a CAD/BIM model.

    If you get the error message shown in Figure 01, you have tried to import an .stp file based on STEP using the DSTV interface. As described above, both formats are not compatible with each other.

    In this case, select the STEP format for the import, as shown in Figure 02. If a message shown in Figure 03 appears, it is because this interface requires the RF-LINK add-on module.

  • Answer

    Unfortunately, we currently have no videos or webinars for these modules.

    However, there are some examples and specialist articles to help you get started:

    • At the bottom of the links , you find references to VBA examples in our Knowledge Base.
    • On your computer, you can find some Excel files with examples in the SDK folder. This folder can be found in the directory C: \ Users \ Public \ Documents \ Dlubal.
    • Some example macros are listed in an archive folder. You can download it on the following page by using the "HELP-FILES AND EXAMPLE MACROS" box:
      https://www.dlubal.com/en-US/products/rfem-and-rstab-add-on-modules/others/rf-com
  • Answer

    There are two possibilities for the export to Bentley ProStructures.

    1. The data can be exported to the target program by using the product interface.

    First, export the program data with the product interface for steel construction "Bentley ProStructure" in *.stp format. Then, import this file to the target program.

    Find the product interface for steel construction "Bentley ProStructure" by selecting "Export" on the "File" menu. The "Export" dialog box with the "Format" tab opens.

    By means of the product interface for steel construction (*.stp) you can transfer the complete structural system including materials, cross-sections, releases, loads, combinations, supports and results. This format is managed by the product interface for steel construction according to DSTV (German Steel Construction Association). The DSTV interface (*.stp) is supported for example by Bentley ProStructures, Tekla Structures, Bocad, Intergraph Frameworks, Advanced Steel and Cadwork.

    2. The data can be exported to the target program by using the Bentley ISM interface.

    First, export the program data with the Bentley ISM interface in *.ism.dgn format. Then, import this file to the target program.

    Find the ISM interface by selecting "Export" on the "File" menu. The "Export" dialog box with the "Format" tab opens.

    With the help of this technology, you can also export surface elements like walls or plates in addition to members.

Contact us

Contact Dlubal Software

Did you find your question?
If not, contact us via our free e-mail, chat, or forum support, or send us your question via the online form.

(267) 702-2815

info-us@dlubal.com

First Steps

First steps

We provide hints and tips to help you get started with the main programs RFEM and RSTAB.

Your support is by far the best

“Thank you very much for the useful information.

I would like to pay a compliment to your support team. I am always impressed how quickly and professionally the questions are answered. In the industry of structural analysis, I use several software including service contract, but your support is by far the best.”