Modelle als Blöcke in RFEM 6 speichern

Fachbeitrag zum Thema Statik und Anwendung von Dlubal Software

  • Knowledge Base

Fachbeitrag

In RFEM 6 ist es möglich, selektierte Objekte, aber auch ganze Strukturen als Blöcke zu speichern und in anderen Modellen wieder zu verwenden. Es lassen sich drei Arten von Blöcken unterscheiden: Ohne Parameter, mit Parameter und dynamische Blöcke (mittels JavaScript). In diesem Beitrag wird der erste Blocktyp (ohne Parameter) vorgestellt.

Die Blöcke in RFEM 6 lassen sich über das Dlubal Center | Blöcke verwalten (Bild 1). Eine Vielzahl von Modellen unterschiedlicher Kategorien (z. B. Träger, Fachwerkstäbe, Rahmen, Türme und Masten, Membranbau und Textilbau, Silos und Speicherbehälter usw.) sind im Katalog vordefiniert und können gleich verwendet werden.

Es lassen sich aber auch neue Blöcke erzeugen, indem man Strukturen oder Strukturteile selektiert und über "Datei → Als Block speichern" speichert. Neben Name des Blocks und der Beschreibung ist es wichtig, das Modell nach Typ, verwendeten Objekten und der relevanten Kategorie zu klassifizieren (Bild 2). Diese Angaben helfen, den Block später im Katalog zu finden und wiederzuverwenden.

Wurde der Block einmal gespeichert, kann dieser einfach in jede beliebige RFEM 6-Datei importiert werden. Dazu muss das Dlubal Center | Blöcke geöffnet und der Block aus der relevanten Kategorie ausgewählt werden (Bild 3).

Nun öffnet sich das Fenster Blöcke bearbeiten, um den Einfügepunkt des Blocks und seine Lage im RFEM-Arbeitsfenster festzulegen. Der Punkt kann über die Auswahl des Knotens in der Grafik oder über die Koordinaten zugewiesen werden (Bild 4). Änderungen am Block können auch über das Register Struktur vorgenommen werden. So können beispielsweise Material und Querschnitte vor dem Einfügen des Blocks geändert werden (Bild 5). In gleicher Weise kann im Register Klassifizierung dieses Dialogs die Blockklassifizierung angepasst werden.

Wichtig ist, dass der eingefügte Block als spezielles Objekt zur Verfügung steht und über das Navigator-Register Daten weiter bearbeitet werden kann, wie in Bild 6 zu sehen ist. Zudem kann der Block über die RFEM-Funktionen (z. B. Drag & Drop) direkt bearbeitet werden.

Schlussbemerkungen

Unzählige Modelle sind im Dlubal Center bereits als Blöcke vordefiniert und stehen zur Verfügung. In RFEM 6 ist es aber auch möglich, Tragwerksteile oder ganze Strukturen als Blöcke einzufügen. Zur besseren Orientierung ist es wichtig, das zu speichernde Modell als Block hinsichtlich Typ, verwendeter Objekte und Kategorie zu klassifizieren.

Zum Einfügen des abgespeicherten Blocks in eine Datei ist es notwendig, den Einfügepunkt des Blocks und seine Lage im RFEM-Arbeitsfenster festzulegen. An dieser Stelle sind auch Änderungen des Blocks hinsichtlich des Aufbaus und der Klassifizierung möglich. Der Block kann auch nachträglich bearbeitet werden, da er nach dem Einfügen als spezielles Objekt im Navigator-Register Daten zur Verfügung steht.

Autor

Irena Kirova, M.Sc.

Irena Kirova, M.Sc.

Marketing & Customer Support

Frau Kirova ist bei Dlubal zuständig für die Erstellung von technischen Fachbeiträgen und unterstützt unsere Anwender im Kundensupport.

Schlüsselwörter

Blöcke Parametrisierung Parameter

Schreiben Sie einen Kommentar...

Schreiben Sie einen Kommentar...

  • Aufrufe 1022x
  • Aktualisiert 11. Januar 2023

Kontakt

Kontakt zu Dlubal

Haben Sie Fragen oder brauchen Sie einen Rat? Kontaktieren Sie uns über unseren kostenlosen E-Mail-, Chat- bzw. Forum-Support oder nutzen Sie die häufig gestellten Fragen (FAQs) rund um die Uhr.

+49 9673 9203 0

[email protected]

Online Training | German

Eurocode 3 | Stahltragwerke nach DIN EN 1993-1-1

Online-Schulung 28. Februar 2023 8:30 - 12:30 CET

Online-Schulung | Englisch

Eurocode 3 | Stahltragwerke nach DIN EN 1993-1-1

Online-Schulung 2. März 2023 9:00 - 13:00 CET

Online Training | German

Eurocode 5 | Holztragwerke nach DIN EN 1995-1-1

Online-Schulung 14. März 2023 8:30 - 12:30 CET

Online-Schulung | Englisch

Eurocode 5 | Holztragwerke nach DIN EN 1995-1-1

Online-Schulung 16. März 2023 9:00 - 13:00 CET

Online Training | German

RFEM 6 | Baudynamik und Erdbebenbemessung nach EC 8

Online-Schulung 28. März 2023 8:30 - 12:30 CEST

Einladung zur Veranstaltung

Internationale Konferenz für Holzwerkstoff

Seminar/Konferenz 27. März 2023 - 29. März 2023

Online-Schulung | Englisch

RFEM 6 | Dynamische Analyse und Erdbebenbemessung nach EC 8

Online-Schulung 30. März 2023 9:00 - 13:00 CEST

BAU 2023 | München

BAU 2023

Messe 17. April 2023 - 22. April 2023

Online-Schulung | Englisch

Eurocode 2 | Betonbauten nach DIN EN 1992-1-1

Online-Schulung 26. Januar 2023 9:00 - 13:00 CET

Online Training | German

Eurocode 2 | Stahlbetontragwerke nach DIN EN 1992-1-1

Online-Schulung 24. Januar 2023 8:30 - 12:30 CET

Bemessung eines Stahlbetonbehälters \n in RFEM 6

Bemessung eines Stahlbetonbehälters in RFEM 6 (USA)

Webinar 19. Januar 2023 14:00 - 15:00 EDT

Online-Schulung | Englisch

RFEM 6 | Grundlagen

Online-Schulung 19. Januar 2023 9:00 - 13:00 CET

RFEM 6
Halle mit Bogendach

Basisprogramm

Die Statik-Software RFEM 6 ist die Basis einer modular aufgebauten Programmfamilie. Das Hauptprogramm RFEM 6 dient zur Definition der Strukturen, Materialien und Einwirkungen ebener und räumlicher Platten-, Scheiben-, Schalen- und Stabtragwerke. Mit dem Programm können auch Mischsysteme sowie Volumen- und Kontaktelemente bemessen werden.

Erstlizenzpreis
4.450,00 EUR